Sun VirtualBox®

User Manual

Version 3.0.10 Edition

Sun Microsystems, Inc.

http://www.virtualbox.org

Copyright © 2004-2009 Sun Microsystems, Inc.

Table of Contents

1. Introduction
1.1. Virtualization basics
1.2. Software vs. hardware virtualization (VT-x and AMD-V)
1.3. Features overview
1.4. Supported host operating systems
1.5. Supported guest operating systems
1.6. 64-bit guests
2. Installation
2.1. Installing on Windows hosts
2.1.1. Prerequisites
2.1.2. Performing the installation
2.1.3. Uninstallation
2.1.4. Unattended installation
2.2. Installing on Mac OS X hosts
2.2.1. Performing the installation
2.2.2. Uninstallation
2.2.3. Unattended installation
2.3. Installing on Linux hosts
2.3.1. Prerequisites
2.3.2. The VirtualBox kernel module
2.3.3. USB and advanced networking support
2.3.4. Performing the installation
2.3.5. Starting VirtualBox on Linux
2.4. Installing on Solaris hosts
2.4.1. Performing the installation
2.4.2. Starting VirtualBox on Solaris
2.4.3. Uninstallation
2.4.4. Unattended installation
2.4.5. Configuring a zone for running VirtualBox
3. Starting out with VirtualBox
3.1. Starting the graphical user interface
3.2. Creating a virtual machine
3.3. Basics of virtual machine configuration
3.4. Running a virtual machine
3.4.1. Keyboard and mouse support in virtual machines
3.4.2. Changing removable media
3.4.3. Saving the state of the machine
3.4.4. Snapshots
3.5. The Virtual Disk Manager
3.6. Deleting virtual machines
3.7. Virtual machine settings
3.7.1. General settings
3.7.2. System settings
3.7.3. Display settings
3.7.4. Hard disk settings
3.7.5. CD/DVD-ROM and floppy settings
3.7.6. Audio settings
3.7.7. Network settings
3.7.8. Serial ports
3.7.9. USB support
3.7.10. Shared folders
3.8. Importing and exporting virtual machines
4. Guest Additions
4.1. Introduction
4.2. Windows Guest Additions
4.2.1. Installing the Windows Guest Additions
4.2.2. Updating the Windows Guest Additions
4.2.3. Unattended Installation
4.2.4. Manual file extraction
4.2.5. Windows Vista networking
4.3. Linux Guest Additions
4.3.1. Installing the Linux Guest Additions
4.3.2. Video acceleration and high resolution graphics modes
4.3.3. Updating the Linux Guest Additions
4.4. Solaris Guest Additions
4.4.1. Installing the Solaris Guest Additions
4.4.2. Uninstalling the Solaris Guest Additions
4.4.3. Updating the Solaris Guest Additions
4.5. OS/2 Guest Additions
4.6. Folder sharing
4.7. Seamless windows
4.8. Hardware 3D acceleration (OpenGL and DirectX 8/9)
4.9. Guest properties
5. Virtual storage
5.1. Hard disk controllers: IDE, SATA (AHCI), SCSI
5.2. Disk image files (VDI, VMDK, VHD)
5.3. Configuring image write operations
5.4. Cloning disk images
5.5. iSCSI servers
5.5.1. Access iSCSI targets via Internal Networking
6. Virtual networking
6.1. Virtual networking hardware
6.2. Introduction to networking modes
6.3. "Not attached" mode
6.4. Network Address Translation (NAT)
6.4.1. Configuring port forwarding with NAT
6.4.2. PXE booting with NAT
6.4.3. NAT limitations
6.5. Bridged networking
6.6. Internal networking
6.7. Host-only networking
7. Alternative front-ends; remote virtual machines
7.1. Introduction
7.2. Using VBoxManage to control virtual machines
7.3. VBoxSDL, the simplified VM displayer
7.4. Remote virtual machines (VRDP support)
7.4.1. Common third-party RDP viewers
7.4.2. VBoxHeadless, the VRDP-only server
7.4.3. Step by step: creating a virtual machine on a headless server
7.4.4. Remote USB
7.4.5. RDP authentication
7.4.6. RDP encryption
7.4.7. VRDP multiple connections
8. VBoxManage reference
8.1. VBoxManage list
8.2. VBoxManage showvminfo
8.3. VBoxManage registervm / unregistervm
8.4. VBoxManage createvm
8.5. VBoxManage modifyvm
8.5.1. General settings
8.5.2. Storage settings
8.5.3. Networking settings
8.5.4. Serial port, audio, clipboard, VRDP and USB settings
8.6. VBoxManage import
8.7. VBoxManage export
8.8. VBoxManage startvm
8.9. VBoxManage controlvm
8.10. VBoxManage discardstate
8.11. VBoxManage snapshot
8.12. VBoxManage openmedium / closemedium
8.13. VBoxManage showhdinfo
8.14. VBoxManage createhd
8.15. VBoxManage modifyhd
8.16. VBoxManage clonehd
8.17. VBoxManage convertfromraw
8.18. VBoxManage addiscsidisk
8.19. VBoxManage getextradata/setextradata
8.20. VBoxManage setproperty
8.21. VBoxManage usbfilter add/modify/remove
8.22. VBoxManage sharedfolder add/remove
8.23. VBoxManage metrics
8.24. VBoxManage guestproperty
8.25. VBoxManage dhcpserver
9. Advanced topics
9.1. VirtualBox configuration data
9.2. Automated Windows guest logons (VBoxGINA)
9.3. Custom external VRDP authentication
9.4. Secure labeling with VBoxSDL
9.5. Custom VESA resolutions
9.6. Multiple monitors for the guest
9.7. Releasing modifiers with VBoxSDL on Linux
9.8. Launching more than 120 VMs on Solaris hosts
9.9. Using serial ports
9.10. Using a raw host hard disk from a guest
9.10.1. Access to entire physical hard disk
9.10.2. Access to individual physical hard disk partitions
9.11. Allowing a virtual machine to start even with unavailable CD/DVD/floppy devices
9.12. Fine-tuning the VirtualBox NAT engine
9.12.1. Configuring the address of a NAT network interface
9.12.2. Configuring the boot server (next server) of a NAT network interface
9.12.3. Tuning TCP/IP buffers for NAT
9.12.4. Binding NAT sockets to a specific interface
9.12.5. Enabling DNS proxy in NAT mode
9.13. Configuring the maximum resolution of guests when using the graphical frontend
9.14. Configuring the BIOS DMI information
9.15. Configuring the guest time stamp counter (TSC) to reflect guest execution
9.16. Configuring the hard disk vendor product data (VPD)
10. VirtualBox programming interfaces
11. Troubleshooting
11.1. General
11.1.1. Collecting debugging information
11.1.2. Guest shows IDE errors for VDI on slow host file system
11.1.3. Responding to guest IDE flush requests
11.2. Windows guests
11.2.1. Windows bluescreens after changing VM configuration
11.2.2. Windows 0x101 bluescreens with SMP enabled (IPI timeout)
11.2.3. Windows 2000 installation failures
11.2.4. How to record bluescreen information from Windows guests
11.2.5. No networking in Windows Vista guests
11.2.6. Windows guests may cause a high CPU load
11.3. Linux and X11 guests
11.3.1. Linux guests may cause a high CPU load
11.3.2. AMD Barcelona CPUs
11.3.3. Buggy Linux 2.6 kernel versions
11.3.4. Shared clipboard, auto-resizing and seamless desktop in X11 guests
11.4. Windows hosts
11.4.1. VBoxSVC out-of-process COM server issues
11.4.2. CD/DVD changes not recognized
11.4.3. Sluggish response when using Microsoft RDP client
11.4.4. Running an iSCSI initiator and target on a single system
11.5. Linux hosts
11.5.1. Linux kernel module refuses to load
11.5.2. Linux host CD/DVD drive not found
11.5.3. Linux host CD/DVD drive not found (older distributions)
11.5.4. Linux host floppy not found
11.5.5. Strange guest IDE error messages when writing to CD/DVD
11.5.6. VBoxSVC IPC issues
11.5.7. USB not working
11.5.8. PAX/grsec kernels
11.5.9. Linux kernel vmalloc pool exhausted
11.6. Solaris hosts
11.6.1. Cannot start VM, not enough contiguous memory
11.6.2. VM aborts with out of memory errors on Solaris 10 hosts
12. Change log
12.1. Version 3.0.10 (2009-10-29)
12.2. Version 3.0.8 (2009-10-02)
12.3. Version 3.0.6 (2009-09-09)
12.4. Version 3.0.4 (2009-08-04)
12.5. Version 3.0.2 (2009-07-10)
12.6. Version 3.0.0 (2009-06-30)
12.7. Version 2.2.4 (2009-05-29)
12.8. Version 2.2.2 (2009-04-27)
12.9. Version 2.2.0 (2009-04-08)
12.10. Version 2.1.4 (2009-02-16)
12.11. Version 2.1.2 (2009-01-21)
12.12. Version 2.1.0 (2008-12-17)
12.13. Version 2.0.8 (2009-03-10)
12.14. Version 2.0.6 (2008-11-21)
12.15. Version 2.0.4 (2008-10-24)
12.16. Version 2.0.2 (2008-09-12)
12.17. Version 2.0.0 (2008-09-04)
12.18. Version 1.6.6 (2008-08-26)
12.19. Version 1.6.4 (2008-07-30)
12.20. Version 1.6.2 (2008-05-28)
12.21. Version 1.6.0 (2008-04-30)
12.22. Version 1.5.6 (2008-02-19)
12.23. Version 1.5.4 (2007-12-29)
12.24. Version 1.5.2 (2007-10-18)
12.25. Version 1.5.0 (2007-08-31)
12.26. Version 1.4.0 (2007-06-06)
12.27. Version 1.3.8 (2007-03-14)
12.28. Version 1.3.6 (2007-02-20)
12.29. Version 1.3.4 (2007-02-12)
12.30. Version 1.3.2 (2007-01-15)
12.31. Version 1.2.4 (2006-11-16)
12.32. Version 1.2.2 (2006-11-14)
12.33. Version 1.1.12 (2006-11-14)
12.34. Version 1.1.10 (2006-07-28)
12.35. Version 1.1.8 (2006-07-17)
12.36. Version 1.1.6 (2006-04-18)
12.37. Version 1.1.4 (2006-03-09)
12.38. Version 1.1.2 (2006-02-03)
12.39. Version 1.0.50 (2005-12-16)
12.40. Version 1.0.48 (2005-11-23)
12.41. Version 1.0.46 (2005-11-04)
12.42. Version 1.0.44 (2005-10-25)
12.43. Version 1.0.42 (2005-08-30)
12.44. Version 1.0.40 (2005-06-17)
12.45. Version 1.0.39 (2005-05-05)
12.46. Version 1.0.38 (2005-04-27)
12.47. Version 1.0.37 (2005-04-12)
13. Known limitations
A. Third-party licenses
A.1. Materials
A.2. Licenses
A.2.1. GNU General Public License (GPL)
A.2.2. GNU Lesser General Public License (LGPL)
A.2.3. Mozilla Public License (MPL)
A.2.4. MIT License
A.2.5. X Consortium License (X11)
A.2.6. zlib license
A.2.7. OpenSSL license
A.2.8. Slirp license
A.2.9. liblzf license
A.2.10. libpng license
A.2.11. lwIP license
A.2.12. libxml license
A.2.13. libxslt licenses
A.2.14. gSOAP Public License Version 1.3a
A.2.15. Chromium licenses
A.2.16. curl license
B. VirtualBox privacy policy
Glossary


Chapter 1. Introduction

Table of Contents

1.1. Virtualization basics
1.2. Software vs. hardware virtualization (VT-x and AMD-V)
1.3. Features overview
1.4. Supported host operating systems
1.5. Supported guest operating systems
1.6. 64-bit guests

Sun VirtualBox is a collection of powerful virtual machine tools, targeting desktop computers, enterprise servers and embedded systems. With VirtualBox, you can virtualize 32-bit and 64-bit operating systems on machines with Intel and AMD processors, either by using hardware virtualization features provided by these processors or even entirely in software, at your option.

You can find a brief feature overview in Section 1.3, “Features overview”; see Chapter 12, Change log for a detailed list of version changes.

1.1. Virtualization basics

With VirtualBox, you can run unmodified operating systems -- including all of the software that is installed on them -- directly on top of your existing operating system, in a special environment called a "virtual machine". Your physical computer is then usually called the "host", while the virtual machine is often called a "guest".

The following image shows you how VirtualBox, on a Linux host, is running Windows Vista as guest operating system in a virtual machine window:

VirtualBox allows the guest code to run unmodified, directly on the host computer, and the guest operating system "thinks" it's running on a real machine. In the background, however, VirtualBox intercepts certain operations that the guest performs to make sure that the guest does not interfere with other programs on the host.

The techniques and features that VirtualBox provides are useful for several scenarios:

  • Operating system support. With VirtualBox, one can run software written for one operating system on another (for example, Windows software on Linux) without having to reboot to use it. You can even install an old operating system such as DOS or OS/2 in a virtual machine if your real computer's hardware is too advanced to be supported.

  • Infrastructure consolidation. Virtualization can significantly reduce hardware and electricity costs. The full performance provided by today's powerful hardware is only rarely really needed, and typical servers have an average load of only a fraction of their theoretical power. So, instead of running many such physical computers that are only partially used, one can pack many virtual machines onto a few powerful hosts and balance the loads between them. With VirtualBox, you can even run virtual machines as mere servers for the VirtualBox Remote Desktop Protocol (VRDP), with full client USB support. This allows for consolidating the desktop machines in an enterprise on just a few RDP servers, while the actual clients only have to be capable of displaying VRDP data.

  • Testing and disaster recovery. Once installed, a virtual box and its virtual hard disk can be considered a "container" that can be arbitrarily frozen, woken up, copied, backed up, and transported between hosts. On top of that, with the use of another VirtualBox feature called "snapshots", one can save a particular state of a virtual machine and revert back to that state, if necessary. This way, one can freely experiment with a computing environment. If something goes wrong (e.g. after installing misbehaving software or infecting the guest with a virus), one can easily switch back to a previous snapshot and avoid the need of frequent backups and restores.

When dealing with virtualization (and also for understanding the following chapters of this documentation), it helps to acquaint oneself with a bit of crucial terminology, especially the following terms:

Host operating system (host OS):

the operating system of the physical computer where VirtualBox is running. There are versions of VirtualBox for several host operating systems (see Section 1.4, “Supported host operating systems” for further information). While the various VirtualBox versions are usually discussed together in this document, there may be platform-specific differences which we will point out where appropriate.

Guest operating system (guest OS):

the operating system that is running inside the virtual machine. Theoretically, VirtualBox can run any x86 operating system (DOS, Windows, OS/2, FreeBSD, OpenBSD), but to achieve near-native performance of the guest code on your machine, we had to go through a lot of optimizations that are specific to certain operating systems. So while your favorite operating system may run as a guest, we officially support and optimize for a select few (which, however, include the most common ones).

See Section 1.5, “Supported guest operating systems” for further information.

Virtual machine (VM).

When running, a VM is the special environment that VirtualBox creates for your guest operating system. So, in other words, you run your guest operating system "in" a VM. Normally, a VM will be shown as a window on your computer's desktop, but depending on which of the various frontends of VirtualBox you use, it can be displayed in full-screen mode or remotely by use of the Remote Desktop Protocol (RDP).

Sometimes we also use the term "virtual machine" in a more abstract way. Internally, VirtualBox thinks of a VM as a set of parameters that determine its operation. These settings are mirrored in the VirtualBox graphical user interface as well as the VBoxManage command line program; see Chapter 8, VBoxManage reference. They include hardware settings (how much memory the VM should have, what hard disks VirtualBox should virtualize through which container files, what CD-ROMs are mounted etc.) as well as state information (whether the VM is currently running, saved, its snapshots etc.).

In other words, a VM is also what you can see in its settings dialog.

Guest Additions.

With "Guest Additions", we refer to special software packages that are shipped with VirtualBox. Even though they are part of VirtualBox, they are designed to be installed inside a VM to improve performance of the guest OS and to add extra features. This is described in detail in Chapter 4, Guest Additions.


1.2. Software vs. hardware virtualization (VT-x and AMD-V)

In a nutshell, virtualization means that the software in the virtual machine is allowed to run directly on the processor of the host, while VirtualBox employs an array of complex techniques to intercept operations that would interfere with your host.

Whenever the guest attempts to do something that could be harmful to your computer and its data, VirtualBox steps in and takes action. In particular, for lots of hardware that the guest believes to be accessing, VirtualBox simulates a certain "virtual" environment according to how you have configured a virtual machine. For example, if the guest attempts to access a hard disk, VirtualBox redirects these requests to whatever you have configured to be the virtual machine's virtual hard disk -- normally, an image file on your host.

There are two ways in which VirtualBox can achieve virtualization: either entirely in software or, with newer processors, using certain hardware features.

  • For some years, Intel and AMD processors have had support for so-called "hardware virtualization". This means that these processors aid virtualization software such as VirtualBox in intercepting potentially dangerous operations that a guest operating system may be attempting and in presenting virtual hardware to a virtual machine.

    These hardware features differ between Intel and AMD processors. Intel named its technology VT-x; AMD calls theirs AMD-V.

    Note

    On most systems, the hardware virtualization features first need to be enabled in the BIOS before VirtualBox can use them.

  • As opposed to other virtualization software, for many usage scenarios, VirtualBox does not require hardware virtualization features to be present. Through sophisticated techniques, VirtualBox virtualizes many guest operating systems entirely in software. This means that you can run virtual machines even on older processors which do not support hardware virtualization.

You can select for each virtual machine individually whether VirtualBox should use software or hardware virtualization. Prior to version 2.2, software virtualization was the default; starting with version 2.2, VirtualBox will enable hardware virtualization by default for new virtual machines that you create. (Existing virtual machines are not automatically changed for compatibility reasons, and the default can of course be changed for each virtual machine.)

Even though VirtualBox does not always require hardware virtualization, enabling it is required in the following three scenarios:

  • Certain rare guest operating systems like OS/2 make use of very esoteric processor instructions that are not supported with our software virtualization. For virtual machines that are configured to contain such an operating system, hardware virtualization is enabled automatically.

  • VirtualBox's 64-bit guest support (added with version 2.0) and multiprocessing (SMP, added with version 3.0) both require hardware virtualization to be enabled. (This is not much of a limitation since the vast majority of today's 64-bit and multicore CPUs ship with hardware virtualization anyway; the exceptions to this rule are e.g. older Intel Celeron and AMD Opteron CPUs.)

The reason for changing the default with version 2.2 is that the hardware has significantly improved with the latest Intel and AMD processors, and VirtualBox has also fine-tuned its hardware virtualization support to a degree that it is now faster than software virtualization in many situations.

Warning

Do not run other hypervisors (open-source or commercial virtualization products) together with VirtualBox! While several hypervisors can normally be installed in parallel, do not attempt to run several virtual machines from competing hypervisors at the same time. VirtualBox cannot track what another hypervisor is currently attempting to do on the same host, and especially if several products attempt to use hardware virtualization features such as VT-x, this can crash the entire host.

In addition to "plain" hardware virtualization, your processor may also support additional sophisticated techniques:[1]

  • A newer feature called "nested paging" implements some memory management in hardware, which can greatly accelerate hardware virtualization since these tasks no longer need to be performed by the virtualization software.

    On AMD processors, nested paging has been available starting with the Barcelona (K10) architecture; Intel added support for nested paging, which they call "extended page tables" (EPT), with their Core i7 (Nehalem) processors.

    Nested paging is still disabled by default even for new machines, but it can be enabled for each virtual machine individually in the machine settings.

    If your system supports nested paging (AMD-V) or EPT (VT-x), then you can expect a significant performance increase by enabling hardware virtualization and the nested paging feature

  • Another hardware feature called "Virtual Processor Identifiers" (VPIDs) can greatly accelerate context switching by reducing the need for expensive flushing of the processor's Translation Lookaside Buffers (TLBs). To enable this feature for a VM, you need to use the command line; see Section 8.5, “VBoxManage modifyvm”.

[1] VirtualBox 2.0 added support for AMD's nested paging; support for Intel's EPT and VPIDs was added with version 2.1.


1.3. Features overview

Here's a brief outline of VirtualBox's main features:

  • Portability. VirtualBox runs on a large number of 32-bit and 64-bit host operating systems (Windows, Linux, Mac OS X and Solaris; see Section 1.4, “Supported host operating systems” for details). Virtual machines can easily be imported and exported using the industry-standard Open Virtualization Format (OVF, see Section 3.8, “Importing and exporting virtual machines”). Since the file and image formats used are identical on all the platforms, this works between all supported host operating systems.

  • Clean architecture; unprecedented modularity. VirtualBox has an extremely modular design with well-defined internal programming interfaces and a clean separation of client and server code. This makes it easy to control it from several interfaces at once: for example, you can start a VM simply by clicking on a button in the VirtualBox graphical user interface and then control that machine from the command line, or even remotely. See Chapter 7, Alternative front-ends; remote virtual machines for details.

    Due to its modular architecture, VirtualBox can also expose its full functionality and configurability through a comprehensive software development kit (SDK), which allows for integrating every aspect of VirtualBox with other software systems. Please see Chapter 10, VirtualBox programming interfaces for details.

  • No hardware virtualization required. As explained in the previous chapter, in most cases, VirtualBox does not require the processor features built into newer hardware like Intel VT-x or AMD-V. As opposed to many other virtualization solutions, you can therefore use VirtualBox even on older hardware where these features are not present.

  • Guest Additions: shared folders, seamless windows, 3D virtualization. The VirtualBox Guest Additions are software packages which can be installed inside of supported guest systems to improve their performance and to provide additional integration and communication with the host system. After installing the Guest Additions, a virtual machine will support automatic adjustment of video resolutions, seamless windows, accelerated 3D graphics and more. The Guest Additions are described in detail in Chapter 4, Guest Additions.

    In particular, Guest Additions provide for "shared folders", which let you access files from the host system from within a guest machine. Shared folders are described in Section 4.6, “Folder sharing”.

  • Great hardware support. Among others, VirtualBox supports:

    • Guest multiprocessing (SMP). Starting with version 3.0, VirtualBox can present up to 32 virtual CPUs to a virtual machine.

    • Hardware compatibility. VirtualBox virtualizes a vast array of virtual devices, among them many devices that are typically provided by other virtualization platforms -- including an Input/Output Advanced Programmable Interrupt Controller (I/O APIC) which is found in many modern PC systems. This eases cloning of PC images from real machines or 3rd party virtual machines into VirtualBox.

    • USB device support. VirtualBox implements a virtual USB controller and allows you to connect arbitrary USB devices to your virtual machines without having to install device-specific drivers on the host. USB support is not limited to certain device categories. For details, see Section 3.7.9.1, “USB settings”.

    • Full ACPI support. The Advanced Configuration and Power Interface (ACPI) is fully supported by VirtualBox. This eases cloning of PC images from real machines or third-party virtual machines into VirtualBox. With its unique ACPI power status support, VirtualBox can even report to ACPI-aware guest operating systems the power status of the host. For mobile systems running on battery, the guest can thus enable energy saving and notify the user of the remaining power (e.g. in fullscreen modes).

    • Multiscreen resolutions. VirtualBox virtual machines support screen resolutions many times that of a physical screen, allowing them to be spread over a large number of screens attached to the host system.

    • Built-in iSCSI support. This unique feature allows you to connect a virtual machine directly to an iSCSI storage server without going through the host system. The VM accesses the iSCSI target directly without the extra overhead that is required for virtualizing hard disks in container files. For details, see Section 5.5, “iSCSI servers”.

    • PXE Network boot. The integrated virtual network cards of VirtualBox fully support remote booting via the Preboot Execution Environment (PXE).

  • Multigeneration snapshots. VirtualBox can save successive snapshots of the state of the virtual machine. You can revert the virtual machine to the state of any of the snapshots. For details, see Section 3.4.4, “Snapshots”.

  • VRDP remote access. You can run any virtual machine in a special VirtualBox program that acts as a server for the VirtualBox Remote Desktop Protocol (VRDP). With this unique feature, VirtualBox provides high-performance remote access to any virtual machine. A custom RDP server has been built directly into the virtualization layer and offers unprecedented performance and feature richness.

    VRDP support is described in detail in Section 7.4, “Remote virtual machines (VRDP support)”.

    On top of this special capacity, VirtualBox offers you more unique features:

    • Extensible RDP authentication. VirtualBox already supports Winlogon on Windows and PAM on Linux for RDP authentication. In addition, it includes an easy-to-use SDK which allows you to create arbitrary interfaces for other methods of authentication; see Section 9.3, “Custom external VRDP authentication” for details.

    • USB over RDP. Via RDP virtual channel support, VirtualBox also allows you to connect arbitrary USB devices locally to a virtual machine which is running remotely on a VirtualBox RDP server; see Section 7.4.4, “Remote USB” for details.


1.4. Supported host operating systems

Currently, VirtualBox is available for the following host operating systems:

  • Windows hosts:

    • Windows XP, all service packs (32-bit)

    • Windows Server 2003 (32-bit)

    • Windows Vista (32-bit and 64-bit[2]).

    • Windows Server 2008 (32-bit and 64-bit)

    • Windows 7 beta (32-bit and 64-bit)

  • Apple Mac OS X hosts: Intel hardware is required, all versions of Mac OS X supported; please see Chapter 13, Known limitations also.[3]

  • Linux hosts (32-bit and 64-bit[4]). Among others, this includes:

    • Debian GNU/Linux 3.1 ("sarge"), 4.0 ("etch") and 5.0 ("lenny")

    • Fedora Core 4 to 11

    • Gentoo Linux

    • Redhat Enterprise Linux 4 and 5

    • SUSE Linux 9 and 10, openSUSE 10.3, 11.0 and 11.1

    • Ubuntu 6.06 ("Dapper Drake"), 6.10 ("Edgy Eft"), 7.04 ("Feisty Fawn"), 7.10 ("Gutsy Gibbon"), 8.04 ("Hardy Heron"), 8.10 ("Intrepid Ibex"), 9.04 ("Jaunty Jackalope").

    • Mandriva 2007.1, 2008.0 and 2009.1

    It should be possible to use VirtualBox on most systems based on Linux kernel 2.6 using either the VirtualBox installer or by doing a manual installation; see Section 2.3, “Installing on Linux hosts”.

    Note that starting with VirtualBox 2.1, Linux 2.4-based host operating systems are no longer supported.

  • Solaris hosts (32-bit and 64-bit[5]) are supported with the restrictions listed in Chapter 13, Known limitations:

    • OpenSolaris (2008.05 and higher, "Nevada" build 86 and higher)

    • Solaris 10 (u5 and higher)

[2] Support for 64-bit Windows was added with VirtualBox 1.5.

[3] Preliminary Mac support (beta stage) was added with VirtualBox 1.4, full support with 1.6.

[4] Support for 64-bit Linux was added with VirtualBox 1.4.

[5] Support for OpenSolaris was added with VirtualBox 1.6.


1.5. Supported guest operating systems

Since VirtualBox is designed to provide a generic virtualization environment for x86 systems, it may run operating systems of any kind, even those that are not officially supported by Sun Microsystems. However, our focus is to optimize the product's performance for a select list of guest systems:

Windows NT 4.0

All versions/editions and service packs are fully supported; however, there are some issues with older service packs. We recommend to install service pack 6a. Guest Additions are available with a limited feature set.

Windows 2000 / XP / Server 2003 / Vista / Server 2008 / Windows 7 beta

All versions/editions and service packs are fully supported (including 64-bit versions, under the preconditions listed below). Guest Additions are available.

DOS / Windows 3.x / 95 / 98 / ME

Limited testing has been performed. Use beyond legacy installation mechanisms not recommended. No Guest Additions available.

Linux 2.4

Limited support.

Linux 2.6

All versions/editions are fully supported (32 bits and 64 bits). Guest Additions are available.

We strongly recommend using a Linux kernel version 2.6.13 or higher for better performance.

Note

Certain Linux kernel releases have bugs that prevent them from executing in a virtual environment; please see Section 11.3.3, “Buggy Linux 2.6 kernel versions” for details.

Solaris 10, OpenSolaris

Fully supported (32 bits and 64 bits). Guest Additions are available.

FreeBSD

Limited support. Guest Additions are not available yet.

OpenBSD

Versions 3.7 and later are supported. Guest Additions are not available yet.

OS/2 Warp 4.5

Requires hardware virtualization to be enabled. We officially support MCP2 only; other OS/2 versions may or may not work. Guest Additions are available with a limited feature set.[6]

[6] See Chapter 13, Known limitations.


1.6. 64-bit guests

Starting with Version 2.0, VirtualBox also supports 64-bit guest operating systems. Starting with Version 2.1, you can even run 64-bit guests on a 32-bit host operating system, so long as you have sufficient hardware.

In particular, 64-bit guests are supported under the following conditions:

  1. You need a 64-bit processor with hardware virtualization support (see Section 1.2, “Software vs. hardware virtualization (VT-x and AMD-V)”).

  2. You must enable hardware virtualization for the particular VM for which you want 64-bit support; software virtualization is not supported for 64-bit VMs.

  3. If you want to use 64-bit guest support on a 32-bit host operating system, you must also select a 64-bit operating system for the particular VM. Since supporting 64 bits on 32-bit hosts incurs additional overhead, VirtualBox only enables this support upon explicit request.

    On 64-bit hosts, 64-bit guest support is always enabled, so you can simply install a 64-bit operating system in the guest.

Warning

On any host, you should enable the I/O APIC for virtual machines that you intend to use in 64-bit mode. This is especially true for 64-bit Windows VMs. See Section 3.7.1.2, “"Advanced" tab”. In addition, for 64-bit Windows guests, you should make sure that the VM uses the Intel networking device, since there is no 64-bit driver support for the AMD PCNet card; see Section 6.1, “Virtual networking hardware”.

If you use the "Create VM" wizard of the VirtualBox graphical user interface (see Section 3.2, “Creating a virtual machine”), VirtualBox will automatically use the correct settings for each selected 64-bit operating system type.


Chapter 2. Installation

Table of Contents

2.1. Installing on Windows hosts
2.1.1. Prerequisites
2.1.2. Performing the installation
2.1.3. Uninstallation
2.1.4. Unattended installation
2.2. Installing on Mac OS X hosts
2.2.1. Performing the installation
2.2.2. Uninstallation
2.2.3. Unattended installation
2.3. Installing on Linux hosts
2.3.1. Prerequisites
2.3.2. The VirtualBox kernel module
2.3.3. USB and advanced networking support
2.3.4. Performing the installation
2.3.5. Starting VirtualBox on Linux
2.4. Installing on Solaris hosts
2.4.1. Performing the installation
2.4.2. Starting VirtualBox on Solaris
2.4.3. Uninstallation
2.4.4. Unattended installation
2.4.5. Configuring a zone for running VirtualBox

As installation of VirtualBox varies depending on your host operating system, we provide installation instructions in four separate chapters for Windows, Mac OS X, Linux and Solaris, respectively.

2.1. Installing on Windows hosts

2.1.1. Prerequisites

For the various versions of Windows that we support as host operating systems, please refer to Section 1.4, “Supported host operating systems”.

In addition, Windows Installer 1.1 or higher must be present on your system. This should be the case if you have all recent Windows updates installed.

2.1.2. Performing the installation

The VirtualBox installation can be started

  • either by double-clicking on its executable file (contains both 32- and 64-bit architectures)

  • or by entering

    VirtualBox.exe -extract

    on the command line. This will extract both installers into a temporary directory in which you'll then find the usual .MSI files. Then you can do a

    msiexec /i VirtualBox-<version>-MultiArch_<x86|amd64>.msi

    to perform the installation.

In either case, this will display the installation welcome dialog and allow you to choose where to install VirtualBox to and which components to install. In addition to the VirtualBox application, the following components are available:

USB support

This package contains special drivers for your Windows host that VirtualBox requires to fully support USB devices inside your virtual machines.

Networking

This package contains extra networking drivers for your Windows host that VirtualBox needs to support Host Interface Networking (to make your VM's virtual network cards accessible from other machines on your physical network).

Depending on your Windows configuration, you may see warnings about "unsigned drivers" or similar. Please select "Continue" on these warnings as otherwise VirtualBox might not function correctly after installation.

The installer will create a "VirtualBox" group in the programs startup folder which allows you to launch the application and access its documentation.

With standard settings, VirtualBox will be installed for all users on the local system. In case this is not wanted, you have to invoke the installer by first extracting it by using

VirtualBox.exe -extract

and then do as follows:

VirtualBox.exe -msiparams ALLUSERS=2

or

msiexec /i VirtualBox-<version>-MultiArch_<x86|amd64>.msi ALLUSERS=2

on the extracted .MSI files. This will install VirtualBox only for the current user.

2.1.3. Uninstallation

As we use the Microsoft Installer, VirtualBox can be safely uninstalled at any time by choosing the program entry in the "Add/Remove Programs" applet in the Windows Control Panel.

2.1.4. Unattended installation

Unattended installations can be performed using the standard MSI support.


2.2. Installing on Mac OS X hosts

2.2.1. Performing the installation

For Mac OS X hosts, VirtualBox ships in a disk image (dmg) file. Perform the following steps:

  1. Double-click on that file to have its contents mounted.

  2. A window will open telling you to double click on the VirtualBox.mpkg installer file displayed in that window.

  3. This will start the installer, which will allow you to select where to install VirtualBox to.

After installation, you can find a VirtualBox icon in the "Applications" folder in the Finder.

2.2.2. Uninstallation

To uninstall VirtualBox, open the disk image (dmg) file again and double-click on the uninstall icon contained therein.

2.2.3. Unattended installation

To perform a non-interactive installation of VirtualBox you can use the command line version of the installer application.

Mount the disk image (dmg) file as described in the normal installation. Then open a terminal session and execute:

sudo installer -pkg /Volumes/VirtualBox/VirtualBox.mpkg \
      -target /Volumes/Macintosh\ HD


2.3. Installing on Linux hosts

2.3.1. Prerequisites

For the various versions of Linux that we support as host operating systems, please refer to Section 1.4, “Supported host operating systems”.

You will need to install the following packages on your Linux system before starting the installation (some systems will do this for you automatically when you install VirtualBox):

  • Qt 4.3.0 or higher;

  • SDL 1.2.7 or higher (this graphics library is typically called libsdl or similar).

Note

To be precise, these packages are only required if you want to run the VirtualBox graphical user interfaces. In particular, VirtualBox, our main graphical user interface, requires both Qt and SDL; VBoxSDL, our simplified GUI, requires only SDL. By contrast, if you only want to run the headless VRDP server that comes with VirtualBox, neither Qt nor SDL are required.

2.3.2. The VirtualBox kernel module

VirtualBox uses a special kernel module to perform physical memory allocation and to gain control of the processor for guest system execution. Without this kernel module, you will still be able to work with virtual machines in the configuration interface, but you will not be able to start any virtual machines.

The VirtualBox kernel module is automatically installed on your system when you install VirtualBox. To maintain it with future kernel updates, for recent Linux distributions -- for example Fedora Core 5 and later, Ubuntu 7.10 (Gutsy) and later and Mandriva 2007.1 and later --, generally we recommend installing Dynamic Kernel Module Support (DKMS)[7]. This framework helps to build kernel modules and to deal with kernel upgrades.

If DKMS is not already installed, execute one of the following:

  • On an Ubuntu system:

    sudo apt-get install dkms

  • On a Fedora system:

    yum install dkms

  • On a Mandriva system:

    urpmi dkms

If DKMS is available and installed, the VirtualBox kernel module should always work automatically, and it will be automatically rebuilt if your host kernel is updated.

Otherwise, there are only two situations in which you will need to worry about the kernel module:

  1. The original installation fails. This probably means that your Linux system is not prepared for building external kernel modules.

    Most Linux distributions can be set up simply by installing the right packages - normally, these will be the GNU compiler (GCC), GNU Make (make) and packages containing header files for your kernel - and making sure that all system updates are installed and that the system is running the most up-to-date kernel included in the distribution. The version numbers of the header file packages must be the same as that of the kernel you are using.

    • With Debian and Ubuntu releases, you must install the right version of the linux-headers and if it exists the linux-kbuild package. Current Ubuntu releases should have the right packages installed by default.

    • In even older Debian and Ubuntu releases, you must install the right version of the kernel-headers package.

    • On Fedora and Redhat systems, the package is kernel-devel.

    • On SUSE and openSUSE Linux, you must install the right versions of the kernel-source and kernel-syms packages.

    • Alternatively, if you have built your own kernel, /usr/src/linux should point to your kernel sources. If you have not removed the files created during the build process, then your system will already be set up correctly.

  2. The kernel of your Linux host got updated. In that case, the kernel module will need to be reinstalled by executing (as root):

    /etc/init.d/vboxdrv setup

2.3.3. USB and advanced networking support

In order to use VirtualBox's USB support, the user account under which you intend to run VirtualBox must have read and write access to the USB filesystem (usbfs).

In addition, access to /dev/net/tun will be required if you want to use Host Interface Networking, which is described in detail in Section 6.5, “Bridged networking”.

2.3.4. Performing the installation

VirtualBox is available in a number of package formats native to various common Linux distributions (see Section 1.4, “Supported host operating systems” for details). In addition, there is an alternative generic installer (.run) which should work on most Linux distributions.

2.3.4.1. Installing VirtualBox from a Debian/Ubuntu package

First, download the appropriate package for your distribution. The following examples assume that you are installing to an Ubuntu Edgy system. Use dpkg to install the Debian package:

sudo dpkg -i VirtualBox_3.0.10_Ubuntu_edgy.deb

You will be asked to accept the VirtualBox Personal Use and Evaluation License. Unless you answer "yes" here, the installation will be aborted.

The group vboxusers will be created during installation. Note that a user who is going to run VirtualBox must be member of that group. A user can be made member of the group vboxusers through the GUI user/group management or at the command line with

sudo usermod -a -G vboxusers username

Also note that adding an active user to that group will require that user to log out and back in again. This should be done manually after successful installation of the package.

The installer will also search for a VirtualBox kernel module suitable for your kernel. The package includes pre-compiled modules for the most common kernel configurations. If no suitable kernel module is found, the installation script tries to build a module itself. If the build process is not successful you will be shown a warning and the package will be left unconfigured. Please have a look at /var/log/vbox-install.log to find out why the compilation failed. You may have to install the appropriate Linux kernel headers (see Section 2.3.2, “The VirtualBox kernel module”). After correcting any problems, do

sudo /etc/init.d/vboxdrv setup

This will start a second attempt to build the module.

If a suitable kernel module was found in the package or the module was successfully built, the installation script will attempt to load that module. If this fails, please see Section 11.5.1, “Linux kernel module refuses to load” for further information.

Once VirtualBox has been successfully installed and configured, you can start it by selecting "VirtualBox" in your start menu or from the command line (see Section 2.3.5, “Starting VirtualBox on Linux”).

2.3.4.2. Using the alternative installer (VirtualBox.run)

The alternative installer performs the following steps:

  • It unpacks the application files to a target directory of choice. By default,

    /opt/VirtualBox/

    will be used.

  • It builds the VirtualBox kernel module (vboxdrv) and installs it.

  • It creates /etc/init.d/vboxdrv, an init script to start the VirtualBox kernel module.

  • It creates a new system group called vboxusers.

  • It creates symbolic links to VirtualBox, VBoxSDL, VBoxVRDP, VBoxHeadless and VBoxManage in /usr/bin.

  • It creates /etc/udev/60-vboxdrv.rules, a description file for udev, if that is present, which makes the module accessible to anyone in the group vboxusers.

  • It writes the installation directory to /etc/vbox/vbox.cfg.

The installer must be executed as root with either install or uninstall as the first parameter. If you do not want the installer to ask you whether you wish to accept the license agreement (for example, for performing unattended installations), you can add the parameter license_accepted_unconditionally. Finally, if you want to use a directory other than the default installation directory, add the desired path as an extra parameter.

sudo ./VirtualBox.run install /opt/VirtualBox

Or if you do not have the "sudo" command available, run the following as root instead:

./VirtualBox.run install /opt/VirtualBox

After that you need to put every user which should be able to use VirtualBox in the group vboxusers, either through the GUI user management tools or by running the following command as root:

sudo usermod -a -G vboxusers username

Note

The usermod command of some older Linux distributions does not support the -a option (which adds the user to the given group without affecting membership of other groups). In this case, find out the current group memberships with the groups command and add all these groups in a comma-separated list to the command line after the -G option, e.g. like this: usermod -G group1,group2,vboxusers username.

If any users on your system should be able to access host USB devices from within VirtualBox guests, you should also add them to the appropriate user group that your distribution uses for USB access, e.g. usb or usbusers.

2.3.4.3. Performing a manual installation

If, for any reason, you cannot use the shell script installer described previously, you can also perform a manual installation. Invoke the installer like this:

./VirtualBox.run --keep --noexec

This will unpack all the files needed for installation in the directory install under the current directory. The VirtualBox application files are contained in VirtualBox.tar.bz2 which you can unpack to any directory on your system. For example:

sudo mkdir /opt/VirtualBox
sudo tar jxf ./install/VirtualBox.tar.bz2 -C /opt/VirtualBox

or as root:

mkdir /opt/VirtualBox
tar jxf ./install/VirtualBox.tar.bz2 -C /opt/VirtualBox

The sources for VirtualBox's kernel module are provided in the src directory. To build the module, change to the directory and issue

make

If everything builds correctly, issue the following command to install the module to the appropriate module directory:

sudo make install

In case you do not have sudo, switch the user account to root and perform

make install

The VirtualBox kernel module needs a device node to operate. The above make command will tell you how to create the device node, depending on your Linux system. The procedure is slightly different for a classical Linux setup with a /dev directory, a system with the now deprecated devfs and a modern Linux system with udev.

On certain Linux distributions, you might experience difficulties building the module. You will have to analyze the error messages from the build system to diagnose the cause of the problems. In general, make sure that the correct Linux kernel sources are used for the build process.

Note that the user who is going to run VirtualBox needs read and write permission on the VirtualBox kernel module device node /dev/vboxdrv. You can either define a vboxusers group by entering

groupadd vboxusers
chgrp vboxusers /dev/vboxdrv
chmod 660 /dev/vboxdrv

or, alternatively, simply give all users access (insecure, not recommended!)

chmod 666 /dev/vboxdrv

You should also add any users who will be allowed to use host USB devices in VirtualBox guests to the appropriate USB users group for your distribution. This group is often called usb or usbusers.

Next, you will have to install the system initialization script for the kernel module:

cp /opt/VirtualBox/vboxdrv.sh /etc/init.d/vboxdrv

(assuming you installed VirtualBox to the /opt/VirtualBox directory) and activate the initialization script using the right method for your distribution. You should create VirtualBox's configuration file:

mkdir /etc/vbox
echo INSTALL_DIR=/opt/VirtualBox > /etc/vbox/vbox.cfg

and, for convenience, create the following symbolic links:

ln -sf /opt/VirtualBox/VBox.sh /usr/bin/VirtualBox
ln -sf /opt/VirtualBox/VBox.sh /usr/bin/VBoxSVC
ln -sf /opt/VirtualBox/VBox.sh /usr/bin/VBoxManage
ln -sf /opt/VirtualBox/VBox.sh /usr/bin/VBoxHeadless
ln -sf /opt/VirtualBox/VBox.sh /usr/bin/VBoxSDL

2.3.4.4. Updating and uninstalling VirtualBox

Before updating or uninstalling VirtualBox, you must terminate any virtual machines which are currently running and exit the VirtualBox or VBoxSVC applications. To update VirtualBox, simply run the installer of the updated version. To uninstall VirtualBox, invoke the installer like this:

sudo ./VirtualBox.run uninstall

or as root

./VirtualBox.run uninstall

. Starting with version 2.2.2, you can uninstall the .run package by invoking

/opt/VirtualBox/uninstall.sh

To manually uninstall VirtualBox, simply undo the steps in the manual installation in reverse order.

2.3.4.5. Automatic installation of Debian packages

The Debian packages will request some user feedback when installed for the first time. The debconf system is used to perform this task. To prevent any user interaction during installation, default values can be defined. A file vboxconf can contain the following debconf settings:

virtualbox virtualbox/module-compilation-allowed boolean true
virtualbox virtualbox/delete-old-modules boolean true

The first line allows compilation of the vboxdrv kernel module if no module was found for the current kernel. The second line allows the package to delete any old vboxdrv kernel modules compiled by previous installations.

These default settings can be applied with

debconf-set-selections vboxconf

prior to the installation of the VirtualBox Debian package.

2.3.4.6. Automatic installation of .rpm packages

The .rpm format does not provide a configuration system comparable to the debconf system. To configure the installation process of our .rpm packages, a file /etc/default/virtualbox is interpreted. The automatic generation of the udev rule can be prevented by the following setting:

INSTALL_NO_UDEV=1

The creation of the group vboxusers can be prevented by

INSTALL_NO_GROUP=1

If the line

INSTALL_NO_VBOXDRV=1

is specified, the package installer will not try to build the vboxdrv kernel module if no module according to the current kernel was found.

2.3.5. Starting VirtualBox on Linux

The easiest way to start a VirtualBox program is by running the program of your choice (VirtualBox, VBoxManage, VBoxSDL or VBoxHeadless) from a terminal. These are symbolic links to VBox.sh that start the required program for you.

The following detailed instructions should only be of interest if you wish to execute VirtualBox without installing it first. You should start by compiling the vboxdrv kernel module (see above) and inserting it into the Linux kernel. VirtualBox consists of a service daemon (VBoxSVC) and several application programs. The daemon is automatically started if necessary. All VirtualBox applications will communicate with the daemon through Unix local domain sockets. There can be multiple daemon instances under different user accounts and applications can only communicate with the daemon running under the user account as the application. The local domain socket resides in a subdirectory of your system's directory for temporary files called .vbox-<username>-ipc. In case of communication problems or server startup problems, you may try to remove this directory.

All VirtualBox applications (VirtualBox, VBoxSDL, VBoxManage and VBoxHeadless) require the VirtualBox directory to be in the library path:

LD_LIBRARY_PATH=. ./VBoxManage showvminfo "Windows XP"

[7] See http://en.wikipedia.org/wiki/Dynamic_Kernel_Module_Support for an introduction.


2.4. Installing on Solaris hosts

For the various versions of Solaris that we support as host operating systems, please refer to Section 1.4, “Supported host operating systems”.

If you have a previously installed instance of VirtualBox on your Solaris host, please uninstall it first before installing a new instance. Refer to Section 2.4.3, “Uninstallation” for uninstall instructions.

2.4.1. Performing the installation

VirtualBox is available as a standard Solaris package. Download the VirtualBox SunOS package which includes both the 32-bit and 64-bit versions of VirtualBox. The installation must be performed as root and from the global zone as the VirtualBox installer loads kernel drivers which cannot be done from non-global zones. To verify which zone you are currently in, execute the zonename command. Execute the following commands:

gunzip -cd VirtualBox-3.0.10-SunOS-x86.tar.gz | tar xvf -

Starting with VirtualBox 1.6.2 we ship the VirtualBox kernel interface module (vbi). The purpose of this module is to shield the VirtualBox kernel driver from changes to the SunOS kernel. If you do not have vbi already installed (check for the existence of the file /platform/i86pc/kernel/misc/vbi) install it by executing the command:

pkgadd -G -d VirtualBoxKern-3.0.10-SunOS.pkg

Future versions of OpenSolaris may ship the VirtualBox kernel interface module, in which case you can remove this one before upgrading OpenSolaris.

Next you should install the main VirtualBox package using:

pkgadd -d VirtualBox-3.0.10-SunOS-x86.pkg

Note

If you are using Solaris Zones, to install VirtualBox only into the current zone and not into any other zone, use pkgadd -G. For more information refer to the pkgadd manual; see also Section 2.4.5, “Configuring a zone for running VirtualBox”.

The installer will then prompt you to enter the package you wish to install. Choose "1" or "all" and proceed. Next the installer will ask you if you want to allow the postinstall script to be executed. Choose "y" and proceed as it is essential to execute this script which installs the VirtualBox kernel module. Following this confirmation the installer will install VirtualBox and execute the postinstall setup script.

Once the postinstall script has been executed your installation is now complete. You may now safely delete the uncompressed package and autoresponse files from your system. VirtualBox would be installed in /opt/VirtualBox.

2.4.2. Starting VirtualBox on Solaris

The easiest way to start a VirtualBox program is by running the program of your choice (VirtualBox, VBoxManage, VBoxSDL or VBoxHeadless) from a terminal. These are symbolic links to VBox.sh that start the required program for you.

Alternatively, you can directly invoke the required programs from /opt/VirtualBox. Using the links provided is easier as you do not have to type the full path.

You can configure some elements of the VirtualBox Qt GUI such as fonts and colours by executing VBoxQtconfig from the terminal.

2.4.3. Uninstallation

Uninstallation of VirtualBox on Solaris requires root permissions. To perform the uninstallation, start a root terminal session and execute:

pkgrm SUNWvbox

After confirmation, this will remove VirtualBox from your system.

To uninstall the VirtualBox kernel interface module, execute:

pkgrm SUNWvboxkern

2.4.4. Unattended installation

To perform a non-interactive installation of VirtualBox we have provided a response file named autoresponse that the installer will use for responses to inputs rather than ask them from you.

Extract the tar.gz package as described in the normal installation. Then open a root terminal session and execute:

pkgadd -d VirtualBox-3.0.10-SunOS-x86 -n -a autoresponse SUNWvbox

To perform a non-interactive uninstallation, open a root terminal session and execute:

pkgrm -n -a /opt/VirtualBox/autoresponse SUNWvbox

2.4.5. Configuring a zone for running VirtualBox

Starting with VirtualBox 1.6 it is possible to run VirtualBox from within Solaris zones. For an introduction of Solaris zones, please refer to http://www.sun.com/bigadmin/features/articles/solaris_zones.jsp.

Assuming that VirtualBox has already been installed into your zone, you need to give the zone access to VirtualBox's device node. This is done by performing the following steps. Start a root terminal and execute:

zonecfg -z vboxzone

Inside the zonecfg prompt add the device resource and match properties to the zone. Here's how it can be done:

zonecfg:vboxzone>add device
zonecfg:vboxzone:device>set match=/dev/vboxdrv
zonecfg:vboxzone:device>end
zonecfg:vboxzone>verify
zonecfg:vboxzone>exit

If you are running VirtualBox 2.2.0 or above on OpenSolaris or Nevada hosts, you should add a device for /dev/vboxusbmon too, similar to what was shown above. This does not apply to Solaris 10 hosts due to lack of USB support.

Replace "vboxzone" with the name of the zone in which you intend to run VirtualBox. Next reboot the zone using zoneadm and you should be able to run VirtualBox from within the configured zone.


Chapter 3. Starting out with VirtualBox

Table of Contents

3.1. Starting the graphical user interface
3.2. Creating a virtual machine
3.3. Basics of virtual machine configuration
3.4. Running a virtual machine
3.4.1. Keyboard and mouse support in virtual machines
3.4.2. Changing removable media
3.4.3. Saving the state of the machine
3.4.4. Snapshots
3.5. The Virtual Disk Manager
3.6. Deleting virtual machines
3.7. Virtual machine settings
3.7.1. General settings
3.7.2. System settings
3.7.3. Display settings
3.7.4. Hard disk settings
3.7.5. CD/DVD-ROM and floppy settings
3.7.6. Audio settings
3.7.7. Network settings
3.7.8. Serial ports
3.7.9. USB support
3.7.10. Shared folders
3.8. Importing and exporting virtual machines

As already mentioned in Section 1.1, “Virtualization basics”, VirtualBox allows you to run each of your guest operating systems on its own virtual computer system, which is called a "virtual machine" (VM). The guest system will run in its VM as if it were installed on a real computer, according to the VM settings you have specified. All software running on the guest system does so as it would on a real machine.

You have considerable latitude in deciding what virtual hardware will be provided to the guest. The virtual hardware can be used for communicating with the host system or with other guests. For instance, if you provide VirtualBox with the image of a CD-ROM in an ISO file, VirtualBox can present this image to a guest system as if it were a physical CD-ROM. Similarly, you can give a guest system access to the real network via its virtual network card, and, if you choose, give the host system, other guests, or computers on the Internet access to the guest system.

VirtualBox comes with many advanced interfaces, which will be described later in this manual:

  • Section 7.3, “VBoxSDL, the simplified VM displayer” explains how to run a single VM at a time with a reduced graphical interface;

  • Section 7.4.2, “VBoxHeadless, the VRDP-only server” shows how to run virtual machines remotely;

  • Chapter 8, VBoxManage reference explains how to create, configure, and control virtual machines completely from the command line.

The following introductory sections, however, describe VirtualBox, the graphical user interface, which is the simplest way to get started.

3.1. Starting the graphical user interface

Depending on your host operating system, you can start VirtualBox as follows:

  • On a Windows host, in the standard "Programs" menu, click on the item in the "VirtualBox" group.

  • On a Mac OS X host, in the Finder, double-click on the "VirtualBox" item in the "Applications" folder. (You may want to drag this item onto your Dock.)

  • On a Linux or Solaris host, depending on your desktop environment, a "VirtualBox" item may have been placed in either the "System" or "System Tools" group of your "Applications" menu. Alternatively, you can type VirtualBox in a terminal.

A window like the following should come up:

On the left, you can see a pane that lists all the virtual machines you have created so far (quite a few in the example above). A row of buttons above it allows you to create new VMs and work on existing VMs. The pane on the right displays the properties of the virtual machine currently selected, if any.

When you start VirtualBox for the first time, as there is no virtual machine yet, everything will be empty.


3.2. Creating a virtual machine

Clicking on the "New" button in the user interface will guide you through setting up a new virtual machine (VM). A wizard will show up:

On the following pages, the wizard will ask you for the bare minimum of information that is needed to create a VM, in particular:

  1. A name for your VM, and the type of operating system (OS) you want to install.

    The name is what you will later see in the VirtualBox main window, and what your settings will be stored under. It is purely informational, but once you have created a few VMs, you will appreciate if you have given your VMs informative names. "My VM" probably is therefore not as useful as "Windows XP SP2".

    For "Operating System Type", select the operating system that you want to install later. Depending on your selection, VirtualBox will enable or disable certain VM settings that your guest operating system may require. This is particularly important for 64-bit guests (see Section 1.6, “64-bit guests”). It is therefore recommended to always set it to the correct value.

  2. The amount of memory (RAM) that the virtual machine should have for itself. Every time a virtual machine is started, VirtualBox will allocate this much memory from your host machine and present it to the guest operating system, which will report this size as the (virtual) computer's installed RAM.

    Note

    Choose this setting carefully! The memory you give to the VM will not be available to your host OS while the VM is running, so do not specify more than you can spare. For example, if your host machine has 1 GB of RAM and you enter 512 MB as the amount of RAM for a particular virtual machine, while that VM is running, you will only have 512 MB left for all the other software on your host. If you run two VMs at the same time, even more memory will be allocated for the second VM (which may not even be able to start if that memory is not available). On the other hand, you should specify as much as your guest OS (and your applications) will require to run properly.

    A Windows XP guest will require at least a few hundred MB RAM to run properly, and Windows Vista will even refuse to install with less than 512 MB. Of course, if you want to run graphics-intensive applications in your VM, you may require even more RAM.

    So, as a rule of thumb, if you have 1 GB of RAM or more in your host computer, it is usually safe to allocate 512 MB to each VM. But, in any case, make sure you always have at least 256-512 MB of RAM left on your host operating system. Otherwise you may cause your host OS to excessively swap out memory to your hard disk, effectively bringing your host system to a standstill.

    As with the other settings, you can change this setting later, after you have created the VM.

  3. Next, you must specify a virtual hard disk for your VM.

    There are many and potentially complicated ways in which VirtualBox can provide hard disk space to a VM (see Chapter 5, Virtual storage for details), but the most common way is to use a large image file on your "real" hard disk, whose contents VirtualBox presents to your VM as if it were a complete hard disk.

    The wizard presents to you the following window:

    The wizard allows you to create an image file or use an existing one. Note also that the disk images can be separated from a particular VM, so even if you delete a VM, you can keep the image, or copy it to another host and create a new VM for it there.

    In the wizard, you have the following options:

    • If you have previously created any virtual hard disks which have not been attached to other virtual machines, you can select those from the drop-down list in the wizard window.

    • Otherwise, to create a new virtual hard disk, press the "New" button.

    • Finally, for more complicated operations with virtual disks, the "Existing..." button will bring up the Virtual Disk Manager, which is described in more detail in Section 3.5, “The Virtual Disk Manager”.

    Most probably, if you are using VirtualBox for the first time, you will want to create a new disk image. Hence, press the "New" button.

    This brings up another window, the "Create New Virtual Disk Wizard".

    VirtualBox supports two types of image files:

    • A dynamically expanding file will only grow in size when the guest actually stores data on its virtual hard disk. It will therefore initially be small on the host hard drive and only later grow to the size specified as it is filled with data.

    • A fixed-size file will immediately occupy the file specified, even if only a fraction of the virtual hard disk space is actually in use. While occupying much more space, a fixed-size file incurs less overhead and is therefore slightly faster than a dynamically expanding file.

    For details about the differences, please refer to Section 5.2, “Disk image files (VDI, VMDK, VHD)”.

    To prevent your physical hard disk from running full, VirtualBox limits the size of the image file. Still, it needs to be large enough to hold the contents of your operating system and the applications you want to install -- for a modern Windows or Linux guest, you will probably need several gigabytes for any serious use:

    After having selected or created your image file, again press "Next" to go to the next page.

  4. After clicking on "Finish", your new virtual machine will be created. You will then see it in the list on the left side of the main window, with the name you have entered.


3.3. Basics of virtual machine configuration

When you select a virtual machine from the list in the main VirtualBox window, you will see a summary of that machine's settings on the right of the window, under the "Details" tab.

Clicking on the "Settings" button in the toolbar at the top of VirtualBox main window brings up a detailed window where you can configure many of the properties of the VM that is currently selected. But be careful: even though it is possible to change all VM settings after installing a guest operating system, certain changes might prevent a guest operating system from functioning correctly if done after installation.

Note

The "Settings" button is disabled while a VM is either in the "running" or "saved" state. This is simply because the settings dialog allows you to change fundamental characteristics of the virtual computer that is created for your guest operating system, and this operating system may not take it well when, for example, half of its memory is taken away from under its feet. As a result, if the "Settings" button is disabled, shut down the current VM first.

VirtualBox provides a plethora of parameters that can be changed for a virtual machine. The various settings that can be changed in the "Settings" window are described in detail in Section 3.7, “Virtual machine settings”. Even more parameters are available with the command line interface; see Chapter 8, VBoxManage reference.

For now, if you have just created an empty VM, you will probably be most interested in the settings presented by the "CD/DVD-ROM" section if you want to make a CD-ROM or a DVD-ROM available the first time you start it, in order to install your guest operating system.

For this, you have two options:

  • If you have actual CD or DVD media from which you want to install your guest operating system (e.g. in the case of a Windows installation CD or DVD), put the media into your host's CD or DVD drive.

    Then, in the settings dialog, go to the "CD/DVD-ROM" section and select "Host drive" with the correct drive letter (or, in the case of a Linux host, device file).

    This will allow your VM to access the media in your host drive, and you can proceed to install from there.

  • If you have downloaded installation media from the Internet in the form of an ISO image file (most probably in the case of a Linux distribution), you would normally burn this file to an empty CD or DVD and proceed as just described. With VirtualBox however, you can skip this step and mount the ISO file directly. VirtualBox will then present this file as a CD or DVD-ROM drive to the virtual machine, much like it does with virtual hard disk images.

    In this case, in the settings dialog, go to the "CD/DVD-ROM" section and select "ISO image file". This brings up the Virtual Disk Image Manager, where you perform the following steps:

    1. Press the "Add" button to add your ISO file to the list of registered images. This will present an ordinary file dialog that allows you to find your ISO file on your host machine.

    2. Back to the manager window, select the ISO file that you just added and press the "Select" button. This selects the ISO file for your VM.

    The Virtual Disk Image Manager is described in detail in Section 3.5, “The Virtual Disk Manager”.


3.4. Running a virtual machine

The "Start" button in the main window starts the virtual machine that is currently selected.

This opens up a new window, and the virtual machine which you selected will boot up. Everything which would normally be seen on the virtual system's monitor is shown in the window, as can be seen with the image in Section 1.1, “Virtualization basics”.

In general, you can use the virtual machine much like you would use a real computer. There are couple of points worth mentioning however.

3.4.1. Keyboard and mouse support in virtual machines

3.4.1.1. Capturing and releasing keyboard and mouse

Since the operating system in the virtual machine does not "know" that it is not running on a real computer, it expects to have exclusive control over your keyboard and mouse. This is, however, not the case since, unless you are running the VM in full-screen mode, your VM needs to share keyboard and mouse with other applications and possibly other VMs on your host.

As a result, initially after installing a host operating system and before you install the guest additions (we will explain this in a minute), only one of the two -- your VM or the rest of your computer -- can "own" the keyboard and the mouse. You will see a second mouse pointer which will always be confined to the limits of the VM window. Basically, you activate the VM by clicking inside it.

To return ownership of keyboard and mouse to your host operating system, VirtualBox reserves a special key on your keyboard for itself: the "host key". By default, this is the right Control key on your keyboard; on a Mac host, the default host key is the left Command key. You can change this default in the VirtualBox Global Settings. In any case, the current setting for the host key is always displayed at the bottom right of your VM window, should you have forgotten about it:

In detail, all this translates into the following:

  • Your keyboard is owned by the VM if the VM window on your host desktop has the keyboard focus (and then, if you have many windows open in your guest operating system as well, the window that has the focus in your VM). This means that if you want to type within your VM, click on the title bar of your VM window first.

    To release keyboard ownership, press the Host key (as explained above, typically the right Control key).

    Note that while the VM owns the keyboard, some key sequences (like Alt-Tab for example) will no longer be seen by the host, but will go to the guest instead. After you press the host key to re-enable the host keyboard, all key presses will go through the host again, so that sequences like Alt-Tab will no longer reach the guest.

  • Your mouse is owned by the VM only after you have clicked in the VM window. The host mouse pointer will disappear, and your mouse will drive the guest's pointer instead of your normal mouse pointer.

    Note that mouse ownership is independent of that of the keyboard: even after you have clicked on a titlebar to be able to type into the VM window, your mouse is not necessarily owned by the VM yet.

    To release ownership of your mouse by the VM, also press the Host key.

As this behavior can be inconvenient, VirtualBox provides a set of tools and device drivers for guest systems called the "VirtualBox Guest Additions" which make VM keyboard and mouse operation a lot more seamless. Most importantly, the Additions will get rid of the second "guest" mouse pointer and make your host mouse pointer work directly in the guest.

This will be described later in Chapter 4, Guest Additions.

3.4.1.2. Typing special characters

Operating systems expect certain key combinations to initiate certain procedures. Some of these key combinations may be difficult to enter into a virtual machine, as there are three candidates as to who receives keyboard input: the host operating system, VirtualBox, or the guest operating system. Who of these three receives keypresses depends on a number of factors, including the key itself.

  • Host operating systems reserve certain key combinations for themselves. For example, it is impossible to enter the Ctrl+Alt+Delete combination if you want to reboot the guest operating system in your virtual machine, because this key combination is usually hard-wired into the host OS (both Windows and Linux intercept this), and pressing this key combination will therefore reboot your host.

    Also, on systems running the X Window System, the key combination Ctrl+Alt+Backspace normally resets the X server (to restart the entire graphical user interface in case it got stuck). As the X server intercepts this combination, pressing it will usually restart your host graphical user interface (and kill all running programs, including VirtualBox, in the process).

    Third, on systems supporting virtual terminals, the key combination Ctrl+Alt+Fx (where Fx is one of the function keys from F1 to F12) normally allows to switch between virtual terminals. As with Ctrl+Alt+Delete, these combinations are intercepted by the host operating system and therefore always switch terminals on the host.

    If, instead, you want to send these key combinations to the guest operating system in the virtual machine, you will need to use one of the following methods:

    • Use the items in the "Machine" menu of the virtual machine window. There you will find "Insert Ctrl+Alt+Delete" and "Ctrl+Alt+Backspace"; the latter will only have an effect with Linux guests, however.

    • Press special key combinations with the Host key (normally the right Control key), which VirtualBox will then translate for the virtual machine:

      • Host key + Del to send Ctrl+Alt+Del (to reboot the guest);

      • Host key + Backspace to send Ctrl+Alt+Backspace (to restart the graphical user interface of a Linux guest);

      • Host key + F1 (or other function keys) to simulate Ctrl+Alt+F1 (or other function keys, i.e. to switch between virtual terminals in a Linux guest).

  • For some other keyboard combinations such as Alt-Tab (to switch between open windows), VirtualBox allows you to configure whether these combinations will affect the host or the guest, if a virtual machine currently has the focus. This is a global setting for all virtual machines and can be found under "File" -> "Global settings" -> "Input" -> "Auto-capture keyboard".

3.4.2. Changing removable media

While a virtual machine is running, you can change removable media in the "Devices" menu of the VM's window. Here you can select in detail what VirtualBox presents to your VM as a CD, DVD, or floppy.

The settings are the same as would be available for the VM in the "Settings" dialog of the VirtualBox main window, but since that dialog is disabled while the VM is in the "running" or "saved" state, this extra menu saves you from having to shut down and restart the VM every time you want to change media.

Hence, in the "Devices" menu, VirtualBox allows you to attach the host drive to the guest or select a floppy or DVD image using the Disk Image Manager, all as described in Section 3.3, “Basics of virtual machine configuration”.

3.4.3. Saving the state of the machine

When you click on the "Close" button of your virtual machine window (at the top right of the window, just like you would close any other window on your system) (or press the Host key together with "Q"), VirtualBox asks you whether you want to "save" or "power off" the VM.

The difference between these three options is crucial. They mean:

  • Save the machine state: With this option, VirtualBox "freezes" the virtual machine by completely saving its state to your local disk. When you later resume the VM (by again clicking the "Start" button in the VirtualBox main window), you will find that the VM continues exactly where it was left off. All your programs will still be open, and your computer resumes operation.

    Saving the state of a virtual machine is thus in some ways similar to suspending a laptop computer (e.g. by closing its lid).

  • Send the shutdown signal. This will send an ACPI shutdown signal to the virtual machine, which has the same effect as if you had pressed the power button on a real computer. So long as a fairly modern operating system is installed and running in the VM, this should trigger a proper shutdown mechanism in the VM.

  • Power off the machine: With this option, VirtualBox also stops running the virtual machine, but without saving its state.

    This is equivalent to pulling the power plug on a real computer without shutting it down properly. If you start the machine again after powering it off, your operating system will have to reboot completely and may begin a lengthy check of its (virtual) system disks.

    As a result, this should not normally be done, since it can potentially cause data loss or an inconsistent state of the guest system on disk.

The "Discard" button in the main VirtualBox window discards a virtual machine's saved state. This has the same effect as powering it off, and the same warnings apply.

3.4.4. Snapshots

With VirtualBox's snapshots, you can save a particular state of a virtual machine for later use. At any later time, you can revert to that state, even though you may have changed the VM considerably since then.

This is particularly useful for making sure that a guest installation is not damaged by accidental changes, misbehaving software, or viruses.

Once you have set up the machine the way you want it, simply take a snapshot, and should anything happen to the installation, you can simply revert to its snapshot state.

To take a snapshot of your VM, perform the following steps:

  1. If your VM is currently in either the "saved" or the "powered off" state (as displayed next to the VM in the VirtualBox main window), click on the "Snapshots" tab on the top right of the main window, and then on the small camera icon (for "Take snapshot").

    If your VM is currently running, select "Take snapshot" from the "Machine" pull-down menu of the VM window.

  2. A window will pop up and ask you to name the snapshot. This name is purely for reference purposes to help you remember the state of the snapshot. For example, a useful name would be "Fresh installation from scratch, no external drivers".

  3. Your new snapshot will then appear in the list of snapshots under the "Snapshots" tab. Underneath, you will see an item called "Current state", signifying that the current state of your VM is a variation based on the snapshot you took earlier.

    (If you later take another snapshot, you will see that they will be displayed in sequence, and each subsequent snapshot is a derivation of the earlier one.)

To revert to an earlier snapshot, you right-click on the "Current state" item and select "Revert to current snapshot". This will bring the VM back to the state of the nearest (most recent) snapshot. Similarly, you can merge several earlier snapshots into one by right-clicking on a snapshot and selecting "Discard snapshot".

Note

The snapshot reverted to will affect the virtual hard drives that are connected to your VM, as the entire state of the virtual hard drive will be reverted as well. This means also that all files that have been created since the snapshot and all other file changes will be lost. In order to prevent such data loss while still making use of the snapshot feature, it is possible to add a second hard drive in "write-through" mode using the VBoxManage interface and use it to store your data. As write-through hard drives are not included in snapshots, they remain unaltered when a machine is reverted. See Section 5.3, “Configuring image write operations” for details.


3.5. The Virtual Disk Manager

VirtualBox keeps an internal registry of all available hard disk, CD/DVD-ROM and floppy disk images. This registry can be viewed and changed in the Virtual Disk Manager, which you can access from the "File" menu in the VirtualBox main window:

The Disk Image Manager shows you all images that are currently registered with VirtualBox, conveniently grouped in three tabs for the three possible formats. These formats are:

  • Hard disk images, either in VirtualBox's own Virtual Disk Image (VDI) format or in the widely supported VMDK format[8];

  • CD/DVD images in standard ISO format;

  • floppy images in standard RAW format.

As you can see in the screenshot above, for each image, the Virtual Disk Manager shows you the full path of the image file and other information, such as the virtual machine the image is currently attached to, if any. Also, as can be seen in the screenshot, if you have created snapshots for a virtual machine, additional "differencing" hard disk images may automatically be created; see Section 3.4.4, “Snapshots” for details.

The Virtual Disk Manager allows you to

  • create new hard disk images using the "New" button; this will bring up the "Create Disk Image" wizard already described in Section 3.2, “Creating a virtual machine”;

  • import existing VDI or VMDK files from your hard drive into VirtualBox using the "Add" button;

  • remove an image from the registry (and optionally delete the image file when doing so);

  • "release" an image, that is, detach it from a virtual machine if it is currently attached to one as a virtual hard disk.

We recommend that you maintain two special folders on your system for keeping images: one for hard disk image files (which can, in the case of dynamically expanding images, grow to considerable sizes), and one for ISO files (which were probably downloaded from the Internet).

Hard disk image files can be copied onto other host systems and imported into virtual machines there, although certain guest systems (notably Windows 2000 and XP) will require that the new virtual machine be set up in a similar way to the old one.

Note

Do not simply make copies of virtual disk images. If you import such a second copy into a virtual machine, VirtualBox will complain with an error, since VirtualBox assigns a unique identifier (UUID) to each disk image to make sure it is only used once. See Section 5.4, “Cloning disk images” for instructions on this matter.

Details about the different container formats supported by VirtualBox are described in Chapter 5, Virtual storage.

[8] With the VMDK support of VirtualBox, you can continue using VMDK images you may have created with another virtualization product that uses the VMDK format. See Section 5.2, “Disk image files (VDI, VMDK, VHD)” for details.


3.6. Deleting virtual machines

The "Delete" button in the main VirtualBox window lets you remove a virtual machine which you no longer need. All settings for that machine will be lost. However, any hard disk images attached to the machine will be kept; you can delete those separately using the Disk Image Manager (described just above).

You cannot delete a machine which has snapshots or is in a saved state, so you must discard these first.


3.7. Virtual machine settings

Most of the settings described below are available in the settings window after selecting a virtual machine in the VirtualBox main window and clicking on the "Settings" button. To keep the user interface simple, those of the following settings which are not as commonly used are not shown in that settings window. They are, however, available through VBoxManage and will be described in Chapter 8, VBoxManage reference later.

3.7.1. General settings

In the Settings window, under "General", you can configure the most fundamental aspects of the virtual machine such as memory and essential hardware. There are four tabs, "Basic", "Advanced", "Description" and "Other".

3.7.1.1. "Basic" tab

Under the "Basic" tab of the "General" settings category, you can find these settings:

Name

The name under which the VM is shown in the list of VMs in the main window. Under this name, VirtualBox also saves the VM's configuration files. By changing the name, VirtualBox renames these files as well. As a result, you can only use characters which are allowed in your host operating system's file names.

Note that internally, VirtualBox uses unique identifiers (UUIDs) to identify virtual machines. You can display these with VBoxManage.

Operating system / Version

The type of the guest operating system that is (or will be) installed in the VM. This is the same setting that was specified in the "New Virtual Machine" wizard, as described with Section 3.2, “Creating a virtual machine” above.

3.7.1.2. "Advanced" tab

Snapshot folder

By default, VirtualBox saves snapshot data together with your other VirtualBox configuration data; see Section 9.1, “VirtualBox configuration data”. With this setting, you can specify any other folder for each VM.

Shared clipboard

If the virtual machine has Guest Additions installed, you can select here whether the clipboard of the guest operating system should be shared with that of your host. If you select "Bidirectional", then VirtualBox will always make sure that both clipboards contain the same data. If you select "Host to guest" or "Guest to host", then VirtualBox will only ever copy clipboard data in one direction.

Remember mounted media at runtime

If this is checked, VirtualBox will save the state of what media has been mounted between several runs of a virtual machine.

Mini toolbar

In full screen or seamless mode, VirtualBox can display a small toolbar that contains some of the items that are normally available from the virtual machine's menu bar. This toolbar reduces itself to a small gray line unless you move the mouse over it. With the toolbar, you can return from full screen or seamless mode, control machine execution or enable certain devices. If you don't want to see the toolbar, disable this setting.

3.7.1.3. "Description" tab

Here you can enter any description for your virtual machine, if you want. This has no effect of the functionality of the machine, but you may find this space useful to note down things like the configuration of a virtual machine and the software that has been installed into it.

3.7.2. System settings

The "System" category groups various settings that are related to the basic hardware that is presented to the virtual machine.

Note

As the activation mechanism of Microsoft Windows is sensitive to hardware changes, if you are changing hardware settings for a Windows guest, some of these changes may trigger a request for another activation with Microsoft.

3.7.2.1. "Motherboard" tab

On the "Motherboard" tab, you can influence virtual hardware that would normally be on the motherboard of a real computer.

Base memory

This sets the amount of RAM that is allocated and given to the VM when it is running. The specified amount of memory will be requested from the host operating system, so it must be available or made available as free memory on the host when attempting to start the VM and will not be available to the host while the VM is running. This is the same setting that was specified in the "New Virtual Machine" wizard, as described with guidelines under Section 3.2, “Creating a virtual machine” above.

Generally, it is possible to change the memory size after installing the guest operating system (provided you do not reduce the memory to an amount where the operating system would no longer boot).

Boot order

This setting determines the order in which the guest operating system will attempt to boot from the various virtual boot devices. Analogous to a real PC's BIOS setting, VirtualBox can tell a guest OS to start from the virtual floppy, the virtual CD/DVD drive, the virtual hard drive (each of these as defined by the other VM settings), the network, or none of these.

If you select "Network", the VM will attempt to boot from a network via the PXE mechanism. This needs to be configured in detail on the command line; please see Section 8.5, “VBoxManage modifyvm”.

Enable ACPI

VirtualBox can present the Advanced Configuration and Power Interface (ACPI) to the guest operating system for configuring the virtual hardware. In addition, via ACPI, VirtualBox can present the host's power status information to the guest.

ACPI is the current industry standard to allow operating systems to recognize hardware, configure motherboards and other devices and manage power. As all modern PCs contain this feature and Windows and Linux have been supporting it for years, it is also enabled by default in VirtualBox.

Warning

All Windows operating systems starting with Windows 2000 install different kernels depending on whether ACPI is available, so ACPI must not be turned off after installation of a Windows guest OS. Turning it on after installation will have no effect however.

Enable I/O APIC

Advanced Programmable Interrupt Controllers (APICs) are a newer x86 hardware feature that have replaced old-style Programmable Interrupt Controllers (PICs) in recent years. With an I/O APIC, operating systems can use more than 16 interrupt requests (IRQs) and therefore avoid IRQ sharing for improved reliability.

Note

Enabling the I/O APIC is required for 64-bit guest operating systems, especially Windows Vista; it is also required if you want to use more than one virtual CPU in a virtual machine.

However, software support for I/O APICs has been unreliable with some operating systems other than Windows. Also, the use of an I/O APIC slightly increases the overhead of virtualization and therefore slows down the guest OS a little.

Warning

All Windows operating systems starting with Windows 2000 install different kernels depending on whether an I/O APIC is available. As with ACPI, the I/O APIC therefore must not be turned off after installation of a Windows guest OS. Turning it on after installation will have no effect however.

3.7.2.2. "Processor" tab

On the "Processor" tab, you can set how many virtual CPU cores the guest operating systems should see. Starting with version 3.0, VirtualBox supports symmetrical multiprocessing (SMP) and can present up to 32 virtual CPU cores to each virtual machine.

You should not, however, configure virtual machines to use more CPU cores than you have available physically.

In addition, the "Enable PAE/NX" setting determines whether the PAE and NX capabilities of the host CPU will be exposed to the virtual machine. PAE stands for "Physical Address Extension". Normally, if enabled and supported by the operating system, then even a 32-bit x86 CPU can access more than 4 GB of RAM. This is made possible by adding another 4 bits to memory addresses, so that with 36 bits, up to 64 GB can be addressed. Some operating systems (such as Ubuntu Server) require PAE support from the CPU and cannot be run in a virtual machine without it.

3.7.2.3. "Acceleration" tab

On this page, you can determine whether VirtualBox should make use of hardware virtualization; see Section 1.2, “Software vs. hardware virtualization (VT-x and AMD-V)” for an introduction.

The "Enable VT-x/AMD-V" setting determines whether the virtualization engine will try to use the host CPU's hardware virtualization extensions such as Intel VT-x and AMD-V. For 64-bit guest operating systems, SMP and for some rather exotic guest operating systems such as OS/2, this setting needs to be enabled.

Starting with VirtualBox 2.2, this setting is enabled by default for newly created machines.

Nested paging is not enabled automatically when you enable hardware virtualization; you can enable it separately once you have enabled hardware virtualization.

Note

You can mix software and hardware virtualization when running multiple VMs. In certain cases a small performance penalty will be unavoidable when mixing VT-x and software virtualization VMs. We recommend not mixing virtualization modes if maximum performance and low overhead are essential. This does not apply to AMD-V.

3.7.3. Display settings

Video memory size

This sets the size of the memory provided by the virtual graphics card available to the guest, in MB. As with the main memory, the specified amount will be allocated from the host's resident memory. Based on the amount of video memory, higher resolutions and color depths may be available.

Enable 3D acceleration

If the virtual machine has Guest Additions installed, you can select here whether the guest should support accelerated 3D graphics. Please refer to Section 4.8, “Hardware 3D acceleration (OpenGL and DirectX 8/9)” for details.

Remote display

Under the "Remote display" tab, you can enable the VRDP server that is built into VirtualBox to allow you to connect to the virtual machine remotely. For this, you can use any standard RDP viewer, such as the one that comes with Microsoft Windows (typically found under "Accessories" -> "Communication" -> "Remote Desktop Connection") or, on Linux systems, the standard open-source rdesktop program.

These features are described in detail in Section 7.4, “Remote virtual machines (VRDP support)”.

3.7.4. Hard disk settings

In the VM Settings window, the "Hard Disks" section allows you to connect virtual hard disk images to your virtual machine:

As with a real PC, VirtualBox by default offers you two IDE controllers, each with a "master" and a "slave" connection. With one of these four connectors being reserved to the CD-ROM/DVD drive (see below), that leaves you with three possible hard disks, each represented by one disk image file.

You can select which IDE controller type VirtualBox should present to the virtual machine (PIIX3, PIIX4 or ICH6). This should not make much of a difference, but if you import a virtual machine from another virtualization product, the operating system in that machine may expect a particular controller and crash if it isn't found.

In addition to the IDE controller, VirtualBox can also present either an SATA or SCSI controller to the guest; however, this may require that you run a modern guest operating system. See Section 5.1, “Hard disk controllers: IDE, SATA (AHCI), SCSI” for details.

The settings of the first IDE disk (the "primary master") are initially set by the "Create VM" wizard. In many cases, you will stick with this default for the rest of a VM's lifetime. You may, however, freely remove, add and exchange virtual hard drives after the machine has been set up. For example, if you wish to copy some files from another virtual disk that you created, you can connect that disk as a second hard disk.

To connect an additional disk, double-click on the empty space in the list of virtual disks, or click on the respective icon to the right of that list. You can then select where the virtual disk should be connected to (primary master or slave or secondary slave) and which image to use. If you click on the "Select virtual disk" icon to the right, this will bring up the Virtual Disk Image Manager (see Section 3.5, “The Virtual Disk Manager” for details), where you can select a different image.

To remove a virtual disk, select it and click on the "remove" icon on the right.

We have dedicated an entire chapter of this User Manual to virtual storage: please see Chapter 5, Virtual storage.

3.7.5. CD/DVD-ROM and floppy settings

In the VM Settings window, the settings in these two categories determine what VirtualBox provides as a floppy disk and as a CD/DVD-ROM drive to your VM's guest operating system.

For both the floppy and CD/DVD-ROM categories, if the "Mount" checkbox is unchecked, VirtualBox will report to the guest that no media is in the drive. Otherwise, if the "Mount" checkbox is set, the following options are available:

  • Host drive: The physical device of the host computer is connected to the VM, so that the guest operating system can read from and write to your physical device. This is, for instance, useful if you want to install Windows from a real installation CD. In this case, select your host drive from the drop-down list presented.

  • Image file: Quite similar to virtual hard disks, this presents a file on your host as a device to the guest operating system. To use an image file, you must first import it into the Virtual Disk Manager; see Section 3.5, “The Virtual Disk Manager”. The image file format varies depending on the type of device:

    • For floppies, the file must be in raw format.

    • For CD- and DVD-ROMs, the file must be in ISO format. Most commonly, you will select this option when installing an operating system from an ISO file that you have obtained from the Internet. For example, most Linux distributions are available in this way.

All these settings can be changed while the guest is running. Since the "Settings" dialog is not available at that time, you can also access these settings from the "Devices" menu of your virtual machine window.

Note

The identification string of the drive provided to the guest (which, in the guest, would be displayed by configuration tools such as the Windows Device Manager) is always "VBOX CD-ROM", irrespective of the current configuration of the virtual drive. This is to prevent hardware detection from being triggered in the guest operating system every time the configuration is changed.

Using the host drive normally provides a read-only drive to the guest. As an experimental feature (which currently works for data only, audio is not supported), it is possible to give the guest access to the CD/DVD writing features of the host drive (if available):

VBoxManage modifyvm <vmname> --dvdpassthrough on

See also Section 8.5, “VBoxManage modifyvm”.

This deliberately does not pass through really all commands. Unsafe commands (such as updating the drive firmware) are blocked.

3.7.6. Audio settings

The "Audio" section in a virtual machine's Settings window determines whether the VM will see a sound card connected, and whether the audio output should be heard on the host system.

If audio is enabled for a guest, you can choose between the emulation of an Intel AC'97 controller or a SoundBlaster 16 card. In any case, you can select what audio driver VirtualBox will use on the host.

On a Linux host, depending on your host configuration, you can also select between the OSS, ALSA or the PulseAudio subsystem. On newer Linux distributions (Fedora 8 and above, Ubuntu 8.04 and above) the PulseAudio subsystem should be preferred.

3.7.7. Network settings

The "Network" section in a virtual machine's Settings window allows you to configure how VirtualBox presents virtual network cards to your VM, and how they operate.

When you first create a virtual machine, VirtualBox by default enables one virtual network card and selects the "Network Address Translation" (NAT) mode for it. This way the guest can connect to the outside world using the host's networking and the outside world can connect to services on the guest which you choose to make visible outside of the virtual machine.

Note

If you are installing Windows Vista in a virtual machine, you will probably have no networking initially. See Section 4.2.5, “Windows Vista networking” for instructions how to solve this problem.

In most cases, this default setup will work fine for you.

However, VirtualBox is extremely flexible in how it can virtualize networking. It supports up to eight virtual network cards per virtual machine, the first four of which can be configured in detail in the graphical user interface. All eight network cards can be configured on the command line with VBoxManage. Because of this, we have dedicated an entire chapter of this manual to discussing networking configuration; please see Chapter 6, Virtual networking.

3.7.8. Serial ports

VirtualBox fully supports virtual serial ports in a virtual machine in an easy-to-use manner.[9]

Ever since the original IBM PC, personal computers have been equipped with one or two serial ports (also called COM ports by DOS and Windows). While these are no longer as important as they were until a few years ago (especially since mice are no longer connected to serial ports these days), there are still some important uses left for them. For example, serial ports can be used to set up a primitive network over a null-modem cable, in case Ethernet is not available. Also, serial ports are indispensable for system programmers needing to do kernel debugging, since kernel debugging software usually interacts with developers over a serial port. In other words, with virtual serial ports, system programmers can do kernel debugging on a virtual machine instead of needing a real computer to connect to.

If a virtual serial port is enabled, the guest operating system sees it a standard 16450-type serial port. Both receiving and transmitting data is supported. How this virtual serial port is then connected to the host is configurable, and details depend on your host operating system.

You can use either the graphical user interface or the command-line VBoxManage tool to set up virtual serial ports. For the latter, please refer to Section 8.5, “VBoxManage modifyvm”; in that section, look for the --uart and --uartmode options.

In either case, you can configure up to two virtual serial ports simultaneously. For each such device, you will need to determine

  1. what kind of serial port the virtual machine should see by selecting an I/O base address and interrupt (IRQ). For these, we recommend to use the traditional values[10], which are:

    1. COM1: I/O base 0x3F8, IRQ 4

    2. COM2: I/O base 0x2F8, IRQ 3

    3. COM3: I/O base 0x3E8, IRQ 4

    4. COM4: I/O base 0x2E8, IRQ 3

  2. Then, you will need to determine what this virtual port should be connected to. For each virtual serial port, you have the following options:

    • You can elect to have the virtual serial port "disconnected", which means that the guest will see it as hardware, but it will behave as if no cable had been connected to it.

    • You can connect the virtual serial port to a physical serial port on your host. (On a Windows host, this will be a name like COM1; on Linux or OpenSolaris hosts, it will be a device node like /dev/ttyS0). VirtualBox will then simply redirect all data received from and sent to the virtual serial port to the physical device.

    • You can tell VirtualBox to connect the virtual serial port to a software pipe on the host. This depends on your host operating system:

      • On a Windows host, data will be sent and received through a named pipe. You can use a helper program called VMware Serial Line Gateway, available for download at http://www.l4ka.org/tools/vmwaregateway.php . This tool provides a fixed server mode named pipe at \\.\pipe\vmwaredebug and connects incoming TCP connections on port 567 with the named pipe.

      • On a Mac, Linux or OpenSolaris host, a local domain socket is used instead. On Linux there are various tools which can connect to a local domain socket or create one in server mode. The most flexible tool is socat and is available as part of many distributions.

      In this case, you can configure whether VirtualBox should create the named pipe (or, on non-Windows hosts, the local domain socket) itself or whether VirtualBox should assume that the pipe (or socket) exists already. With the VBoxManage command-line options, this is referred to as "server" or "client" mode, respectively.

Up to two serial ports can be configured simultaneously per virtual machine, but you can pick any port numbers out of the above. For example, you can configure two serial ports to be able to work with COM2 and COM4 in the guest.

3.7.9. USB support

3.7.9.1. USB settings

The "USB" section in a virtual machine's Settings window allows you to configure VirtualBox's sophisticated USB support.

VirtualBox can allow virtual machines to access the USB devices on your host directly. To achieve this, VirtualBox presents the guest operating system with a virtual USB controller. As soon as the guest system starts using a USB device, it will appear as unavailable on the host.

Note

  1. Be careful with USB devices that are currently in use on the host! For example, if you allow your guest to connect to your USB hard disk that is currently mounted on the host, when the guest is activated, it will be disconnected from the host without a proper shutdown. This may cause data loss.

  2. Solaris hosts have a few known limitations regarding USB support; please see Chapter 13, Known limitations.

In addition to allowing a guest access to your local USB devices, VirtualBox even allows your guests to connect to remote USB devices by use of the VRDP protocol. For details about this, see Section 7.4.4, “Remote USB”.

In the Settings dialog, you can first configure whether USB is available in the guest at all, and in addition also optionally enable the USB 2.0 (EHCI) controller for the guest. If so, you can determine in detail which devices are available. For this, you must create so-called "filters" by specifying certain properties of the USB device.

Clicking on the "+" button to the right of the "USB Device Filters" window creates a new filter. You can give the filter a name (for referencing it later) and specify the filter criteria. The more criteria you specify, the more precisely devices will be selected. For instance, if you specify only a vendor ID of 046d, all devices produced by Logitech will be available to the guest. If you fill in all fields, on the other hand, the filter will only apply to a particular device model from a particular vendor, and not even to other devices of the same type with a different revision and serial number.

In detail, the following criteria are available:

  1. Vendor and product ID. With USB, each vendor of USB products carries an identification number that is unique world-wide, the "vendor ID". Similarly, each line of products is assigned a "product ID" number. Both numbers are commonly written in hexadecimal (that is, they are composed of the numbers 0-9 and the letters A-F), and a colon separates the vendor from the product ID. For example, 046d:c016 stands for Logitech as a vendor, and the "M-UV69a Optical Wheel Mouse" product.

    Alternatively, you can also specify "Manufacturer" and "Product" by name.

    To list all the USB devices that are connected to your host machine with their respective vendor and product IDs, you can use the following command (see Chapter 8, VBoxManage reference):

    VBoxManage list usbhost

    On Windows, you can also see all USB devices that are attached to your system in the Device Manager. On Linux, you can use the lsusb command.

  2. Serial number. While vendor and product ID are already quite specific to identify USB devices, if you have two identical devices of the same brand and product line, you will also need their serial numbers to filter them out correctly.

  3. Remote. This setting specifies whether the device will be local only, or remote only (over VRDP), or either.

On a Windows host, you will need to unplug and reconnect a USB device to use it after creating a filter for it.

As an example, you could create a new USB filter and specify a vendor ID of 046d (Logitech, Inc), a manufacturer index of 1, and "not remote". Then any USB devices on the host system produced by Logitech, Inc with a manufacturer index of 1 will be visible to the guest system.

Several filters can select a single device -- for example, a filter which selects all Logitech devices, and one which selects a particular webcam.

You can deactivate filters without deleting them by clicking in the checkbox next to the filter name.

3.7.9.2. Implementation notes for Windows and Linux hosts

On Windows hosts, a kernel mode device driver provides USB proxy support. It implements both a USB monitor, which allows VirtualBox to capture devices when they are plugged in, and a USB device driver to claim USB devices for a particular virtual machine. As opposed to VirtualBox versions before 1.4.0, system reboots are no longer necessary after installing the driver. Also, you no longer need to replug devices for VirtualBox to claim them.

On newer Linux hosts, VirtualBox accesses USB devices through special files in the file system. When VirtualBox is installed, these are made available to all users in the vboxusers system group. In order to be able to access USB from guest systems, make sure that you are a member of this group.

On older Linux hosts, USB devices are accessed using the usbfs file system. Therefore, the user executing VirtualBox needs read and write permission to the USB file system. Most distributions provide a group (e.g. usbusers) which the VirtualBox user needs to be added to. Also, VirtualBox can only proxy to virtual machines USB devices which are not claimed by a Linux host USB driver. The Driver= entry in /proc/bus/usb/devices will show you which devices are currently claimed. Please refer to Section 11.5.7, “USB not working” also for details about usbfs.

3.7.10. Shared folders

Shared folders allow you to easily exchange data between a virtual machine and your host. This feature requires that the VirtualBox Guest Additions be installed in a virtual machine and is described in detail in Section 4.6, “Folder sharing”.

[9] Serial port support was added with VirtualBox 1.5.

[10] See, for example, http://en.wikipedia.org/wiki/COM_(hardware_interface).


3.8. Importing and exporting virtual machines

Starting with version 2.2, VirtualBox can import and export virtual machines in the industry-standard Open Virtualization Format (OVF).

OVF is a cross-platform standard supported by many virtualization products which allows for creating ready-made virtual machines that can then be imported into a virtualizer such as VirtualBox. As opposed to other virtualization products, VirtualBox now supports OVF with an easy-to-use graphical user interface as well as using the command line. This allows for packaging so-called virtual appliances: disk images together with configuration settings that can be distributed easily. This way one can offer complete ready-to-use software packages (operating systems with applications) that need no configuration or installation except for importing into VirtualBox.

Note

The OVF standard is complex, and support in VirtualBox is an ongoing process. In particular, no guarantee is made that VirtualBox supports all appliances created by other virtualization software. For a list of know limitations, please see Chapter 13, Known limitations.

An appliance in OVF format will typically consist of several files:

  1. one or several disk images, typically in the widely-used VMDK format (see Section 5.2, “Disk image files (VDI, VMDK, VHD)”) and

  2. a textual description file in an XML dialect with an .ovf extension.

These files must reside in the same directory for VirtualBox to be able to import them.

A future version of VirtualBox will also support packages that include the OVF XML file and the disk images packed together in a single archive.

To import an appliance in OVF format, select "File" -> "Import appliance" from the main window of the VirtualBox graphical user interface. Then open the file dialog and navigate to the OVF text file with the .ovf file extension.

If VirtualBox can handle the file, a dialog similar to the following will appear:

This presents the virtual machines described in the OVF file and allows you to change the virtual machine settings by double-clicking on the description items. Once you click on "Import", VirtualBox will copy the disk images and create local virtual machines with the settings described in the dialog. These will then show up in the list of virtual machines.

Note that since disk images tend to be big, and VMDK images that come with virtual appliances are typically shipped in a special compressed format that is unsuitable for being used by virtual machines directly, the images will need to be unpacked and copied first, which can take a few minutes.

For how to import an image at the command line, please see Section 8.6, “VBoxManage import”.

Conversely, to export virtual machines that you already have in VirtualBox, select the machines and "File" -> "Export appliance". A different dialog window shows up that allows you to combine several virtual machines into an OVF appliance. Then, you select the target location where the OVF and VMDK files should be stored, and the conversion process begins. This can again take a while.

For how to export an image at the command line, please see Section 8.7, “VBoxManage export”.

Note

OVF cannot describe every feature that VirtualBox provides for virtual machines. For example, snapshot information gets lost on export; the disk images will have a "flattened" state identical to the current state of the virtual machine, but any snapshots that were defined for the machine will have been merged.


Chapter 4. Guest Additions

Table of Contents

4.1. Introduction
4.2. Windows Guest Additions
4.2.1. Installing the Windows Guest Additions
4.2.2. Updating the Windows Guest Additions
4.2.3. Unattended Installation
4.2.4. Manual file extraction
4.2.5. Windows Vista networking
4.3. Linux Guest Additions
4.3.1. Installing the Linux Guest Additions
4.3.2. Video acceleration and high resolution graphics modes
4.3.3. Updating the Linux Guest Additions
4.4. Solaris Guest Additions
4.4.1. Installing the Solaris Guest Additions
4.4.2. Uninstalling the Solaris Guest Additions
4.4.3. Updating the Solaris Guest Additions
4.5. OS/2 Guest Additions
4.6. Folder sharing
4.7. Seamless windows
4.8. Hardware 3D acceleration (OpenGL and DirectX 8/9)
4.9. Guest properties

The previous chapter covered getting started with VirtualBox and installing operating systems in a virtual machine. For any serious and interactive use, the VirtualBox Guest Additions will make your life much easier by providing closer integration between host and guest and improving the interactive performance of guest systems. This chapter describes the Guest Additions in detail.

4.1. Introduction

As said in Section 1.1, “Virtualization basics”, the Guest Additions are designed to be installed inside a virtual machine after the guest operating system has been installed. They consist of device drivers and system applications that optimize the guest operating system for better performance and usability. Please see Section 1.5, “Supported guest operating systems” for details on what guest operating systems are fully supported with Guest Additions by VirtualBox.

The VirtualBox Guest Additions for all supported guest operating systems are provided as a single CD-ROM image file which is called VBoxGuestAdditions.iso. This image file is located in the installation directory of VirtualBox. To install the Guest Additions for a particular VM, you mount this ISO file in your VM as a virtual CD-ROM and install from there.

The Guest Additions offer the following features:

Mouse pointer integration

To overcome the limitations for mouse support that were described in Section 3.4.1.1, “Capturing and releasing keyboard and mouse”, this provides you with seamless mouse support. You will only have one mouse pointer and pressing the Host key is no longer required to "free" the mouse from being captured by the guest OS. To make this work, a special mouse driver is installed in the guest that communicates with the "real" mouse driver on your host and moves the guest mouse pointer accordingly.

Better video support

While the virtual graphics card which VirtualBox emulates for any guest operating system provides all the basic features, the custom video drivers that are installed with the Guest Additions provide you with extra high and non-standard video modes as well as accelerated video performance.

In addition, with Windows and recent Linux, Solaris and OpenSolaris guests, if the Guest Additions are installed, you can resize the virtual machine's window, and the video resolution in the guest will be automatically adjusted (as if you had manually entered an arbitrary resolution in the guest's display settings).

For Linux and Solaris guests, the Xorg server version 1.3 or later is required for automatic resizing (the feature has been disabled on Fedora 9 guests due to a bug in the X server they supply). The server version can be checked with Xorg -version.

Finally, if the Guest Additions are installed, 3D graphics for guest applications can be accelerated; see Section 4.8, “Hardware 3D acceleration (OpenGL and DirectX 8/9)”.

Time synchronization

With the Guest Additions installed, VirtualBox can ensure that the guest's system time is better synchronized. This fixes the problem that an operating system normally expects to have 100% of a computer's time for itself without interference, which is no longer the case when your VM runs together with your host operating system and possibly other applications on your host. As a result, your guest operating system's timing will soon be off significantly. The Guest Additions will re-synchronize the time regularly.

Shared folders

These provide an easy way to exchange files between the host and the guest. Much like ordinary Windows network shares, you can tell VirtualBox to treat a certain host directory as a shared folder, and VirtualBox will make it available to the guest operating system as a network share. For details, please refer to Section 4.6, “Folder sharing”.

Seamless windows

With this feature, the individual windows that are displayed on the desktop of the virtual machine can be mapped on the host's desktop, as if the underlying application was actually running on the host. See Section 4.7, “Seamless windows” for details.

Shared clipboard

With the Guest Additions installed, the clipboard of the guest operating system can optionally be shared with your host operating system; see Section 3.7.1, “General settings”.

Automated Windows logons

(Credentials passing; Windows guests only) For details, please see Section 9.2, “Automated Windows guest logons (VBoxGINA)”.


4.2. Windows Guest Additions

The VirtualBox Windows Guest Additions are designed to be installed in a virtual machine running a Windows operating system. The following versions of Windows guests are supported:

  • Microsoft Windows NT 4.0 (any service pack)

  • Microsoft Windows 2000 (any service pack)

  • Microsoft Windows XP (any service pack)

  • Microsoft Windows Server 2003 (any service pack)

  • Microsoft Windows Vista (all editions)

  • Microsoft Windows 7 (all editions)

Generally, it is strongly recommend to install the Windows Guest Additions.

4.2.1. Installing the Windows Guest Additions

After mounting the Guest Additions ISO file, the Windows guest should automatically start the Guest Additions installer, which installs the Guest Additions into your Windows guest.

Note

For Direct 3D acceleration to work in a Windows Guest, you must install the Guest Additions in "Safe Mode"; see Chapter 13, Known limitations for details.

4.2.1.1. Mounting the Additions ISO file

In the "Devices" menu in the virtual machine's menu bar, VirtualBox has a handy menu item named "Install guest additions", which will automatically bring up the Additions in your VM window.

If you prefer to mount the additions manually, you can perform the following steps:

  1. Start the virtual machine in which you have installed Windows.

  2. Select "Mount CD/DVD-ROM" from the "Devices" menu in the virtual machine's menu bar and then "CD/DVD-ROM image". This brings up the Virtual Disk Manager described in Section 3.5, “The Virtual Disk Manager”.

  3. In the Virtual Disk Manager, press the "Add" button and browse your host file system for the VBoxGuestAdditions.iso file:

    • On a Windows host, you can find this file in the VirtualBox installation directory (usually under C:\Program files\Sun\xVM VirtualBox).

    • On Mac OS X hosts, you can find this file in the application bundle of VirtualBox. (Right click on the VirtualBox icon in Finder and choose Show Package Contents. There it is located in the Contents/MacOS folder.)

    • On a Linux host, you can find this file in the additions folder under where you installed VirtualBox (normally /opt/VirtualBox/).

    • On Solaris hosts, you can find this file in the additions folder under where you installed VirtualBox (normally /opt/VirtualBox).

  4. Back in the Virtual Disk Manager, select that ISO file and press the "Select" button. This will mount the ISO file and present it to your Windows guest as a CD-ROM.

4.2.1.2. Running the installer

Unless you have the Autostart feature disabled in your Windows guest, Windows will now autostart the VirtualBox Guest Additions installation program from the Additions ISO. If the Autostart feature has been turned off, choose VBoxWindowsAdditions.exe from the CD/DVD drive inside the guest to start the installer.

The installer will add several device drivers to the Windows driver database and then invoke the hardware detection wizard.

Depending on your configuration, it might display warnings that the drivers are not digitally signed. You must confirm these in order to continue the installation and properly install the Additions.

After installation, reboot your guest operating system to activate the Additions.

4.2.2. Updating the Windows Guest Additions

Windows Guest Additions can be updated by running the installation program again, as previously described. This will then replace the previous Additions drivers with updated versions.

Alternatively, you may also open the Windows Device Manager and select "Update driver..." for two devices:

  1. the VirtualBox Graphics Adapter and

  2. the VirtualBox System Device.

For each, choose to provide your own driver and use "Have Disk" to point the wizard to the CD-ROM drive with the Guest Additions.

4.2.3. Unattended Installation

In order to allow for completely unattended guest installations, you can specify a command line parameter to the install launcher:

        VBoxWindowsAdditions.exe /S

This automatically installs the right files and drivers for the corresponding platform (32- or 64-bit).

Note

Because of the drivers are not yet WHQL certified, you still might get some driver installation popups, depending on the Windows guest version.

For more options regarding unattended guest installations, consult the command line help by using the command:

        VBoxWindowsAdditions.exe /?

4.2.4. Manual file extraction

If you would like to install the files and drivers manually, you can extract the files from the Windows Guest Additions setup by typing:

VBoxWindowsAdditions.exe /extract

To explicitly extract the Windows Guest Additions for another platform than the current running one (e.g. 64-bit files on a 32-bit system), you have to execute the appropriate platform installer (VBoxWindowsAdditions-x86.exe or VBoxWindowsAdditions-amd64.exe) with the /extract parameter.

4.2.5. Windows Vista networking

Earlier versions of VirtualBox provided a virtual AMD PCNet Ethernet card to guests by default. Since Microsoft no longer ships a driver for that card with Windows (starting with Windows Vista), if you select Windows Vista or newer as the guest operating system for a virtual machine, VirtualBox will instead present a virtual Intel network controller to the guest (see Section 6.1, “Virtual networking hardware”).

However, if for any reason you have a 32-bit Windows Vista VM that is configured to use an AMD PCNet card, you will have no networking in the guest initially.

As a convenience, VirtualBox ships with a 32-bit driver for the AMD PCNet card, which comes with the Windows Guest Additions. If you install these in a 32-bit Vista guest, the driver will automatically be installed as well. If, for some reason, you would like to install the driver manually, you can extract the required files from the Windows Guest Additions setup. Please consult Section 4.2.4, “Manual file extraction” on how to achieve this. You will then find the AMD PCNet driver files in the x86\Network\AMD\netamd.inf subdirectory of the default install directory.

Alternatively, change the Vista guest's VM settings to use an Intel networking card instead of the default AMD PCNet card; see Section 3.7.7, “Network settings” for details.

Unfortunately, there is no 64-bit driver available for the AMD PCNet card. So for 64-bit Windows VMs, you should always use the Intel networking devices.


4.3. Linux Guest Additions

Like the Windows Guest Additions, the VirtualBox Guest Additions for Linux take the form of a set of device drivers and system applications which may be installed in the guest operating system.

The following Linux distributions are officially supported:

  • Fedora Core 4, 5, 6, 7, 8, 9 and 11;

  • Redhat Enterprise Linux 3, 4 and 5;

  • SUSE and openSUSE Linux 9, 10.0, 10.1, 10.2, 10.3, 11.0 and 11.1;

  • Ubuntu 5.10, 6.06, 7.04, 7.10, 8.04, 8.10 and 9.04.

Other distributions may work if they are based on comparable software releases.

The version of the Linux kernel supplied by default in SUSE and openSUSE 10.2, Ubuntu 6.10 (all versions) and Ubuntu 6.06 (server edition) contains a bug which can cause it to crash during startup when it is run in a virtual machine. The Guest Additions work in those distributions.

As with Windows guests, we recommend installation of the VirtualBox Guest Additions for Linux.

4.3.1. Installing the Linux Guest Additions

The VirtualBox Guest Additions for Linux are provided on the same ISO CD-ROM as the Additions for Windows described above. They also come with an installation program guiding you through the setup process, although, due to the significant differences between Linux distributions, installation may be slightly more complex.

Installation involves the following steps:

  1. Before installing the Guest Additions, you will have to prepare your guest system for building external kernel modules. This works similarly as described in Section 2.3.2, “The VirtualBox kernel module”, except that this step must now be performed in your Linux guest instead of on a Linux host system, as described there.

    Again, as with Linux hosts, we recommend using DKMS for Linux guests as well. If it is not installed, use this command:

    sudo apt-get install dkms

    Install DKMS before installing the Linux Guest Additions.

  2. Mount the VBoxGuestAdditions.iso file as your Linux guest's virtual CD-ROM drive, exactly the same way as described for a Windows guest in Section 4.2.1.1, “Mounting the Additions ISO file”.

  3. Change to the directory where your CD-ROM drive is mounted and execute as root:

    sh ./VBoxLinuxAdditions-x86.run

    In a 64-bit Linux guest, use VBoxLinuxAdditions-amd64.run instead.

The VirtualBox Guest Additions contain several different drivers. If for any reason you do not wish to install them all, you can specify the ones which you wish on the command line - for example

sh ./VBoxAdditions.run x11

to install the X Window graphic drivers. Type in the command

sh ./VBoxAdditions.run help

for more information.

To recompile the guest kernel modules, use this command:

/etc/init.d/vboxadd setup

After compilation you should reboot your guest to ensure that the new modules are actually used.

4.3.2. Video acceleration and high resolution graphics modes

In Linux guests, VirtualBox video acceleration is available through the X Window System. Typically, in today's Linux distributions, this will be the X.Org server. During the installation process, X will be set up to use the VirtualBox video driver. On recent Linux guests (that is, guests running X.Org server version 1.3 or later with the exception of Fedora 9), graphics modes can be selected by resizing the VirtualBox window using the mouse, or sending video mode hints using the VBoxManage tool.

If you are only using recent Linux guests systems, you can skip the rest of this section. On older guest systems, whatever graphics modes were set up before the installation will be used. If these modes do not suit your requirements, you can change your setup by editing the configuration file of the X server, usually found in /etc/X11/xorg.conf.

VirtualBox can use any default X graphics mode which fits into the virtual video memory allocated to the virtual machine, as described in Section 3.7.1, “General settings”. You can also add your own modes to the X server configuration file. You simply need to add them to the "Modes" list in the "Display" subsection of the "Screen" section. For example, the section shown here has a custom 2048x800 resolution mode added:

Section "Screen"
        Identifier    "Default Screen"
        Device        "VirtualBox graphics card"
        Monitor       "Generic Monitor"
        DefaultDepth  24
        SubSection "Display"
                Depth         24
                Modes         "2048x800" "800x600" "640x480"
        EndSubSection
EndSection

4.3.3. Updating the Linux Guest Additions

The Guest Additions can simply be updated by going through the installation procedure again with an updated CD-ROM image. This will replace the drivers with updated versions. You should reboot after updating the Guest Additions.


4.4. Solaris Guest Additions

Like the Windows Guest Additions, the VirtualBox Guest Additions for Solaris take the form of a set of device drivers and system applications which may be installed in the guest operating system.

The following Solaris distributions are officially supported:

  • OpenSolaris Nevada (Build 82 and higher; this includes OpenSolaris 2008.05, 2008.11 and 2009.06);

  • OpenSolaris Indiana (Developer Preview 2 and higher);

  • Solaris 10 (u5 and higher).

Other distributions may work if they are based on comparable software releases.

As with Windows and Linux guests, we recommend installation of the VirtualBox Guest Additions for Solaris.

4.4.1. Installing the Solaris Guest Additions

The VirtualBox Guest Additions for Solaris are provided on the same ISO CD-ROM as the Additions for Windows and Linux described above. They also come with an installation program guiding you through the setup process.

Installation involves the following steps:

  1. Mount the VBoxGuestAdditions.iso file as your Solaris guest's virtual CD-ROM drive, exactly the same way as described for a Windows guest in Section 4.2.1.1, “Mounting the Additions ISO file”.

    If in case the CD-ROM drive on the guest doesn't get mounted (observed on some versions of Solaris 10), execute as root:

    svcadm restart volfs

  2. Change to the directory where your CD-ROM drive is mounted and execute as root:

    pkgadd -d ./VBoxSolarisAdditions.pkg

  3. Choose "1" and confirm installation of the guest additions package. After the installation is complete, re-login to X server on your guest to activate the X11 Guest Additions.

4.4.2. Uninstalling the Solaris Guest Additions

The Solaris Guest Additions can be safely removed by removing the package from the guest. Open a root terminal session and execute:

pkgrm SUNWvboxguest

4.4.3. Updating the Solaris Guest Additions

The Guest Additions should be updated by first uninstalling the existing Guest Additions and then installing the new ones. Attempting to install new Guest Additions without removing the existing ones is not possible.


4.5. OS/2 Guest Additions

VirtualBox also ships with a set of drivers that improve running OS/2 in a virtual machine. Due to restrictions of OS/2 itself, this variant of the Guest Additions has a limited feature set; see Chapter 13, Known limitations for details.

The OS/2 Guest Additions are provided on the same ISO CD-ROM as those for the other platforms. As a result, mount the ISO in OS/2 as described previously. The OS/2 Guest Additions are located in the directory \32bit\OS2.

As we do not provide an automatic installer at this time, please refer to the readme.txt file in that directory, which describes how to install the OS/2 Guest Additions manually.


4.6. Folder sharing

Shared folders allow you to access files of your host system from within the guest system, much like ordinary shares on Windows networks would -- except that shared folders do not need require networking. Shared folders must physically reside on the host and are then shared with the guest; sharing is accomplished using a special service on the host and a file system driver for the guest, both of which are provided by VirtualBox.

In order to use this feature, the VirtualBox Guest Additions have to be installed. Note however that Shared Folders are only supported with Windows (2000 or newer), Linux and Solaris guests.

To share a host folder with a virtual machine in VirtualBox, you must specify the path of that folder and choose for it a "share name" that the guest can use to access it. Hence, first create the shared folder on the host; then, within the guest, connect to it.

There are several ways in which shared folders can be set up for a particular virtual machine:

  • In the graphical user interface of a running virtual machine, you can select "Shared folders" from the "Devices" menu, or click on the folder icon on the status bar in the bottom right corner of the virtual machine window.

  • If a virtual machine is not currently running, you can configure shared folders in each virtual machine's "Settings" dialog.

  • From the command line, you can create shared folders using the VBoxManage command line interface; see Chapter 8, VBoxManage reference. The command is as follows:

    VBoxManage sharedfolder add "VM name"
      --name "sharename" --hostpath "C:\test"

There are two types of shares:

  1. VM shares which are only available to the VM for which they have been defined;

  2. transient VM shares, which can be added and removed at runtime and do not persist after a VM has stopped; for these, add the --transient option to the above command line.

Shared folders have read/write access to the files at the host path by default. To restrict the guest to have read-only access, create a read-only shared folder. This can either be achieved using the GUI or by appending the parameter --readonly when creating the shared folder with VBoxManage.

Then, you can mount the shared folder from inside a VM the same way as you would mount an ordinary network share:

  • In a Windows guest, starting with VirtualBox 1.5.0, shared folders are browseable and are therefore visible in Windows Explorer. So, to attach the host's shared folder to your Windows guest, open Windows Explorer and look for it under "My Networking Places" -> "Entire Network" -> "VirtualBox Shared Folders". By right-clicking on a shared folder and selecting "Map network drive" from the menu that pops up, you can assign a drive letter to that shared folder.

    Alternatively, on the Windows command line, use the following:

    net use x: \\vboxsvr\sharename

    While vboxsvr is a fixed name (note that vboxsrv would also work), replace "x:" with the drive letter that you want to use for the share, and sharename with the share name specified with VBoxManage.

  • In a Linux guest, use the following command:

    mount -t vboxsf [-o OPTIONS] sharename mountpoint

  • In a Solaris guest, use the following command:

    mount -F vboxfs [-o OPTIONS] sharename mountpoint

    Replace sharename (use lowercase) with the share name specified with VBoxManage or the GUI, and mountpoint with the path where you want the share to be mounted on the guest (e.g. /mnt/share). The usual mount rules apply, that is, create this directory first if it does not exist yet.

    Here is an example of mounting the shared folder for the user "jack" on OpenSolaris:

    $id
uid=5000(jack) gid=1(other)
$mkdir /export/home/jack/mount
$pfexec mount -F vboxfs -o uid=5000,gid=1 jackshare /export/home/jack/mount
$cd ~/mount
$ls
sharedfile1.mp3 sharedfile2.txt
$

    Beyond the standard options supplied by the mount command, the following are available:

    iocharset CHARSET

    to set the character set used for I/O operations (utf8 by default) and

    convertcp CHARSET

    to specify the character set used for the shared folder name (utf8 by default).

    The generic mount options (documented in the mount manual page) apply also. Especially useful are the options uid, gid and mode, as they allow access by normal users (in read/write mode, depending on the settings) even if root has mounted the filesystem.


4.7. Seamless windows

With the "seamless windows" feature of VirtualBox, you can have the windows that are displayed within a virtual machine appear side by side next to the windows of your host. This feature is supported for the following guest operating systems (provided that the Guest Additions are installed):

  • Windows guests (support added with VirtualBox 1.5);

  • Linux or Solaris/OpenSolaris guests with an X.org server version 1.3 or higher[11] (support added with VirtualBox 1.6). The exception is Fedora 9, due to a bug in its X server.

After seamless windows are enabled (see below), VirtualBox suppresses the display of the Desktop background of your guest, allowing you to run the windows of your guest operating system seamlessly next to the windows of your host:

To enable seamless mode, after starting the virtual machine, press the Host key (normally the right control key) together with "L". This will enlarge the size of the VM's display to the size of your host screen and mask out the guest operating system's background. To go back to the "normal" VM display (i.e. to disable seamless windows), press the Host key and "L" again.

[11] The X server version is not the same as the version of the entire X.org suite. You can type X -version in a terminal to find out about the X.org server version level that is currently installed.


4.8. Hardware 3D acceleration (OpenGL and DirectX 8/9)

The VirtualBox Guest Additions contain experimental hardware 3D support for Windows, Linux and Solaris guests.[12]

With this feature, if an application inside your virtual machine uses 3D features through the OpenGL or DirectX 8/9 programming interfaces, instead of emulating them in software (which would be slow), VirtualBox will attempt to use your host's 3D hardware. This works for all supported host platforms (Windows, Mac, Linux, Solaris), provided that your host operating system can make use of your accelerated 3D hardware in the first place.

The 3D acceleration currently has the following preconditions:

  1. It is only available for certain Windows, Linux and Solaris guests. In particular:

    • For Windows guests, support is restricted to 32-bit versions of XP and Vista. Both OpenGL and DirectX 8/9 are supported (experimental).

    • OpenGL on Linux requires kernel 2.6.27 and higher as well as X.org server version 1.5 and higher. Ubuntu 8.10 and Fedora 10 have been tested and confirmed as working.

    • OpenGL on Solaris guests requires X.org server version 1.5 and higher.

  2. The Guest Additions must be installed.

    Note

    For Direct 3D acceleration to work in a Windows Guest, VirtualBox needs to replace Windows system files in the virtual machine. As a result, the Guest Additions installation program offers Direct 3D acceleration as an option that must be explicitly enabled.

    Also, you must install the Guest Additions in "Safe Mode"; see Chapter 13, Known limitations for details.

  3. Because 3D support is still experimental at this time, it is disabled by default and must be manually enabled in the VM settings (see Section 3.7.1, “General settings”).

Technically, VirtualBox implements this by installing an additional hardware 3D driver inside your guest when the Guest Additions are installed. This driver acts as a hardware 3D driver and reports to the guest operating system that the (virtual) hardware is capable of 3D hardware acceleration. When an application in the guest then requests hardware acceleration through the OpenGL or Direct3D programming interfaces, these are sent to the host through a special communication tunnel implemented by VirtualBox, and then the host performs the requested 3D operation via the host's programming interfaces.

[12] OpenGL support for Windows guests was added with VirtualBox 2.1; support for Linux and Solaris followed with version 2.2. With version 3, DirectX 8/9 support was added for Windows guests. OpenGL 2.0 is now supported as well.


4.9. Guest properties

Starting with version 2.1, VirtualBox allows for requesting certain properties from a running guest, provided that the VirtualBox Guest Additions are installed and the VM is running. This is good for two things:

  1. A number of predefined VM characteristics are automatically maintained by VirtualBox and can be retrieved on the host, e.g. to monitor VM performance and statistics.

  2. In addition, arbitrary string data can be exchanged between guest and host, and in both directions.

To accomplish this, VirtualBox establishes a private communication channel between the VirtualBox Guest Additions and the host, and software on both sides can use this channel to exchange string data for arbitrary purposes. Guest properties are simply string keys to which a value is attached. They can be set (written to) by either the host and the guest, and they can also be read from both sides.

In addition to establishing the general mechanism of reading and writing values, a set of predefined guest properties is automatically maintained by the VirtualBox Guest Additions to allow for retrieving interesting guest data such as the guest's exact operating system and service pack level, the installed version of the Guest Additions, users that are currently logged into the guest OS, network statistics and more. These predefined properties are all prefixed with /VirtualBox/ and organized into a hierarchical tree of keys.

Note

Currently this information is only available with Windows guests.

Some of this runtime information is shown when you select "Session Information Dialog" from a virtual machine's "Machine" menu.

A more flexible way to use this channel is via the VBoxManage guestproperty command set; see Section 8.24, “VBoxManage guestproperty” for details. For example, to have all the available guest properties for a given running VM listed with their respective values, use this:

$ VBoxManage guestproperty enumerate "Windows Vista III"
VirtualBox Command Line Management Interface Version 3.0.10
(C) 2005-2008 Sun Microsystems, Inc.
All rights reserved.

Name: /VirtualBox/GuestInfo/OS/Product, value: Windows Vista Business Edition,
    timestamp: 1229098278843087000, flags:
Name: /VirtualBox/GuestInfo/OS/Release, value: 6.0.6001,
    timestamp: 1229098278950553000, flags:
Name: /VirtualBox/GuestInfo/OS/ServicePack, value: 1,
    timestamp: 1229098279122627000, flags:
Name: /VirtualBox/GuestAdd/InstallDir,
    value: C:/Program Files/Sun/xVM VirtualBox
    Guest Additions, timestamp: 1229098279269739000, flags:
Name: /VirtualBox/GuestAdd/Revision, value: 40720,
    timestamp: 1229098279345664000, flags:
Name: /VirtualBox/GuestAdd/Version, value: 3.0.10,
    timestamp: 1229098279479515000, flags:
Name: /VirtualBox/GuestAdd/Components/VBoxControl.exe, value: 3.0.10r40720,
    timestamp: 1229098279651731000, flags:
Name: /VirtualBox/GuestAdd/Components/VBoxHook.dll, value: 3.0.10r40720,
    timestamp: 1229098279804835000, flags:
Name: /VirtualBox/GuestAdd/Components/VBoxDisp.dll, value: 3.0.10r40720,
    timestamp: 1229098279880611000, flags:
Name: /VirtualBox/GuestAdd/Components/VBoxMRXNP.dll, value: 3.0.10r40720,
    timestamp: 1229098279882618000, flags:
Name: /VirtualBox/GuestAdd/Components/VBoxService.exe, value: 3.0.10r40720,
    timestamp: 1229098279883195000, flags:
Name: /VirtualBox/GuestAdd/Components/VBoxTray.exe, value: 3.0.10r40720,
    timestamp: 1229098279885027000, flags:
Name: /VirtualBox/GuestAdd/Components/VBoxGuest.sys, value: 3.0.10r40720,
    timestamp: 1229098279886838000, flags:
Name: /VirtualBox/GuestAdd/Components/VBoxMouse.sys, value: 3.0.10r40720,
    timestamp: 1229098279890600000, flags:
Name: /VirtualBox/GuestAdd/Components/VBoxSF.sys, value: 3.0.10r40720,
    timestamp: 1229098279893056000, flags:
Name: /VirtualBox/GuestAdd/Components/VBoxVideo.sys, value: 3.0.10r40720,
    timestamp: 1229098279895767000, flags:
Name: /VirtualBox/GuestInfo/OS/LoggedInUsers, value: 1,
    timestamp: 1229099826317660000, flags:
Name: /VirtualBox/GuestInfo/OS/NoLoggedInUsers, value: false,
    timestamp: 1229098455580553000, flags:
Name: /VirtualBox/GuestInfo/Net/Count, value: 1,
    timestamp: 1229099826299785000, flags:
Name: /VirtualBox/HostInfo/GUI/LanguageID, value: C,
    timestamp: 1229098151272771000, flags:
Name: /VirtualBox/GuestInfo/Net/0/V4/IP, value: 192.168.2.102,
    timestamp: 1229099826300088000, flags:
Name: /VirtualBox/GuestInfo/Net/0/V4/Broadcast, value: 255.255.255.255,
    timestamp: 1229099826300220000, flags:
Name: /VirtualBox/GuestInfo/Net/0/V4/Netmask, value: 255.255.255.0,
    timestamp: 1229099826300350000, flags:
Name: /VirtualBox/GuestInfo/Net/0/Status, value: Up,
    timestamp: 1229099826300524000, flags:
Name: /VirtualBox/GuestInfo/OS/LoggedInUsersList, value: username,
    timestamp: 1229099826317386000, flags:

To query the value of a single property, use the "get" subcommand like this:

$ VBoxManage guestproperty get "Windows Vista III"
         "/VirtualBox/GuestInfo/OS/Product"
VirtualBox Command Line Management Interface Version 3.0.10
(C) 2005-2008 Sun Microsystems, Inc.
All rights reserved.

Value: Windows Vista Business Edition

For more complex needs, you can use the VirtualBox programming interfaces; see Chapter 10, VirtualBox programming interfaces.


Chapter 5. Virtual storage

Table of Contents

5.1. Hard disk controllers: IDE, SATA (AHCI), SCSI
5.2. Disk image files (VDI, VMDK, VHD)
5.3. Configuring image write operations
5.4. Cloning disk images
5.5. iSCSI servers
5.5.1. Access iSCSI targets via Internal Networking

As the virtual machine will most probably expect to see a hard disk built into its virtual computer, VirtualBox must be able to present "real" storage to the guest as a virtual hard disk. There are presently three methods in which to achieve this:

  1. Most commonly, VirtualBox will use large image files on a real hard disk and present them to a guest as a virtual hard disk. This is described in Section 5.2, “Disk image files (VDI, VMDK, VHD)”.

  2. Alternatively, if you have iSCSI storage servers, you can attach such a server to VirtualBox as well; this is described in Section 5.5, “iSCSI servers”.

  3. Finally, as an experimental feature, you can allow a virtual machine to access one of your host disks directly; this advanced feature is described in Section 9.10, “Using a raw host hard disk from a guest”.

Each such virtual storage device (image file, iSCSI target or physical hard disk) will need to be connected to the virtual hard disk controller that VirtualBox presents to a virtual machine. This is explained in the next section.

5.1. Hard disk controllers: IDE, SATA (AHCI), SCSI

In a real PC, hard disks and CD-ROM/DVD drives are connected to a device called hard disk controller which drives hard disk operation and data transfers. VirtualBox can emulate the three most common types of hard disk controllers typically found in today's PCs: IDE, SCSI and SATA (AHCI).[13]

  • IDE (ATA) controllers have been in use since the 1980s. Initially, this type of interface worked only with hard disks, but was later extended to also support CD-ROM drives and other types of removable media. In physical PCs, this standard uses flat ribbon parallel cables with 40 or 80 wires. Each such cable can connect two devices to a controller, which have traditionally been called "master" and "slave". Typical hard disk controllers have two connectors for such cables; as a result, most PCs support up to four devices.

    In VirtualBox, each virtual machine has one IDE controller enabled by default. You can therefore connect up to four virtual storage devices to a virtual machine. Since one of these (the secondary master) is always configured to be a CD-ROM/DVD drive, this leaves you with up to three virtual hard disks that you can attach to a virtual machine's IDE controller.

    So even if your guest operating system has no support for SCSI or SATA devices, it should always be able to see the default IDE controller that is enabled by default. Of the four slots attached to it, one is normally used when you create a virtual machine with the "New Virtual Machine" wizard of the graphical user interface.

  • SCSI is another established industry standard, standing for "Small Computer System Interface". This was established as early as 1986 as a generic interface for data transfer between all kinds of devices, including storage devices. Today SCSI is still used for connecting hard disks and tape devices, but it has mostly been displaced in commodity hardware. It is still in common use in high-performance workstations and servers.

    Primarily for compatibility with other virtualization software, VirtualBox optionally supports LsiLogic and BusLogic SCSI controllers, to which up to 16 virtual hard disks can be attached.

    To enable the SCSI controller, on the "Hard Disks" page of a virtual machine's settings dialog, check the "Enable Additional Controller" box and select one of the two SCSI modes from the list below. After this, the additional controller will appear as a separate PCI device in the virtual machine.

    Warning

    There are limitations with the default SCSI drivers shipped with some operating systems: the standard Windows XP driver for the LsiLogic controller does not detect a hard disk attached to the controller's first port, and the BusLogic controller does not work with Windows NT4 guests.

  • Finally, Serial ATA (SATA) is a newer standard introduced in 2003. Compared to IDE, it supports both much higher speeds and more devices per hard disk controller. Also, with real hardware, devices can be added and removed while the system is running. The standard interface for SATA controllers is called Advanced Host Controller Interface (AHCI).

    For compatibility reasons, AHCI controllers by default operate the disks attached to it in a so-called IDE compatibility mode, unless SATA support is explicitly requested. "IDE compatibility mode" means that the BIOS can operate these drives. Disks assigned to those slots will operate in full-speed AHCI mode once the guest operating system has loaded its AHCI device driver.

    Like a real SATA controller, VirtualBox's virtual SATA controller operates faster and also consumes less CPU resources than the virtual IDE controller. Also, this allows you to connect up to 30 virtual hard disks to one machine instead of just three, as with IDE. Of these, the first four (numbered 0-3 in the graphical user interface) are operated in IDE compatibility mode by default.

    To enable the SATA controller, on the "Hard Disks" page of a virtual machine's settings dialog, check the "Enable Additional Controller" box and select "SATA (AHCI)" from the list below. After this, the additional controller will appear as a separate PCI device in the virtual machine.

    Warning

    The entire SATA controller and the virtual disks attached to it (including those in IDE compatibility mode) will only seen by operating systems that have device support for AHCI. In particular, there is no support for AHCI in Windows before Windows Vista; Windows XP (even SP2) will not see such disks unless you install additional drivers. We therefore do not recommend installing operating systems on SATA disks at this time.

    To change the IDE compatibility mode settings for the SATA controller, please see Section 8.5, “VBoxManage modifyvm”.

In summary, VirtualBox gives you the following categories of virtual hard disk slots:

  1. three slots attached to the traditional IDE controller, which are always present (plus one for the virtual CD-ROM device);

  2. 16 slots attached to the SCSI controller or 30 slots attached to the SATA controller, provided that your guest operating system can see it. In the case of SATA, these can either be

    1. in IDE compatibility mode (by default, slots 0-3) or

    2. in SATA mode.

[13] SATA support was added with VirtualBox 1.6; experimental SCSI support was added with 2.1 and fully implemented with 2.2.


5.2. Disk image files (VDI, VMDK, VHD)

Disk image files reside on the host system and are seen by the guest systems as hard disks of a certain geometry. When creating an image, its size needs to be specified, which determines this fixed geometry. It is therefore not possible to change the size of the virtual hard disk later.

VirtualBox supports two variants of disk image files:

  • Normally, VirtualBox uses its own container format for guest hard disks -- Virtual Disk Image (VDI) files. In particular, this format will be used when you create a new virtual machine with a new disk.

  • VirtualBox also fully supports the popular and open VMDK container format that is used by many other virtualization products, in particular, by VMware.[14]

  • Finally, VirtualBox also fully supports the VHD format used by Microsoft.

Irrespective of the disk format, as briefly mentioned in Section 3.2, “Creating a virtual machine”, there are two options of how to create a disk image: fixed-size or dynamically expanding.

  • If you create a fixed-size image of e.g. 10 GB, an image file of roughly the same size will be created on your host system. Note that the creation of a fixed-size image can take a long time depending on the size of the image and the write performance of your hard disk.

  • For more flexible storage management, use a dynamically expanding image. This will initially be very small and not occupy any space for unused virtual disk sectors, but the image file will grow every time a disk sector is written to for the first time. While this format takes less space initially, the fact that VirtualBox needs to constantly expand the image file consumes additional computing resources, so until the disk has fully expanded, write operations are slower than with fixed size disks. However, after a dynamic disk has fully expanded, the performance penalty for read and write operations is negligible.

[14] Initial support for VMDK was added with VirtualBox 1.4; since version 2.1, VirtualBox supports VMDK fully, meaning that you can create snapshots and use all the other advanced features described above for VDI images with VMDK also.


5.3. Configuring image write operations

For either of the above image formats (VDI, VMDK or VHD and irrespective of whether an image is fixed-size or dynamically expanding), you can also specify how write operations from the VM should affect the image:

  1. With normal images (the default setting), there are no restrictions on how guests can read from and write to the disk.

    When you take a snapshot of your virtual machine as described in Section 3.4.4, “Snapshots”, the state of such a "normal hard disk" will be recorded together with the snapshot, and when reverting to the snapshot, its state will be fully reset.

    While you can attach the same "normal" image to more than one virtual machine, only one of these virtual machines attached to the same image file can be executed simultaneously, as otherwise there would be conflicts if several machines write to the same image file.[15]

  2. By contrast, immutable images only remember write accesses temporarily while the virtual machine is running; all changes are lost when the virtual machine is closed.

    Technically, VirtualBox never writes to an immutable image directly at all. All write operations from the VM will be directed to a special differencing disk image which VirtualBox creates automatically when the VM starts. The next time the VM is started, the differencing image is reset so that every time the VM starts, its immutable images have exactly the same content.[16]

    If the automatic discarding of the differencing image on VM startup does not fit your needs, you can turn it off using the autoreset parameter of VBoxManage modifyhd; see Section 8.15, “VBoxManage modifyhd” for details.

    With respect to snapshots, the behavior of immutable images is identical to that of "normal" images. When reverting to a snapshot taken of an immutable image, its state will be fully reset to that of the snapshot.

    As a result, as opposed to "normal" images, the same immutable image can be used with several virtual machines without restrictions.

    Normally, you would not create an immutable image, but instead create a "normal" image first and then, when you deem its contents useful, later mark it immutable using VBoxManage modifyhd; again, please see Section 8.15, “VBoxManage modifyhd”. Alternatively, open an existing image in "immutable" mode using VBoxManage openmedium; see Section 8.12, “VBoxManage openmedium / closemedium”.

  3. Finally, write-through hard disks are like normal hard disks in that they fully support read and write operations. However, their state is not saved when a snapshot is taken, and not restored when a VM's state is reverted.

    To create a disk image in VDI format as "write-through", use the VBoxManage createhd command; see Section 8.14, “VBoxManage createhd”. To mark an existing image as write-through, use VBoxManage modifyhd; see Section 8.15, “VBoxManage modifyhd”.

To illustrate the differences between the various types with respect to snapshots: Assume you have installed your guest operating system in your VM, and you have taken a snapshot. Imagine you have accidentally infected your VM with a virus and would like to go back to the snapshot. With a normal hard disk image, you simply revert the state of the VM, and the earlier state of your hard disk image will be restored as well (and your virus infection will be undone). With an immutable hard disk, irrespective of the snapshot, all it takes is to shut down and restart your VM, and the virus infection will be discarded. With a write-through image however, you cannot easily undo the virus infection by means of virtualization, but will have to disinfect your virtual machine like a real computer.

Still, you might find write-though images useful if you want to preserve critical data irrespective of snapshots, and since you can attach more than one image to a VM, you may want to have one immutable for the operating system and one write-through for your data files.

[15] This restriction is more lenient now than it was before VirtualBox 2.2. Previously, each "normal" disk image could only be attached to one single machine. Now it can be attached to more than one machine so long as only one of these machines is running.

[16] This behavior also changed with VirtualBox 2.2. Previously, the differencing images were discarded when the VM session ended; now they are discarded every time the VM starts.


5.4. Cloning disk images

You can duplicate hard disk image files on the same host to quickly produce a second virtual machine with the same operating system setup. However, you should only make copies of virtual disk images using the utility supplied with VirtualBox; see Section 8.16, “VBoxManage clonehd”. This is because VirtualBox assigns a unique identity number (UUID) to each disk image, which is also stored inside the image, and VirtualBox will refuse to work with two images that use the same number. If you do accidentally try to reimport a disk image which you copied normally, you can make a second copy using VirtualBox's utility and import that instead.

Note that newer Linux distributions identify the boot hard disk from the ID of the drive. The ID VirtualBox reports for a drive is determined from the UUID of the virtual disk image. So if you clone a disk image and try to boot the copied image the guest might not be able to determine its own boot disk as the UUID changed. In this case you have to adapt the disk ID in your boot loader script (for example /boot/grub/menu.lst). The disk ID looks like scsi-SATA_VBOX_HARDDISK_VB5cfdb1e2-c251e503. The ID for the copied image can be determined with

hdparm -i /dev/sda


5.5. iSCSI servers

iSCSI stands for "Internet SCSI" and is a standard that allows for using the SCSI protocol over Internet (TCP/IP) connections. Especially with the advent of Gigabit Ethernet, it has become affordable to attach iSCSI storage servers simply as remote hard disks to a computer network. In iSCSI terminology, the server providing storage resources is called an "iSCSI target", while the client connecting to the server and accessing its resources is called "iSCSI initiator".

VirtualBox can transparently present iSCSI remote storage to a virtual machine as a virtual hard disk. The guest operating system will not see any difference between a virtual disk image (VDI file) and an iSCSI target. To achieve this, VirtualBox has an integrated iSCSI initiator.

VirtualBox's iSCSI support has been developed according to the iSCSI standard and should work with all standard-conforming iSCSI targets. To use an iSCSI target with VirtualBox, you must first register it as a virtual hard disk with VBoxManage; see Section 8.18, “VBoxManage addiscsidisk”. The target will show up in the list of disk images, as described in Section 3.5, “The Virtual Disk Manager”, and can thus be attached to one of the VM's three hard disk slots the usual way.

5.5.1. Access iSCSI targets via Internal Networking

As an experimental feature, VirtualBox allows for accessing an iSCSI target running in a virtual machine which is configured for using Internal Networking mode (as described in Section 6.6, “Internal networking”). The setup of the virtual machine which uses such an iSCSI target is done as described above. The only difference is that the IP address of the target must be specified as a numeric IP address.

The IP stack accessing Internal Networking must be configured in the virtual machine which accesses the iSCSI target. A free static IP and a MAC address not used by other virtual machines must be chosen. In the example below, adapt the name of the virtual machine, the MAC address, the IP configuration and the Internal Networking name ('MyIntNet') according to your needs. The following 7 commands must be issued:

VBoxManage setextradata VMNAME
      VBoxInternal/Devices/IntNetIP/0/Trusted 1
VBoxManage setextradata VMNAME
      VBoxInternal/Devices/IntNetIP/0/Config/MAC 08:00:27:01:02:0f
VBoxManage setextradata VMNAME
      VBoxInternal/Devices/IntNetIP/0/Config/IP 10.0.9.1
VBoxManage setextradata VMNAME
      VBoxInternal/Devices/IntNetIP/0/Config/Netmask 255.255.255.0
VBoxManage setextradata VMNAME
      VBoxInternal/Devices/IntNetIP/0/LUN#0/Driver IntNet
VBoxManage setextradata VMNAME
      VBoxInternal/Devices/IntNetIP/0/LUN#0/Config/Network MyIntNet
VBoxManage setextradata VMNAME
      VBoxInternal/Devices/IntNetIP/0/LUN#0/Config/IsService 1

Finally the iSCSI disk must be registered with the --intnet option to tell the iSCSI initiator to use internal networking:

VBoxManage addiscsidisk --server 10.0.9.30
      --target iqn.2008-12.com.sun:sampletarget --intnet

The target address must be specified as a numeric IP address, as there is no DNS resolver for internal networking.

The virtual machine with the iSCSI target should be started before the VM using it is powered on. If a virtual machine using an iSCSI disk is started without having the iSCSI target powered up, it can take up to 200 seconds to detect this situation. The VM will fail to power up.


Chapter 6. Virtual networking

Table of Contents

6.1. Virtual networking hardware
6.2. Introduction to networking modes
6.3. "Not attached" mode
6.4. Network Address Translation (NAT)
6.4.1. Configuring port forwarding with NAT
6.4.2. PXE booting with NAT
6.4.3. NAT limitations
6.5. Bridged networking
6.6. Internal networking
6.7. Host-only networking

As briefly mentioned in Section 3.7.7, “Network settings”, VirtualBox provides up to eight virtual PCI Ethernet cards for each virtual machine. For each such card, you can individually select

  1. the hardware that will be virtualized as well as

  2. the virtualization mode that the virtual card will be operating in with respect to your physical networking hardware on the host.

Four of the network cards can be configured in the "Network" section of the settings dialog in the graphical user interface of VirtualBox. You can configure all eight network cards on the command line via VBoxManage modifyvm; see Section 8.5, “VBoxManage modifyvm”.

This chapter explains the various networking settings in more detail.

6.1. Virtual networking hardware

For each card, you can individually select what kind of hardware will be presented to the virtual machine. VirtualBox can virtualize the following five types of networking hardware:

  • AMD PCNet PCI II;

  • AMD PCNet FAST III (the default);

  • Intel PRO/1000 MT Desktop;

  • Intel PRO/1000 T Server.

  • Intel PRO/1000 MT Server.

The PCNet FAST III is the default because it is supported by nearly all operating systems out of the box, as well as the GNU GRUB boot manager. As an exception, the Intel PRO/1000 family adapters are chosen for some guest operating system types that no longer ship with drivers for the PCNet card, such as Windows Vista; see Section 4.2.5, “Windows Vista networking” for details.[17]

VirtualBox has limited support for so-called jumbo frames, i.e. networking packets with more than 1500 bytes of data, provided that you use the Intel card virtualization and bridged networking. In other words, jumbo frames are not supported in NAT mode or with the AMD networking devices; in those cases, jumbo packets will silently be dropped for both the transmit and the receive direction. Guest operating systems trying to use this feature will observe this as a packet loss, which may lead to unexpected application behavior in the guest. This does not cause problems with guest operating systems in their default configuration, as jumbo frames need to be explicitly enabled.

[17] Support for the Intel PRO/1000 MT Desktop type was added with VirtualBox 1.6. The T Server variant of the Intel PRO/1000 card was added with VirtualBox 1.6.2 because this one is recognized by Windows XP guests without additional driver installation. The MT Server variant was added with VirtualBox 2.2 to facilitate OVF imports from other platforms.


6.2. Introduction to networking modes

Each of the eight networking adapters can be separately configured to operate in one of the following five modes:

  • Not attached

  • Network Address Translation (NAT)

  • Bridged networking

  • Internal networking

  • Host-only networking

By default, virtual network cards are set up to use network address translation, which is well suited to standard networking needs (accessing the Internet from programs running in the guest and providing network services for machines in a local intranet). In particular, if all you want is to browse the Web, download files and view e-mail inside the guest, then the default configuration of the NAT network should be sufficient for you, and you can safely skip the rest of this section. Please note that the ping utility does not work over NAT, and that there are certain limitations when using Windows file sharing (see Section 6.4.3, “NAT limitations” for details).

For advanced networking needs such as network simulations, bridged networking can be used to set up an additional, software based network interface on the host to which the virtual machine is connected.

VirtualBox internal networking can be used to create a virtual network which is visible to selected virtual machines, but not to applications running on the host or to the outside world.

Finally, host-only networking can be used to create a network containing the host and a set of virtual machines, without the need for the host's physical network interface. Instead, a virtual network interface (similar to a loopback interface) is created on the host, providing connectivity among virtual machines and the host.

The following sections describe the available network modes in more detail.


6.3. "Not attached" mode

When a virtual network card's mode is set to "Not attached", VirtualBox reports to the guest that a network card is present, but that there is no connection -- as if no Ethernet cable was plugged into the card. This way it is possible to "pull" the virtual Ethernet cable and disrupt the connection, which can be useful to inform a guest operating system that no network connection is available and enforce a reconfiguration.


6.4. Network Address Translation (NAT)

Network Address Translation (NAT) is the simplest way of accessing an external network from a virtual machine. Usually, it does not require any configuration on the host network and guest system. For this reason, it is the default networking mode in VirtualBox.

A virtual machine with NAT enabled acts much like a real computer that connects to the Internet through a router. The "router", in this case, is the VirtualBox networking engine, which maps traffic from and to the virtual machine transparently. The disadvantage of NAT mode is that, much like a private network behind a router, the virtual machine is invisible and unreachable from the outside internet; you cannot run a server this way unless you set up port forwarding (described below).

The virtual machine receives its network address and configuration on the private network from a DHCP server integrated into VirtualBox. The IP address thus assigned to the virtual machine is usually on a completely different network than the host. As more than one card of a virtual machine can be set up to use NAT, the first card is connected to the private network 10.0.2.0, the second card to the network 10.0.3.0 and so on. If you need to change the guest-assigned IP range for some reason, please refer to Section 9.12, “Fine-tuning the VirtualBox NAT engine”.

The network frames sent out by the guest operating system are received by VirtualBox's NAT engine, which extracts the TCP/IP data and resends it using the host operating system. To an application on the host, or to another computer on the same network as the host, it looks like the data was sent by the VirtualBox application on the host, using an IP address belonging to the host. VirtualBox listens for replies to the packages sent, and repacks and resends them to the guest machine on its private network.

6.4.1. Configuring port forwarding with NAT

As the virtual machine is connected to a private network internal to VirtualBox and invisible to the host, network services on the guest are not accessible to the host machine or to other computers on the same network. However, VirtualBox can make selected services available outside of the guest by using port forwarding. This means that VirtualBox listens to certain ports on the host and resends all packets which arrive on them to the guest on the ports used by the services being forwarded.

To an application on the host or other physical (or virtual) machines on the network, it looks as though the service being proxied is actually running on the host (note that this also means that you cannot run the same service on the same ports on the host). However, you still gain the advantages of running the service in a virtual machine -- for example, services on the host machine or on other virtual machines cannot be compromised or crashed by a vulnerability or a bug in the service, and the service can run in a different operating system than the host system.

You can set up a guest service which you wish to proxy using the command line tool VBoxManage. You will need to know which ports on the guest the service uses and to decide which ports to use on the host (often but not always you will want to use the same ports on the guest and on the host). You can use any ports on the host which are not already in use by a service. An example of how to set up incoming NAT connections to an ssh server on the guest requires the following three commands:

VBoxManage setextradata "Linux Guest"
      "VBoxInternal/Devices/pcnet/0/LUN#0/Config/guestssh/Protocol" TCP
VBoxManage setextradata "Linux Guest"
      "VBoxInternal/Devices/pcnet/0/LUN#0/Config/guestssh/GuestPort" 22
VBoxManage setextradata "Linux Guest"
      "VBoxInternal/Devices/pcnet/0/LUN#0/Config/guestssh/HostPort" 2222

The above example assumes a PCNet virtual network card; if you have configured the guest to use the Intel PRO/1000, replace "pcnet" with "e1000" in the above commands. Similarly, if you want to configure a different interface instance replace the /0/ with the appropriate index. pcnet and e1000 are counted separately in this respect, and counting starts at 0 for both types.

The name guestssh is an arbitrary one chosen for this particular forwarding configuration. With that configuration in place, all TCP connections to port 2222 on the host will be forwarded to port 22 on the guest. Protocol can be either of TCP or UDP (these are case insensitive). To remove a mapping again, use the same commands, but leaving out the values (in this case TCP, 22 and 2222).

It is not possible to configure incoming NAT connections while the VM is running. However you can change the settings for a VM which is currently saved (or powered off at a snapshot).

6.4.2. PXE booting with NAT

PXE booting is now supported in NAT mode. The NAT DHCP server provides a boot file name of the form vmname.pxe if the directory TFTP exists in the directory where the user's VirtualBox.xml file is kept. It is the responsibility of the user to provide vmname.pxe.

6.4.3. NAT limitations

There are four limitations of NAT mode which users should be aware of:

ICMP protocol limitations:

Some frequently used network debugging tools (e.g. ping or tracerouting) rely on the ICMP protocol for sending/receiving messages. While ICMP support has been improved with VirtualBox 2.1 (ping should now work), some other tools may not work reliably.

Receiving of UDP broadcasts is not reliable:

The guest does not reliably receive broadcasts, since, in order to save resources, it only listens for a certain amount of time after the guest has sent UDP data on a particular port. As a consequence, NetBios name resolution based on broadcasts does not always work (but WINS always works). As a workaround, you can use the numeric IP of the desired server in the \\server\share notation.

Protocols such as GRE are unsupported:

Protocols other than TCP and UDP are not supported. This means some VPN products (e.g. PPTP from Microsoft) cannot be used. There are other VPN products which use simply TCP and UDP.

Forwarding host ports < 1024 impossible:

On Unix-based hosts (e.g. Linux, Solaris, Mac OS X) it is not possible to bind to ports below 1024 from applications that are not run by root. As a result, if you try to configure such a port forwarding, the VM will refuse to start.

These limitations normally don't affect standard network use. But the presence of NAT has also subtle effects that may interfere with protocols that are normally working. One example is NFS, where the server is often configured to refuse connections from non-privileged ports (i.e. ports not below 1024).


6.5. Bridged networking

With bridged networking, VirtualBox uses a device driver on your host system that filters data from your physical network adapter. This driver is therefore called a "net filter" driver. This allows VirtualBox to intercept data from the physical network and inject data into it, effectively creating a new network interface in software. When a guest is using such a new software interface, it looks to the host system as though the guest were physically connected to the interface using a network cable: the host can send data to the guest through that interface and receive data from it. This means that you can set up routing or bridging between the guest and the rest of your network.

For this to work, VirtualBox needs a device driver on your host system. The way bridged networking works has been completely rewritten with VirtualBox 2.0 and 2.1, depending on the host operating system. From the user perspective, the main difference is that complex configuration is no longer necessary on any of the supported host operating systems.[18]

Note

Even though TAP is no longer necessary on Linux with bridged networking, you can still use TAP interfaces for certain advanced setups, since you can connect a VM to any host interface -- which could also be a TAP interface.

To enable bridged networking, all you need to do is to open the Settings dialog of a virtual machine, go to the "Network" page and select "Bridged network" in the drop down list for the "Attached to" field. Finally, select desired host interface from the list at the bottom of the page, which contains the physical network interfaces of your systems. On a typical MacBook, for example, this will allow you to select between "en1: AirPort" (which is the wireless interface) and "en0: Ethernet", which represents the interface with a network cable.

Depending on your host operating system, the following limitations should be kept in mind:

  • On Macintosh hosts, functionality is limited when using AirPort (the Mac's wireless networking) for bridged networking. Currently, VirtualBox supports only IPv4 over AirPort. For other protocols such as IPv6 and IPX, you must choose a wired interface.

  • On Linux hosts, functionality is limited when using wireless interfaces for bridged networking. Currently, VirtualBox supports only IPv4 over wireless. For other protocols such as IPv6 and IPX, you must choose a wired interface.

    Also, setting the MTU to less than 1500 bytes on wired interfaces provided by the sky2 driver on the Marvell Yukon II EC Ultra Ethernet NIC is known to cause packet losses under certain conditions.

  • On Solaris hosts, there is no support for using wireless interfaces. Filtering guest traffic using IPFilter is also not completely supported due to technical restrictions of the Solaris networking subsystem. These issues would be addressed in a future release of OpenSolaris.

    With VirtualBox 2.0.4 and above, it is possible to use Crossbow Virtual Network Interfaces (VNICs) with bridged networking, but with the following caveats:

    • A VNIC cannot be shared between multiple guest network interfaces, i.e. each guest network interface must have its own, exclusive VNIC.

    • The VNIC and the guest network interface that uses the VNIC must be assigned identical MAC addresses.

[18] For Mac OS X and Solaris hosts, net filter drivers were already added in VirtualBox 2.0 (as initial support for Host Interface Networking on these platforms). With VirtualBox 2.1, net filter drivers were also added for the Windows and Linux hosts, replacing the mechanisms previously present in VirtualBox for those platforms; especially on Linux, the earlier method required creating TAP interfaces and bridges, which was complex and varied from one distribution to the next. None of this is necessary anymore. Bridged network was formerly called "Host Interface Networking" and has been renamed with version 2.2 without any change in functionality.


6.6. Internal networking

Internal Networking is similar to bridged networking in that the VM can directly communicate with the outside world. However, the "outside world" is limited to other VMs which connect to the same internal network.

Even though technically, everything that can be done using internal networking can also be done using bridged networking, there are two good reasons why this additional mode was implemented:

  1. Security. In bridged networking mode, all traffic goes through a physical interface of the host system. It is therefore possible to attach a packet sniffer (such as Wireshark) to the host interface and log all traffic that goes over it. If, for any reason, you prefer two or more VMs on the same machine to communicate privately, hiding their data from both the host system and the user, bridged networking therefore is not an option.

  2. Speed. Internal networking is more efficient than bridged networking, as VirtualBox can directly transmit the data without having to send it through the host operating system's networking stack.

Internal networks are created automatically as needed, i.e. there is no central configuration. Every internal network is identified simply by its name. Once there is more than one active virtual network card with the same internal network ID, the VirtualBox support driver will automatically "wire" the cards and act as a network switch. The VirtualBox support driver implements a complete Ethernet switch and supports both broadcast/multicast frames and promiscuous mode.

In order to attach a VM's network card to an internal network, set its networking mode to "internal networking". There are two ways to accomplish this:

  • You can use a VM's "Settings" dialog in the VirtualBox graphical user interface. In the "Networking" category of the settings dialog, select "Internal Networking" from the drop-down list of networking modes. Now select the name of an existing internal network from the drop-down below or enter a new name into the entry field.

  • You can use VBoxManage modifyvm <VM name> --nic<x> intnet. Optionally, you can specify a network name with the command VBoxManage modifyvm <VM name> --intnet<x> <network name>. If you do not specify a network name, the network card will be attached to the network intnet by default.

Unless you configure the (virtual) network cards in the guest operating systems that are participating in the internal network to use static IP addresses, you may want to use the DHCP server that is built into VirtualBox to manage IP addresses for the internal network. Please see Section 8.25, “VBoxManage dhcpserver” for details.

As a security measure, the Linux implementation of internal networking only allows VMs running under the same user ID to establish an internal network.


6.7. Host-only networking

Host-only networking is another networking mode that was added with version 2.2 of VirtualBox. It can be thought of as a hybrid between the bridged and internal networking modes: as with bridged networking, the virtual machines can talk to each other and the host as if they were connected through a physical ethernet switch. Similarly, as with internal networking however, a physical networking interface need not be present, and the virtual machines cannot talk to the world outside the host since they are not connected to a physical networking interface.

Instead, when host-only networking is used, VirtualBox creates a new software interface on the host which then appears next to your existing network interfaces. In other words, whereas with bridged networking an existing physical interface is used to attach virtual machines to, with host-only networking a new "loopback" interface is created on the host. And whereas with internal networking, the traffic between the virtual machines cannot be seen, the traffic on the "loopback" interface on the host can be intercepted.

Host-only networking is particularly useful for preconfigured virtual appliances, where multiple virtual machines are shipped together and designed to cooperate. For example, one virtual machine may contain a web server and a second one a database, and since they are intended to talk to each other, the appliance can instruct VirtualBox to set up a host-only network for the two. A second (bridged) network would then connect the web server to the outside world to serve data to, but the outside world cannot connect to the database.

To change a virtual machine's virtual network interface to "host only" mode:

  • either go to the "Network" page in the virtual machine's settings notebook in the graphical user interface and select "Host-only networking", or

  • on the command line, type VBoxManage modifyvm <VM name> --nic<x> hostonly; see Section 8.5, “VBoxManage modifyvm” for details.

For host-only networking, like with internal networking, you may find the DHCP server useful that is built into VirtualBox. This can be enabled to then manage the IP addresses in the host-only network since otherwise you would need to configure all IP addresses statically.

  • In the VirtualBox graphical user interface, you can configure all these items in the global settings via "File" -> "Settings" -> "Network", which lists all host-only networks which are presently in use. Click on the network name and then on the "Edit" button to the right, and you can modify the adapter and DHCP settings.

  • Alternatively, you can use VBoxManage dhcpserver on the command line; please see Section 8.25, “VBoxManage dhcpserver” for details.


Chapter 7. Alternative front-ends; remote virtual machines

Table of Contents

7.1. Introduction
7.2. Using VBoxManage to control virtual machines
7.3. VBoxSDL, the simplified VM displayer
7.4. Remote virtual machines (VRDP support)
7.4.1. Common third-party RDP viewers
7.4.2. VBoxHeadless, the VRDP-only server
7.4.3. Step by step: creating a virtual machine on a headless server
7.4.4. Remote USB
7.4.5. RDP authentication
7.4.6. RDP encryption
7.4.7. VRDP multiple connections

7.1. Introduction

As briefly mentioned in Section 1.3, “Features overview”, VirtualBox has a very flexible internal design that allows you to use different front-ends to control the same virtual machines. To illustrate, you can, for example, start a virtual machine with VirtualBox's easy-to-use graphical user interface and then stop it from the command line. With VirtualBox's support for the Remote Desktop Protocol (VRDP), you can even run virtual machines remotely on a headless server and have all the graphical output redirected over the network.

In detail, the following front-ends are shipped in the standard VirtualBox package:

  1. VirtualBox is our graphical user interface (GUI), which most of this User Manual is dedicated to describing, especially in Chapter 3, Starting out with VirtualBox. While this is the easiest-to-use of our interfaces, it does not (yet) cover all the features that VirtualBox provides. Still, this is the best way to get to know VirtualBox initially.

  2. VBoxManage is our command-line interface and is described in the next section.

  3. VBoxSDL is an alternative, simple graphical front-end with an intentionally limited feature set, designed to only display virtual machines that are controlled in detail with VBoxManage. This is interesting for business environments where displaying all the bells and whistles of the full GUI is not feasible. VBoxSDL is described in Section 7.3, “VBoxSDL, the simplified VM displayer”.

  4. Finally, VBoxHeadless is yet another front-end that produces no visible output on the host at all, but merely acts as a VRDP server. Now, even though the other graphical front-ends (VirtualBox and VBoxSDL) also have VRDP support built-in and can act as a VRDP server, this particular front-end requires no graphics support. This is useful, for example, if you want to host your virtual machines on a headless Linux server that has no X Window system installed. For details, see Section 7.4.2, “VBoxHeadless, the VRDP-only server”.

If the above front-ends still do not satisfy your particular needs, it is relatively painless to create yet another front-end to the complex virtualization engine that is the core of VirtualBox, as the VirtualBox core neatly exposes all of its features in a clean API; please refer to Chapter 10, VirtualBox programming interfaces.


7.2. Using VBoxManage to control virtual machines

This section will give you a brief introduction to VBoxManage and how you can use it to create and operate virtual machines.

In essence, VBoxManage supports everything that our graphical user interface allows you to do with the click of a button. VBoxManage supports a lot more than that, however. It exposes really all the features of the virtualization engine, even those that cannot (yet) be accessed from the GUI.

You will need to use the command line if you want to

  • use a different user interface than the main GUI (for example, VBoxSDL or the VBoxHeadless server);

  • control some of the more advanced and experimental configuration settings for a VM.

There are two main things to keep in mind when using VBoxManage: First, VBoxManage must always be used with a specific "subcommand", such as "list" or "createvm" or "startvm". All the subcommands that VBoxManage supports are described in detail in Chapter 8, VBoxManage reference.

Second, most of these subcommands require that you specify a particular virtual machine after the subcommand. There are two ways you can do this:

  • You can specify the VM name, as it is shown in the VirtualBox GUI. Note that if that name contains spaces, then you must enclose the entire name in double quotes (as it is always required with command line arguments that contain spaces).

    For example:

    VBoxManage startvm "Windows XP"

  • You can specify the UUID, which is the internal unique identifier that VirtualBox uses to refer to the virtual machine. Assuming that the aforementioned VM called "Windows XP" has the UUID shown below, the following command has the same effect as the previous:

    VBoxManage startvm 670e746d-abea-4ba6-ad02-2a3b043810a5

You can type VBoxManage list vms to have all currently registered VMs listed with all their settings, including their respective names and UUIDs.

Some typical examples of how to control VirtualBox from the command line are listed below:

  • To create a new virtual machine from the command line and immediately register it with VirtualBox, use VBoxManage createvm with the --register option,[19] like this:

    $ VBoxManage createvm --name "SUSE 10.2" --register
VirtualBox Command Line Management Interface Version 3.0.10
(C) 2005-2008 Sun Microsystems, Inc.
All rights reserved.

Virtual machine 'SUSE 10.2' is created.
UUID: c89fc351-8ec6-4f02-a048-57f4d25288e5
Settings file: '/home/username/.VirtualBox/Machines/SUSE 10.2/SUSE 10.2.xml'

    As can be seen from the above output, a new virtual machine has been created with a new UUID and a new XML settings file.

  • To show the configuration of a particular VM, use VBoxManage showvminfo; see Section 8.2, “VBoxManage showvminfo” for details and an example.

  • To change VM settings, use VBoxManage modifyvm, e.g. as follows:

    VBoxManage modifyvm "Windows XP" --memory "512MB"

    For details, see Section 8.5, “VBoxManage modifyvm”.

  • To control VM operation, use one of the following:

    • To start a VM that is currently powered off, use VBoxManage startvm; see Section 8.8, “VBoxManage startvm” for details.

    • To pause or save a VM that is currently running, use VBoxManage controlvm; see Section 8.9, “VBoxManage controlvm” for details.

[19] For details, see Section 8.4, “VBoxManage createvm”.


7.3. VBoxSDL, the simplified VM displayer

VBoxSDL is a simple graphical user interface (GUI) that lacks the nice point-and-click support which VirtualBox, our main GUI, provides. VBoxSDL is currently primarily used internally for debugging VirtualBox and therefore not officially supported. Still, you may find it useful for environments where the virtual machines are not necessarily controlled by the same person that uses the virtual machine.

As you can see in the following screenshot, VBoxSDL does indeed only provide a simple window that contains only the "pure" virtual machine, without menus or other controls to click upon and no additional indicators of virtual machine activity:

To start a virtual machine with VBoxSDL instead of the VirtualBox GUI, enter the following on a command line:

VBoxSDL --startvm <vm>

where <vm> is, as usual with VirtualBox command line parameters, the name or UUID of an existing virtual machine.


7.4. Remote virtual machines (VRDP support)

VirtualBox, the graphical user interface, has a built-in server for the VirtualBox Remote Desktop Protocol (VRDP). This allows you to see the output of a virtual machine's window remotely on any other computer and control the virtual machine from there, as if the virtual machine was running locally.

VRDP is a backwards-compatible extension to Microsoft's Remote Desktop Protocol (RDP). Typically graphics updates and audio are sent from the remote machine to the client, while keyboard and mouse events are sent back. As a result, you can use any standard RDP client to control the remote VM.

With VirtualBox, the graphical user interface, the VRDP server is disabled by default, but can easily be enabled on a per-VM basis either in the "Display" settings (see Section 3.7.3, “Display settings”) or with VBoxManage:

VBoxManage modifyvm <vmname> --vrdp on

If you use VBoxHeadless (described further below), VRDP support will be automatically enabled since VBoxHeadless has no other means of output.

7.4.1. Common third-party RDP viewers

You can use any standard RDP viewer to connect to such a remote virtual machine (examples follow below). In any case, you must specify the IP address of your host system (not of the virtual machine!) as the server address to connect to, as well as the port number that the RDP server is using. By default, the VRDP server uses the standard RDP TCP port 3389. The port can be changed either in the "Display" settings of the graphical user interface or with --vrdpport option of the VBoxManage modifyvm command; see Section 8.5, “VBoxManage modifyvm” for details. You will need to change the default port if you run more than one VRDP server, since the port can only be used by one server at a time; you might also need to change it on Windows hosts since the default port might already be used by RDP server that is built into Windows itself. Ports 5000 through 5050 are typically not used and might be a good choice.

Here follow examples for the most common RDP viewers:

  • On Windows, you can use the Microsoft Terminal Services Connector (mstsc.exe) that ships with Windows. You can start it by bringing up the "Run" dialog (press the Windows key and "R") and typing "mstsc". You can also find it under "Start" -> "All Programs" -> "Accessories" -> "Remote Desktop Connection". If you use the "Run" dialog, you can type in options directly:

    mstsc 1.2.3.4[:port]

    Replace "1.2.3.4" with the host IP adress, and 3389 with a different port if necessary.

  • On other systems, you can use the standard open-source rdesktop program. This ships with most Linux distributions, but VirtualBox also comes with a modified variant of rdesktop for remote USB support (see Section 7.4.4, “Remote USB” below).

    With rdesktop, use a command line such as the following:

    rdesktop -a 16 -N 1.2.3.4:3389

    As said for the Microsoft viewer above, replace "1.2.3.4" with the host IP adress, and 3389 with a different port if necessary. The -a 16 option requests a color depth of 16 bits per pixel, which we recommend. (For best performance, after installation of the guest operating system, you should set its display color depth to the same value). The -N option enables use of the NumPad keys.

  • If you run the KDE desktop, you might prefer krdc, the KDE RDP viewer. The command line would look like this:

    krdc --window --high-quality rdp:/1.2.3.4[:3389]

    Again, replace "1.2.3.4" with the host IP adress, and 3389 with a different port if necessary. The "rdp:/" bit is required with krdc to switch it into RDP mode.

7.4.2. VBoxHeadless, the VRDP-only server

While the VRDP server that is built into the VirtualBox GUI is perfectly capable of running virtual machines remotely, it is not convenient to have to run VirtualBox if you never want to have VMs displayed locally in the first place. In particular, if you are running servers whose only purpose is to host VMs, and all your VMs are supposed to run remotely over VRDP, then it is pointless to have a graphical user interface on the server at all -- especially since, on a Linux or Solaris host, VirtualBox comes with dependencies on the Qt and SDL libraries, which is inconvenient if you would rather not have the X Window system on your server at all.

VirtualBox therefore comes with yet another front-end called VBoxHeadless, which produces no visible output on the host at all, but instead only delivers VRDP data.[20]

To start a virtual machine with VBoxHeadless, you have two options:

  • You can use VBoxManage startvm <vmname> --type vrdp. The extra --type option causes the VirtualBox core to use VBoxHeadless as the front-end to the internal virtualization engine.

  • The recommended way, however, is to use VBoxHeadless directly, as follows:

    VBoxHeadless --startvm <uuid|name>

    This is the recommended way, because when starting the headless interface through VBoxManage, you will not be able to view or log messages that VBoxHeadless may have output on the console. Especially in case of startup errors, such output might be desirable for problem diagnosis.

Note that when you use VBoxHeadless to start a VM, since the headless server has no other means of output, the built-in VRDP server will always be enabled, regardless of whether you have enabled the VRDP server in the VM's settings. If this is undesirable (for example because you want to access the VM via ssh only), start the VM like this:

VBoxHeadless --startvm <uuid|name> --vrdp=off

To have the VRDP server use the setting from the VM configuration, as the other front-ends would, use this:

VBoxHeadless --startvm <uuid|name> --vrdp=config

7.4.3. Step by step: creating a virtual machine on a headless server

The following instructions may give you an idea how to create a virtual machine on a headless server over a network connection. We will create a virtual machine, establish a VRDP connection and install a guest operating system -- all without having to touch the headless server. All you need is the following:

  1. VirtualBox on a server machine with a supported host operating system; for the following example, we will assume a Linux server;

  2. an ISO file on the server, containing the installation data for the guest operating system to install (we will assume Windows XP in the following example);

  3. a terminal connection to that host over which you can access a command line (e.g. via telnet or ssh);

  4. an RDP viewer on the remote client; see Section 7.4.1, “Common third-party RDP viewers” above for examples.

Note again that on the server machine, since we will only use the headless server, neither Qt nor SDL nor the X Window system will be needed.

  1. On the headless server, create a new virtual machine:

    VBoxManage createvm --name "Windows XP" --register

    Note that if you do not specify --register, you will have to manually use the registervm command later.

  2. Make sure the settings for this VM are appropriate for the guest operating system that we will install. For example:

    VBoxManage modifyvm "Windows XP" --memory "256MB"
      --acpi on --boot1 dvd --nic1 nat

  3. Create a virtual hard disk for the VM (in this case, 10GB in size) and register it with VirtualBox:

    VBoxManage createhd --filename "WinXP.vdi" --size 10000 --remember

  4. Set this newly created VDI file as the first virtual hard disk of the new VM:

    VBoxManage modifyvm "Windows XP" --hda "WinXP.vdi"

  5. Register the ISO file that contains the operating system installation that you want to install later:

    VBoxManage openmedium dvd /full/path/to/iso.iso

  6. Attach this ISO to the virtual machine, so it can boot from it:

    VBoxManage modifyvm "Windows XP" --dvd /full/path/to/iso.iso

    (Alternatively, you can use VBoxManage controlvm dvdattach directly, without having to register the image first; see Section 8.9, “VBoxManage controlvm” for details.)

  7. Start the virtual machine using VBoxHeadless:

    VBoxHeadless --startvm "Windows XP"

    If everything worked, you should see a copyright notice. If, instead, you are returned to the command line, then something went wrong.

  8. On the client machine, fire up the RDP viewer and try to connect to the server (see Section 7.4.1, “Common third-party RDP viewers” above for how to use various common RDP viewers).

    You should now be seeing the installation routine of your guest operating system in the RDP viewer.

7.4.4. Remote USB

As a special feature on top of the VRDP support, VirtualBox supports remote USB devices over the wire as well. That is, the VirtualBox guest that runs on one computer can access the USB devices of the remote computer on which the RDP data is being displayed the same way as USB devices that are connected to the actual host. This allows for running virtual machines on a VirtualBox host that acts as a server, where a client can connect from elsewhere that needs only a network adapter and a display capable of running an RDP viewer. When USB devices are plugged into the client, the remote VirtualBox server can access them.

For these remote USB devices, the same filter rules apply as for other USB devices, as described with Section 3.7.9.1, “USB settings”. All you have to do is specify "Remote" (or "Any") when setting up these rules.

Accessing remote USB devices is only possible if the RDP client supports this extension. On Linux and Solaris hosts, the VirtualBox installation provides a suitable RDP client called rdesktop-vrdp. RDP clients for other platforms will be provided in future VirtualBox versions.

To make a remote USB device available to a VM, rdesktop-vrdp should be started as follows:

rdesktop-vrdp -r usb -a 16 -N my.host.address

Note that rdesktop-vrdp can access USB devices only through /proc/bus/usb. Please refer to Section 11.5.7, “USB not working” for further details on how to properly set up the permissions. Furthermore it is advisable to disable automatic loading of any host driver on the remote host which might work on USB devices to ensure that the devices are accessible by the RDP client. If the setup was properly done on the remote host, plug/unplug events are visible on the VBox.log file of the VM.

7.4.5. RDP authentication

For each virtual machine that is remotely accessible via RDP, you can individually determine if and how RDP connections are authenticated.

For this, use VBoxManage modifyvm command with the --vrdpauthtype option; see Section 8.5, “VBoxManage modifyvm” for a general introduction. Three methods of authentication are available:

  • The "null" method means that there is no authentication at all; any client can connect to the VRDP server and thus the virtual machine. This is, of course, very insecure and only to be recommended for private networks.

  • The "external" method provides external authentication through a special authentication library.

    VirtualBox comes with two default libraries for external authentication:

    • On Linux hosts, VRDPAuth.so authenticates users against the host's PAM system.

    • On Windows hosts, VRDPAuth.dll authenticates users against the host's WinLogon system.

    In other words, the "external" method per default performs authentication with the user accounts that exist on the host system. Any user with valid authentication credentials is accepted, i.e. the username does not have to correspond to the user running the VM.

    However, you can replace the default "external" authentication module with any other module. For this, VirtualBox provides a well-defined interface that allows you to write your own authentication module; see Section 9.3, “Custom external VRDP authentication” for details.

  • Finally, the "guest" authentication method performs authentication with a special component that comes with the Guest Additions; as a result, authentication is not performed with the host users, but with the guest user accounts. This method is currently still in testing and not yet supported.

7.4.6. RDP encryption

RDP features data stream encryption, which is based on the RC4 symmetric cipher (with keys up to 128bit). The RC4 keys are being replaced in regular intervals (every 4096 packets).

RDP provides three different authentication methods:

  1. Historically, RDP4 authentication was used, with which the RDP client does not perform any checks in order to verify the identity of the server it connects to. Since user credentials can be obtained using a man in the middle (MITM) attack, RDP4 authentication is insecure and should generally not be used.

  2. RDP5.1 authentication employs a server certificate for which the client possesses the public key. This way it is guaranteed that the server possess the corresponding private key. However, as this hard-coded private key became public some years ago, RDP5.1 authentication is also insecure and cannot be recommended.

  3. RDP5.2 authentication is based on TLS 1.0 with customer-supplied certificates. The server supplies a certificate to the client which must be signed by a certificate authority (CA) that the client trusts (for the Microsoft RDP Client 5.2, the CA has to be added to the Windows Trusted Root Certificate Authorities database). VirtualBox allows you to supply your own CA and server certificate and uses OpenSSL for encryption.

While VirtualBox supports all of the above, only RDP5.2 authentication should be used in environments where security is a concern. As the client that connects to the server determines what type of encryption will be used, with rdesktop, the Linux RDP viewer, use the -4 or -5 options.

7.4.7. VRDP multiple connections

The VirtualBox built-in RDP server supports simultaneous connections to the same running VM from different clients. All connected clients see the same screen output and share a mouse pointer and keyboard focus. This is similar to several people using the same computer at the same time, taking turns at the keyboard.

The following command enables multiple connection mode:

VBoxManage modifyvm VMNAME --vrdpmulticon on

If the guest uses multiple monitors then multiple connection mode must be active in order to use them at the same time (see Section 9.6, “Multiple monitors for the guest”).

[20] Before VirtualBox 1.6, the headless server was called VBoxVRDP. For the sake of backwards compatibility, the VirtualBox installation still installs an executable with that name as well.


Chapter 8. VBoxManage reference

Table of Contents

8.1. VBoxManage list
8.2. VBoxManage showvminfo
8.3. VBoxManage registervm / unregistervm
8.4. VBoxManage createvm
8.5. VBoxManage modifyvm
8.5.1. General settings
8.5.2. Storage settings
8.5.3. Networking settings
8.5.4. Serial port, audio, clipboard, VRDP and USB settings
8.6. VBoxManage import
8.7. VBoxManage export
8.8. VBoxManage startvm
8.9. VBoxManage controlvm
8.10. VBoxManage discardstate
8.11. VBoxManage snapshot
8.12. VBoxManage openmedium / closemedium
8.13. VBoxManage showhdinfo
8.14. VBoxManage createhd
8.15. VBoxManage modifyhd
8.16. VBoxManage clonehd
8.17. VBoxManage convertfromraw
8.18. VBoxManage addiscsidisk
8.19. VBoxManage getextradata/setextradata
8.20. VBoxManage setproperty
8.21. VBoxManage usbfilter add/modify/remove
8.22. VBoxManage sharedfolder add/remove
8.23. VBoxManage metrics
8.24. VBoxManage guestproperty
8.25. VBoxManage dhcpserver

When running VBoxManage without parameters or when supplying an invalid command line, the below syntax diagram will be shown. Note that the output will be slightly different depending on the host platform; when in doubt, check the output of VBoxManage for the commands available on your particular host.

Usage:

VBoxManage [-v|--version]    print version number and exit
VBoxManage [-q|--nologo] ... suppress the logo

VBoxManage list [--long|-l] vms|runningvms|ostypes|hostdvds|hostfloppies|
                            bridgedifs|hostinfo|dhcpservers|
                            hddbackends|hdds|dvds|floppies|
                            usbhost|usbfilters|systemproperties

VBoxManage showvminfo       <uuid>|<name> [--details] [--statistics]
                            [--machinereadable]

VBoxManage registervm       <filename>

VBoxManage unregistervm     <uuid>|<name> [--delete]

VBoxManage createvm         --name <name>
                            [--ostype <ostype>]
                            [--register]
                            [--basefolder <path> | --settingsfile <path>]
                            [--uuid <uuid>]

VBoxManage modifyvm         <uuid|name>
                            [--name <name>]
                            [--ostype <ostype>]
                            [--memory <memorysize in MB>]
                            [--vram <vramsize in MB>]
                            [--acpi on|off]
                            [--ioapic on|off]
                            [--pae on|off]
                            [--hwvirtex on|off]
                            [--nestedpaging on|off]
                            [--vtxvpid on|off]
                            [--cpus <number>]
                            [--monitorcount <number>]
                            [--accelerate3d <on|off>]
                            [--bioslogofadein on|off]
                            [--bioslogofadeout on|off]
                            [--bioslogodisplaytime <msec>]
                            [--bioslogoimagepath <imagepath>]
                            [--biosbootmenu disabled|menuonly|messageandmenu]
                            [--biossystemtimeoffset <msec>]
                            [--biospxedebug on|off]
                            [--boot<1-4> none|floppy|dvd|disk|net>]
                            [--hd<a|b|d> none|<uuid>|<filename>]
                            [--idecontroller PIIX3|PIIX4]
                            [--dvd none|<uuid>|<filename>|host:<drive>]
                            [--dvdpassthrough on|off]
                            [--floppy disabled|empty|<uuid>|
                                      <filename>|host:<drive>]
                            [--nic<1-N> none|null|nat|bridged|intnet]
                            [--nictype<1-N> Am79C970A|Am79C973]
                            [--cableconnected<1-N> on|off]
                            [--nictrace<1-N> on|off]
                            [--nictracefile<1-N> <filename>]
                            [--nicspeed<1-N> <kbps>]
                            [--bridgeadapter<1-N> none|<devicename>]
                            [--intnet<1-N> <network name>]
                            [--natnet<1-N> <network>|default]
                            [--macaddress<1-N> auto|<mac>]
                            [--uart<1-N> off|<I/O base> <IRQ>]
                            [--uartmode<1-N> disconnected|
                                             server <pipe>|
                                             client <pipe>|
                                             file <file>|
                                             <devicename>]
                            [--gueststatisticsinterval <seconds>]
                            [--audio none|null|dsound|solaudio|oss|coreaudio]
                            [--audiocontroller ac97|sb16]
                            [--clipboard disabled|hosttoguest|guesttohost|
                                         bidirectional]
                            [--vrdp on|off]
                            [--vrdpport default|<port>]
                            [--vrdpaddress <host>]
                            [--vrdpauthtype null|external|guest]
                            [--vrdpmulticon on|off]
                            [--vrdpreusecon on|off]
                            [--usb on|off]
                            [--usbehci on|off]
                            [--snapshotfolder default|<path>]

VBoxManage import           <ovf> [--dry-run|-n] [more options]
    (run with -n to have options displayed for a particular OVF)

VBoxManage export           <machines> --output|-o <ovf>
                            [--legacy09]
                            [--vsys <number of virtual system>]
                                    [--product <product name>]
                                    [--producturl <product url>]
                                    [--vendor <vendor name>]
                                    [--vendorurl <vendor url>]
                                    [--version <version info>]
                                    [--eula <license text>]
                                    [--eulafile <filename>]

VBoxManage startvm          <uuid>|<name>
                            [--type gui|sdl|vrdp|headless]

VBoxManage controlvm        <uuid>|<name>
                            pause|resume|reset|poweroff|savestate|
                            acpipowerbutton|acpisleepbutton|
                            keyboardputscancode <hex> [<hex> ...]|
                            injectnmi|
                            setlinkstate<1-N> on|off |
                            usbattach <uuid>|<address> |
                            usbdetach <uuid>|<address> |
                            dvdattach none|<uuid>|<filename>|host:<drive> |
                            floppyattach none|<uuid>|<filename>|host:<drive> |
                            vrdp on|off] |
                            vrdpport default|<port>] |
                            setvideomodehint <xres> <yres> <bpp> [display]|
                            setcredentials <username> <password> <domain>
                                           [--allowlocallogon <yes|no>]

VBoxManage discardstate     <uuid>|<name>

VBoxManage adoptstate       <uuid>|<name> <state_file>

VBoxManage snapshot         <uuid>|<name>
                            take <name> [--description <desc>] |
                            discard <uuid>|<name> |
                            discardcurrent --state|--all |
                            edit <uuid>|<name>|--current
                                 [--name <name>]
                                 [--description <desc>] |
                            showvminfo <uuid>|<name>

VBoxManage openmedium       disk|dvd|floppy <filename>
                            [--type normal|immutable|writethrough] (disk only)

VBoxManage closemedium      disk|dvd|floppy <uuid>|<filename>

VBoxManage showhdinfo       <uuid>|<filename>

VBoxManage createhd         --filename <filename>
                            --size <megabytes>
                            [--format VDI|VMDK|VHD] (default: VDI)
                            [--variant Standard,Fixed,Split2G,Stream,ESX]
                            [--type normal|writethrough] (default: normal)
                            [--comment <comment>]
                            [--remember]

VBoxManage modifyhd         <uuid>|<filename>
                            [--type normal|writethrough|immutable]
                            [--autoreset on|off]
                            [--compact]

VBoxManage clonehd          <uuid>|<filename> <outputfile>
                            [--format VDI|VMDK|VHD|RAW|<other>]
                            [--variant Standard,Fixed,Split2G,Stream,ESX]
                            [--type normal|writethrough|immutable]
                            [--remember] [--existing]

VBoxManage convertfromraw   <filename> <outputfile>
                            [--format VDI|VMDK|VHD]
                            [--variant Standard,Fixed,Split2G,Stream,ESX]
VBoxManage convertfromraw   stdin <outputfile> <bytes>
                            [--format VDI|VMDK|VHD]
                            [--variant Standard,Fixed,Split2G,Stream,ESX]

VBoxManage addiscsidisk     --server <name>|<ip>
                            --target <target>
                            [--port <port>]
                            [--lun <lun>]
                            [--encodedlun <lun>]
                            [--username <username>]
                            [--password <password>]
                            [--type normal|writethrough|immutable]
                            [--comment <comment>]
                            [--intnet]

VBoxManage getextradata     global|<uuid>|<name>
                            <key>|enumerate

VBoxManage setextradata     global|<uuid>|<name>
                            <key>
                            [<value>] (no value deletes key)

VBoxManage setproperty      hdfolder default|<folder> |
                            machinefolder default|<folder> |
                            vrdpauthlibrary default|<library> |
                            websrvauthlibrary default|null|<library> |
                            loghistorycount <value>

VBoxManage usbfilter        add <index,0-N>
                            --target <uuid>|<name>|global
                            --name <string>
                            --action ignore|hold (global filters only)
                            [--active yes|no] (yes)
                            [--vendorid <XXXX>] (null)
                            [--productid <XXXX>] (null)
                            [--revision <IIFF>] (null)
                            [--manufacturer <string>] (null)
                            [--product <string>] (null)
                            [--remote yes|no] (null, VM filters only)
                            [--serialnumber <string>] (null)
                            [--maskedinterfaces <XXXXXXXX>]

VBoxManage usbfilter        modify <index,0-N>
                            --target <uuid>|<name>|global
                            [--name <string>]
                            [--action ignore|hold] (global filters only)
                            [--active yes|no]
                            [--vendorid <XXXX>|""]
                            [--productid <XXXX>|""]
                            [--revision <IIFF>|""]
                            [--manufacturer <string>|""]
                            [--product <string>|""]
                            [--remote yes|no] (null, VM filters only)
                            [--serialnumber <string>|""]
                            [--maskedinterfaces <XXXXXXXX>]

VBoxManage usbfilter        remove <index,0-N>
                            --target <uuid>|<name>|global

VBoxManage sharedfolder     add <vmname>|<uuid>
                            --name <name> --hostpath <hostpath>
                            [--transient] [--readonly]

VBoxManage sharedfolder     remove <vmname>|<uuid>
                            --name <name> [--transient]

VBoxManage vmstatistics     <vmname>|<uuid> [--reset]
                            [--pattern <pattern>] [--descriptions]

VBoxManage metrics          list [*|host|<vmname> [<metric_list>]]
                                                 (comma-separated)

VBoxManage metrics          setup
                            [--period <seconds>]
                            [--samples <count>]
                            [--list]
                            [*|host|<vmname> [<metric_list>]]

VBoxManage metrics          query [*|host|<vmname> [<metric_list>]]

VBoxManage metrics          collect
                            [--period <seconds>]
                            [--samples <count>]
                            [--list]
                            [--detach]
                            [*|host|<vmname> [<metric_list>]]

VBoxManage dhcpserver       add|modify --netname <network_name> |
                                [--ip <ip_address>
                                 --netmask <network_mask>
                                 --lowerip <lower_ip>
                                 --upperip <upper_ip>]
                                [--enable | --disable]
VBoxManage dhcpserver       remove --netname <network_name> |

Each time VBoxManage is invoked, only one command can be executed. However, a command might support several subcommands which then can be invoked in one single call. The following sections provide detailed reference information on the different commands.

8.1. VBoxManage list

The list command gives relevant information about your system and information about VirtualBox's current settings.

The following subcommands are available with VBoxManage list:

  • vms lists all virtual machines currently registered with VirtualBox. By default this displays a compact list with each VM's name and UUID; if you also specify --long or -l, this will be a detailed list as with the showvminfo command (see below).

  • runningvms lists all currently running virtual machines by their unique identifiers (UUIDs) in the same format as with vms.

  • hdds, dvds and floppies all give you information about virtual disk images currently registered in VirtualBox, including all their settings, the unique identifiers (UUIDs) associated with them by VirtualBox and all files associated with them.

  • ostypes lists all guest operating systems presently known to VirtualBox, along with the identifiers used to refer to them with the modifyvm command.

  • hostdvds, hostfloppies and hostifs, respectively, list DVD, floppy and host networking interfaces on the host, along with the name used to access them from within VirtualBox.

  • hostusb supplies information about USB devices attached to the host, notably information useful for constructing USB filters and whether they are currently in use by the host.

  • usbfilters lists all global USB filters registered with VirtualBox -- that is, filters for devices which are accessible to all virtual machines -- and displays the filter parameters.

  • systemproperties displays some global VirtualBox settings, such as minimum and maximum guest RAM and virtual hard disk size, folder settings and the current authentication library in use.

  • hddbackends lists all known hdd backends of VirtualBox. Beside the name of the backend itself, descriptions about the capabilities, configuration and other useful informations are displayed.


8.2. VBoxManage showvminfo

The showvminfo command shows information about a particular virtual machine. This is the same information as VBoxManage list vms --long would show for all virtual machines.

You will get information similar to the following:

$ VBoxManage showvminfo "Windows XP"
VirtualBox Command Line Management Interface Version 3.0.10
(C) 2005-2008 Sun Microsystems, Inc.
All rights reserved.

Name:            Windows XP
Guest OS:        Other/Unknown
UUID:            1bf3464d-57c6-4d49-92a9-a5cc3816b7e7
Config file:     /home/username/.VirtualBox/Machines/Windows XP/Windows XP.xml
Memory size:     128MB
VRAM size:       8MB
Boot menu mode:  message and menu
ACPI:            on
IOAPIC:          off
Hardw. virt.ext: off
State:           powered off
Floppy:          empty
DVD:             empty
NIC 1:           disabled
NIC 2:           disabled
NIC 3:           disabled
NIC 4:           disabled
Audio:           disabled (Driver: Unknown)
VRDP:            disabled
USB:             disabled

USB Device Filters:
<none>

Shared folders:
<none>


8.3. VBoxManage registervm / unregistervm

The registervm command allows you to import a virtual machine definition in an XML file into VirtualBox. There are some restrictions here: the machine must not conflict with one already registered in VirtualBox and it may not have any hard or removable disks attached. It is advisable to place the definition file in the machines folder before registering it.

Note

When creating a new virtual machine with VBoxManage createvm (see below), you can directly specify the --register option to avoid having to register it separately.

The unregistervm command unregisters a virtual machine. If --delete is also specified then the XML definition file will be deleted.


8.4. VBoxManage createvm

This command creates a new XML virtual machine definition file.

The --name <name> parameter is required and must specify the name of the machine. Since this name is used by default as the file name of the settings file (with the extension .xml) and the machine folder (a subfolder of the .VirtualBox/Machines folder), it must conform to your host operating system's requirements for file name specifications. If the VM is later renamed, the file and folder names will change automatically.

However, if the --basefolder <path> and the --settingsfile <filename> options are used, the XML definition file will be given the name <filename> and the machine folder will be named <path>. In this case, the names of the file and the folder will not change if the virtual machine is renamed.

By default, this command only creates the XML file without automatically registering the VM with your VirtualBox installation. To register the VM instantly, use the optional --register option, or run VBoxManage registervm separately afterwards.


8.5. VBoxManage modifyvm

This command changes the properties of a registered virtual machine. Most of the properties that this command makes available correspond to the VM settings that VirtualBox graphical user interface displays in each VM's "Settings" dialog; these were described in Section 3.7, “Virtual machine settings”. Some of the more advanced settings, however, are only available through the VBoxManage interface.

8.5.1. General settings

The following general settings are available through VBoxManage modifyvm:

  • --name <name>: This changes the VM's name and possibly renames the internal virtual machine files, as described with VBoxManage createvm above.

  • --ostype <ostype>: This specifies what guest operating system is supposed to run in the VM. To learn about the various identifiers that can be used here, use VBoxManage list ostypes.

  • --memory <memorysize>: This sets the amount of RAM, in MB, that the virtual machine should allocate for itself from the host. See the remarks in Section 3.2, “Creating a virtual machine” for more information.

  • --vram <vramsize>: This sets the amount of RAM that the virtual graphics card should have. See Section 3.7.3, “Display settings” for details.

  • --acpi on|off; --ioapic on|off: These two determine whether the VM should have ACPI and I/O APIC support, respectively; see Section 3.7.2.1, “"Motherboard" tab” for details.

  • --pae on|off: This enables/disables PAE (see Section 3.7.2.2, “"Processor" tab”).

  • --hwvirtex on|off|default: This enables or disables the use of hardware virtualization extensions (Intel VT-x or AMD-V) in the processor of your host system; see Section 1.2, “Software vs. hardware virtualization (VT-x and AMD-V)”.

  • --nestedpaging on|off: If hardware virtualization is enabled, this additional setting enables or disables the use of the nested paging feature in the processor of your host system; see Section 1.2, “Software vs. hardware virtualization (VT-x and AMD-V)”.

  • --vtxvpid on|off: If hardware virtualization is enabled, for Intel VT-x only, this additional setting enables or disables the use of the tagged TLB (VPID) feature in the processor of your host system; see Section 1.2, “Software vs. hardware virtualization (VT-x and AMD-V)”.

  • --accelerate3d on|off: This enables, if the Guest Additions are installed, whether hardware 3D acceleration should be available; see Section 4.8, “Hardware 3D acceleration (OpenGL and DirectX 8/9)”.

  • You can influence the BIOS logo that is displayed when a virtual machine starts up with a number of settings. Per default, a VirtualBox logo is displayed.

    With --bioslogofadein on|off and --bioslogofadeout on|off, you can determine whether the logo should fade in and out, respectively.

    With --bioslogodisplaytime <msec> you can set how long the logo should be visible, in milliseconds.

    With --bioslogoimagepath <imagepath> you can, if you are so inclined, replace the image that is shown, with your own logo. The image must be an uncompressed 256 color BMP file.

  • --biosbootmenu disabled|menuonly|messageandmenu: This specifies whether the BIOS allows the user to select a temporary boot device. menuonly suppresses the message, but the user can still press F12 to select a temporary boot device.

  • --boot<1-4> none|floppy|dvd|disk|net: This specifies the boot order for the virtual machine. There are four "slots", which the VM will try to access from 1 to 4, and for each of which you can set a device that the VM should attempt to boot from.

  • --snapshotfolder default|<path>: This allows you to specify the folder in which snapshots will be kept for a virtual machine.

8.5.2. Storage settings

The following storage settings are available through VBoxManage modifyvm:

  • --hd<a|b|d> none|<uuid>|<filename>: This specifies the settings for each of the three virtual hard disks that can be attached to a VM's IDE controller (primary master and slave, and secondary slave; the secondary master is always reserved for the virtual CD/DVD drive). For each of these three, specify either the UUID or a filename of a virtual disk that you have

    • either registered with VBoxManage openmedium; see Section 8.12, “VBoxManage openmedium / closemedium”;

    • or created using VBoxManage createhd with the --register option; see Section 8.14, “VBoxManage createhd”;

    • alternatively, specify the UUID of an iSCSI target that you have registered with VBoxManage addiscsidisk; see Section 8.18, “VBoxManage addiscsidisk”.

  • --sata on|off: this determines whether VirtualBox, in addition to the IDE controller, should also present an SATA controller as a second PCI device to the virtual machine. See Section 5.1, “Hard disk controllers: IDE, SATA (AHCI), SCSI” for additional information.

  • --sataportcount <1-30>: if the SATA controller is enabled, this determines how many ports the SATA controller should support.

  • --sataport<1-30> none|<uuid>|<filename>: if the SATA controller is enabled, this specifies how an SATA slot should be occupied. This works just like the --hd options explained above.

  • --sataideemulation<1-4> <1-30>: if the SATA controller is enabled, this specifies which SATA ports should operate in IDE emulation mode. As explained in Section 5.1, “Hard disk controllers: IDE, SATA (AHCI), SCSI”, by default, this is the case for SATA ports 1-4; with this command, you can map four IDE channels to any of the 30 supported SATA ports.

  • --dvd none|<uuid>|<filename>|host:<drive>: This specifies what VirtualBox should provide to the VM as the virtual CD/DVD drive; specify either the UUID or the filename of an image file that you have registered with VBoxManage openmedium (see Section 8.12, “VBoxManage openmedium / closemedium”). Alternatively, specify "host:" with the drive specification of your host's drive.

  • --dvdpassthrough on|off: With this, you can enable DVD writing support (currently experimental; see Section 3.7.5, “CD/DVD-ROM and floppy settings”).

  • --floppy disabled|empty|<uuid>|<filename>|host:<drive>: This is the floppy equivalent to the --dvd option described above. disabled completely disables the floppy controller, whereas empty keeps the floppy controller enabled, but without a media inserted.

8.5.3. Networking settings

The following networking settings are available through VBoxManage modifyvm:

  • --nic<1-N> none|null|nat|bridged|intnet|hostonly: With this, you can set, for each of the VM's virtual network cards, what type of networking should be available. They can be not present (none), not connected to the host (null), use network address translation (nat), bridged networking (bridged) or communicate with other virtual machines using internal networking (intnet) or host-only networking (hostonly). These options correspond to the modes which are described in detail in Section 6.2, “Introduction to networking modes”.

  • --nictype<1-N> Am79C970A|Am79C973|82540EM: This allows you, for each of the VM's virtual network cards, to specify which networking hardware VirtualBox presents to the guest; see Section 6.1, “Virtual networking hardware”.

  • --cableconnected<1-N> on|off: This allows you to temporarily disconnect a virtual network interface, as if a network cable had been pulled from a real network card. This might be useful for resetting certain software components in the VM.

  • With the "nictrace" options, you can optionally trace network traffic by dumping it to a file, for debugging purposes.

    With --nictrace<1-N> on|off, you can enable network tracing for a particular virtual network card.

    If enabled, you must specify with --nictracefile<1-N> <filename> what file the trace should be logged to.

  • --bridgeadapter<1-N> none|<devicename>: If bridged networking has been enabled for a virtual network card (see the --nic option above; otherwise this setting has no effect), use this option to specify which host interface the given virtual network interface will use. For details, please see Section 6.5, “Bridged networking”.

  • --hostonlyadapter<1-N> none|<devicename>: If host-only networking has been enabled for a virtual network card (see the --nic option above; otherwise this setting has no effect), use this option to specify which host-only networking interface the given virtual network interface will use. For details, please see Section 6.7, “Host-only networking”.

  • --intnet<1-N> network: If internal networking has been enabled for a virtual network card (see the --nic option above; otherwise this setting has no effect), use this option to specify the name of the internal network (see Section 6.6, “Internal networking”).

  • --macaddress<1-N> auto|<mac>: With this option you can set the MAC address of the virtual network card. Normally, each virtual network card is assigned a random address by VirtualBox at VM creation.

8.5.4. Serial port, audio, clipboard, VRDP and USB settings

The following other settings are available through VBoxManage modifyvm:

  • --uart<1-N> off|<I/O base> <IRQ>: With this option you can configure virtual serial ports for the VM; see Section 3.7.8, “Serial ports” for an introduction.

  • --uartmode<1-N> <arg>: This setting controls how VirtualBox connects a given virtual serial port (previously configured with the --uartX setting, see above) to the host on which the virtual machine is running. As described in detail in Section 3.7.8, “Serial ports”, for each such port, you can specify <arg> as one of the following options:

    • disconnected: Even though the serial port is shown to the guest, it has no "other end" -- like a real COM port without a cable.

    • server <pipename>: On a Windows host, this tells VirtualBox to create a named pipe on the host named <pipename> and connect the virtual serial device to it. Note that Windows requires that the name of a named pipe begin with \\.\pipe\.

      On a Linux host, instead of a named pipe, a local domain socket is used.

    • client <pipename>: This operates just like server ..., except that the pipe (or local domain socket) is not created by VirtualBox, but assumed to exist already.

    • <devicename>: If, instead of the above, the device name of a physical hardware serial port of the host is specified, the virtual serial port is connected to that hardware port. On a Windows host, the device name will be a COM port such as COM1; on a Linux host, the device name will look like /dev/ttyS0. This allows you to "wire" a real serial port to a virtual machine.

  • --audio none|null|oss: With this option, you can set whether the VM should have audio support.

  • --clipboard disabled|hosttoguest|guesttohost|bidirectional: With this setting, you can select whether the guest operating system's clipboard should be shared with the host; see Section 3.7.1, “General settings”. This requires that the Guest Additions be installed in the virtual machine.

  • --vrdp on|off: With the VirtualBox graphical user interface, this enables or disables the built-in VRDP server. Note that if you are using VBoxHeadless (see Section 7.4.2, “VBoxHeadless, the VRDP-only server”), VRDP output is always enabled.

  • --vrdpport default|<port>: This lets you specify which port should be used; "default" or "0" means port 3389, the standard port for RDP. Only one machine can use a given port at a time.

  • --vrdpauthtype null|external|guest: This allows you to choose whether and how authorization will be performed; see Section 7.4.5, “RDP authentication” for details.

  • --vrdpmulticon on|off: This enables multiple VRDP connections to the same VRDP server; see Section 7.4.7, “VRDP multiple connections”.

  • --monitorcount <count>: This enables multi-monitor support for VRDP; see Section 9.6, “Multiple monitors for the guest”.

  • --usb on|off: This option enables or disables the VM's virtual USB controller; see Section 3.7.9.1, “USB settings” for details.

  • --usbehci on|off: This option enables or disables the VM's virtual USB 2.0 controller; see Section 3.7.9.1, “USB settings” for details.


8.6. VBoxManage import

This command imports a virtual appliance in OVF format by copying the virtual disk images and creating virtual machines in VirtualBox. See Section 3.8, “Importing and exporting virtual machines” for an introduction to appliances.

The import subcommand takes at least the path name of an OVF file as input and expects the disk images, if needed, in the same directory as the OVF file. A lot of additional command-line options are supported to control in detail what is being imported and modify the import paramters, but the details depend on the content of the OVF file.

It is therefore recommended to first run the import subcommand with the --dry-run or -n option. This will then print a description of the appliance's contents to the screen how it would be imported into VirtualBox, together with the optional command-line options to influence the import behavior.

As an example, here is the screen output with a sample appliance containing a Windows XP guest:

VBoxManage import WindowsXp.ovf --dry-run
Interpreting WindowsXp.ovf...
OK.
Virtual system 0:
 0: Suggested OS type: "WindowsXP"
    (change with "--vsys 0 --ostype <type>"; use "list ostypes" to list all)
 1: Suggested VM name "Windows XP Professional_1"
    (change with "--vsys 0 --vmname <name>")
 3: Number of CPUs (ignored): 1
 4: Guest memory: 956 MB (change with "--vsys 0 --memory <MB>")
 5: Sound card (appliance expects "ensoniq1371", can change on import)
    (disable with "--vsys 0 --unit 5 --ignore")
 6: USB controller
    (disable with "--vsys 0 --unit 6 --ignore")
 7: Network adapter: orig bridged, config 2, extra type=bridged
 8: Floppy
    (disable with "--vsys 0 --unit 8 --ignore")
 9: SCSI controller, type BusLogic
    (change with "--vsys 0 --unit 9 --scsitype {BusLogic|LsiLogic}";
    disable with "--vsys 0 --unit 9 --ignore")
10: IDE controller, type PIIX4
    (disable with "--vsys 0 --unit 10 --ignore")
11: Hard disk image: source image=WindowsXp.vmdk,
      target path=/home/user/disks/WindowsXp.vmdk, controller=9;channel=0
    (change controller with "--vsys 0 --unit 11 --controller <id>";
    disable with "--vsys 0 --unit 11 --ignore")

As you can see, the individual configuration items are numbered, and depending on their type support different command-line options. The import subcommand can be directed to ignore many such items with a --vsys X --unit Y --ignore option, where X is the number of the virtual system (zero unless there are several virtual system descriptions in the appliance) and Y the item number, as printed on the screen.

In the above example, Item #1 specifies the name of the target machine in VirtualBox. Items #9 and #10 specify hard disk controllers, respectively. Item #11 describes a hard disk image; in this case, the additional --controller option indicates which item the disk image should be connected to, with the default coming from the OVF file.

You can combine several items for the same virtual system behind the same --vsys option. For example, to import a machine as described in the OVF, but without the sound card and without the USB controller, and with the disk image connected to the IDE controller instead of the SCSI controller, use this:

VBoxManage import WindowsXp.ovf
      --vsys 0 --unit 5 --ignore --unit 6 --ignore --unit 11 --controller 10


8.7. VBoxManage export

This command exports one or more virtual machines from VirtualBox into a virtual appliance in OVF format, including copying their virtual disk images to compressed VMDK. See Section 3.8, “Importing and exporting virtual machines” for an introduction to appliances.

The export command is simple to use: list the machine (or the machines) that you would like to export to the same OVF file and specify the target OVF file after an additional --output or -o option. Note that the directory of the target OVF file will also receive the exported disk images in the compressed VMDK format (regardless of the original format) and should have enough disk space left for them.

Beside a simple export of a given virtual machine, you can append several product information to the appliance file. Use --product, --producturl, --vendor, --vendorurl and --version to specify this additional information. For legal reasons you may add a license text or the content of a license file by using the --eula and --eulafile option respectively. As with OVF import, you must use the --vsys X option to direct the previously mentioned options to the correct virtual machine.

For virtualization products which aren't fully compatible with the OVF standard 1.0 you can enable a OVF 0.9 legacy mode with the --legacy09 option.


8.8. VBoxManage startvm

This command starts a virtual machine that is currently in the "Powered off" or "Saved" states.

Note

This is provided for backwards compatibility only. We recommend to start virtual machines directly by running the respective front-end, as you might otherwise miss important error and state information that VirtualBox may display on the console. This is especially important for front-ends other than VirtualBox, our graphical user interface, because those cannot display error messages in a popup window. See Section 7.4.2, “VBoxHeadless, the VRDP-only server” for more information.

The optional --type specifier determines whether the machine will be started in a window (GUI mode, which is the default) or whether the output should go through VBoxHeadless, with VRDP enabled or not; see Section 7.4.2, “VBoxHeadless, the VRDP-only server” for more information. The list of types is subject to change, and it's not guaranteed that all types are accepted by any product variant.

The following values are allowed:

gui

Starts a VM showing a GUI window. This is the default.

vrdp

Starts a VM showing a GUI window, with its graphics card output accessible by an RDP client.

headless

Starts a VM without a window for remote RDP display only.


8.9. VBoxManage controlvm

The controlvm subcommand allows you to change the state of a virtual machine that is currently running. The following can be specified:

  • VBoxManage controlvm <vm> pause temporarily puts a virtual machine on hold, without changing its state for good. The VM window will be painted in gray to indicate that the VM is currently paused. (This is equivalent to selecting the "Pause" item in the "Machine" menu of the GUI.)

  • Use VBoxManage controlvm <vm> resume to undo a previous pause command. (This is equivalent to selecting the "Resume" item in the "Machine" menu of the GUI.)

  • VBoxManage controlvm <vm> reset has the same effect on a virtual machine as pressing the "Reset" button on a real computer: a cold reboot of the virtual machine, which will restart and boot the guest operating system again immediately. The state of the VM is not saved beforehand, and data may be lost. (This is equivalent to selecting the "Reset" item in the "Machine" menu of the GUI.)

  • VBoxManage controlvm <vm> poweroff has the same effect on a virtual machine as pulling the power cable on a real computer. Again, the state of the VM is not saved beforehand, and data may be lost. (This is equivalent to selecting the "Close" item in the "Machine" menu of the GUI or pressing the window's close button, and then selecting "Power off the machine" in the dialog.)

    After this, the VM's state will be "Powered off". From there, it can be started again; see Section 8.8, “VBoxManage startvm”.

  • VBoxManage controlvm <vm> savestate will save the current state of the VM to disk and then stop the VM. (This is equivalent to selecting the "Close" item in the "Machine" menu of the GUI or pressing the window's close button, and then selecting "Save the machine state" in the dialog.)

    After this, the VM's state will be "Saved". From there, it can be started again; see Section 8.8, “VBoxManage startvm”.

A few extra options are available with controlvm that do not directly affect the VM's running state:

  • The setlinkstate<1-4> operation connects or disconnects virtual network cables from their network interfaces.

  • usbattach and usbdettach make host USB devices visible to the virtual machine on the fly, without the need for creating filters first. The USB devices can be specified by UUID (unique identifier) or by address on the host system.

    You can use VBoxManage list usbhost to locate this information.

  • dvdattach inserts a DVD image into the virtual machine or connects it to the host DVD drive. With this command (as opposed to VBoxManage modifyvm), the image file does not first have to be registered with VirtualBox.

    You can use VBoxManage list hostdvds to display all the drives found on the host and the names VirtualBox uses to access them.

  • floppyattach works in a similar way.

  • setvideomodehint requests that the guest system change to a particular video mode. This requires that the guest additions be installed, and will not work for all guest systems.

  • The setcredentials operation is used for remote logons in Windows guests. For details, please refer to Section 9.2, “Automated Windows guest logons (VBoxGINA)”.


8.10. VBoxManage discardstate

This command discards the saved state of a virtual machine which is not currently running, which will cause its operating system to restart next time you start it. This is the equivalent of pulling out the power cable on a physical machine, and should be avoided if possible.


8.11. VBoxManage snapshot

This command is used for taking snapshots of a virtual machine and for manipulating and discarding snapshots.

The take operation takes a snapshot of a virtual machine. You must supply a name for the snapshot and can optionally supply a description.

The discard operation discards a snapshot specified by name or by identifier (UUID).

The discardcurrent operation will either revert the current state to the most recent snapshot (if you specify the --state option) or discard the last snapshot and revert to the last but one (with the --all option).


8.12. VBoxManage openmedium / closemedium

These commands register or unregister hard disk, DVD or floppy images in VirtualBox. This is the command-line equivalent of the Virtual Disk Manager; see Section 3.5, “The Virtual Disk Manager” for more information.

Note

For compatibility with earlier versions of VirtualBox, the "registerimage" and "unregisterimage" commands are also supported and mapped internally to the "openmedium" and "closemedium" commands, respectively.

Note however that when you unregister a hard disk image using VBoxManage, it will not be deleted from the host computer's hard drive.


8.13. VBoxManage showhdinfo

This command shows information about a virtual hard disk image, notably its size, its size on disk, its type and the VM it is in use by.

Note

For compatibility with earlier versions of VirtualBox, the "showvdiinfo" command is also supported and mapped internally to the "showhdinfo" command.


8.14. VBoxManage createhd

This command creates a new virtual hard disk image. The syntax is as follows:

VBoxManage createhd         --filename <filename>
                            --size <megabytes>
                            [--format VDI|VMDK|VHD] (default: VDI)
                            [--variant Standard,Fixed,Split2G,Stream,ESX]
                            [--type normal|writethrough] (default: normal)
                            [--comment <comment>]
                            [--remember]

where the parameters mean:

filename

Allows to choose a file name. Mandatory.

size

Allows to define the image capacity, in 1 MiB units. Mandatory.

format

Allows to choose a file format for the output file different from the file format of the input file.

variant

Allows to choose a file format variant for the output file. It is a comma-separated list of variant flags. Not all combinations are supported, and specifying inconsistent flags will result in an error message.

type

Only honored if --remember is also specified. Defines what kind of hard disk type this image should be.

comment

Allows to attach a comment to the image.

remember

Keep the destination image registered after it was successfully written.

Note

For compatibility with earlier versions of VirtualBox, the "createvdi" command is also supported and mapped internally to the "createhd" command.


8.15. VBoxManage modifyhd

With the modifyhd command, you can change the type of an existing image between the normal, immutable and write-through modes; see Section 5.3, “Configuring image write operations” for details.

Note

For compatibility with earlier versions of VirtualBox, the "modifyvdi" command is also supported and mapped internally to the "modifyhd" command.

For immutable (differencing) hard disks only, the modifyhd autoreset on|off command determines whether the disk is automatically reset on every VM startup (again, see Section 5.3, “Configuring image write operations”). The default is "on".

In addition, the modifyhd --compact command can be used to compact disk images, i.e. remove blocks that only contains zeroes. For this operation to be effective, it is required to zero out free space in the guest system using a suitable software tool. Microsoft provides the sdelete tool for Windows guests. Execute sdelete -c in the guest to zero the free disk space before compressing the virtual disk image. Compaction works both for base images and for diff images created as part of a snapshot.


8.16. VBoxManage clonehd

This command duplicates a registered virtual hard disk image to a new image file with a new unique identifier (UUID). The new image can be transferred to another host system or imported into VirtualBox again using the Virtual Disk Manager; see Section 3.5, “The Virtual Disk Manager” and Section 5.4, “Cloning disk images”. The syntax is as follows:

VBoxManage clonehd         <uuid>|<filename> <outputfile>
                           [--format VDI|VMDK|VHD|RAW|<other>]
                           [--variant Standard,Fixed,Split2G,Stream,ESX]
                           [--type normal|writethrough|immutable]
                           [--remember]

where the parameters mean:

format

Allow to choose a file format for the output file different from the file format of the input file.

variant

Allow to choose a file format variant for the output file. It is a comma-separated list of variant flags. Not all combinations are supported, and specifying inconsistent flags will result in an error message.

type

Only honored if --remember is also specified. Defines what kind of hard disk type this image should be.

remember

Keep the destination image registered after it was successfully written.

Note

For compatibility with earlier versions of VirtualBox, the "clonevdi" command is also supported and mapped internally to the "clonehd" command.


8.17. VBoxManage convertfromraw

This command converts a raw disk image to a VirtualBox Disk Image (VDI) file. The syntax is as follows:

VBoxManage convertfromraw   <filename> <outputfile>
                            [--format VDI|VMDK|VHD]
                            [--variant Standard,Fixed,Split2G,Stream,ESX]
VBoxManage convertfromraw   stdin <outputfile> <bytes>
                            [--format VDI|VMDK|VHD]
                            [--variant Standard,Fixed,Split2G,Stream,ESX]

where the parameters mean:

format

Select the disk image format to create. Default is VDI.

variant

Allow to choose a file format variant for the output file. It is a comma-separated list of variant flags. Not all combinations are supported, and specifying inconsistent flags will result in an error message.

The second form forces VBoxManage to read the content for the disk image from standard input (useful for using that command in a pipe).

Note

For compatibility with earlier versions of VirtualBox, the "convertdd" command is also supported and mapped internally to the "convertfromraw" command.


8.18. VBoxManage addiscsidisk

The addiscsidisk command attaches an iSCSI network storage unit to VirtualBox. The iSCSI target can then be made available to and used by a virtual machine as though it were a standard write-through virtual disk image.

This command has the following syntax:

VBoxManage addiscsidisk --server <name>|<ip>
                        --target <target>
                        [--port <port>]
                        [--lun <lun>]
                        [--username <username>]
                        [--password <password>]
                        [--type normal|writethrough|immutable]
                        [--comment <comment>]
                        [--intnet]

where the parameters mean:

server

The host name or IP address of the iSCSI target.

target

Target name string. This is determined by the iSCSI target and used to identify the storage resource.

port

TCP/IP port number of the iSCSI service on the target (optional).

lun

Logical Unit Number of the target resource (optional). Often, this value is zero.

username, password

Username and password for target authentication, if required (optional).

Note

Currently, username and password are stored without encryption (i.e. in cleartext) in the machine configuration file.

type

Defines what kind of hard disk type this image should be.

comment

Any description that you want to have stored with this item (optional; e.g. "Big storage server downstairs"). This is stored internally only and not needed for operation.

intnet

Connect to the iSCSI target via Internal Networking. This needs further configuration which is described in Section 5.5.1, “Access iSCSI targets via Internal Networking”.


8.19. VBoxManage getextradata/setextradata

These commands let you attach and retrieve string data to a virtual machine or to a VirtualBox configuration (by specifying global instead of a virtual machine name). You must specify a key (as a text string) to associate the data with, which you can later use to retrieve it. For example:

VBoxManage setextradata Fedora5 installdate 2006.01.01
VBoxManage setextradata SUSE10 installdate 2006.02.02

would associate the string "2006.01.01" with the key installdate for the virtual machine Fedora5, and "2006.02.02" on the machine SUSE10. You could retrieve the information as follows:

VBoxManage getextradata Fedora5 installdate

which would return

VirtualBox Command Line Management Interface Version 3.0.10
(C) 2005-2008 Sun Microsystems, Inc.
All rights reserved.

Value: 2006.01.01


8.20. VBoxManage setproperty

This command is used to change global settings which affect the entire VirtualBox installation. Some of these correspond to the settings in the "Global settings" dialog in the graphical user interface. The following properties are available:

hdfolder

This specifies the default folder that is used to keep disk image files (.vdi, .vmdk, .vhd).

machinefolder

This specifies the default folder in which virtual machine definitions are kept; see Section 9.1, “VirtualBox configuration data” for details.

vrdpauthlibrary

This specifies which library to use when "external" VRDP authentication has been selected for a particular virtual machine; see Section 7.4.5, “RDP authentication” for details.

websrvauthlibrary

This specifies which library the web service uses to authenticate users. For details about the VirtualBox web service, please refer to the separate VirtualBox SDK reference (see Chapter 10, VirtualBox programming interfaces).

hwvirtexenabled

This selects whether or not hardware virtualization support is enabled by default.


8.21. VBoxManage usbfilter add/modify/remove

The usbfilter commands are used for working with USB filters in virtual machines, or global filters which affect the whole VirtualBox setup. Global filters are applied before machine-specific filters, and may be used to prevent devices from being captured by any virtual machine. Global filters are always applied in a particular order, and only the first filter which fits a device is applied. So for example, if the first global filter says to hold (make available) a particular Kingston memory stick device and the second to ignore all Kingston devices, that memory stick will be available to any machine with an appropriate filter, but no other Kingston device will.

When creating a USB filter using usbfilter add, you must supply three or four mandatory parameters. The index specifies the position in the list at which the filter should be placed. If there is already a filter at that position, then it and the following ones will be shifted back one place. Otherwise the new filter will be added onto the end of the list. The target parameter selects the virtual machine that the filter should be attached to or use "global" to apply it to all virtual machines. name is a name for the new filter and for global filters, action says whether to allow machines access to devices that fit the filter description ("hold") or not to give them access ("ignore"). In addition, you should specify parameters to filter by. You can find the parameters for devices attached to your system using VBoxManage list usbhost. Finally, you can specify whether the filter should be active, and for local filters, whether they are for local devices, remote (over an RDP connection) or either.

When you modify a USB filter using usbfilter modify, you must specify the filter by index (see the output of VBoxManage list usbfilters to find global filter indexes and that of VBoxManage showvminfo to find indexes for individual machines) and by target, which is either a virtual machine or "global". The properties which can be changed are the same as for usbfilter add. To remove a filter, use usbfilter remove and specify the index and the target.


8.22. VBoxManage sharedfolder add/remove

This command allows you to share folders on the host computer with guest operating systems. For this, the guest systems must have a version of the VirtualBox guest additions installed which supports this functionality.

Shared folders are described in detail in Section 4.6, “Folder sharing”.


8.23. VBoxManage metrics

This command supports monitoring the usage of system resources. Resources are represented by various metrics associated with the host system or a particular VM. For example, the host system has a CPU/Load/User metric that shows the percentage of time CPUs spend executing in user mode over a specific sampling period.

Metric data is collected and retained internally; it may be retrieved at any time with the VBoxManage metrics query subcommand. The data is available as long as the background VBoxSVC process is alive. That process terminates shortly after all VMs and frontends have been closed.

By default no metrics are collected at all. Metrics collection does not start until VBoxManage metrics setup is invoked with a proper sampling interval and the number of metrics to be retained. The interval is measured in seconds. For example, to enable collecting the host processor and memory usage metrics every second and keeping the 5 most current samples, the following command can be used:

VBoxManage metrics setup --period 1 --samples 5 host CPU/Load,RAM/Usage

Specifying 0 as either the interval or as the number of retained samples disables metric collection again. Note that the VBoxManage metrics setup subcommand discards all samples that may have been previously collected for the specified set of objects and metrics.

The host and VMs have different sets of associated metrics. Available metrics can be listed with VBoxManage metrics list subcommand.

A complete metric name may include an aggregate function. The name has the following form: Category/Metric[/SubMetric][:aggregate]. For example, RAM/Usage/Free:min stands for the minimum amount of available memory over all retained data if applied to the host object.

Subcommands may apply to all objects and metrics or can be limited to one object or/and a list of metrics. If no objects or metrics are given in the parameters, the subcommands will apply to all available metrics of all objects. You may use an asterisk ("*") to explicitly specify that the command should be applied to all objects or metrics. Use "host" as the object name to limit the scope of the command to host-related metrics. To limit the scope to a subset of metrics, use a metric list with names separated by commas.

For example, to query metric data on the CPU time spent in user and kernel modes by the virtual machine named "test", you can use the following command:

VBoxManage query test CPU/Load/User,CPU/Load/Kernel

The following list summarizes the available subcommands:

list

This subcommand shows the parameters of the currently existing metrics. Note that VM-specific metrics are only available when a particular VM is running.

setup

This subcommand sets the interval between taking two samples of metric data and the number of samples retained internally. The retained data is available for displaying with the query subcommand. The --list option shows which metrics have been modified as the result of the command execution.

query

This subcommand retrieves and displays the currently retained metric data.

Note

The query subcommand does not remove or "flush" retained data. If you query often enough you will see how old samples are gradually being "phased out" by new samples.

collect

This subcommand sets the interval between taking two samples of metric data and the number of samples retained internally. The collected data is displayed periodically until Ctrl-C is pressed unless the --detach option is specified. With the --detach option, this subcommand operates the same way as setup does. The --list option shows which metrics match the specified filter.


8.24. VBoxManage guestproperty

The "guestproperty" commands allow you to get or set properties of a running virtual machine. Please see Section 4.9, “Guest properties” for an introduction. As explained there, guest properties are arbitrary key/value string pairs which can be written to and read from by either the guest or the host, so they can be used as a low-volume communication channel for strings, provided that a guest is running and has the Guest Additions installed. In addition, a number of values whose keys begin with "/VirtualBox/" are automatically set and maintained by the Guest Additions.

The following subcommands are available (where <vm>, in each case, can either be a VM name or a VM UUID, as with the other VBoxManage commands):

  • enumerate <vm> [-patterns <pattern>]: This lists all the guest properties that are available for the given VM, including the value. This list will be very limited if the guest's service process cannot be contacted, e.g. because the VM is not running or the Guest Additions are not installed.

    If --patterns <pattern> is specified, it acts as a filter to only list properties that match the given pattern. The pattern can contain the following wildcard characters:

    • * (asterisk): represents any number of characters; for example, "/VirtualBox*" would match all properties beginning with "/VirtualBox".

    • ? (question mark): represents a single arbitrary character; for example, "fo?" would match both "foo" and "for".

    • | (pipe symbol): can be used to specify multiple alternative patterns; for example, "s*|t*" would match anything starting with either "s" or "t".

  • get <vm>: This retrieves the value of a single property only. If the property cannot be found (e.g. because the guest is not running), this will print "No value set!".

  • set <vm> <property> [<value> [-flags <flags>]]: This allows you to set a guest property by specifying the key and value. If <value> is omitted, the property is deleted. With --flags you can optionally specify additional behavior (you can combine several by separating them with commas):

    • TRANSIENT: the value will not be stored with the VM data when the VM exits;

    • RDONLYGUEST: the value can only be changed by the host, but the guest can only read it;

    • RDONLYHOST: reversely, the value can only be changed by the guest, but the host can only read it;

    • READONLY: a combination of the two, the value cannot be changed at all.

  • wait <vm> <pattern> --timeout <timeout>: This waits for a particular value described by "pattern" to change or to be deleted or created. The pattern rules are the same as for the "enumerate" subcommand above.


8.25. VBoxManage dhcpserver

The "dhcpserver" commands allow you to control the DHCP server that is built into VirtualBox. You may find this useful when using internal or host-only networking. (Theoretically, you can enable it for a bridged network as well, but that will likely cause conflicts with other DHCP servers in your physical network.)

Use the following command line options:

  • If you use internal networking for a virtual network adapter of a virtual machine, use VBoxManage dhcpserver add --netname <network_name>, where <network_name> is the same network name you used with VBoxManage modifyvm <vmname> --intnet<X> <network_name>.

  • If you use host-only networking for a virtual network adapter of a virtual machine, use VBoxManage dhcpserver add --ifname <hostonly_if_name> instead, where <hostonly_if_name> is the same host-only interface name you used with VBoxManage modifyvm <vmname> --hostonlyadapter<X> <hostonly_if_name>.

    Alternatively, you can also use the --netname option as with internal networks if you know the host-only network's name; you can see the names with VBoxManage list hostonlyifs (see Section 8.1, “VBoxManage list” above).

The following additional parameters are required when first adding a DHCP server:

  • With --ip, specify the IP address of the DHCP server itself.

  • With --netmask, specify the netmask of the network.

  • With --lowerip and --upperip, you can specify the lowest and highest IP address, respectively, that the DHCP server will hand out to clients.

Finally, you must specify --enable or the the DHCP server will be created in the disabled state, doing nothing.

After this, VirtualBox will automatically start the DHCP server for given internal or host-only network as soon as the first virtual machine which uses that network is started.

Reversely, use VBoxManage dhcpserver remove with the given --netname <network_name> or --ifname <hostonly_if_name> to remove the DHCP server again for the given internal or host-only network.

To modify the settings of a DHCP server created earlier with VBoxManage dhcpserver add, you can use VBoxManage dhcpserver modify for a given network or host-only interface name.


Chapter 9. Advanced topics

Table of Contents

9.1. VirtualBox configuration data
9.2. Automated Windows guest logons (VBoxGINA)
9.3. Custom external VRDP authentication
9.4. Secure labeling with VBoxSDL
9.5. Custom VESA resolutions
9.6. Multiple monitors for the guest
9.7. Releasing modifiers with VBoxSDL on Linux
9.8. Launching more than 120 VMs on Solaris hosts
9.9. Using serial ports
9.10. Using a raw host hard disk from a guest
9.10.1. Access to entire physical hard disk
9.10.2. Access to individual physical hard disk partitions
9.11. Allowing a virtual machine to start even with unavailable CD/DVD/floppy devices
9.12. Fine-tuning the VirtualBox NAT engine
9.12.1. Configuring the address of a NAT network interface
9.12.2. Configuring the boot server (next server) of a NAT network interface
9.12.3. Tuning TCP/IP buffers for NAT
9.12.4. Binding NAT sockets to a specific interface
9.12.5. Enabling DNS proxy in NAT mode
9.13. Configuring the maximum resolution of guests when using the graphical frontend
9.14. Configuring the BIOS DMI information
9.15. Configuring the guest time stamp counter (TSC) to reflect guest execution
9.16. Configuring the hard disk vendor product data (VPD)

9.1. VirtualBox configuration data

For each system user, VirtualBox stores configuration data in the user's home directory, as per the conventions of the host operating system:

  • On Windows, this is %HOMEDRIVE%%HOMEPATH%\.VirtualBox; typically something like C:\Documents and Settings\Username\.VirtualBox.

  • On Mac OS X, this is $HOME/Library/VirtualBox.

  • On Unix-like systems (Linux, Solaris), this is $HOME/.VirtualBox.

VirtualBox creates this configuration directory automatically, if necessary. Optionally, you can supply an alternate configuration directory by setting the VBOX_USER_HOME environment variable.

VirtualBox stores all its global and machine-specific configuration data in XML documents. We intentionally do not document the specifications of these files, as we must reserve the right to modify them in the future. We therefore strongly suggest that you do not edit these files manually. VirtualBox provides complete access to its configuration data through its the VBoxManage command line tool (see Chapter 8, VBoxManage reference) and its API (see Chapter 10, VirtualBox programming interfaces).

In the configuration directory, VirtualBox.xml is the main configuration file. This includes global configuration options and the media and virtual machine registry. The media registry links to all CD/DVD, floppy and disk images that have been added to the Virtual Disk Manager. For each registered VM, there is one entry which points to the VM configuration file, also in XML format.

You can globally change some of the locations where VirtualBox keeps extra configuration and data by selecting "Global settings" from the "File" menu in the VirtualBox main window. Then, in the window that pops up, click on the "General" tab.

  • Virtual machine settings and files are, by default, saved as XML files in a subdirectory of the .VirtualBox/Machines directory. You can change the location of this main "Machines" folder in the "Global settings" dialog.

    By default, for each virtual machine, VirtualBox uses another subdirectory of the "Machines" directory that carries the same name as the virtual machine. As a result, your virtual machine names must conform to the conventions of your operating system for valid file names. For example, a machine called "Fedora 6" would, by default, have its settings saved in .VirtualBox/Machines/Fedora 6/Fedora 6.xml. If you would like more control over the file names used, you can create the machine using VBoxManage createvm with the --settingsfile option; see Section 8.4, “VBoxManage createvm”.

    The virtual machine directory will be renamed if you change the machine name. If you do not wish this to happen, you can create the machine using VBoxManage createvm with the --basefolder option. In this case, the folder name will never change.

  • VirtualBox keeps snapshots and saved states in another special folder for each virtual machine. By default, this is a subfolder of the virtual machine folder called Snapshots -- in our example, .VirtualBox/Machines/Fedora 6/Snapshots. You can change this setting for each machine using VBoxManage as well.

  • VDI container files are, by default, created in the .VirtualBox/VDI directory. In particular, this directory is used when the "Create new virtual disk" wizard is started to create a new VDI file. Changing this default is probably most useful if the disk containing your home directory does not have enough room to hold your VDI files, which can grow very large.


9.2. Automated Windows guest logons (VBoxGINA)

When Windows is running in a virtual machine, it might be desirable to perform coordinated and automated logons of guest operating systems using credentials from a master logon system. (With "credentials", we are referring to logon information consisting of user name, password and domain name, where each value might be empty.) Since Windows NT, Windows has provided a modular system logon subsystem ("Winlogon") which can be customized and extended by means of so-called GINA modules (Graphical Identification and Authentication). The VirtualBox Guest Additions for Windows come with such a GINA module and therefore allow Windows guests to perform automated logons.

To activate the GINA module, install the Guest Additions with the command line switch /with_gina. To manually install the GINA module, extract the Guest Additions (see Section 4.2.4, “Manual file extraction”) and copy the file VBoxGINA.dll to the Windows SYSTEM32 directory. Then, in the registry, create the following key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\
                       Winlogon\GinaDLL

with a value of VBoxGINA.dll.

Note

The VirtualBox GINA is implemented as a wrapper around the standard Windows GINA (MSGINA.DLL) so it will most likely not work correctly with 3rd party GINA modules.

To set credentials, use the following command on a running VM:

VBoxManage controlvm "Windows XP"
      setcredentials "John Doe" "secretpassword" "DOMTEST"

While the VM is running, the credentials can be queried by the VirtualBox GINA module using the VirtualBox Guest Additions device driver. When Windows is in "logged out" mode, the GINA module will constantly poll for credentials and if they are present, a logon will be attempted. After retrieving the credentials, the GINA module will erase them so that the above command will have to be repeated for subsequent logons.

For security reasons, credentials are not stored in any persistent manner and will be lost when the VM is reset. Also, the credentials are "write-only", i.e. there is no way to retrieve the credentials from the host side. Credentials can be reset from the host side by setting empty values.

Depending on the particular variant of the Windows guest, the following restrictions apply:

  1. For Windows XP guests, the logon subsystem has to be configured to use the classical logon dialog as the VirtualBox GINA does not support the XP style welcome dialog.

  2. Since Windows Vista, GINA has been replaced with a newer concept. VBoxGINA will not work with Windows Vista or Windows 7; support for these versions will be added in a later version of VirtualBox.

The following command forces VirtualBox to keep the credentials after they were read by the guest and on VM reset:

VBoxManage setextradata "Windows XP"
      VBoxInternal/Devices/VMMDev/0/Config/KeepCredentials 1

Note that this is a potential security risk as a malicious application running on the guest could request this information using the proper interface.


9.3. Custom external VRDP authentication

As described in Section 7.4.5, “RDP authentication”, VirtualBox supports arbitrary external modules to perform authentication with its VRDP servers. When the authentication method is set to "external" for a particular VM, VirtualBox calls the library that was specified with VBoxManage setproperty vrdpauthlibrary. This library will be loaded by the VM process on demand, i.e. when the first RDP connection is made by an external client.

External authentication is the most flexible as the external handler can both choose to grant access to everyone (like the "null" authentication method would) and delegate the request to the guest authentication component. When delegating the request to the guest component, it will still be called afterwards with the option to override the result.

A VRDP authentication library is required to implement exactly one entry point:

#include "VRDPAuth.h"

/**
 * Authentication library entry point. Decides whether to allow
 * a client connection.
 *
 * Parameters:
 *
 *   pUuid            Pointer to the UUID of the virtual machine
 *                    which the client connected to.
 *   guestJudgement   Result of the guest authentication.
 *   szUser           User name passed in by the client (UTF8).
 *   szPassword       Password passed in by the client (UTF8).
 *   szDomain         Domain passed in by the client (UTF8).
 *
 * Return code:
 *
 *   VRDPAuthAccessDenied    Client access has been denied.
 *   VRDPAuthAccessGranted   Client has the right to use the
 *                           virtual machine.
 *   VRDPAuthDelegateToGuest Guest operating system must
 *                           authenticate the client and the
 *                           library must be called again with
 *                           the result of the guest
 *                           authentication.
 */
VRDPAuthResult VRDPAUTHCALL VRDPAuth(
    PVRDPAUTHUUID pUuid,
    VRDPAuthGuestJudgement guestJudgement,
    const char *szUser,
    const char *szPassword
    const char *szDomain)
{
    /* process request against your authentication source of choice */
    return VRDPAuthAccessGranted;
}

A note regarding the UUID implementation of the first argument: VirtualBox uses a consistent binary representation of UUIDs on all platforms. For this reason the integer fields comprising the UUID are stored as little endian values. If you want to pass such UUIDs to code which assumes that the integer fields are big endian (often also called network byte order), you need to adjust the contents of the UUID to e.g. achieve the same string representation. The required changes are:

  • reverse the order of byte 0, 1, 2 and 3

  • reverse the order of byte 4 and 5

  • reverse the order of byte 6 and 7.

Using this conversion you will get identical results when converting the binary UUID to the string representation.

The second arguments contains information about the guest authentication status. For the first call, it is always set to VRDPAuthGuestNotAsked. In case the function returns VRDPAuthDelegateToGuest, a guest authentication will be attempted and another call to the method is made with its result. This can be either granted / denied or no judgement (the guest component chose for whatever reason to not make a decision). In case there is a problem with the guest authentication module (e.g. the Additions are not installed or not running or the guest did not respond within a timeout), the "not reacted" status will be returned.


9.4. Secure labeling with VBoxSDL

When running guest operating systems in fullscreen mode, the guest operating system usually has control over the whole screen. This could present a security risk as the guest operating system might fool the user into thinking that it is either a different system (which might have a higher security level) or it might present messages on the screen that appear to stem from the host operating system.

In order to protect the user against the above mentioned security risks, the secure labeling feature has been developed. Secure labeling is currently available only for VBoxSDL. When enabled, a portion of the display area is reserved for a label in which a user defined message is displayed. The label height in set to 20 pixels in VBoxSDL. The label font color and background color can be optionally set as hexadecimal RGB color values. The following syntax is used to enable secure labeling:

VBoxSDL --startvm VMNAME
      --securelabel --seclabelfnt ~/fonts/arial.ttf
      --seclabelsiz 14 --seclabelfgcol 00FF00 --seclabelbgcol 00FFFF

In addition to enabling secure labeling, a TrueType font has to be supplied. To use another font size than 12 point use the parameter --seclabelsiz.

The label text can be set with

VBoxManage setextradata VMNAME "VBoxSDL/SecureLabel" "The Label"

Changing this label will take effect immediately.

Typically, full screen resolutions are limited to certain "standard" geometries such as 1024 x 768. Increasing this by twenty lines is not usually feasible, so in most cases, VBoxSDL will chose the next higher resolution, e.g. 1280 x 1024 and the guest's screen will not cover the whole display surface. If VBoxSDL is unable to choose a higher resolution, the secure label will be painted on top of the guest's screen surface. In order to address the problem of the bottom part of the guest screen being hidden, VBoxSDL can provide custom video modes to the guest that are reduced by the height of the label. For Windows guests and recent Solaris and Linux guests, the VirtualBox Guest Additions automatically provide the reduced video modes. Additionally, the VESA BIOS has been adjusted to duplicate its standard mode table with adjusted resolutions. The adjusted mode IDs can be calculated using the following formula:

reduced_modeid = modeid + 0x30

For example, in order to start Linux with 1024 x 748 x 16, the standard mode 0x117 (1024 x 768 x 16) is used as a base. The Linux video mode kernel parameter can then be calculated using:

vga = 0x200 | 0x117 + 0x30
vga = 839

The reason for duplicating the standard modes instead of only supplying the adjusted modes is that most guest operating systems require the standard VESA modes to be fixed and refuse to start with different modes.

When using the X.org VESA driver, custom modelines have to be calculated and added to the configuration (usually in /etc/X11/xorg.conf. A handy tool to determine modeline entries can be found at http://www.tkk.fi/Misc/Electronics/faq/vga2rgb/calc.html.)


9.5. Custom VESA resolutions

Apart from the standard VESA resolutions, the VirtualBox VESA BIOS allows you to add up to 16 custom video modes which will be reported to the guest operating system. When using Windows guests with the VirtualBox Guest Additions, a custom graphics driver will be used instead of the fallback VESA solution so this information does not apply.

Additional video modes can be configured for each VM using the extra data facility. The extra data key is called CustomVideoMode<x> with x being a number from 1 to 16. Please note that modes will be read from 1 until either the following number is not defined or 16 is reached. The following example adds a video mode that corresponds to the native display resolution of many notebook computers:

VBoxManage setextradata VMNAME
      "CustomVideoMode1" "1400x1050x16"

The VESA mode IDs for custom video modes start at 0x160. In order to use the above defined custom video mode, the following command line has be supplied to Linux:

vga = 0x200 | 0x160
vga = 864

For guest operating systems with VirtualBox Guest Additions, a custom video mode can be set using the video mode hint feature.


9.6. Multiple monitors for the guest

VirtualBox allows the guest to use multiple virtual monitors. Up to sixty-four virtual monitors are supported.

Note

  1. Multiple monitors currently work only with Windows XP guests, and Guest Additions must be installed, as the implementation resides in the Guest Additions video driver.

  2. Multiple monitors work only with the VBoxHeadless frontend. You must also enable VRDP multiconnection mode (see Section 7.4.7, “VRDP multiple connections”) to access two or more VM displays when the guest is using multiple monitors.

  3. The guest video RAM size should be increased when multiple monitors are used. The VRAM is shared among the virtual monitors so that only part of it is available for each one. Therefore the available resolutions and color depths will be reduced if the VRAM size remains the same and multiple monitors are enabled.

The following command enables three virtual monitors for the VM:

VBoxManage modifyvm VMNAME --monitorcount 3

The following command enables VRDP multiconnection mode for the VM:

VBoxManage modifyvm VMNAME --vrdpmulticon on

The RDP client can select the virtual monitor number to connect to using the domain logon parameter. If the parameter ends with @ followed by a number, VBoxHeadless interprets this number as the screen index. The primary guest screen is selected with @1, the first secondary screen is @2, etc.

The MS RDP6 client does not let you specify a separate domain name. Instead, use domain\username in the Username: field -- for example, @2\name. name must be supplied, and must be the name used to log in if the VRDP server is set up to require credentials. If it is not, you may use any text as the username.


9.7. Releasing modifiers with VBoxSDL on Linux

When switching from a X virtual terminal (VT) to another VT using Ctrl-Alt-Fx while the VBoxSDL window has the input focus, the guest will receive Ctrl and Alt keypress events without receiving the corresponding key release events. This is an architectural limitation of Linux. In order to reset the modifier keys, it is possible to send SIGUSR1 to the VBoxSDL main thread (first entry in the ps list). For example, when switching away to another VT and saving the virtual machine from this terminal, the following sequence can be used to make sure the VM is not saved with stuck modifiers:

kill -usr1 <pid>
VBoxManage controlvm "Windows 2000" savestate


9.8. Launching more than 120 VMs on Solaris hosts

Solaris hosts have a fixed number of IPC semaphores IDs per process preventing users from starting more than 120 VMs. While trying to launch more VMs you would be shown a "Cannot create IPC semaphore" error.

In order to run more VMs, you will need to bump the semaphore ID limit of the VBoxSVC process. Execute as root the prctl command as shown below. The process ID of VBoxSVC can be obtained using the ps list command.

prctl -r -n project.max-sem-ids -v 2048 <pid-of-VBoxSVC>


9.9. Using serial ports

Starting with version 1.4, VirtualBox provided support for virtual serial ports, which, at the time, was rather complicated to set up with a sequence of VBoxManage setextradata statements. Since version 1.5, that way of setting up serial ports is no longer necessary and deprecated. To set up virtual serial ports, use the methods now described in Section 3.7.8, “Serial ports”.

Note

For backwards compatibility, the old setextradata statements, whose description is retained below from the old version of the manual, take precedence over the new way of configuring serial ports. As a result, if configuring serial ports the new way doesn't work, make sure the VM in question does not have old configuration data such as below still active.

The old sequence of configuring a serial port used the following 6 commands:

VBoxManage setextradata "YourVM"
      "VBoxInternal/Devices/serial/0/Config/IRQ" 4
VBoxManage setextradata "YourVM"
      "VBoxInternal/Devices/serial/0/Config/IOBase" 0x3f8
VBoxManage setextradata "YourVM"
      "VBoxInternal/Devices/serial/0/LUN#0/Driver" Char
VBoxManage setextradata "YourVM"
      "VBoxInternal/Devices/serial/0/LUN#0/AttachedDriver/Driver" NamedPipe
VBoxManage setextradata "YourVM"
      "VBoxInternal/Devices/serial/0/LUN#0/AttachedDriver/Config/Location"
      "\\.\pipe\vboxCOM1"
VBoxManage setextradata "YourVM"
      "VBoxInternal/Devices/serial/0/LUN#0/AttachedDriver/Config/IsServer"
      1

This sets up a serial port in the guest with the default settings for COM1 (IRQ 4, I/O address 0x3f8) and the Location setting assumes that this configuration is used on a Windows host, because the Windows named pipe syntax is used. Keep in mind that on Windows hosts a named pipe must always start with \\.\pipe\. On Linux the same config settings apply, except that the path name for the Location can be chosen more freely. Local domain sockets can be placed anywhere, provided the user running VirtualBox has the permission to create a new file in the directory. The final command above defines that VirtualBox acts as a server, i.e. it creates the named pipe itself instead of connecting to an already existing one.


9.10. Using a raw host hard disk from a guest

Starting with version 1.4, as an alternative to using virtual disk images (as described in detail in Chapter 5, Virtual storage), VirtualBox can also present either entire physical hard disks or selected partitions thereof as virtual disks to virtual machines.

With VirtualBox, this type of access is called "raw hard disk access"; it allows a guest operating system to access its virtual hard disk without going through the host OS file system. The actual performance difference for image files vs. raw disk varies greatly depending on the overhead of the host file system, whether dynamically growing images are used and on host OS caching strategies. The caching indirectly also affects other aspects such as failure behavior, i.e. whether the virtual disk contains all data written before a host OS crash. Consult your host OS documentation for details on this.

Warning

Raw hard disk access is for expert users only. Incorrect use or use of an outdated configuration can lead to total loss of data on the physical disk. Most importantly, do not attempt to boot the partition with the currently running host operating system in a guest. This will lead to severe data corruption.

Raw hard disk access -- both for entire disks and individual partitions -- is implemented as part of the VMDK image format support. As a result, you will need to create a special VMDK image file which defines where the data will be stored. After creating such a special VMDK image, you can use it like a regular virtual disk image. For example, you can use the Virtual Disk Manager (Section 3.5, “The Virtual Disk Manager”) or VBoxManage to assign the image to a virtual machine.

9.10.1. Access to entire physical hard disk

While this variant is the simplest to set up, you must be aware that this will give a guest operating system direct and full access to an entire physical disk. If your host operating system is also booted from this disk, please take special care to not access the partition from the guest at all. On the positive side, the physical disk can be repartitioned in arbitrary ways without having to recreate the image file that gives access to the raw disk.

To create an image that represents an entire physical hard disk (which will not contain any actual data, as this will all be stored on the physical disk), on a Linux host, use the command

VBoxManage internalcommands createrawvmdk -filename /path/to/file.vmdk
        -rawdisk /dev/sda

This creates the image /path/to/file.vmdk (must be absolute), and all data will be read and written from /dev/sda.

On a Windows host, instead of the above device specification, use e.g. \\.\PhysicalDrive0. On a Mac OS X host, instead of the above device specification use e.g. /dev/disk1. Note that on OS X you can only get access to an entire disk if no volume is mounted from it.

Creating the image requires read/write access for the given device. Read/write access is also later needed when using the image from a virtual machine.

Just like with regular disk images, this does not automatically register the newly created image in the internal registry of hard disks. If you want this done automatically, add -register:

VBoxManage internalcommands createrawvmdk -filename /path/to/file.vmdk
      -rawdisk /dev/sda -register

After registering, you can assign the newly created image to a virtual machine with

VBoxManage modifyvm WindowsXP -hda /path/to/file.vmdk

When this is done the selected virtual machine will boot from the specified physical disk.

9.10.2. Access to individual physical hard disk partitions

This "raw partition support" is quite similar to the "full hard disk" access described above. However, in this case, any partitioning information will be stored inside the VMDK image, so you can e.g. install a different boot loader in the virtual hard disk without affecting the host's partitioning information. While the guest will be able to see all partitions that exist on the physical disk, access will be filtered in that reading from partitions for which no access is allowed the partitions will only yield zeroes, and all writes to them are ignored.

To create a special image for raw partition support (which will contain a small amount of data, as already mentioned), on a Linux host, use the command

VBoxManage internalcommands createrawvmdk -filename /path/to/file.vmdk
      -rawdisk /dev/sda -partitions 1,5

As you can see, the command is identical to the one for "full hard disk" access, except for the additional -partitions parameter. This example would create the image /path/to/file.vmdk (which, again, must be absolute), and partitions 1 and 5 of /dev/sda would be made accessible to the guest.

VirtualBox uses the same partition numbering as your Linux host. As a result, the numbers given in the above example would refer to the first primary partition and the first logical drive in the extended partition, respectively.

On a Windows host, instead of the above device specification, use e.g. \\.\PhysicalDrive0. On a Mac OS X host, instead of the above device specification use e.g. /dev/disk1. Note that on OS X you can only use partitions which are not mounted (eject the respective volume first). Partition numbers are the same on Linux, Windows and Mac OS X hosts.

The numbers for the list of partitions can be taken from the output of

VBoxManage internalcommands listpartitions -rawdisk /dev/sda

The output lists the partition types and sizes to give the user enough information to identify the partitions necessary for the guest.

Images which give access to individual partitions are specific to a particular host disk setup. You cannot transfer these images to another host; also, whenever the host partitioning changes, the image must be recreated.

Creating the image requires read/write access for the given device. Read/write access is also later needed when using the image from a virtual machine. If this is not feasible, there is a special variant for raw partition access (currently only available on Linux hosts) that avoids having to give the current user access to the entire disk. To set up such an image, use

VBoxManage internalcommands createrawvmdk -filename /path/to/file.vmdk
      -rawdisk /dev/sda -partitions 1,5 -relative

When used from a virtual machine, the image will then refer not to the entire disk, but only to the individual partitions (in the example /dev/sda1 and /dev/sda5). As a consequence, read/write access is only required for the affected partitions, not for the entire disk. During creation however, read-only access to the entire disk is required to obtain the partitioning information.

In some configurations it may be necessary to change the MBR code of the created image, e.g. to replace the Linux boot loader that is used on the host by another boot loader. This allows e.g. the guest to boot directly to Windows, while the host boots Linux from the "same" disk. For this purpose the -mbr parameter is provided. It specifies a file name from which to take the MBR code. The partition table is not modified at all, so a MBR file from a system with totally different partitioning can be used. An example of this is

VBoxManage internalcommands createrawvmdk -filename /path/to/file.vmdk
      -rawdisk /dev/sda -partitions 1,5 -mbr winxp.mbr

The modified MBR will be stored inside the image, not on the host disk.

For each of the above variants, you can register the resulting image for immediate use in VirtualBox by adding -register to the respective command line. The image will then immediately appear in the list of registered disk images. An example is

VBoxManage internalcommands createrawvmdk -filename /path/to/file.vmdk
      -rawdisk /dev/sda -partitions 1,5 -relative -register

which creates an image referring to individual partitions, and registers it when the image is successfully created.


9.11. Allowing a virtual machine to start even with unavailable CD/DVD/floppy devices

When, on VM startup, a CD, DVD or floppy device is unavailable, VirtualBox by default prints an error message and refuses to start the virtual machine. In some situations this behavior is not desirable.

The behavior can be changed for the CD/DVD drive with the following configuration change command:

VBoxManage setextradata "YourVM"
      "VBoxInternal/Devices/piix3ide/0/LUN#2/Config/AttachFailError" 0

The equivalent command for the floppy drive is:

VBoxManage setextradata "YourVM"
      "VBoxInternal/Devices/i82078/0/LUN#0/Config/AttachFailError" 0

You will still get a warning message that a device is not available. Some guest operating systems may show strange behavior when using saved state or snapshots, especially if a previously mounted medium is no longer available when the virtual machine is resumed.


9.12. Fine-tuning the VirtualBox NAT engine

9.12.1. Configuring the address of a NAT network interface

In NAT mode, the guest network interface is assigned to the IPv4 range 10.0.x.0/24 by default where x corresponds to the instance of the NAT interface +2 of that VM. So x is 2 if there is only once NAT instance active. In that case the guest is assigned to the address 10.0.2.15, the gateway is set to 10.0.2.2 and the name server can be found at 10.0.2.3.

If, for any reason, the NAT network needs to be changed, this can be achieved with the following command:

VBoxManage modifyvm "My VM" --natnet1 "192.168/16"

This command would reserve the network addresses 192.168.0.0 ... 192.168.254.254 for the first NAT network instance of "My VM". The guest IP would be assigned to 192.168.0.15 and the default gateway could be found at 192.168.0.2.

9.12.2. Configuring the boot server (next server) of a NAT network interface

For network booting in NAT mode, by default VirtualBox uses a built-in TFTP server at the IP address 10.0.2.3. This default behavior should work fine for typical remote-booting scenarios. However, it is possible to change the boot server IP and the location of the boot image with the following commands:

VBoxManage setextradata "Linux Guest"
      "VBoxInternal/Devices/pcnet/0/LUN#0/Config/NextServer" 10.0.2.2
VBoxManage setextradata "Linux Guest"
      "VBoxInternal/Devices/pcnet/0/LUN#0/Config/BootFile"
      /srv/tftp/boot/MyPXEBoot.pxe

9.12.3. Tuning TCP/IP buffers for NAT

The VirtualBox NAT stack performance is often determined by its interaction with the host's TCP/IP stack and the size of several buffers (SO_RCVBUF and SO_SNDBUF). For certain setups users might want to adjust the buffer size for better performance. This can by achieved using the following commands (values are in kilobytes and can range from 8 to 1024):

VBoxManage setextradata "Linux Guest"
      "VBoxInternal/Devices/pcnet/0/LUN#0/Config/SocketRcvBuf" 128
VBoxManage setextradata "Linux Guest"
      "VBoxInternal/Devices/pcnet/0/LUN#0/Config/SocketSndBuf" 128
VBoxManage setextradata "Linux Guest"
      "VBoxInternal/Devices/pcnet/0/LUN#0/Config/TcpRcvSpace" 128
VBoxManage setextradata "Linux Guest"
      "VBoxInternal/Devices/pcnet/0/LUN#0/Config/TcpSndSpace" 128

Each of these buffers has a default size of 64KB.

9.12.4. Binding NAT sockets to a specific interface

By default, VirtualBox's NAT engine will route TCP/IP packets through the default port assigned by the host's TCP/IP stack. (The technical reason for this is that the NAT engine uses sockets for communication.) If, for some reason, you want to change this behavior, you can tell the NAT engine to bind to a particular IP address instead. Use the following command:

VBoxManage setextradata "Linux Guest"
      "VBoxInternal/Devices/pcnet/0/LUN#0/Config/BindIP" "10.45.0.2"

After this, all outgoing traffic will be sent through the interface with the IP address 10.45.0.2. Please make sure that this interface is up and running prior to this assignment.

Also, if you have configured port forwarding for the NAT engine as described in Section 6.4.1, “Configuring port forwarding with NAT”, you can bind this configuration only to a particular interface as well. Assuming that you have configured port forwarding for a "guestssh" service, you would use the following additional command:

VBoxManage setextradata "Linux Guest"
      "VBoxInternal/Devices/pcnet/0/LUN#0/Config/guestssh/BindIP" "127.0.0.1"

This would make ssh port forwarding available from host only.

9.12.5. Enabling DNS proxy in NAT mode

For resolving network names the DHCP server of the NAT engine offers a list of registered DNS servers of the host. For some reason you might need to hide the DNS server list, thereby forcing the VirtualBox NAT engine to react to changes in the host network settings, for example about the end of DHCP leases. Replacing of the real list with the address of the DNS proxy can be achieved with the following command:

VBoxManage setextradata "Linux Guest"
      "VBoxInternal/Devices/pcnet/0/LUN#0/Config/DNSProxy" 1


9.13. Configuring the maximum resolution of guests when using the graphical frontend

When guest systems with the Guest Additions installed are started using the graphical frontend (the normal VirtualBox application), they will not be allowed to use screen resolutions greater than the host's screen size unless the user manually resizes them by dragging the window, switching to fullscreen or seamless mode or sending a video mode hint using VBoxManage. This behavior is what most users will want, but if you have different needs, it is possible to change it by issuing one of the following commands from the command line:

VBoxManage setextradata global GUI/MaxGuestResolution any

will remove all limits on guest resolutions.

VBoxManage setextradata global GUI/MaxGuestResolution
      >width,height<

manually specifies a maximum resolution.

VBoxManage setextradata global GUI/MaxGuestResolution auto

restores the default settings. Note that these settings apply globally to all guest systems, not just to a single machine.


9.14. Configuring the BIOS DMI information

The DMI data VirtualBox provides to guests can be changed for a specific VM. Use the following commands to configure the DMI BIOS information:

VBoxManage setextradata "My VM"
      "VBoxInternal/Devices/pcbios/0/Config/DmiBIOSVendor"
      "Host BIOS Vendor"
VBoxManage setextradata "My VM"
      "VBoxInternal/Devices/pcbios/0/Config/DmiBIOSVersion"
      "Host BIOS Version"
VBoxManage setextradata "My VM"
      "VBoxInternal/Devices/pcbios/0/Config/DmiBIOSReleaseDate"
      "Host BIOS Release Date"
VBoxManage setextradata "My VM"
      "VBoxInternal/Devices/pcbios/0/Config/DmiBIOSReleaseMajor"
      1
VBoxManage setextradata "My VM"
      "VBoxInternal/Devices/pcbios/0/Config/DmiBIOSReleaseMinor"
      2
VBoxManage setextradata "My VM"
      "VBoxInternal/Devices/pcbios/0/Config/DmiBIOSFirmwareMajor"
      3
VBoxManage setextradata "My VM"
      "VBoxInternal/Devices/pcbios/0/Config/DmiBIOSFirmwareMinor"
      4

If a DMI string is not set, the default value of VirtualBox is used. To set an empty string use "<EMPTY>".

Changing this information can be necessary to provide the DMI information of the host to the guest to prevent Windows from asking for a new product key. On Linux hosts the DMI BIOS information can be obtained with

dmidecode -t0

and the DMI system information can be obtained with

dmidecode -t1


9.15. Configuring the guest time stamp counter (TSC) to reflect guest execution

By default, VirtualBox keeps all sources of time visible to the guest synchronized to a single time source, the monotonic host time. This reflects the assumptions of many guest operating systems, which expect all time sources to reflect "wall clock" time. In special circumstances it may be useful however to make the TSC (time stamp counter) in the guest reflect the time actually spent executing the guest.

This special TSC handling mode can be enabled on a per-VM basis, and for best results must be used only in combination with hardware virtualization. To enable this mode use the following command:

VBoxManage setextradata "My VM" "VBoxInternal/TM/TSCTiedToExecution" 1

To revert to the default TSC handling mode use:

VBoxManage setextradata "My VM" "VBoxInternal/TM/TSCTiedToExecution"

Note that if you use the special TSC handling mode with a guest operating system which is very strict about the consistency of time sources you may get a warning or error message about the timing inconsistency. It may also cause clocks to become unreliable with some guest operating systems depending on they use the TSC.


9.16. Configuring the hard disk vendor product data (VPD)

VirtualBox reports vendor product data for its virtual hard disks which consist of hard disk serial number, firmware revision and model number. These can be changed using the following commands:

VBoxManage setextradata "My VM"
      "VBoxInternal/Devices/ahci/0/Config/Port0/SerialNumber"
      "serial"
VBoxManage setextradata "My VM"
      "VBoxInternal/Devices/ahci/0/Config/Port0/FirmwareRevision"
      "firmware"
VBoxManage setextradata "My VM"
      "VBoxInternal/Devices/ahci/0/Config/Port0/ModelNumber"
      "model"

The serial number is a 20 byte alphanumeric string, the firmware revision an 8 byte alphanumeric string and the model number a 40 byte alphanumeric string. Instead of "Port0" (referring to the first port), specify the desired SATA hard disk port.


Chapter 10. VirtualBox programming interfaces

VirtualBox comes with comprehensive support for third-party developers. The so-called "Main API" of VirtualBox exposes the entire feature set of the virtualization engine. It is completely documented and available to anyone who wishes to control VirtualBox programmatically.

With VirtualBox, all programming information (documentation, reference information, header and other interface files as well as samples) have been split out to a separate Software Development Kit (SDK), which is available for download from http://www.virtualbox.org. In particular, the SDK comes with a "Programming Guide and Reference" in PDF format, which contains, among other things, the information that was previously in this chapter of the User Manual.


Chapter 11. Troubleshooting

Table of Contents

11.1. General
11.1.1. Collecting debugging information
11.1.2. Guest shows IDE errors for VDI on slow host file system
11.1.3. Responding to guest IDE flush requests
11.2. Windows guests
11.2.1. Windows bluescreens after changing VM configuration
11.2.2. Windows 0x101 bluescreens with SMP enabled (IPI timeout)
11.2.3. Windows 2000 installation failures
11.2.4. How to record bluescreen information from Windows guests
11.2.5. No networking in Windows Vista guests
11.2.6. Windows guests may cause a high CPU load
11.3. Linux and X11 guests
11.3.1. Linux guests may cause a high CPU load
11.3.2. AMD Barcelona CPUs
11.3.3. Buggy Linux 2.6 kernel versions
11.3.4. Shared clipboard, auto-resizing and seamless desktop in X11 guests
11.4. Windows hosts
11.4.1. VBoxSVC out-of-process COM server issues
11.4.2. CD/DVD changes not recognized
11.4.3. Sluggish response when using Microsoft RDP client
11.4.4. Running an iSCSI initiator and target on a single system
11.5. Linux hosts
11.5.1. Linux kernel module refuses to load
11.5.2. Linux host CD/DVD drive not found
11.5.3. Linux host CD/DVD drive not found (older distributions)
11.5.4. Linux host floppy not found
11.5.5. Strange guest IDE error messages when writing to CD/DVD
11.5.6. VBoxSVC IPC issues
11.5.7. USB not working
11.5.8. PAX/grsec kernels
11.5.9. Linux kernel vmalloc pool exhausted
11.6. Solaris hosts
11.6.1. Cannot start VM, not enough contiguous memory
11.6.2. VM aborts with out of memory errors on Solaris 10 hosts

This chapter provides answers to commonly asked questions. In order to improve your user experience with VirtualBox, it is recommended to read this section to learn more about common pitfalls and get recommendations on how to use the product.

11.1. General

11.1.1. Collecting debugging information

For problem determination, it is often important to collect debugging information which can be analyzed by VirtualBox support. This section contains information about what kind of information can be obtained.

Every time VirtualBox starts up a VM, a log file is created containing some information about the VM configuration and runtime events. The log file is called VBox.log and resides in the VM log file folder. Typically this will be a directory like this:

$HOME/.VirtualBox/Machines/{machinename}/Logs

When starting a VM, the configuration file of the last run will be renamed to .1, up to .3. Sometimes when there is a problem, it is useful to have a look at the logs. Also when requesting support for VirtualBox, supplying the corresponding log file is mandatory.

For convenience, for each virtual machine, the VirtualBox main window can show these logs in a window. To access it, select a virtual machine from the list on the left and select "Show logs..." from the "Machine" window.

11.1.2. Guest shows IDE errors for VDI on slow host file system

Occasionally, some host file systems provide very poor writing performance and as a consequence cause the guest to time out IDE commands. This is normal behavior and should normally cause no real problems, as the guest should repeat commands that have timed out. However some guests (e.g. some Linux versions) have severe problems if a write to a VDI file takes longer than about 15 seconds. Some file systems however require more than a minute to complete a single write, if the host cache contains a large amount of data that needs to be written.

The symptom for this problem is that the guest can no longer access its files during large write or copying operations, usually leading to an immediate hang of the guest.

In order to work around this problem (the true fix is to use a faster file system that doesn't exhibit such unacceptable write performance), it is possible to flush the VDI after a certain amount of data has been written. This interval is normally infinite, but can be configured individually for each disk of a VM using the following command:

VBoxManage setextradata VMNAME
      "VBoxInternal/Devices/piix3ide/0/LUN#[x]/Config/FlushInterval" [b]

The value [x] that selects the disk is 0 for the master device on the first channel, 1 for the slave device on the first channel, 2 for the master device on the second channel or 3 for the master device on the second channel. Only disks support this configuration option. It must not be set for CD-ROM drives.

The unit of the interval [b] is the number of bytes written since the last flush. The value for it must be selected so that the occasional long write delays do not occur. Since the proper flush interval depends on the performance of the host and the host filesystem, finding the optimal value that makes the problem disappear requires some experimentation. Values between 1000000 and 10000000 (1 to 10 megabytes) are a good starting point. Decreasing the interval both decreases the probability of the problem and the write performance of the guest. Setting the value unnecessarily low will cost performance without providing any benefits. An interval of 1 will cause a flush for each write operation and should solve the problem in any case, but has a severe write performance penalty.

Providing a value of 0 for [b] is treated as an infinite flush interval, effectively disabling this workaround. Removing the extra data key by specifying no value for [b] has the same effect.

11.1.3. Responding to guest IDE flush requests

If desired, the virtual disk images (VDI) can be flushed when the guest issues the IDE FLUSH CACHE command. Normally these requests are ignored for improved performance. To enable flushing, issue the following command:

VBoxManage setextradata VMNAME
      "VBoxInternal/Devices/piix3ide/0/LUN#[x]/Config/IgnoreFlush" 0

The value [x] that selects the disk is 0 for the master device on the first channel, 1 for the slave device on the first channel, 2 for the master device on the second channel or 3 for the master device on the second channel. Only disks support this configuration option. It must not be set for CD-ROM drives.

Note that this doesn't affect the flushes performed according to the configuration described in 11.1.2. Restoring the default of ignoring flush commands is possible by setting the value to 1 or by removing the key.


11.2. Windows guests

11.2.1. Windows bluescreens after changing VM configuration

Often, customers encounter Windows startup failures (the infamous "blue screen") after performing configuration changes to a virtual machine which are not allowed for an already installed Windows operating system. Depending on the presence of several hardware features, the Windows installation program chooses special kernel and device driver versions and will fail to startup should these hardware features be removed.

Most importantly, never disable ACPI and the I/O APIC if they were enabled at installation time. Enabling them for a Windows VM which was installed without them does not cause any harm. However, Windows will not use these features in this case.

11.2.2. Windows 0x101 bluescreens with SMP enabled (IPI timeout)

If a VM is configured to have more than one processor (symmetrical multiprocessing, SMP), some configurations of Windows guests crash with an 0x101 error message, indicating a timeout for inter-processor interrupts (IPIs). These interrupts synchronize memory management between processors.

According to Microsoft, this is due to a race condition in Windows. A hotfix is available.[21] If this does not help, please reduce the number of virtual processors to 1.

11.2.3. Windows 2000 installation failures

When installing Windows 2000 guests, you might run into one of the following issues:

  • Installation reboots, usually during component registration.

  • Installation fills the whole hard disk with empty log files.

  • Installation complains about a failure installing msgina.dll.

These problems are all caused by a bug in the hard disk driver of Windows 2000. After issuing a hard disk request, there is a race condition in the Windows driver code which leads to corruption if the operation completes too fast, i.e. the hardware interrupt from the IDE controller arrives too soon. With physical hardware, there is a guaranteed delay in most systems so the problem is usually hidden there (however it should be possible to reproduce it on physical hardware as well). In a virtual environment, it is possible for the operation to be done immediately (especially on very fast systems with multiple CPUs) and the interrupt is signaled sooner than on a physical system. The solution is to introduce an artificial delay before delivering such interrupts. This delay can be configured for a VM using the following command:

VBoxManage setextradata VMNAME
      "VBoxInternal/Devices/piix3ide/0/Config/IRQDelay" 1

This sets the delay to one millisecond. In case this doesn't help, increase it to a value between 1 and 5 milliseconds. Please note that this slows down disk performance. After installation, you should be able to remove the key (or set it to 0).

11.2.4. How to record bluescreen information from Windows guests

When Windows guests run into a kernel crash, they display the infamous bluescreen. Depending on how Windows is configured, the information will remain on the screen until the machine is restarted or it will reboot automatically. During installation, Windows is usually configured to reboot automatically. With automatic reboots, there is no chance to record the bluescreen information which might be important for problem determination.

VirtualBox provides a method of halting a guest when it wants to perform a reset. In order to enable this feature, issue the following command:

VBoxManage setextradata VMNAME "VBoxInternal/PDM/HaltOnReset" 1

11.2.5. No networking in Windows Vista guests

Unfortunately, with Vista, Microsoft dropped support for the virtual AMD PCNet card that we are providing to virtual machines. As a result, after installation, Vista guests initially have no networking. VirtualBox therefore ships a driver for that card with the Windows Guest Additions; see Section 4.2.5, “Windows Vista networking”.

Starting with version 1.6.0 VirtualBox can emulate an Intel E1000 network device which is supported by Vista without any third-party drivers.

11.2.6. Windows guests may cause a high CPU load

Several background applications of Windows guests, especially virus scanners, are known to increases the CPU load notably even if the guest appears to be idle. We recommend to deactivate virus scanners within virtualized guests if possible.

[21] See http://support.microsoft.com/kb/955076.


11.3. Linux and X11 guests

11.3.1. Linux guests may cause a high CPU load

Some Linux guests may cause a high CPU load even if the guest system appears to be idle. This can be caused by a high timer frequency of the guest kernel. Some Linux distributions, for example Fedora, ship a Linux kernel configured for a timer frequency of 1000Hz. We recommend to recompile the guest kernel and to select a timer frequency of 100Hz.

11.3.2. AMD Barcelona CPUs

Most Linux-based guests will fail with AMD Phenoms or Barcelona-level Opterons due to a bug in the Linux kernel. Enable the I/O-APIC to work around the problem (see Section 3.7.1.2, “"Advanced" tab”).

11.3.3. Buggy Linux 2.6 kernel versions

The following bugs in Linux kernels prevent them from executing correctly in VirtualBox, causing VM boot crashes:

  • The Linux kernel version 2.6.18 (and some 2.6.17 versions) introduced a race condition that can cause boot crashes in VirtualBox. Please use a kernel version 2.6.19 or later.

  • With hardware virtualization and the I/O APIC enabled, kernels before 2.6.24-rc6 may panic on boot with the following message:

    Kernel panic - not syncing: IO-APIC + timer doesn't work!  Boot with
apic=debug and send a report.  Then try booting with the 'noapic' option

    If you see this message, either disable hardware virtualization or the I/O APIC (see Section 3.7.2, “System settings”), or upgrade the guest to a newer kernel.[22]

11.3.4. Shared clipboard, auto-resizing and seamless desktop in X11 guests

Guest desktop services in guests running the X11 window system (Solaris, Linux and others) are provided by a guest service called VBoxClient, which runs under the ID of the user who started the desktop session and is automatically started using the following command lines

VBoxClient --clipboard
        VBoxClient --autoresize
        VBoxClient --seamless

when your X11 user session is started if you are using a common desktop environment (Gnome, KDE and others). If a particular desktop service is not working correctly, it is worth checking whether the process which should provide it is running.

The VBoxClient processes create files in the user's home directory with names of the form .vboxclient-*.pid when they are running in order to prevent a given service from being started twice. It can happen due to misconfiguration that these files are created owned by root and not deleted when the services are stopped, which will prevent them from being started in future sessions. If the services cannot be started, you may wish to check whether these files still exist.

[22] See http://www.mail-archive.com/git-commits-head@vger.kernel.org/msg30813.html for details about the kernel fix.


11.4. Windows hosts

11.4.1. VBoxSVC out-of-process COM server issues

VirtualBox makes use of the Microsoft Component Object Model (COM) for inter- and intra-process communication. This allows VirtualBox to share a common configuration among different virtual machine processes and provide several user interface options based on a common architecture. All global status information and configuration is maintained by the process VBoxSVC.exe, which is an out-of-process COM server. Whenever a VirtualBox process is started, it requests access to the COM server and Windows automatically starts the process. Note that it should never be started by the end user.

When the last process disconnects from the COM server, it will terminate itself after some seconds. The VirtualBox configuration (XML files) is maintained and owned by the COM server and the files are locked whenever the server runs.

In some cases - such as when a virtual machine is terminated unexpectedly - the COM server will not notice that the client is disconnected and stay active for a longer period (10 minutes or so) keeping the configuration files locked. In other rare cases the COM server might experience an internal error and subsequently other processes fail to initialize it. In these situations, it is recommended to use the Windows task manager to kill the process VBoxSVC.exe.

11.4.2. CD/DVD changes not recognized

In case you have assigned a physical CD/DVD drive to a guest and the guest does not notice when the medium changes, make sure that the Windows media change notification (MCN) feature is not turned off. This is represented by the following key in the Windows registry:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Cdrom\Autorun

Certain applications may disable this key against Microsoft's advice. If it is set to 0, change it to 1 and reboot your system. VirtualBox relies on Windows notifying it of media changes.

11.4.3. Sluggish response when using Microsoft RDP client

If connecting to a Virtual Machine via the Microsoft RDP client (called Remote Desktop Connection), there can be large delays between input (moving the mouse over a menu is the most obvious situation) and output. This is because this RDP client collects input for a certain time before sending it to the VRDP server built into VirtualBox.

The interval can be decreased by setting a Windows registry key to smaller values than the default of 100. The key does not exist initially and must be of type DWORD. The unit for its values is milliseconds. Values around 20 are suitable for low-bandwidth connections between the RDP client and server. Values around 4 can be used for a gigabit Ethernet connection. Generally values below 10 achieve a performance that is very close to that of the local input devices and screen of the host on which the Virtual Machine is running.

Depending whether the setting should be changed for an individual user or for the system, either

HKEY_CURRENT_USER\Software\Microsoft\Terminal Server
        Client\Min Send Interval

or

HKEY_LOCAL_MACHINE\Software\Microsoft\Terminal Server
        Client\Min Send Interval

can be set appropriately.

11.4.4. Running an iSCSI initiator and target on a single system

Deadlocks can occur on a Windows host when attempting to access an iSCSI target running in a guest virtual machine with an iSCSI initiator (e.g. Microsoft iSCSI Initiator) that is running on the host. This is caused by a flaw in the Windows cache manager component, and causes sluggish host system response for several minutes, followed by a "Delayed Write Failed" error message in the system tray or in a separate message window. The guest is blocked during that period and may show error messages or become unstable.

Setting the environment variable VBOX_DISABLE_HOST_DISK_CACHE to 1 will enable a workaround for this problem until Microsoft addresses the issue. For example, open a command prompt window and start VirtualBox like this:

set VBOX_DISABLE_HOST_DISK_CACHE=1
VirtualBox

While this will decrease guest disk performance (especially writes), it does not affect the performance of other applications running on the host.


11.5. Linux hosts

11.5.1. Linux kernel module refuses to load

If the VirtualBox kernel module (vboxdrv) refuses to load, i.e. you get an "Error inserting vboxdrv: Invalid argument", check (as root) the output of the dmesg command to find out why the load failed. The most common reasons are:

  • With Linux 2.6.19 and higher, the NMI watchdog may be active. Add nmi_watchdog=0 to the kernel command line (e.g. in your grub configuration) and reboot. With the Debian and Ubuntu installation modules, execute sudo dpkg-reconfigure virtualbox again.

  • The kernel disagrees about the version of the gcc used to compile the module. Make sure that you use the same compiler as used to build the kernel.

11.5.2. Linux host CD/DVD drive not found

If you have configured a virtual machine to use the host's CD/DVD drive, but this does not appear to work, make sure that the current user has permission to access the corresponding Linux device file (/dev/hdc or /dev/scd0 or /dev/cdrom or similar). On most distributions, the user must be added to a corresponding group (usually called cdrom or cdrw).

11.5.3. Linux host CD/DVD drive not found (older distributions)

On older Linux distributions, if your CD/DVD device has a different name, VirtualBox may be unable to find it. On older Linux hosts, VirtualBox performs the following steps to locate your CD/DVD drives:

  1. VirtualBox examines if the environment variable VBOX_CDROM is defined (see below). If so, VirtualBox omits all the following checks.

  2. VirtualBox tests if /dev/cdrom works.

  3. In addition, VirtualBox checks if any CD/DVD drives are currently mounted by checking /etc/mtab.

  4. In addition, VirtualBox checks if any of the entries in /etc/fstab point to CD/DVD devices.

In other words, you can try to set VBOX_CDROM to contain a list of your CD/DVD devices, separated by colons, for example as follows:

export VBOX_CDROM='/dev/cdrom0:/dev/cdrom1'

On modern Linux distributions, VirtualBox uses the hardware abstraction layer (hal) to locate CD and DVD hardware.

11.5.4. Linux host floppy not found

The previous instructions (for CD and DVD drives) apply accordingly to floppy disks, except that on older distributions VirtualBox tests for /dev/fd* devices by default, and this can be overridden with the VBOX_FLOPPY environment variable.

11.5.5. Strange guest IDE error messages when writing to CD/DVD

If the experimental CD/DVD writer support is enabled with an incorrect VirtualBox, host or guest configuration, it is possible that any attempt to access the CD/DVD writer fails and simply results in guest kernel error messages (for Linux guests) or application error messages (for Windows guests). VirtualBox performs the usual consistency checks when a VM is powered up (in particular it aborts with an error message if the device for the CD/DVD writer is not writable by the user starting the VM), but it cannot detect all misconfigurations. The necessary host and guest OS configuration is not specific for VirtualBox, but a few frequent problems are listed here which occurred in connection with VirtualBox.

Special care must be taken to use the correct device. The configured host CD/DVD device file name (in most cases /dev/cdrom) must point to the device that allows writing to the CD/DVD unit. For CD/DVD writer units connected to a SCSI controller or to a IDE controller that interfaces to the Linux SCSI subsystem (common for some SATA controllers), this must refer to the SCSI device node (e.g. /dev/scd0). Even for IDE CD/DVD writer units this must refer to the appropriate SCSI CD-ROM device node (e.g. /dev/scd0) if the ide-scsi kernel module is loaded. This module is required for CD/DVD writer support with all Linux 2.4 kernels and some early 2.6 kernels. Many Linux distributions load this module whenever a CD/DVD writer is detected in the system, even if the kernel would support CD/DVD writers without the module. VirtualBox supports the use of IDE device files (e.g. /dev/hdc), provided the kernel supports this and the ide-scsi module is not loaded.

Similar rules (except that within the guest the CD/DVD writer is always an IDE device) apply to the guest configuration. Since this setup is very common, it is likely that the default configuration of the guest works as expected.

11.5.6. VBoxSVC IPC issues

On Linux, VirtualBox makes use of a custom version of Mozilla XPCOM (cross platform component object model) for inter- and intra-process communication (IPC). The process VBoxSVC serves as a communication hub between different VirtualBox processes and maintains the global configuration, i.e. the XML database. When starting a VirtualBox component, the processes VBoxSVC and VirtualBoxXPCOMIPCD are started automatically. They are only accessible from the user account they are running under. VBoxSVC owns the VirtualBox configuration database which normally resides in ~/.VirtualBox. While it is running, the configuration files are locked. Communication between the various VirtualBox components and VBoxSVC is performed through a local domain socket residing in /tmp/.vbox-<username>-ipc. In case there are communication problems (i.e. a VirtualBox application cannot communicate with VBoxSVC), terminate the daemons and remove the local domain socket directory.

11.5.7. USB not working

If USB is not working on your Linux host, make sure that the current user is a member of the vboxusers group. On older hosts, you need to make sure that the user has permission to access the USB filesystem (usbfs), which VirtualBox relies on to retrieve valid information about your host's USB devices. The rest of this section only applies to those older systems.

Note

The current rdesktop-vrdp implementation does not support accessing USB devices through the sysfs!

As usbfs is a virtual filesystem, a chmod on /proc/bus/usb has no effect. The permissions for usbfs can therefore only be changed by editing the /etc/fstab file.

For example, most Linux distributions have a user group called usb or similar, of which the current user must be a member. To give all users of that group access to usbfs, make sure the following line is present:

# 85 is the USB group
none     /proc/bus/usb     usbfs      devgid=85,devmode=664    0    0

Replace 85 with the group ID that matches your system (search /etc/group for "usb" or similar). Alternatively, if you don't mind the security hole, give all users access to USB by changing "664" to "666".

The various distributions are very creative from which script the usbfs filesystem is mounted. Sometimes the command is hidden in unexpected places. For SuSE 10.0 the mount command is part of the udev configuration file /etc/udev/rules.d/50-udev.rules. As this distribution has no user group called usb, you may e.g. use the vboxusers group which was created by the VirtualBox installer. Since group numbers are allocated dynamically, the following example uses 85 as a placeholder. Modify the line containing (a linebreak has been inserted to improve readability)

DEVPATH="/module/usbcore", ACTION=="add",
    RUN+="/bin/mount -t usbfs usbfs /proc/bus/usb"

and add the necessary options (make sure that everything is in a single line):

DEVPATH="/module/usbcore", ACTION=="add",
    RUN+="/bin/mount -t usbfs usbfs /proc/bus/usb -o devgid=85,devmode=664"

Debian Etch has the mount command in /etc/init.d/mountkernfs.sh. Since that distribution has no group usb, it is also the easiest solution to allow all members of the group vboxusers to access the USB subsystem. Modify the line

domount usbfs usbdevfs /proc/bus/usb -onoexec,nosuid,nodev

so that it contains

domount usbfs usbdevfs /proc/bus/usb -onoexec,nosuid,nodev,devgid=85,devmode=664

As usual, replace the 85 with the actual group number which should get access to USB devices.

Other distributions do similar operations in scripts stored in the /etc/init.d directory.

11.5.8. PAX/grsec kernels

Linux kernels including the grsec patch (see http://www.grsecurity.net/) and derivates have to disable PAX_MPROTECT for the VBox binaries to be able to start a VM. The reason is that VBox has to create executable code on anonymous memory.

11.5.9. Linux kernel vmalloc pool exhausted

When running a large number of VMs with a lot of RAM on a Linux system (say 20 VMs with 1GB of RAM each), additional VMs might fail to start with a kernel error saying that the vmalloc pool is exhausted and should be extended. The error message also tells you to specify vmalloc=256MB in your kernel parameter list. If adding this parameter to your GRUB or LILO configuration makes the kernel fail to boot (with a weird error message such as "failed to mount the root partition"), then you have probably run into a memory conflict of your kernel and initial RAM disk. This can be solved by adding the following parameter to your GRUB configuration:

uppermem 524288


11.6. Solaris hosts

11.6.1. Cannot start VM, not enough contiguous memory

The ZFS file system is known to use all available RAM as cache if the default system settings are not changed. This may lead to a heavy fragmentation of the host memory preventing VirtualBox VMs from being started. We recommend to limit the ZFS cache by adding a line

set zfs:zfs_arc_max = xxxx

to /etc/system where xxxx bytes is the amount of memory usable for the ZFS cache.

11.6.2. VM aborts with out of memory errors on Solaris 10 hosts

Solaris 10 hosts (bug 1225025) requires swap space equal to, or greater than the host's physical memory size. For example, 8 GB physical memory would require at least 8 GB swap. This can be configured during a Solaris 10 install by choosing a 'custom install' and changing the default partitions.

For existing Solaris 10 installs, an additional swap image needs to be mounted and used as swap. Hence if you have 1 GB swap and 8 GB of physical memory, you require to add 7 GB more swap. This can be done as follows:

For ZFS (as root user):

zfs create -V 8gb /_<ZFS volume>_/swap
swap -a /dev/zvol/dsk/_<ZFS volume>_/swap

To mount if after reboot, add the following line to /etc/vfstab:

/dev/zvol/dsk/_<ZFS volume>_/swap - - swap - no -

For UFS (as root user):

mkfile 7g /path/to/swapfile.img
swap -a /path/to/swapfile.img

To mount it after reboot, add the following line to /etc/vfstab:

/path/to/swap.img - - swap - no -


Chapter 12. Change log

Table of Contents

12.1. Version 3.0.10 (2009-10-29)
12.2. Version 3.0.8 (2009-10-02)
12.3. Version 3.0.6 (2009-09-09)
12.4. Version 3.0.4 (2009-08-04)
12.5. Version 3.0.2 (2009-07-10)
12.6. Version 3.0.0 (2009-06-30)
12.7. Version 2.2.4 (2009-05-29)
12.8. Version 2.2.2 (2009-04-27)
12.9. Version 2.2.0 (2009-04-08)
12.10. Version 2.1.4 (2009-02-16)
12.11. Version 2.1.2 (2009-01-21)
12.12. Version 2.1.0 (2008-12-17)
12.13. Version 2.0.8 (2009-03-10)
12.14. Version 2.0.6 (2008-11-21)
12.15. Version 2.0.4 (2008-10-24)
12.16. Version 2.0.2 (2008-09-12)
12.17. Version 2.0.0 (2008-09-04)
12.18. Version 1.6.6 (2008-08-26)
12.19. Version 1.6.4 (2008-07-30)
12.20. Version 1.6.2 (2008-05-28)
12.21. Version 1.6.0 (2008-04-30)
12.22. Version 1.5.6 (2008-02-19)
12.23. Version 1.5.4 (2007-12-29)
12.24. Version 1.5.2 (2007-10-18)
12.25. Version 1.5.0 (2007-08-31)
12.26. Version 1.4.0 (2007-06-06)
12.27. Version 1.3.8 (2007-03-14)
12.28. Version 1.3.6 (2007-02-20)
12.29. Version 1.3.4 (2007-02-12)
12.30. Version 1.3.2 (2007-01-15)
12.31. Version 1.2.4 (2006-11-16)
12.32. Version 1.2.2 (2006-11-14)
12.33. Version 1.1.12 (2006-11-14)
12.34. Version 1.1.10 (2006-07-28)
12.35. Version 1.1.8 (2006-07-17)
12.36. Version 1.1.6 (2006-04-18)
12.37. Version 1.1.4 (2006-03-09)
12.38. Version 1.1.2 (2006-02-03)
12.39. Version 1.0.50 (2005-12-16)
12.40. Version 1.0.48 (2005-11-23)
12.41. Version 1.0.46 (2005-11-04)
12.42. Version 1.0.44 (2005-10-25)
12.43. Version 1.0.42 (2005-08-30)
12.44. Version 1.0.40 (2005-06-17)
12.45. Version 1.0.39 (2005-05-05)
12.46. Version 1.0.38 (2005-04-27)
12.47. Version 1.0.37 (2005-04-12)

This section summarizes the changes between VirtualBox versions. Note that this change log is not exhaustive; not all changes are listed.

VirtualBox version numbers consist of three numbers separated by dots where the first number represents the major version, the 2nd number the minor version and the 3rd one the build number. Build numbers of official releases are always even. An odd build number represents an internal development or test build.

12.1. Version 3.0.10 (2009-10-29)

This is a maintenance release. The following items were fixed and/or added:

  • VMM: guest SMP stability fixes

  • VMM: fixed guru meditation with nested paging and SMP guests (bug #5222)

  • VMM: changed VT-x/AMD-V usage to detect other active hypervisors; necessary for e.g. Windows 7 XP compatibility mode (Windows & Mac OS X hosts only; bug #4239)

  • VMM: guru meditation during SCO OpenServer installation and reboot (VT-x only; bug #5164)

  • VMM: fixed accessed bit handling in certain cases (bug #5248)

  • VMM: fixed VPID flushing (VT-x only)

  • VMM: fixed broken nested paging for 64 bits guests on 32 bits hosts (AMD-V only; bug #5285)

  • VMM: fixed loading of old saved states/snapshots (bug #3984)

  • Mac OS X hosts: fixed memory leaks (bug #5084)

  • Mac OS X hosts (Snow Leopard): fixed redraw problem in a dual screen setup (bug #4942)

  • Windows hosts: installer updates for Windows 7

  • Solaris hosts: out of memory handled incorrectly (bug #5241)

  • Solaris hosts: the previous fix for #5077 broke the DVD host support on Solaris 10 (VBox 3.0.8 regression)

  • Linux hosts: fixed module compilation against Linux 2.6.32rc4 and later

  • Guest Additions: fixed possible guest OS kernel memory exhaustion

  • Guest Additions: fixed stability issues with SMP guests

  • Windows Additions: fixed color depth issue with low resolution hosts, netbooks, etc. (bug #4935)

  • Windows Additions: fixed NO_MORE_FILES error when saving to shared folders (bug #4106)

  • Windows Additions: fixed subdirectory creation on shared folders (bug #4299)

  • Linux Additions: sendfile() returned -EOVERFLOW when executed on a shared folder (bug #2921)

  • Linux Additions: fixed incorrect disk usage value (non-Windows hosts only)

  • Linux installer: register the module sources at DKMS even if the package provides proper modules for the current running kernel

  • 3D support: removed invalid OpenGL assertion (bug #5158)

  • Network: fixed the Am79C973 PCNet emulation for QNX (and probably other) guests (bug #3206)

  • VMDK: fix handling of split image variants

  • VHD: do not delay updating the footer when expanding the image to prevent image inconsistency

  • USB: stability fix for some USB 2.0 devices

  • GUI: added a search index to the .chm help file

  • GUI/Windows hosts: fixed CapsLock handling on French keyboards (bug #2025)

  • Shared clipboard/X11 hosts: fixed a crash when clipboard initialisation failed (bug #4987)


12.2. Version 3.0.8 (2009-10-02)

This is a maintenance release. The following items were fixed and/or added:

  • VMM: fixed 64 bits guest on 32 bits host regression in 3.0.6 (VT-x only; bug #4947)

  • VMM: fixed a recompiler triple fault guru meditation (VT-x & AMD-V only; bug #5058)

  • VMM: fixed hang after guest state restore (AMD-V, 32 bits Windows guest and IO-APIC enabled only; bug #5059)

  • VMM: fixed paging issue with OS/2 guests

  • VMM: fixed guru meditation in rare cases (2.0 regression; software virtualization only)

  • VMM: fixed release assertion during state restore when using the Sound Blaster 16 emulation (bug #5042)

  • Security: fixed vulnerability that allowed to execute commands with root privileges

  • Linux hosts: fixed runtime assertion in semaphore implementation which was triggered under certain conditions (bug #616)

  • Linux hosts: change the default USB access mode on certain distributions (bugs #3394 and #4291)

  • Linux hosts: on hardened Gentoo, the VBoxSVC daemon crashed by opening the VM network settings (bug #3732)

  • Linux hosts, Solaris hosts: pass the XAUTHORITY variable along the DISPLAY variable when starting a VM from VBoxManage or from the VM selector (bug #5063)

  • Linux hosts: use sysfs to enumerate host drives if hal is not available

  • Solaris hosts: fixed a bug which would hang the host sporadically as interrupts were not re-enabled everytime

  • Solaris hosts: fixed a kernel panic with bridged and host-only networking (bug #4775)

  • Solaris hosts: fixed incorrectly persistent CD/DVD-ROMs when changing them (bug #5077)

  • X11-based hosts: support additional function keys on Sun keyboards (bug #4907)

  • Mac OS X hosts (Snow Leopard): fixed problem starting headless VMs without a graphical session (bug #5002)

  • Mac OS X hosts: fixed problem listing host-only adapter names with trailing garbage (attached VMs won't start)

  • Windows Additions: now work with Vista 64-bit Home editions (bug #3865)

  • Windows Additions: fixed screen corruption with ZoomText Magnifier

  • Windows Additions: fixed NPGetUniversalName failure (bug #4853)

  • Windows Additions: fixed Windows NT regression (bug #4946)

  • Windows Additions: fixed VBoxService not running if no Shared Folders are installed

  • Linux Additions: implemented ftrunctate (bug #4771)

  • VRDP: start VM even if configured VRDP port is in use

  • Networking: the PCnet network device stopped receiving under rare conditions (bug #4870)

  • VBoxManage: implemented controlvm vrdpport command

  • iSCSI: fixed issue with NetApp targets (#5072)

  • SCSI: add support for virtual disks larger than 2TB

  • USB: fixed potential crash when unplugging USB2 devices (bug #5089)

  • NAT: IPSEC did not properly work with Linux guests (bug #4801)


12.3. Version 3.0.6 (2009-09-09)

This is a maintenance release. The following items were fixed and/or added:

  • VMM: fixed IO-APIC overhead for 32 bits Windows NT, 2000, XP and 2003 guests (AMD-V only; bug #4392)

  • VMM: fixed a Guru meditation under certain circumstances when enabling a disabled device (bug #4510)

  • VMM: fixed a Guru meditation when booting certain Arch Linux guests (software virtualization only; bug #2149)

  • VMM: fixed hangs with 64 bits Solaris & OpenSolaris guests (bug #2258)

  • VMM: fixed decreasing rdtsc values (AMD-V & VT-x only; bug #2869)

  • VMM: small Solaris/OpenSolaris performance improvements (VT-x only)

  • VMM: cpuid change to correct reported virtual CPU id in Linux

  • VMM: NetBSD 5.0.1 CD hangs during boot (VT-x only; bug #3947)

  • Solaris hosts: worked around an issue that caused the host to hang (bug #4486)

  • Solaris hosts: fixed a rare host system deadlock when using bridged networking

  • Solaris hosts: fixed a potential host system deadlock when CPUs were onlined or offlined

  • Solaris hosts installer: added missing dependency for UTF-8 package (bug #4899)

  • Linux hosts: don't crash on Linux PAE kernels < 2.6.11 (in particular RHEL/CentOS 4); disable VT-x on Linux kernels < 2.6.13 (bug #1842)

  • Linux/Solaris hosts: correctly detect keyboards with fewer keys than usual (bug #4799)

  • Mac OS X hosts: prevent password dialogs in 32 bits Snow Leopard

  • Python WS: fixed issue with certain enumerations constants having wrong values in Python webservices bindings

  • Python API: several threading and platform issues fixed

  • Python shell: added exportVM command

  • Python shell: various improvements and bugfixes

  • Python shell: corrected detection of home directory in remote case

  • OVF: fixed XML comment handling that could lead to parser errors

  • Main: fixed a rare parsing problem with port numbers of USB device filters in machine settings XML

  • Main: restrict guest RAM size to 1.5 GB (32 bits Windows hosts only)

  • Main: fixed possible hang during guest reboot (bug #3792)

  • GUI: fixed rare crash when removing the last disk from the media manager (bug #4795)

  • VBoxManage: fixed guestproperty for Mac OS X hosts (bug #3806)

  • VBoxManage: fixed setting guest properties with --flags or -flags

  • Webservice: fixed a severe memory leak, at least on platforms using XPCOM

  • Serial: fixed host mode (Solaris, Linux and Mac OS X hosts; bug #4672)

  • VRDP: Remote USB Protocol version 3

  • SATA: fixed hangs and BSODs introduced with 3.0.4 (bugs #4695, #4739, #4710)

  • SATA: fixed a bug which prevented Windows 7 from detecting more than one hard disk

  • SATA/SCSI: fixed rare random guest crashes and hangs

  • SCSI: fixed problem with Fedora 11 refusing to boot after kernel update

  • iSCSI: fix logging out when the target has dropped the connection, fix negotiation of parameters, fix command resend when the connection was dropped, fix processing SCSI status for targets which do not use phase collapse

  • BIOS: fixed a bug that caused the OS/2 boot manager to fail (2.1.0 regression, bug #3911)

  • PulseAudio: don't hang during VM termination if the connection to the server was unexpectedly terminated (bug #3100)

  • Mouse: fixed weird mouse behaviour with SMP (Solaris) guests (bug #4538)

  • HostOnly Network: fixed failure in CreateHostOnlyNetworkInterface() on Linux (no GUID)

  • HostOnly Network: fixed wrong DHCP server startup while hostonly interface bringup on Linux

  • HostOnly Network: fixed incorrect factory and default MAC address on Solaris

  • HostOnly Network: fixed the problem with listing host-only interfaces on Mac OS X when all physical interfaces are down (bugs #4698, #4790)

  • DHCP: fixed a bug in the DHCP server where it allocated one IP address less than the configured range

  • E1000: fixed receiving of multicast packets

  • E1000: fixed up/down link notification after resuming a VM

  • NAT: fixed ethernet address corruptions (bug #4839)

  • NAT: fixed hangs, dropped packets and retransmission problems (bug #4343)

  • Bridged Network: fixed packet queue issue which might cause DRIVER_POWER_STATE_FAILURE BSOD for Windows hosts (bug #4821)

  • Windows Additions: fixed a bug in VBoxGINA which prevented selecting the right domain when logging in the first time

  • Windows host installer: should now also work on unicode systems (like Korean, bug #3707)

  • Windows host installer: check for sufficient disk space

  • Shared clipboard: do not send zero-terminated text to X11 guests and hosts (bug #4712)

  • Shared clipboard: use a less CPU intensive way of checking for new data on X11 guests and hosts (bug #4092)

  • Guest Additions: do not hide the host mouse cursor when restoring a saved state (bug #4700)

  • Windows guests: fixed issues with the display of the mouse cursor image (bugs #2603, #2660 and #4817)

  • SUSE 11 guests: fixed Guest Additions installation (bug #4506)

  • Guest Additions: support Fedora 12 Alpha guests (bugs #4731, #4733 and #4734)


12.4. Version 3.0.4 (2009-08-04)

This is a maintenance release. The following items were fixed and/or added:

  • VMM: 64 bits guest stability fixes (AMD-V only; bugs #3923 & #3666)

  • VMM: SMP stability fixes (AMD-V only)

  • VMM: SMP performance improvement (esp. for Solaris guests)

  • VMM: eliminated several bugs which could lead to a host reboot

  • VMM: fixed OS/2 ACP2 boot floppy hang (VT-x only)

  • VMM: small performance improvement for OpenSolaris guests (AMD-V only)

  • VMM: fixed CentOS/Xen reboot (software virtualization only; bug #4509)

  • SATA: fixed hangs / BSOD during Windows XP installation (bug #4342)

  • SATA: mark the ports as non hotpluggable (bug #3920)

  • 3D support: fix deadlocks and context/window tracking for multithreaded applications (bug #3922)

  • 3D support: fix memory leaks when terminating OpenGL guest applications

  • 3D support: fix crash in Call of Duty

  • NAT: using two or more NAT adapters in one VM was broken (3.0.0 regression)

  • NAT: fixed network communication corruptions (bugs #4499, #4540, #4591, #4604)

  • NAT: fixed passive ftp access to host server (bug #4427)

  • iSCSI: fixed cloning to/from iSCSI disks

  • GUI: fixed path separator handling for the OVF export on Windows (bug #4354)

  • GUI: the mini toolbar was only shown on the first host display (bug #4654)

  • GUI: added a VM option to display the mini toolbar on top

  • GUI: don't crash when adding plus configuring host-only network interfaces

  • Shared Folders: fixed selection of a drive root directory as a shared folder host path in VirtualBox (Windows host only)

  • USB: fixed a bug that may have rendered USB device filter settings inactive (3.0.2 regression, bug #4668)

  • Guest Additions: report the Guest Additions version to the guest properties (bug #3415)

  • Mac OS X hosts: fix creation of VMDK files giving raw partition access (bug #1461)

  • Mac OS X hosts: improved support for Snow Leopard

  • Linux hosts: fixed problems leading to wrong colors or transparency in host windows with some graphics drivers (bug #3095)

  • Linux hosts: hardware detection fallbacks if the hal service fails to find any DVD drives

  • Linux and Solaris hosts: work around color handling problems in Qt (bug #4353)

  • Solaris hosts: fixed memory leaks in host-only networking

  • Solaris Installer: fixed incorrect netmask for Host-only interface (bug #4590)

  • Solaris Installer: added package dependency for Python and Python-devel (bug #4570)

  • X11 guests: prevent windows from being skipped in seamless mode KDE guests (bugs #1681 and #3574)

  • X11 guests: fixed screen corruption in X11 guests when large amounts of video RAM were allocated (bug #4430)

  • X11 guests: some fixes when switching between host and guest-drawn mouse pointers

  • X11 guests: fixed an issue which caused seamless mode to stop working as it should (the main issue listed in bug #2238).


12.5. Version 3.0.2 (2009-07-10)

This is a maintenance release. The following items were fixed and/or added:

  • VMM: fixed network regressions (guest hangs during network IO) (bug #4343)

  • VMM: guest SMP performance improvements

  • VMM: fixed hangs and poor performance with Kaspersky Internet Security (VT-x/AMD-V only; bug #1778)

  • VMM: fixed crashes when executing certain Linux guests (software virtualization only; bugs #2696 & #3868)

  • ACPI: fixed Windows 2000 kernel hangs with IO-APIC enabled (bug #4348)

  • APIC: fixed high idle load for certain Linux guests (3.0 regression)

  • BIOS: properly handle Ctrl-Alt-Del in real mode

  • iSCSI: fixed configuration parsing (bug #4236)

  • OVF: fix potential confusion when exporting networks

  • OVF: compatibility fix (bug #4452)

  • OVF: accept ovf:/disk/ specifiers with a single slash in addition to ovf://disk/ (bug #4452)

  • NAT: fixed crashes under certain circumstances (bug #4330)

  • 3D support: fixed dynamic linking on Solaris/OpenSolaris guests (bug #4399)

  • 3D support: fixed incorrect context/window tracking for multithreaded applications

  • Shared Folders: fixed loading from saved state (bug #1595)

  • Shared Folders: host file permissions set to 0400 with Windows guest (bug #4381)

  • X11 host and guest clipboard: fixed a number of issues, including bugs #4380 and #4344

  • X11 Additions: fixed some issues with seamless windows in X11 guests (bug #3727)

  • Windows Additions: added VBoxServiceNT for NT4 guests (for time synchronization and guest properties)

  • Windows Additions: fixed version lookup

  • Linux Installer: support Pardus Linux

  • Linux hosts: workaround for buggy graphics drivers showing a black VM window on recent distributions (bug #4335)

  • Linux hosts: fixed typo in kernel module startup script (bug #4388)

  • Solaris hosts: several installer fixes

  • Solaris host: fixed a preemption issue causing VMs to never start on Solaris 10 (bug #4328).

  • Solaris guest: fixed mouse integration for OpenSolaris 2009.06 (bug #4365)

  • Windows hosts: fixed high CPU usage after resuming the host (bug #2978)

  • Fixed a settings file conversion bug which sometimes caused hardware acceleration to be enabled for virtual machines that had no explicit configuration in the XML.


12.6. Version 3.0.0 (2009-06-30)

This version is a major update. The following major new features were added:

  • Guest SMP with up to 32 virtual CPUs (VT-x and AMD-V only; see Section 3.7.2.2, “"Processor" tab”)

  • Windows guests: ability to use Direct3D 8/9 applications / games (experimental; see Section 4.8, “Hardware 3D acceleration (OpenGL and DirectX 8/9)”)

  • Support for OpenGL 2.0 for Windows, Linux and Solaris guests

In addition, the following items were fixed and/or added:

  • Solaris hosts: allow suspend/resume on the host when a VM is running (bug #3826)

  • Solaris hosts: loosen the restriction for contiguous physical memory under certain conditions

  • Mac OS X hosts: fixed guest PAE

  • Linux hosts: kernel module compile fixes for 2.6.31 (bug #4264)

  • VMM: fixed occasional guru meditation when loading a saved state (VT-x only)

  • VMM: eliminated IO-APIC overhead with 32 bits guests (VT-x only, some Intel CPUs don't support this feature (most do); bug #638)

  • VMM: fixed 64 bits CentOS guest hangs during early boot (AMD-V only; bug #3927)

  • VMM: performance improvements for certain PAE guests (e.g. Linux 2.6.29+ kernels)

  • VMM: some Windows guests detected a completely wrong CPU frequency (bug #2227)

  • VMM: fixed hanging and unkillable VM processes (bug #4040)

  • VMM: fixed random infrequent guest crashes due XMM state corruption (Win64 hosts only)

  • VMM: performance improvements for network I/O (VT-x/AMD-V only)

  • GUI: added mini toolbar for fullscreen and seamless mode (Thanks to Huihong Luo)

  • GUI: redesigned settings dialogs

  • GUI: allow to create/remove more than one host-only network adapters (non Windows hosts)

  • GUI: display estimated time for long running operations (e.g. OVF import/export)

  • GUI: fixed rare hangs when open the OVF import/export wizards (bug #4157)

  • 3D support: fixed VM crashes for client applications using incorrect OpenGL states

  • 3D support: fixed memory corruption when querying for supported texture compression formats

  • 3D support: fixed incorrect rendering of glDrawRangeElements

  • 3D support: fixed memory leak when using VBOs

  • 3D support: fixed glew library detection

  • 3D support: fixed random textures corruption

  • VRDP: support Windows 7 RDP client

  • Networking: fixed another problem with TX checksum offloading with Linux kernels up to version 2.6.18

  • NAT: fixed "open ports on virtual router 10.0.2.2 - 513, 514" (forum)

  • NAT: allow to configure socket and internal parameters

  • NAT: allow to bind sockets to specific interface

  • PXE boot: significant performance increase (VT-x/AMD-V only)

  • VHD: properly write empty sectors when cloning of VHD images (bug #4080)

  • VHD: fixed crash when discarding snapshots of a VHD image

  • VHD: fixed access beyond the block bitmap which could lead to arbitrary crashes

  • VBoxManage: fixed incorrect partition table processing when creating VMDK files giving raw partition access (bug #3510)

  • VBoxManage: support cloning to existing image file

  • OVF: several OVF 1.0 compatibility fixes

  • OVF: fixed exporting of disk images when multiple virtual machines are exported at once

  • Virtual mouse device: eliminated micro-movements of the virtual mouse which were confusing some applications (bug #3782)

  • Shared Folders: sometimes a file was created using the wrong permissions (2.2.0 regression; bug #3785)

  • Shared Folders: allow to change file attributes from Linux guests and use the correct file mode when creating files

  • Shared Folders: some content was incorrectly written under certain conditions (bug #11187)

  • Shared Folders: fixed incorrect file timestamps, when using Windows guest on a Linux host (bug #3404)

  • X11 clipboard: fix duplicate end of lines (bug #4270)

  • X11 guests: a number of shared clipboard fixes

  • Linux guests: Guest Additions support for SUSE Linux Enterprise Desktop 11

  • Linux guests: new daemon vboxadd-service to handle time synchronization and guest property lookup

  • Linux guests: implemented guest properties (OS info, logged in users, basic network information)

  • Windows host installer: VirtualBox Python API can now be installed automatically (requires Python and Win32 Extensions installed)

  • USB: Support for high-speed isochronous endpoints has been added. In addition, read-ahead buffering is performed for input endpoints (currently Linux hosts only). This should allow additional devices to work, notably webcams (bug #242).

  • USB: fixed error handling for some USB dongles

  • Web service: fixed inability to handle NULL pointers for object arguments, which are valid values for a lot of APIs, in both the raw and the object-oriented web service.

  • Web service: object-oriented bindings for JAX-WS did not exhibit interface inheritance correctly, fixed

  • Web service: added support for IDisplay and IGuest interfaces, which were previously unavailable

  • Registration dialog uses Sun Online accounts now


12.7. Version 2.2.4 (2009-05-29)

This is a maintenance release. The following items were fixed and/or added:

  • Windows Installer: fixed a potential hang during installation

  • Windows Installer: fixed several problems (bug #3892)

  • Solaris hosts: make it work with Solaris build 114 or later (bug #3981)

  • Solaris hosts: fixed a bug serial port character handling found during loopback (bug #3120)

  • Linux hosts: adapted vboxdrv.sh to the latest changes in VBoxManage list runningvms (bug #4034)

  • Windows hosts: fixed a crash caused by host-only/bridged networking

  • Mac OS X hosts: fixed access to host DVD with passthrough disabled (bug #4077)

  • Guest Additions: fixed problems with KDE 4 not recognizing mouse clicks

  • Windows Additions: fixed incorrect 8-bit guest color depth in Windows 7 guests

  • GUI: warn if VT-x/AMD-V could not be enabled for guests that require this setting (bug #4055)

  • VMM: fixed occasional crash due to insufficient memory

  • VMM: fixed hanging 64 bits Solaris guests

  • VMM: restore from a saved state occasionally failed (bugs #3984 and #2742)

  • Clipboard: fixed a deadlock while shutting down the shared clipboard on X11 hosts (bug #4020)

  • OVF: fixed potential hang during import

  • OVF: fixed potential crashes during import/export on Win64 hosts

  • VBoxManage modifyhd --compact: fixed bug which could lead to crashes and image corruption (bug #3864)

  • VBoxManage metrics collect: now flushes the output stream

  • VHD: made VBoxManage internalcommands sethduuid work for .vhd files (bug #3443)

  • VHD: some .vhd files could not be cloned (bug #4080)

  • NAT: improvement of TCP connection establishment (bug #2987)

  • NAT: fixed order of DNS servers in DHCP lease (bug #4091)

  • NAT: fixed DHCP lease for multiple name servers (bug #3692)

  • NAT: fixed a potential segfault if the host lost its connectivity (bug #3964)

  • Shared Folders: deny access to parent directories on Windows hosts (bug #4090)

  • Shared Folders: make rm/rmdir work with Solaris guests on Windows hosts

  • Networking: fixed the problem with blocked receiving thread when a broadcast packet arrives too early to be handled by uninitialized e1000 adapter

  • Networking: fixed the problem that caused host freezes/crashes when using bridged mode with host's interface having RX checksum offloading on (bug #3926 and related). Fixes problems with TX offloading as well (bug #3870)

  • PXE boot: Added support for PRO/1000 MT Server adapter

  • Python bindings: fixed keyword conflict

  • SCSI: fixed occasional crashes on Win64

  • Serial: allow to redirect the serial port to a raw file (bug #1023)

  • VRDP: fixed a rare incorrect screen update

  • VMDK: fixed creating snapshots


12.8. Version 2.2.2 (2009-04-27)

This is a maintenance release. The following items were fixed and/or added:

  • Host and guest clipboard: fixed a number of issues affecting hosts and guests running the X window system

  • Guest Additions: make sure the virtual mouse autodetection works on first reboot after installing the Additions on X.Org server 1.5 and later

  • Guest Additions: properly report process identity number of running services

  • Guest Additions: clean up properly if the X Window server terminates

  • Linux Additions: fixed installation path for OpenGL libraries in some 64-bit guests (bug #3693)

  • Solaris Additions: fixed installation to work when X.Org is not installed on the guest

  • Solaris Additions: fixed a bug that could panic the guest when unmounting a busy shared folder

  • Windows Additions: fixed mouse pointer integration of some Windows guests (2.2.0 regression, bug #3734)

  • Windows Additions: fixed installation on Windows Server 2008 Core (bug #2628)

  • Main: do not try to use older versions of D-Bus (Linux hosts only, bug #3732)

  • VMM: fixed out-of-memory conditions on Windows hosts (bug #3657)

  • VMM: fixed occasional hangs when attaching USB devices during VM startup (2.2.0 regression; bugs #3787)

  • VMM: fixed guru meditation related to memory management (software virtualization only)

  • Virtual disks: fix possible data corruption when writing to diff images, incorrect detection of redundant writes

  • GUI: reworked network settings dialog

  • GUI: properly show the detailed settings dialog of NAT networks (bug #3702)

  • GUI: HostKey could not be changed (2.2.0 regression, bug #3689)

  • GUI: fixed memory textfield size (Windows hosts only; bug #3679)

  • GUI: fixed crash when selecting a shared folder path (Windows hosts only; bugs #3694, #3751, #3756)

  • VBoxManage modifyhd --compact: implemented again for VDI files, and now supports relative paths (bugs #2180, #2833)

  • VBoxManage snapshot discard: made it work again (2.1.0 regression; bug #3714)

  • NAT: on some Windows hosts, the guest didn't receive a DHCP lease (bug #3655)

  • NAT: fixed release assertion during poll() (bug #3667)

  • Networking: fixed a deadlock caused by the PCnet network device emulation (2.2.0 regression, bug #3676)

  • Clipboard: fixed random crashes (X11 hosts only, bug #3723)

  • Shared Folders: fixed incorrect permissions for Solaris guests

  • Shared Folders: fixed wrong file sizes with Solaris guests

  • CBindings: fixed possible memory leak while releasing the IVirtualBox and ISession Objects

  • Solaris hosts: fixed host-only network interface incompatibility with nwam/dhcpagent (bug #3754)

  • Windows installer: fixed several install and uninstall issues (bugs #3659, #3686, #1730, #3711, #3373, #3382, #3701, #3685, #3710)

  • Mac OS X hosts: preliminary support for Snow Leopard


12.9. Version 2.2.0 (2009-04-08)

This version is a major update. The following major new features were added:

  • OVF (Open Virtualization Format) appliance import and export (see Section 3.8, “Importing and exporting virtual machines”)

  • Host-only networking mode (see Section 6.7, “Host-only networking”)

  • Hypervisor optimizations with significant performance gains for high context switching rates

  • Raised the memory limit for VMs on 64-bit hosts to 16GB

  • VT-x/AMD-V are enabled by default for newly created virtual machines

  • USB (OHCI & EHCI) is enabled by default for newly created virtual machines (Qt GUI only)

  • Experimental USB support for OpenSolaris hosts

  • Shared Folders for Solaris and OpenSolaris guests

  • OpenGL 3D acceleration for Linux and Solaris guests (see Section 4.8, “Hardware 3D acceleration (OpenGL and DirectX 8/9)”)

  • Added C API in addition to C++, Java, Python and Web Services

In addition, the following items were fixed and/or added:

  • VMM: FreeBSD guest related fix for V86 flags (bug #2342)

  • VMM: fixed guru meditation when booting an AsteriskNow Linux VM (bug #2342)

  • VMM: fixed PGMPOOLKIND_FREE guru meditation (bugs #3356, #3431)

  • VMM: fixed Windows XP boot hang (guest PAE + nested paging only)

  • VMM: allow mixing of VT-x/AMD-V and software virtualization

  • VMM: fixed extremely slow safe mode booting in e.g. Windows 2008 (VT-x/AMD-V only)

  • VMM: significant speedup of certain GRUB boot loaders (e.g. Solaris) (VT-x/AMD-V only)

  • VMM: real-mode IOPL fix for DOS guests (VT-x only)

  • VMM: fixed VT-x detection with certain BIOSes that enable VT-x, but don't set the lock bit in MSR_IA32_FEATURE_CONTROL

  • VMM: fixed hibernation issues on Windows XP hosts (VT-x only; bug #1794)

  • VMM: properly emulate RDMSR from the TSC MSR, should fix some NetBSD guests

  • VMM: emulate rdpmc; fixes Windows guests crashes when using the Kaspersky virus scanner (bug #1778)

  • NAT: fixed truncated downloads (FTP) (bug #3257)

  • NAT: blocked UDP packets caused a crash (bug #3426)

  • NAT: allow to configure the next server and the boot file via VBoxManage (bug #2759)

  • IDE: fixed hard disk upgrade from XML-1.2 settings (bug #1518)

  • Hard disk: support more VMDK file variants (including fixed-size ESX server images)

  • Hard disks: refuse to start the VM if a disk image is not writable

  • USB: further reduced host CPU utilization for OHCI and EHCI; the "VBoxInternal/Devices/usb-ohci/0/Config/FrameRate" CFG key is no longer necessary and no longer supported

  • USB: fixed BSOD on the host with certain USB devices (Windows hosts only; bug #1654)

  • E1000: properly handle cable disconnects (bug #3421)

  • VRDP: fixed hangs when VRDP server is enabled or disabled in runtime

  • Shared Folders: respect umask settings on Linux, Mac OS X and Solaris hosts when creating files

  • X11 guests: prevented setting the locale in vboxmouse, as this caused problems with Turkish locales (bug #3563)

  • X11 guests: show the guest mouse pointer at the right position if the virtual desktop is larger than the guest resolution (bug #2306)

  • Linux Additions: fixed typo when detecting Xorg 1.6 (bug #3555)

  • Solaris guests: added xpg4/xcu4 dependency to the Guest Additions installer (bug #3524)

  • Windows guests: bind the VBoxMouse.sys filter driver to the correct guest pointing device (bug #1324)

  • Windows hosts: fixed BSOD when starting a VM with enabled host interface (bug #3414)

  • Linux hosts: do proper reference counting to prevent unloading the vboxnetflt module as long as this code is in use (bug #3104)

  • Linux hosts: do not leave zombies of VBoxSysInfo.sh (bug #3586)

  • Linux installers: fixes for Slackware, Arch Linux and Linux from Scratch systems

  • Windows installers: combined installer executable which contains both (32- and 64-bit) architectures

  • VBoxManage: less cryptic command-line error messages

  • VBoxManage list vms commands now default to compact format

  • VBoxManage controlvm dvdattach did not work if the image was attached before

  • VBoxManage: allow creation of all supported disk image variants

  • VBoxManage showvminfo: don't spam the release log if the Additions don't support statistics information (bug #3457)

  • VBoxManage: big command line processing cleanup, the legacy single-dash options are deprecated and will be removed in the next major release, so switch to the new options now

  • Hard disks: improved immutable disk support to auto-reset diff file at VM startup (related to bug #2772)

  • GUI: enable the audio adapter by default for new VMs

  • GUI: warn if VT-x/AMD-V is not operational when starting a 64-bit guest

  • GUI: deactivate 64-bit guest support when the host CPU does not support VT-x/AMD-V

  • GUI: removed floppy icon from the status bar

  • GUI: show build revision in about dialog

  • GUI: fixed sticky status bar text

  • GUI: improved error dialogs

  • GUI: fail with an appropriate error message when trying to boot a read-only disk image (bug #1745)

  • GUI/Mac OS X: fixed disabled close button

  • GUI/Windows: re-enabled support for copy and paste (Windows hosts 2.0 regression; bug #2065)

  • 3D support: added OpenGL select/feedback support (bug #2920)

  • 3D support: close OpenGL subsystem for terminated guest applications (bug #3243)

  • 3D support: fixed VM hangs when starting guests with 3D acceleration enabled (bug #3437)

  • PXE: fixed boot hangs when hardware virtualization is used (bug #2536)

  • LsiLogic: fixed problems with Solaris guests

  • Main API: close machine settings XML file when unregistering machine (bug #3548)


12.10. Version 2.1.4 (2009-02-16)

This is a maintenance release. The following items were fixed and/or added:

  • Windows hosts: fixed host crashes/hangs on certain 32 bits Windows systems when running Linux guests (bugs #1606, #2269, #2763)

  • Windows hosts: fixed network component BSOD issue (bugs #3168, #2916)

  • Windows hosts: fixed installation issues (bugs #2517, #1730, #3130)

  • Linux hosts: fixed occasional kernel oopses (bug #2556)

  • Linux hosts: fixed module dependency for shipped modules (bug #3115)

  • Linux hosts: moved the udev rules for USB forward so that they don't override existing system rules (bug #3143)

  • Linux hosts: fixed the issue with guest not being able to communicate with each other when attached via TAP interfaces (bug #3215)

  • Linux hosts: give up probing for USB gracefully if DBus or hal are not available (bug #3136)

  • Linux hosts: fixed warnings in installer when SELinux was disabled (bug #3098)

  • Linux hosts: VirtualBox sometimes failed to start if it had been started using sudo previously (bug #3270)

  • Solaris hosts: fixed high CPU load while running many guests in parallel

  • Solaris hosts: fixed inability to start more than 128 VMs

  • VMM: fixed performance regression for Windows guests (bug #3172)

  • VMM: ignore CPU stepping when restoring a saved state/snapshot

  • REM: fixed inability to use gdb to debug programs in Linux guests with software virtualization (bug #3245)

  • GUI: fixed dead key handling on Solaris hosts (bug #3256)

  • GUI: in the shutdown dialog, disable the action send the shutdown signal if the guest is currently not using ACPI

  • GUI: suppress additional key release events sent by X11 hosts when keys are auto-repeated (bug #1296)

  • API: restore case insensitive OS type name lookup (bug #3087)

  • VBoxHeadless: really don't start X11 services (clipboard service, 3D acceleration; Solaris & Mac OS X hosts only; bug #3199)

  • NAT: fixed occasional crashes when the guest is doing traceroute (non-Windows hosts; bug #3200)

  • NAT: fixed crashes under high load (bug #3110)

  • NAT: fixed truncated downloads (Windows hosts only, bug #3257)

  • NAT: don't intercept TFTP packages with a destination address different from the builtin TFTP server (bug #3112)

  • USB: several fixes for USB passthrough on Linux hosts

  • USB: reduced host CPU utilization if EHCI is active

  • VRDP: fixed VRDP server black screen after a client reconnect (bug #1989)

  • VRDP: modified rdesktop client (rdesktop-vrdp) now uses NumLock state synchronization (bug #3253)

  • LsiLogic: make FreeBSD guests work (bug #3174)

  • ATA: fixed deadlock when pausing VM due to problems with the virtual disk (e.g. disk full, iSCSI target unavailable)

  • iSCSI: fixed possible crash when pausing the VM

  • 3D support: added missing GL_MAX_TEXTURE_COORDS_ARB (bug #3246)

  • Windows Additions: fixed ERROR (e0000101) error during installation (bug #1923)

  • Windows Additions: fixed Windows Explorer hang when browsing shared folders with 64 bit guests (bug #2225)

  • Windows Additions: fixed guest screen distortions during a video mode change

  • Windows Additions: fixed the Network drive not connected message for mapped shared folders drives after the guest startup (bug #3157)

  • Linux Additions: fixed occasional file corruption when writing files in O_APPEND mode to a shared folder (bug #2844)

  • Linux Additions: the mouse driver was not properly set up on X.Org release candidates (bug #3212)

  • Linux Additions: fixed installer to work with openSUSE 11.1 (bug #3213)

  • Linux Additions: disable dynamic resizing if the X server is configured for fixed resolutions

  • Linux/Solaris Additions: handle virtual resolutions properly which are larger than the actual guest resolution (bug #3096)


12.11. Version 2.1.2 (2009-01-21)

This is a maintenance release. The following items were fixed and/or added:

  • USB: Linux host support fixes (bug #3136)

  • VMM: fixed guru meditation for PAE guests on non-PAE hosts (AMD-V)

  • VMM: fixed guru meditation on Mac OS X hosts when using VT-x

  • VMM: allow running up to 1023 VMs on 64-bit hosts (used to be 127)

  • VMM: several FreeBSD guest related fixes (bugs #2342, #2341, #2761)

  • VMM: fixed guru meditation when installing Suse Enterprise Server 10U2 (VT-x only; bug #3039)

  • VMM: fixed guru meditation when booting Novell Netware 4.11 (VT-x only; bug #2898)

  • VMM: fixed VERR_ADDRESS_TOO_BIG error on some Mac OS X systems when starting a VM

  • VMM: clear MSR_K6_EFER_SVME after probing for AMD-V (bug #3058)

  • VMM: fixed guru meditation during Windows 7 boot with more than 2 GB guest RAM (VT-x, nested paging only)

  • VMM: fixed hang during OS/2 MCP2 boot (AMD-V and VT-x only)

  • VMM: fixed loop during OpenBSD 4.0 boot (VT-x only)

  • VMM: fixed random crashes related to FPU/XMM with 64 bits guests on 32 bits hosts

  • VMM: fixed occasional XMM state corruption with 64 bits guests

  • GUI: raised the RAM limit for new VMs to 75% of the host memory

  • GUI: added Windows 7 as operating system type

  • VBoxSDL: fixed -fixed fixedmode parameter (bug #3067)

  • Clipboard: stability fixes (Linux and Solaris hosts only, bugs #2675 and #3003)

  • 3D support: fixed VM crashes for certain guest applications (bugs #2781, #2797, #2972, #3089)

  • LsiLogic: improved support for Windows guests (still experimental)

  • VGA: fixed a 2.1.0 regression where guest screen resize events were not properly handled (bug #2783)

  • VGA: significant performance improvements when using VT-x/AMD-V on Mac OS X hosts

  • VGA: better handling for VRAM offset changes (fixes GRUB2 and Dos DOOM display issues)

  • VGA: custom VESA modes with invalid widths are now rounded up to correct ones (bug #2895)

  • IDE: fixed ATAPI passthrough support (Linux hosts only; bug #2795)

  • Networking: fixed kernel panics due to NULL pointer dereference in Linux kernels < 2.6.20 (Linux hosts only; bug #2827)

  • Networking: fixed intermittent BSODs when using the new host interface (Windows hosts only; bugs #2832, #2937, #2929)

  • Networking: fixed several issues with displaying hostif NICs in the GUI (Windows hosts only; bugs 2814, #2842)

  • Networking: fixed the issue with displaying hostif NICs without assigned IP addresses (Linux hosts only; bug #2780)

  • Networking: fixed the issue with sent packets coming back to internal network when using hostif (Linux hosts only; bug #3056).

  • NAT: fixed port forwarding (Windows hosts only; bug #2808)

  • NAT: fixed booting from the builtin TFTP server (bug #1959)

  • NAT: fixed occasional crashes (bug #2709)

  • SATA: vendor product data (VPD) is now configurable

  • SATA: raw disk partitions were not recognized (2.1.0 regression, Windows host only, bug #2778)

  • SATA: fixed timeouts in the guest when using raw VMDK files (Linux host only, bug #2796)

  • SATA: huge speed up during certain I/O operations like formatting a drive

  • SATA/IDE: fixed possible crash/errors during VM shutdown

  • VRDP: fixed loading of libpam.so.1 from the host (Solaris hosts only)

  • VRDP: fixed RDP client disconnects

  • VRDP: fixed VRDP server misbehavior after a broken client connection

  • VBoxManage showvminfo: fixed assertion for running VMs (bug #2773)

  • VBoxManage convertfromraw: added parameter checking and made it default to creating VDI files; fixed and documented format parameter (bug #2776)

  • VBoxManage clonehd: fixed garbled output image when creating VDI files (bug #2813)

  • VBoxManage guestproperty: fixed property enumeration (incorrect parameters/exception)

  • VHD: fixed error when attaching certain container files (bug #2768)

  • Solaris hosts: added support for serial ports (bug #1849)

  • Solaris hosts: fix for Japanese keyboards (bug #2847)

  • Solaris hosts: 32-bit and 64-bit versions now available as a single, unified package

  • Linux hosts: don't depend on libcap1 anymore (bug #2859)

  • Linux hosts: kernel module compile fixes for 2.6.29-rc1

  • Linux hosts: don't drop any capability if the VM was started by root (2.1.0 regression)

  • Mac OS X hosts: save the state of running or paused VMs when the host machine's battery reaches critical level

  • Mac OS X hosts: improved window resizing of the VM window

  • Mac OS X hosts: added GUI option to disable the dock icon realtime preview in the GUI to decrease the host CPU load when the guest is doing 3D

  • Mac OS X hosts: polished realtime preview dock icon

  • Windows Additions: fixed guest property and logging OS type detection for Windows 2008 and Windows 7 Beta

  • Windows Additions: added support for Windows 7 Beta (bugs #2995, #3015)

  • Windows Additions: fixed Windows 2000 guest freeze when accessing files on shared folders (bug #2764)

  • Windows Additions: fixed CTRL-ALT-DEL handling when using VBoxGINA

  • Windows Additions Installer: added /extract switch to only extract (not install) the files to a directory (can be specified with /D=path)

  • Linux installer and Additions: added support for the Linux From Scratch distribution (bug #1587) and recent Gentoo versions (bug #2938)

  • Additions: added experimental support for X.Org Server 1.6 RC on Linux guests

  • Linux Additions: fixed bug which prevented to properly set fmode on mapped shared folders (bug #1776)

  • Linux Additions: fixed appending of files on shared folders (bug #1612)

  • Linux Additions: ignore noauto option when mounting a shared folder (bug #2498)

  • Linux Additions: fixed a driver issue preventing X11 from compiling keymaps (bugs #2793 and #2905)

  • X11 Additions: workaround in the mouse driver for a server crash when the driver is loaded manually (bug #2397)


12.12. Version 2.1.0 (2008-12-17)

This version is a major update. The following major new features were added:

  • Support for hardware virtualization (VT-x and AMD-V) on Mac OS X hosts

  • Support for 64-bit guests on 32-bit host operating systems (experimental; see Section 1.6, “64-bit guests”)

  • Added support for Intel Nehalem virtualization enhancements (EPT and VPID; see Section 1.2, “Software vs. hardware virtualization (VT-x and AMD-V)”)

  • Experimental 3D acceleration via OpenGL (see Section 4.8, “Hardware 3D acceleration (OpenGL and DirectX 8/9)”)

  • Experimental LsiLogic and BusLogic SCSI controllers (see Section 5.1, “Hard disk controllers: IDE, SATA (AHCI), SCSI”)

  • Full VMDK/VHD support including snapshots (see Section 5.2, “Disk image files (VDI, VMDK, VHD)”)

  • New NAT engine with significantly better performance, reliability and ICMP echo (ping) support (bugs #1046, #2438, #2223, #1247)

  • New Host Interface Networking implementations for Windows and Linux hosts with easier setup (replaces TUN/TAP on Linux and manual bridging on Windows)

In addition, the following items were fixed and/or added:

  • VMM: significant performance improvements for VT-x (real mode execution)

  • VMM: support for hardware breakpoints (VT-x and AMD-V only; bug #477)

  • VMM: VGA performance improvements for VT-x and AMD-V

  • VMM: Solaris and OpenSolaris guest performance improvements for AMD-V (Barcelona family CPUs only)

  • VMM: fixed guru meditation while running the Dr. Web virus scanner (software virtualization only; bug #1439)

  • VMM: deactivate VT-x and AMD-V when the host machine goes into suspend mode; reactivate when the host machine resumes (Windows, Mac OS X & Linux hosts; bug #1660)

  • VMM: fixed guest hangs when restoring VT-x or AMD-V saved states/snapshots

  • VMM: fixed guru meditation when executing a one byte debug instruction (VT-x only; bug #2617)

  • VMM: fixed guru meditation for PAE guests on non-PAE hosts (VT-x)

  • VMM: disallow mixing of software and hardware virtualization execution in general (bug #2404)

  • VMM: fixed black screen when booting OS/2 1.x (AMD-V only)

  • GUI: pause running VMs when the host machine goes into suspend mode (Windows & Mac OS X hosts)

  • GUI: resume previously paused VMs when the host machine resumes after suspend (Windows & Mac OS X hosts)

  • GUI: save the state of running or paused VMs when the host machine's battery reaches critical level (Windows hosts)

  • GUI: properly restore the position of the selector window when running on the compiz window manager

  • GUI: properly restore the VM in seamless mode (2.0 regression)

  • GUI: warn user about non optimal memory settings

  • GUI: structure operating system list according to family and version for improved usability

  • GUI: predefined settings for QNX guests

  • IDE: improved ATAPI passthrough support

  • Networking: added support for up to 8 Ethernet adapters per VM

  • Networking: fixed issue where a VM could lose connectivity after a reboot

  • iSCSI: allow snapshot/diff creation using local VDI file

  • iSCSI: improved interoperability with iSCSI targets

  • Graphics: fixed handling of a guest video memory which is not a power of two (bug #2724)

  • VBoxManage: fixed bug which prevented setting up the serial port for direct device access

  • VBoxManage: added support for VMDK and VHD image creation

  • VBoxManage: added support for image conversion (VDI/VMDK/VHD/RAW)

  • Solaris hosts: added IPv6 support between host and guest when using host interface networking

  • Mac OS X hosts: added ACPI host power status reporting

  • API: redesigned storage model with better generalization

  • API: allow attaching a hard disk to more than one VM at a time

  • API: added methods to return network configuration information of the host system

  • Shared Folders: performance and stability fixes for Windows guests (Microsoft Office Applications)


12.13. Version 2.0.8 (2009-03-10)

This is a maintenance release. The following items were fixed and/or added:

  • VMM: fixed guest hangs when restoring VT-x or AMD-V saved states/snapshots

  • VMM: fixed memory allocation issues which can cause VM start failures with VERR_PGM_MAPPING_CONFLICT error

  • VMM: fixed host crashes/hangs on certain 32 bits Windows systems when running Linux guests (bugs #1606, #2269, #2763)

  • XPCOM/Main: fixed synchronization bug caused by SYSV semaphore key collisions

  • ATA: fixed deadlock when pausing VM due to problems with the virtual disk (e.g. disk full, iSCSI target unavailable)

  • iSCSI: fixed possible crash when pausing the VM

  • iSCSI: fix PDU validity checking and detect final PDU reliably

  • VBoxHeadless: really don't start X11 services (clipboard service, 3D acceleration; Solaris & Mac OS X hosts only; bug #3199)

  • Networking: fixed issue where a VM could lose connectivity after a reboot

  • Linux hosts: fixed occasional kernel oopses (bug #2556)

  • Solaris hosts: fixed high CPU load while running many guests in parallel

  • Solaris hosts: fixed inability to start more than 128 VMs

  • Solaris/Web services: fixed SMF script to set home directory correctly

  • Linux Additions: fixed occasional file corruption when writing files in O_APPEND mode to a shared folder (bug #2844)


12.14. Version 2.0.6 (2008-11-21)

This is a maintenance release. The following items were fixed and/or added:

  • VMM: fixed Guru meditation when running 64 bits Windows guests (bug #2220)

  • VMM: fixed Solaris 10U6 boot hangs (VT-x and AMD-V) bug #2565)

  • VMM: fixed Solaris 10U6 reboot hangs (AMD-V only; bug #2565)

  • GUI: the host key was sometimes not properly displayed (Windows hosts only, bug #1996)

  • GUI: the keyboard focus was lost after minimizing and restoring the VM window via the Windows taskbar (bugs #784)

  • VBoxManage: properly show SATA disks when showing the VM information (bug #2624)

  • SATA: fixed access if the buffer size is not sector-aligned (bug #2024)

  • SATA: improved performance

  • SATA: fixed snapshot function with ports>1 (bug #2510)

  • E1000: fixed crash under rare circumstances

  • USB: fixed support for iPhone and Nokia devices (Linux host: bugs #470 & #491)

  • Windows host installer: added proper handling of open VirtualBox applications when updating the installation

  • Windows host installer: fixed default installation directory on 64-bit on new installations (bug #2501)

  • Linux/Solaris/Mac OS X hosts: verify permissions in /tmp/vbox-$USER-ipc

  • Linux hosts: fixed assertion on high network load (AMD64 hosts, fix for Linux distributions with glibc 2.6 and newer (bug #616)

  • Linux hosts: don't crash during shutdown with serial ports connected to a host device

  • Solaris hosts: fixed incompatibility between IPSEC and host interface networking

  • Solaris hosts: fixed a rare race condition while powering off VMs with host interface networking

  • Solaris hosts: fixed VBoxSDL on Solaris 10 by shipping the required SDL library (bug #2475)

  • Windows Additions: fixed logged in users reporting via guest properties when using native RDP connections

  • Windows Additions: fixed Vista crashes when accessing shared folders under certain circumstances (bug #2461)

  • Windows Additions: fixed shared folders access with MS-Office (bug #2591)

  • Linux Additions: fixed compilation of vboxvfs.ko for 64-bit guests (bug #2550)

  • SDK: added JAX-WS port caching to speedup connections


12.15. Version 2.0.4 (2008-10-24)

This is a maintenance release. The following items were fixed and/or added:

  • VMM: better error reporting for VT-x failures

  • VMM: don't overflow the release log with PATM messages (bug #1775)

  • VMM: fixed save state restore in real mode (software virtualization only)

  • GUI: work around a Qt bug on Mac OS X (bug #2321)

  • GUI: properly install the Qt4 accessible plugin (bug #629)

  • SATA: error message when starting a VM with a VMDK connected to a SATA port (bug #2182)

  • SATA: fixed Guru mediation when booting OpenSolaris/64; most likely applies to other guests as well (bug #2292)

  • Network: don't crash when changing the adapter link state if no host driver is attached (bug #2333)

  • VHD: fixed bug which prevents booting from VHD images bigger than 4GB (bug #2085)

  • VRDP: fixed a repaint problem when the guest resolution was not equal to the client resolution

  • Clipboard: don't crash when host service initialization takes longer than expected (Linux hosts only; bug #2001)

  • Windows hosts: VBoxSVC.exe crash (bug #2212)

  • Windows hosts: VBoxSVC.exe memory leak due to a Windows WMI memory leak (Vista only) (bug #2242)

  • Windows hosts: VBoxSVC.exe delays GUI startup

  • Linux hosts: handle jiffies counter overflow (VM stuck after 300 seconds of host uptime; bug #2247)

  • Solaris hosts: fixed host or guest side networking going stale while using host interface networking (bug #2474)

  • Solaris hosts: added support for using unplumbed network interfaces and Crossbow Virtual Network Interfaces (VNICs) with host interface networking

  • Solaris hosts: reworked threading model improves performance for host interface networking

  • Windows Additions: fixed crash when accessing deep directory structures in a shared folder

  • Windows Additions: improved shared folder name resolving (bug #1728)

  • Windows Additions: fixed Windows 2000 shutdown crash (bug #2254)

  • Windows Additions: fixed error code for MoveFile() if the target exists (bug #2350)

  • Linux Additions: fixed seek() for files bigger than 2GB (bug #2379)

  • Linux Additions: support Ubuntu 8.10

  • Linux Additions: clipboard fixes (bug #2015)

  • Web services: improved documentation and fixed example (bug #1642)


12.16. Version 2.0.2 (2008-09-12)

This is a maintenance release. The following items were fixed and/or added:

  • VMM: fixed inability to run more than one VM in parallel (AMD-V on CPUs with erratum 170 only; bug #2167)

  • VMM: VT-x stability fixes (bug #2179 and others)

  • VMM: fixed Linux 2.6.26+ kernel crashes (used by Ubuntu 8.10 Alpha, Fedora 10 Alpha; bug #1875)

  • VMM: fixed 64 bits Linux 2.6.26 kernel crashes (Debian)

  • VMM: fixed Vista (32 bits) guest crash during boot when PAE and NX are enabled (applied to 64 bits hosts with VT-x enabled only)

  • VMM: fixed OS/2 guest crashes during boot (AMD-V; bug #2132)

  • GUI: fixed crash when trying to release an inaccessible image in the virtual disk manager

  • GUI: fixed invalid error message for a changed snapshot path even if that path wasn't changed (bug #2064)

  • GUI: fixed crash when creating a new hard disk image (bug #2060)

  • GUI: fixed crash when adding a hard disk in the VM settings (bug #2081)

  • GUI: fixed a bug where VirtualBox isn't working with the new QGtkStyle plugin (bug #2066)

  • GUI: fixed VM close dialog in seamless mode (Mac OS X hosts only; bug #2067)

  • GUI: fixed standard menu entries for NLS versions (Mac OS X hosts only)

  • GUI: disable the VT-x/AMD-V setting when it's not supported by the CPU (or on Mac OS X hosts)

  • VBoxManage: fixed crash during internalcommands createrawvmdk (bug #2184)

  • VBoxManage: fixed output of snapshot showvminfo (bug #698)

  • Guest properties: added information about guest network interfaces (Windows guests only)

  • Shared Folders: fixed regression that caused Windows guest crashes

  • API: fixed number of installed CPUs (Solaris hosts only)

  • VRDP: allow a client to reconnect to an existing session on the VRDP server by dropping the existing connection (configurable and disabled by default; only relevant when multiconnection mode is disabled)

  • VRDP: fixed an image repaint problem

  • Linux hosts: fixed bug in vboxdrv.ko that could corrupt kernel memory and panic the kernel (bug #2078)

  • Linux hosts: compile fixes for kernel module on Linux 2.6.27

  • Mac OS X hosts: added Python support

  • Additions: fixed a possible hang in HGCM communication after a VM reboot

  • Windows Additions: added support for Windows XP 64 bits (bug #2117)

  • Linux Additions: deactivate dynamic resizing on Linux guests with buggy X servers

  • Linux Additions: support Ubuntu 8.10 guests and Fedora 9 guests (dynamic resizing disabled for the latter)

  • Linux Additions: added installer check for the system architecture

  • Linux Additions: fixed Xorg modules path for some Linux distributions (bug #2128)

  • VMDK: be more liberal with ambiguous parts of the format specification and accept more format variants (bug #2062)

  • VHD: fixed a bug in the VHD backend which resulted in reading the wrong data (bug #2085)

  • Solaris hosts: fixed kernel panic on certain machines when starting VMs with host interface networking (bug #2183)

  • Solaris hosts: fixed inability to access NFS shares on the host when host interface networking was enabled

  • Solaris hosts: installer now detects and reports when installing under the wrong architecture

  • Solaris hosts: fixed security hardening that prevented starting VMs from non-global zones even as root (bug #1948)

  • Solaris Additions: combined the 32 bit and 64 bit Additions installer into a single package

  • Mac OS X hosts: experimental support for attaching a real serial port to the guest


12.17. Version 2.0.0 (2008-09-04)

This version is a major update. The following major new features were added:

  • 64 bits guest support (64 bits host only)

  • New native Leopard user interface on Mac OS X hosts

  • The GUI was converted from Qt3 to Qt4 with many visual improvements

  • New-version notifier

  • Guest property information interface

  • Host Interface Networking on Mac OS X hosts

  • New Host Interface Networking on Solaris hosts

  • Support for Nested Paging on modern AMD CPUs (major performance gain)

  • Framework for collecting performance and resource usage data (metrics)

  • Added SATA asynchronous IO (NCQ: Native Command Queuing) when accessing raw disks/partitions (major performance gain)

  • Clipboard integration for OS/2 Guests

  • Created separate SDK component featuring a new Python programming interface on Linux and Solaris hosts

  • Support for VHD disk images

In addition, the following items were fixed and/or added:

  • VMM: VT-x fixes

  • AHCI: improved performance

  • GUI: keyboard fixes

  • Linux installer: properly uninstall the package even if unregistering the DKMS module fails

  • Linux Additions: the guest screen resolution is properly restored

  • Network: added support for jumbo frames (> 1536 bytes)

  • Shared Folders: fixed guest crash with Windows Media Player 11

  • Mac OS X: Ctrl+Left mouse click doesn't simulate a right mouse click in the guest anymore. Use Hostkey+Left for a right mouse click emulation. (bug #1766)


12.18. Version 1.6.6 (2008-08-26)

This is a maintenance release. The following items were fixed and/or added:

  • VMM: fixed excessive logging (bug #1901)

  • VMM: AMD-V stability fixes (bug #1685)

  • GUI: added support for Ctrl+Caps reversed keyboards (bug #1891)

  • SATA: fixed BSODs of Windows guests on a SATA disk (bug #1941)

  • SATA: fixed hard disk detection on Solaris 10 U5 (bug #1789)

  • VBoxHeadless: don't start the clipboard service (bug #1743)

  • VBoxHeadless: added -vrdp parameter which allows to start the VM session without VRDP (bug #1960)

  • VBoxManage: fixes to creating raw disk/partition VMDK files, now accepts removable media on Windows (bug #1869)

  • VRDP: fixed communication with MS Remote Desktop Connection on Mac OS X (bug #1337)

  • VRDP: clipboard fixes (bug #1410)

  • VRDP: fixed crash during PAM authentication (bug #1953)

  • Shared Folders: fixed a regression introduced in version 1.6.2: the shared folders service was sometimes not properly installed (Windows guests only, bug #1915)

  • Shared Folders: don't deny to load a VM if a shared folder is not accessible (bug #822)

  • BIOS: allow to specify empty DMI strings (bug #1957)

  • OSE archive: added missing Makefiles (bug #1912)

  • Linux hosts: workaround for buggy gcc-4.3 compilers (e.g. openSUSE 11)

  • Linux hosts: one more fix for compiling the kernel modules on Linux 2.6.27 (bug #1962)

  • Mac OS X hosts: shared folders unicode fix

  • Solaris hosts: fixed link issue (bug #1840)

  • Windows Additions: allow to downgrade the package

  • Windows Additions: fixed corrupted installer icon on Windows 2000 (bug #1486)

  • Windows Additions: fixed bug when creating intermediate directories (bug #1870)

  • Windows Additions: implemented /xres=, /yres= and /depth= switches for the installer (bug #1990)

  • Linux Additions: properly unregister the misc device when unloading the kernel module

  • Linux Additions: fixed startup order for recent Linux distributions again (e.g. openSUSE 11)

  • Linux Additions: attempt to fix the autostart issue of VBoxClient with Mandriva guests (bug #1699)

  • Linux Additions: fixed detection of patched Linux 2.6.18 kernels of RHEL5 / FC6 / CentOS 5.2 (bugs #1899, #1973)

  • Linux Additions: added new mount flags dmode, fmode, umask, dmask and fmask allowing to override the file mode (bug #1776)

  • Documentation: added a note that jumbo frames don't work (bug #1877)

  • Documentation: document special host interface names on openSUSE11 (bug #1892)


12.19. Version 1.6.4 (2008-07-30)

This is a maintenance release. The following items were fixed and/or added:

  • AMD-V, VT-x: stability fixes

  • Shared Folders: fixed host crash (Solaris host only, bugs #1336, #1646)

  • Shared Folders: fixed BSOD when debugging with Visual Studio (bug #1627)

  • Shared Folders: fixed BSOD when compiling on a shared folder (bug #1683)

  • Shared Folders: several fixes/stability improvements

  • SATA: fixed a race that could cause an occasional Windows guest system hang

  • SATA: fixed spurious BIOS log messages

  • Networking: fixed NIC tracing with NAT interfaces (bug #1790)

  • USB: fixed crash under certain conditions when unplugging a USB device (bug #1295)

  • Settings: fixed bug when converting 1.5.x settings

  • VRDP: fixed enabling the RDP server during runtime

  • VRDP: properly detect the rdesktop 1.6.0 RDP client

  • VRDP: fixed RDP crash (bug #1521)

  • VRDP: updated modified rdesktop client to version 1.6.0

  • GUI: NLS improvements

  • BIOS: added SMBIOS header to make Solaris and Vista recognize the DMI data

  • ACPI: properly hide a disabled floppy controller

  • VMM: small fixes to protected mode without paging

  • VMDK: fixed handling of .vmdk images without UUIDs

  • Windows hosts: fixed driver parameter validation issue in VBoxDrv.sys that could allow an attacker on the host to crash the system

  • Windows hosts: installer now contains web service examples mentioned in the manual

  • Linux hosts: properly deregister the Linux kernel module before uninstalling a Linux deb/rpm package

  • Linux hosts: kernel module works now with Linux 2.6.27

  • Linux hosts: fixed a typo in the vboxnet setup script for host network interfaces (bug #1714)

  • Linux hosts: fixed usage of tar in installer (bug #1767)

  • Linux hosts: fixed long guest shutdown time when serial port is enabled

  • Solaris hosts: refuse to install in Sun xVM hypervisor dom0

  • Solaris hosts: accept Solaris raw disks when for raw disk access

  • Windows Additions: made installation of shared folders more robust

  • Windows Additions: improved installation

  • Linux Additions: accept every user-defined guest video mode in /etc/X11/xorg.conf

  • Linux Additions: fixed startup order for recent Linux distributions (e.g. openSUSE 11)


12.20. Version 1.6.2 (2008-05-28)

This is a maintenance release. The following items were fixed and/or added:

  • GUI: fixed a bug which prevented to add more than one SATA drive from the GUI

  • GUI: fixed a regression introduced in 1.6.0: the fullscreen mode was left on every guest video mode switch

  • GUI: fixed several minor issues

  • Networking: fixed a host interface networking regression introduced in 1.6.0

  • VMM: fixed starting of VMs with AMD-V enabled

  • VMM: massive performance enhancements for AMD-V

  • VMM: stability improvements for AMD-V on Windows hosts

  • VMM: correctly detect AMD CPUs with erratum 170 (AMD-V)

  • VMM: detect inconsistent timestamp counters on certain AMD Phenom motherboards (Windows host only)

  • VMM: fixed KVM check (Linux hosts only)

  • VMM: fixed a regression introduced in 1.6.0: Windows stuck during installation

  • XPCOM: fixed several races

  • SATA: improved performance with Vista guests

  • SATA: fixed statistics counter

  • Shared Folders: several fixes (iTunes download, speed up browsing)

  • ATA/IDE: fixed boot from CDROM if a medium was added while the boot menu was active

  • Networking: provide an Intel PRO/1000 T Server (82543GC) network device emulation which is recognized by Windows XP guests

  • Networking: fixes for the E1000 emulation (don't crash if not attached, fixed a bug in the statistics counter implementation)

  • NAT: don't crash if the guest sent a DHCPRELEASE message with an invalid IP address

  • NAT: fixed ARP reply for the NAT gateway and for the NAT name server if the guest IP range was changed

  • Internal Networking: fixed shutdown if more than two VMs are connected to the same network

  • BIOS: allow to change the DMI information (see Section 9.14, “Configuring the BIOS DMI information”)

  • RTC: fixed UIP emulation to prevent jumping of time in Solaris guests

  • Windows host: VirtualBox installation directory corrected for 64 bits Windows

  • Windows host: fixed VBoxVRDP.exe symlink

  • Windows host: solved locking problems in raw partition VMDK support

  • Windows host: fixed stability during high system load (page fault in KeQueryActiveProcessors)

  • Mac OS X host: fixed crashes under certain conditions

  • Shared Folders: limited users without admin rights now also can use Shared Folders on Windows guests

  • Linux hosts: fixed default runlevel for the kernel module helper script

  • Solaris hosts: enabled support for VT-x and AMD-V

  • Solaris hosts: dynamic loading of libdlpi fixes a problem where Solaris 10 was not able to start a VM

  • Linux Additions: fixed runlevels for kernel module helper scripts

  • Linux Additions: compatibility fixes with Linux 2.6.26

  • Linux Additions: fixed occasional guest kernel crash during unload of the vboxadd guest kernel module

  • X11 Guest Additions: fixed a problem preventing clipboard transfers over 1K from host to guest


12.21. Version 1.6.0 (2008-04-30)

This version is a major update. The following major new features were added:

  • Solaris and Mac OS X host support

  • Seamless windowing for Linux and Solaris guests

  • Guest Additions for Solaris

  • A webservice API (see Chapter 10, VirtualBox programming interfaces)

  • SATA hard disk (AHCI) controller (see Section 5.1, “Hard disk controllers: IDE, SATA (AHCI), SCSI”)

  • Experimental Physical Address Extension (PAE) support

In addition, the following items were fixed and/or added:

  • GUI: added accessibility support (508)

  • GUI: VM session information dialog

  • VBoxHeadless: renamed from VBoxVRDP

  • VMM: reduced host CPU load of idle guests

  • VMM: many fixes for VT-x/SVM hardware-supported virtualization

  • ATA/IDE: better disk geometry compatibility with VMware images

  • ATA/IDE: virtualize an AHCI controller

  • Storage: better write optimization, prevent images from growing unnecessarily

  • Network: support PXE booting with NAT

  • Network: fixed the Am79C973 PCNet emulation for Nexenta guests

  • NAT: improved builtin DHCP server (implemented DHCPNAK response)

  • NAT: port forwarding stopped when restoring the VM from a saved state

  • NAT: make subnet configurable

  • XPCOM: moved to libxml2

  • XPCOM: fixed VBoxSVC autostart race

  • Audio: SoundBlaster 16 emulation

  • USB: fixed problems with USB 2.0 devices

  • Mac OS X: fixed seamless mode

  • Mac OS X: better desktop integration, several look'n'feel fixes

  • Mac OS X: switched to Quartz2D framebuffer

  • Mac OS X: added support for shared folders

  • Mac OS X: added support for clipboard integration

  • Solaris: added host audio playback support (experimental)

  • Solaris: made it possible to run VirtualBox from non-global zones

  • Shared Folders: many bugfixes to improve stability

  • Seamless windows: added support for Linux guests

  • Linux installer: support DKMS for compiling the kernel module

  • Linux host: compatibility fixes with Linux 2.6.25

  • Windows host: support for USB devices has been significantly improved; many additional USB devices now work

  • Windows Additions: automatically install AMD PCNet drivers on Vista guests

  • Linux Additions: several fixes, experimental support for RandR 1.2

  • Linux Additions: compatibility fixes with Linux 2.6.25


12.22. Version 1.5.6 (2008-02-19)

This version is a maintenance release. It adds an experimental Intel Gigabit Ethernet device emulation and read-only shared folders.

  • GUI: fixed several error messages

  • GUI: fixed registration dialog crashes once and for all

  • GUI: really ask before resetting the VM

  • GUI: release mouse and keyboard before the host activates the screensaver

  • GUI: fixed issue with license display on big screens

  • GUI: added setting for network name for internal networks

  • GUI: added setting for network device type

  • GUI: keyboard fixes

  • GUI: seamless mode and fullscreen mode fixes

  • GUI: fixed soaked hostkey keyup event under certain conditions

  • GUI: more informative message dialog buttons

  • GUI: VM selector context menu

  • VBoxSDL: added -termacpi switch

  • VBoxSDL: fixed automatic adaption of the guest screen resolution to the size of the VM window

  • VMM: under heavy guest activity, for example when copying files to/from a shared folder, the VM could crash with an assertion

  • VMM: added an option to select PIIX4 (improves compatibility with Windows guests created by VMware)

  • VMM: fixed a bug which could lead to memory corruption under rare circumstances

  • VMM: improved performance of Solaris guests

  • VRDP: fixed a 1.5.4 regression: VRDP client and server were out-of-sync if the VM was started using the GUI

  • VRDP: proper error handling if the VRDP library could not be loaded

  • VRDP: fixed compilation of the Linux rdesktop client on newer Linux kernels

  • VRDP: install rdesktop-vrdp on Linux hosts

  • VBoxManage: fixed crash during clonevdi

  • VBoxManage: added 'list runningvms' command

  • VBoxManage: improved the compatibility when reading the partition table of a raw disk

  • Shared Folders: added support for read-only shared folders

  • Shared Clipboard: several fixes

  • Network: don't crash if the device is activated but not attached

  • Network: experimental support for Intel Gigabit Ethernet (E1000) device emulation

  • iSCSI: better check for misconfigured targets

  • iSCSI: allow to directly attach to internal networks with integrated mini IP stack

  • PulseAudio: don't hang during VM initialization if no sound server is available

  • VDI: fixed sized virtual disk images are now completely written during creation to workaround buggy sparse file handling on some OS (e.g. Vista)

  • VDI/VMDK: prevent indexing of .vdi and .vmdk files on Windows hosts

  • ACPI: added sleep button event

  • Serial: proper handling of inaccessible host devices

  • Windows installer: allow smooth upgrade without deinstallation

  • Linux installer: fixed Slackware detection regression

  • Linux installer: updated VBoxTunctl allowing to assign a tap device to a group on Linux kernels > 2.6.23

  • Windows Additions: several fixes, in particular for Windows NT4

  • Windows Additions: made them uninstallable

  • Linux Additions: fixed installer for Kubuntu 8.04

  • Linux Additions: add default video mode for handling video mode hints from the host

  • Linux host: compatibility fixes with Linux > 2.6.24


12.23. Version 1.5.4 (2007-12-29)

This version is a maintenance release. It adds USB 2.0 support and a PulseAudio backend.

  • GUI: fixed registration dialog crashes

  • GUI: allow to enter unicode characters to the name of the registration dialog

  • GUI: pre-select attached media in the disk manager when opened from the VM settings dialog

  • GUI: remember the last active VM

  • GUI: ask before reset the VM

  • GUI: don't accept empty paths for serial/parallel ports in XML

  • GUI: fixed NumLock / CapsLock synchronization on Windows hosts

  • GUI: don't start the kernel timer if no VM is active (Linux host)

  • GUI: fixed accelerators in German translation

  • VMM: improved compatibility with Solaris guests

  • VMM: properly restore CR4 after leaving VT-x mode

  • VMM: fix interrupt storm with Windows guests under certain circumstances (e.g. disable + re-enable the network adapter)

  • VMM: with VT-x a pending interrupt could be cleared behind our back

  • VMM: workaround for missed cpuid patch (some Linux guests refuse to boot on multi-core CPUs)

  • VMM: fixed code for overriding cpuid values

  • VMM: improved error handling on out-of-memory conditions

  • API: don't crash when trying to create a VM with a duplicate name

  • API: don't crash when trying to access the settings of a VM when some other VMs are not accessible

  • API: fixed several memory leaks

  • ATA/IDE: fixed SuSE 9.1 CD read installer regression

  • Serial: several fixes

  • Floppy: fixed inverted write protect flag

  • Floppy: fixed handling of read-only images

  • USB: virtualize an EHCI controller

  • USB: several minor fixes

  • Network: fixed MAC address check

  • Network: host interface fixes for Solaris guests

  • Network: guest networking stopped completely after taking a snapshot

  • Network: don't crash if a network card is enabled but not attached

  • PXE: fix for PXE-EC8 error on soft reboot

  • NAT: update the DNS server IP address on every DNS packet sent by the guest

  • VGA: reset VRAM access handers after a fullscreen update

  • VGA: don't overwrite guest's VRAM when displaying a blank screen

  • ACPI: implemented the sleep button event

  • VRDP: fixed crash when querying VRDP properties

  • VRDP: netAddress fixes

  • VRDP: fixed the Pause/Break keys over VRDP

  • VRDP: workaround for scrambled icons with a guest video mode of 16bpp

  • VRDP: reset modifier keys on RDP_INPUT_SYNCHRONIZE

  • VRDP: reset RDP updates after resize to prevent obsolete updates

  • Clipboard: Windows host/guest fixes

  • Clipboard: fixed a SEGFAULT on VM exit (Linux host)

  • Clipboard: fixed a buffer overflow (Linux host)

  • Shared Folders: fixed memory leaks

  • Linux installer: remove the old kernel module before compiling a new one

  • Linux host: compatibility fixes with Linux 2.6.24

  • Linux host: script fixes for Arch Linux

  • Linux host: load correct HAL library to determine DVD/floppy (libhal.so.1 not libhal.so)

  • Linux host: make sure the tun kernel module is loaded before initializing static TAP interfaces

  • Windows Additions: fixed hang during HGCM communication

  • Windows Additions: fixed delay when shutting down the guest

  • Linux Additions: added sendfile support to allow HTTP servers to send files on shared folders

  • Linux Additions: make Additions work with Fedora 8 (SELinux policy added)

  • Linux Additions: sometimes ARGB pointers were displayed incorrectly

  • Linux Additions: several small script fixes


12.24. Version 1.5.2 (2007-10-18)

This version is a maintenance release and mainly addresses issues discovered in VirtualBox 1.5.0 and improves compatibility with new guest and host OS revisions

  • Windows Installer: fixed installation on Windows 2000 hosts

  • Windows Installer: proper warning when installing a 32-bit VirtualBox version on 64-bit Windows and vice versa

  • Linux Installer: no longer require license acceptance during install, instead at first GUI startup (addresses issues with hanging installer on Debian based distributions)

  • GUI: added user registration dialog

  • GUI: fixed crashes on 64-bit Linux hosts

  • GUI: several fixes and improvements to seamless mode

  • GUI: fixed DirectDraw mode with certain video cards (e.g. Intel i915)

  • GUI: fixed incorrect guest resolution after leaving fullscreen mode

  • GUI: improved keyboard handling on Linux host

  • GUI: show fatal VM aborts (aka "Guru Meditation")

  • GUI: fixed crashes due to a display update race condition on some systems

  • GUI: added ACPI shutdown option to the VM close dialog

  • GUI: NLS improvements

  • BIOS: fixed floppy boot menu

  • BIOS: expose the VM UUID in the DMI/SMBIOS area

  • VGA: fixed CGA video modes

  • VGA: fixed 8-bit DAC handling (Solaris setup)

  • VMM: fixed issue with VT-x on Windows 64-bit hosts

  • VMM: improved compatibility with Linux KVM

  • VMM: fixed issues with Fedora 8 guests

  • VMM: fixed fatal errors while installing Windows guests when using AMD-V

  • VMM: fixed sporadic hangs when minimizing VM window and using VT-x/AMD-V

  • VMM: fixed high load of ksoftirq on tickless Linux hosts

  • VMM: fixed Windows 2000 guests hangs related to IRQ sharing

  • VMM: fixed sporadic errors during openSUSE 10.3 installation

  • VMM: fixed issue with Linux 2.6.23 guests

  • VMM: fixed issues with Solaris guests

  • VMM: fixed stability issue related to incorrect relocations

  • Serial: significantly reduced CPU utilization

  • Network: fixed issues with FreeBSD guests

  • Network: added MII support (100MBit detection fix)

  • Network: improved MAC address handling

  • Network: added PXE release logging

  • IDE: large reads from CD could exceed the I/O buffer size

  • Audio: load ALSA dynamically on Linux (i.e. do not fail when ALSA is not present)

  • VRDP: support additional RDP clients (SunRay, WinConnect, Mac OS X)

  • VRDP: fixed issues when client color depth is higher than server color depth

  • VRDP: make PAM authentication service name configurable

  • VRDP: increased stack size to deal with stack consuming PAM library calls

  • Additions: various fixes and enhancements to clipboard handling

  • Windows Additions: fixed issues with Additions on NT 4 guests

  • Windows Additions: added support for 8-bit video modes

  • Windows Additions: allow specifying custom resolutions for secondary screens

  • Windows Additions: several fixes and improvements for DirectDraw

  • Windows Additions: improved the mouse filter driver compatibility with other mouse drivers

  • Linux Additions: several fixes and enhancements to Shared Folders

  • Linux Additions: added support for X.org Server 1.4

  • Shared Folders: fixed MS Powerpoint access issues (Linux host)

  • API: fixed RPC_E_CHANGED_MODE startup error on Windows hosts

  • API: fixed SMP race condition on Linux hosts

  • API: fixed stability issues on Windows hosts in low memory conditions


12.25. Version 1.5.0 (2007-08-31)

As major new features, Version 1.5 adds:

  • Seamless windows (see Section 4.7, “Seamless windows”)

  • Virtual serial ports (see Section 3.7.8, “Serial ports”)

  • Support for 64-bit Windows hosts (see Section 1.4, “Supported host operating systems”)

  • Intel PXE 2.1 network boot

  • Guest Additions for IBM OS/2 Warp

In addition, the following items were fixed and/or added:

  • GUI: sometimes two mouse cursors were visible when Windows guest Additions became active

  • GUI: added VT-x/AMD-V settings

  • GUI: disable 'Show log...' menu entry to prevent crash if VM list is empty

  • GUI: the log window grabbed the keyboard

  • GUI: fixed error handling if Linux host clipboard initialization fails

  • GUI: pass the Pause key and the PrtScrn key to the guest (Linux hosts)

  • GUI: increased maximum guest RAM to 2 GB (Windows host)

  • GUI: improved rendering performance (Windows host)

  • GUI: status lights for USB and shared folders

  • GUI: properly respect the DISPLAY environment variable

  • GUI: download Guest Additions from virtualbox.org in case they are not present locally

  • VRDP: support for multimonitor configurations in Windows guests

  • VRDP: support for MS RDP6 and MS RDP Mac clients

  • VRDP: added support for WinConnect RDP client

  • VRDP: performance improvements

  • VRDP: fixed sporadic client disconnects

  • VBoxManage: never delete existing target during clonevdi

  • VBoxManage: properly print the size of currently used hard disks

  • VMM: fixed Xandros Desktop 4.1 hang

  • VMM: fixed VT-x/AMD-V hang with newer versions of gcc (Linux hosts)

  • VMM: improved stability of VT-x

  • VMM: check for disabled AMD-V when detecting support

  • VMM: fixed AMD-V issue when running OS/2 guests

  • VMM: fixed application startup regressions (e.g. VideoReDo)

  • VMM: fixed regression that broke disk access in OS/2 and OpenBSD guests (possibly much more)

  • VMM: fixed crashes if memory allocation failed (Linux)

  • VMM: fixed enabling of Local APIC on AMD hosts (fixed Ubuntu Feisty installation kernel hang during boot)

  • VMM: fixed XFree86 4.3 (Debian/Sarge) segfaults when switching to text mode

  • VMM: refuse to start when KVM is active (Linux Host)

  • VMM: fixed bootup hangs with ReactOS

  • VMM: fixed out-of-memory errors under certain environments with enough appropriate memory available

  • API: fixed occasional crashes of the VBoxSVC server during VM shutdown (Linux host)

  • API: some components were not notified when mounting a CD/DVD

  • VMDK: improve geometry compatibility with existing VMDK images

  • IDE/Floppy: optionally make non-available host device non-fatal

  • IDE: improve emulation accuracy of the IRQ line between master and slave drive

  • IDE: guest could freeze when unmounting the CD/DVD drive

  • VGA: several text mode fixes in particular with Windows DOS boxes

  • USB: fixed some issues with Windows hosts

  • USB: fixed race condition between udev and USB filters (Linux host)

  • Shared Folders: reversed network provider order to increase mapping performance (Windows guest)

  • Shared Folders: browsable from Windows Explorer (Windows guests)

  • Shared Folders: stability fixes (Windows guest)

  • Shared Folders: case sensitivity fixes (Windows guest and Linux host)

  • Audio: fall back to the NULL audio driver if no voice could be opened

  • NAT: fixed crash

  • Guest Additions: reworked the shared clipboard for Linux hosts and guests based on user feedback about problems with individual applications

  • Guest Additions: don't allow to disable mouse pointer integration for Linux guests as an Xorg hardware mouse cursor cannot be turned into a software mouse cursor

  • Guest Additions: Linux guests shipping Xorg 1.3 (e.g. Fedora 7, Ubuntu Gutsy) are now supported

  • Guest Additions: added DirectDraw support to the Windows display driver


12.26. Version 1.4.0 (2007-06-06)

  • General: added support for OS X hosts

  • General: added support for AMD64 hosts

  • General: signed all executables and device drivers on Windows

  • GUI: added user interface for Shared Folders

  • GUI: added context menu for network adapters

  • GUI: added VM description field for taking notes

  • GUI: always restore guest mouse pointer when entering VM window (Windows host)

  • GUI: added configuration options for clipboard synchronization

  • GUI: improved keyboard handling on Linux hosts

  • GUI: added first run wizard

  • GUI: improved boot device order dialog

  • GUI: auto-resize did not work after save/restore

  • GUI: restore original window size when returning from fullscreen mode

  • GUI: fixed screen update when switching to fullscreen mode

  • GUI: the size of the VM window was sometimes resetted to 640x480

  • GUI: added localizations

  • GUI: fixed size report of ISO images greater than 4GB

  • GUI: various minor improvements

  • VBoxManage: added convertdd command

  • API: automatically start and terminate VBoxSVC on Linux and OS X hosts

  • VMM: increased startup performance due to lazy memory allocation

  • VMM: significantly increased maximum guest memory size

  • VMM: fixed issues with V86 mode

  • VMM: support V86 extensions (VME)

  • VMM: support guests with a full GDT

  • VMM: fixed boot hangs for some Linux kernels

  • VMM: improved FreeBSD and OpenBSD support

  • VMM: improved performance of guests that aggressively patch kernel code (very recent Linux 2.6 kernels)

  • VMM: added workaround for a design flaw in AMD AM2 CPUs where the timestamp counter shows large differences among CPU cores

  • VMM: fixed Linux guests with grsecurity

  • VMM: fixed issue on 2G/2G Linux kernels (even 1G/3G kernels should work)

  • VMM: fixed Linux detection of Local APIC on non-Intel and non-AMD CPUs

  • VMM: timing improvements with high host system loads (VM starvation)

  • VMM: experimental AMD SVM hardware virtualization support now also handles real and protected mode without paging

  • VMM: added system time offset parameter to allow for VMs to run in the past or future

  • VMM: provide an MPS 1.4 table if the IOAPIC is enabled

  • VRDP: allow binding the VRDP server to a specific interface

  • VRDP: added support for clipboard synchronization

  • VRDP: fixed problems with OS X RDP client

  • VRDP: added support for multiple simultaneous connections to one VM

  • VRDP: added support for MS RDP6 clients (Vista)

  • Storage: experimental support for VMDK images (writethrough mode only, no snapshots yet)

  • Storage: raw host disk support, including individual partitions

  • IDE: improve CHS geometry detection

  • IDE: fixed problem that only one VM could open an immutable image

  • NAT: allow more than one card configured for NAT networking

  • NAT: pass first entry in DNS search list (Linux host) or primary DNS suffix (Windows host) as domain name in DHCP

  • NAT: support UDP broadcasts, which enables using Windows shares

  • NAT: only warn if the name server could not be determined, no fatal error anymore

  • NAT: fix a potential problem with incorrect memory allocation

  • Internal Networking: fixed issue on Windows hosts

  • Host Interface Networking: fixed sporadic crashes on interface creation/destruction (Windows host)

  • Host Interface Networking: reworked TAP handling for Linux 2.6.18+ compatibility

  • PXE: show error for unsupported V86 case

  • PXE: small fix for parsing PXE menu entry without boot server IP

  • Network: fixed network card hang after save/restore

  • USB: rewrote Windows USB handling without the need for a filter driver

  • USB: possible to steal arbitrary devices in Windows

  • Serial: added serial ports with support for named pipes (local domain sockets) on the host

  • Audio: fixed problem with ALSA on Linux before 2.6.18 blocking other ALSA clients on the system

  • Audio: fixed problem with ALSA on AMD64 hosts

  • Input: fixed PS/2 mouse detection in Win 3.x guests

  • Shared Folders: fixed VM save/restore behaviour

  • Shared Folders: functionality and stability fixes

  • Shared Folders: allow non admin users to map folders

  • Additions: added clipboard synchronization

  • Windows Additions: fixed dynamic resolution changes after save/restore

  • Windows Additions: added AMD PCNet driver for Windows Vista guests (with kind permission from AMD)

  • Linux Additions: fixed a dependency problem which caused the vboxadd kernel module sometimes start after the X server

  • Linux Additions: make VBox version visible in Linux modules with modinfo

  • Linux Additions: make X11 guest video driver accept arbitrary X resolutions

  • Linux Additions: make X11 setup work if /tmp uses a separate file system

  • Linux Additions: better support unknown distributions

  • Linux Installer: force a non-executable stack for all binaries and shared libraries

  • Linux Installer: make it work on SELinux-enabled systems

  • Linux Installer: ship VBoxTunctl


12.27. Version 1.3.8 (2007-03-14)

  • Windows installer: fixed installation problem if UAC is active

  • Linux installer: added RPM for rhel4 and Mandriva 2007.1

  • Linux installer: remove any old vboxdrv modules in /lib/modules/*/misc

  • Linux installer: many small improvements for .deb and .rpm packages

  • Linux installer: improved setup of kernel module

  • GUI: Host-Fn sends Ctrl-Alt-Fn to the guest (Linux guest VT switch)

  • GUI: fixed setting for Internal Networking

  • GUI: show correct audio backend on Windows (dsound)

  • GUI: improved error messages if the kernel module is not accessible

  • GUI: never fail to start the GUI if the kernel module is not accessible

  • VMM: fixed occasional crashes when shutting down Windows TAP device

  • VMM: fixed issues with IBM's 1.4.2 JVM in Linux guests

  • VRDP: fixed color encoding with 24bpp

  • BIOS: zero main memory on reboot

  • BIOS: added release logging

  • USB: fixed parsing of certain devices to prevent VBoxSVC crashes

  • USB: properly wakeup suspended ports

  • USB: fixed a problem with unplugged USB devices during suspend

  • Audio: fixed crashes on Vista hosts

  • NAT: allow configuration of incoming connections (aka port mapping)

  • Network: hard reset network device on reboot

  • iSCSI: fixed a hang of unpaused VMs accessing unresponsive iSCSI disks

  • Linux Additions: support Xorg 7.2.x

  • Linux Additions: fixed default video mode if all other modes are invalid

  • Linux Additions: set default DPI to 100,100

  • Linux Additions: fixed initialization of video driver on X server reset


12.28. Version 1.3.6 (2007-02-20)

  • Windows installer: perform installation for all users instead of just the current user (old behavior still available)

  • Linux installer: fixed license display to not block installation

  • Linux installer: added RPM for openSUSE 10.2

  • GUI: fixed problems with several keyboard layouts on Linux hosts

  • GUI: added online help on Linux hosts (using kchmviewer)

  • GUI: fixed handle leak on Windows hosts

  • Graphics: increased VRAM limit to 128MB

  • BIOS: fixed CD/DVD-ROM detection in Windows Vista guests

  • VMM: fixed incompatibility with OpenBSD 4.0

  • VDI: fixed issues with snapshot merging

  • Network: fixed incompatibility between Vista UAC and Host Interface Networking

  • Network: fixed issues with Windows NT 4.0 guests

  • Audio: fixed problem with ALSA on Linux before 2.6.18 causing system reboots

  • VRDP: added support for MS RDP 6.0 clients

  • VRDP: fixed issue with PAM authentication on certain distributions

  • VRDP: fixed sporadic disconnects with MS RDP clients

  • iSCSI: improved behavior when pausing a VM with iSCSI connections

  • iSCSI: improved read timeout handling


12.29. Version 1.3.4 (2007-02-12)

  • General: fixed unresolved symbol issue on Windows 2000 hosts

  • General: added warnings at VirtualBox startup when there is no valid Linux kernel module

  • General: fixed problem with unrecognized host CDROM/DVD drives on Linux

  • General: fixed compatibility issue with SELinux

  • GUI: improved USB user interface, easier filter definitions, menu to directly attach specific devices

  • GUI: added VM settings options for VRDP

  • GUI: fixed GDI handle leak on Windows hosts

  • GUI: worked around issue in the Metacity window manager (GNOME) leading to unmovable VM windows

  • GUI: show an information dialog before entering fullscreen mode about how to get back

  • GUI: several fixes and improvements

  • VMM: fixed occasional crashes when shutting down a Windows guest

  • VMM: fixed crash while loading Xorg on openSUSE 10.2

  • VMM: fixed problems with OpenBSD 3.9 and 4.0

  • VMM: fixed crash while loading XFree86 in SUSE 9.1

  • VMM: fixed Debian 3.1 (Sarge) installation problem (network failure)

  • VMM: fixed crash during SUSE 10.2 installation

  • VMM: fixed crash during Ubuntu 7.04 RC boot

  • VMM: fixed crash during ThinClientOS (Linux 2.4.33) bootup

  • ATA/IDE: pause VM when host disk is full and display message

  • ATA/IDE: fixed incompatibility with OpenSolaris 10

  • VDI containers: do not allocate blocks when guest only writes zeros to it (size optimization when zeroing freespace prior to compacting)

  • CDROM/DVD: fixed media recognition by Linux guests

  • Network: corrected reporting of physical interfaces (fixes Linux guest warnings)

  • Network: fixed IRQ conflict causing occasional major slowdowns with XP guests

  • Network: significantly improved send performance

  • Audio: added mixer support to the AC'97 codec (master volume only)

  • Audio: added support for ALSA on Linux (native, no OSS emulation)

  • iSCSI: improved LUN handling

  • iSCSI: fixed hang due to packet overflow

  • iSCSI: pause VM on iSCSI connection loss

  • Linux module: never fail unloading the module (blocks Ubuntu/Debian uninstall)

  • Linux module: improved compatibility with NMI watchdog enabled

  • Windows Additions: fixed hardware mouse pointer with Windows 2003 Server guests

  • Linux Additions: compile everything from sources instead of using precompiled objects

  • Linux Additions: better compatibility with older glibc versions

  • Linux Additions: when uninstalling, only delete the files we put there during installation, don't remove the directory recursively to prevent unwanted data loss

  • Linux Installer: added support for Slackware

  • Linux Additions: added support for Linux 2.4.28 to 2.4.34

  • VRDP: fixed sporadic disconnects with MS RDP clients

  • VRDP: fixed race condition during resolution resize leading to rare crashes


12.30. Version 1.3.2 (2007-01-15)

  • General: added experimental support for Windows Vista as a host

  • General: added support for Windows Vista as a guest

  • GUI: numerous improvements including a redesigned media manager

  • BIOS: added DMI information for recent Linux kernels

  • VMM: experimental support for AMD SVM hardware virtualization extensions

  • VMM: significant performance improvements for Linux 2.6 guests

  • VMM: performance improvements for Windows guests

  • Network: fixed issues with DOS guests

  • Network: fixed creation of more than one host interface during process lifetime on Windows

  • VBoxManage: added support for compacting VDI files (requires zeroing freespace in the guest)

  • API: startup even when a VM configuration file is inaccessible or corrupted

  • API: faster startup using lazy media access checking

  • Linux Additions: fixed several installation issues and added better error checks

  • Linux Additions: added support for X.org 7.1

  • Installer: added packages for Ubuntu 6.10 (Edgy Eft), Ubuntu 6.06 LTS (Dapper Drake) and Debian 4.0 (Etch)


12.31. Version 1.2.4 (2006-11-16)

Several bug fixes that accidentally didn't make it into 1.2.2


12.32. Version 1.2.2 (2006-11-14)

Note: Guest Additions have to be updated for the enhanced VRDP features to work.

  • Linux Additions: improved compatibility with Red Hat distributions

  • Linux Additions: enhanced display performance, solved several issues

  • Linux Additions: added color pointer support

  • Linux Additions: added support for X.org 7.x

  • VMM: fixed sporadic mouse reset problem

  • VMM: fixed several issues with Linux guests

  • VMM: significant performance improvements for Linux 2.6 guests

  • VMM: significant general performance improvements

  • VMM: fixed sporadic reboot problems (logo hang)

  • VMM: added support for Intel VT-x (aka Vanderpool)

  • VMM: experimental support for IBM OS/2 Warp (requires VT-x to be enabled)

  • USB: added support for isochronous transfers (webcams, audio, etc.)

  • USB: fixed problem with devices not showing up after a guest reboot

  • USB: fixed several issues

  • BIOS: fixed use of fourth boot device

  • BIOS: added boot menu support

  • BIOS: added support for disks up to 2 Terabytes

  • VRDP: significantly enhanced performance and reduced bandwidth usage through new acceleration architecture

  • VBoxManage: added support for capturing network traffic

  • GUI: added fullscreen mode

  • GUI: fixed several problems


12.33. Version 1.1.12 (2006-11-14)

  • Additions: enabled more display modes for X.org 7.x

  • VMM: stability improvements

  • VMM: resolved excessive performance degradation caused by Symantec Antivirus

  • iSCSI: fixed memory corruption issue

  • VBoxSDL: made hostkey configurable

  • VRDP: report error in case binding to the port fails

  • VRDP: added mouse wheel support

  • NAT: significant performance improvements

  • Network: stability fixes

  • Network: significant performance improvements

  • ACPI: improved host power status reporting

  • PXE: added support for Microsoft RIS / ProxyDHCP

  • PXE: fixed several issues, added diagnostic messages


12.34. Version 1.1.10 (2006-07-28)

  • IDE: added workaround for Acronis TrueImage (violates IDE specification)

  • IDE: resolved issues with certain Linux guests

  • ACPI: further improved host power status reporting

  • API: fixed several race conditions and improved reliability

  • API: increased maximum guest RAM size to 2GB (Linux host) and 1.2GB (Windows host)

  • USB: added option to set the OHCI timer rate

  • VMM: fixed several issues

  • VRDP: fixed infinite resize loop

  • GUI: changed the default host key to Right Control


12.35. Version 1.1.8 (2006-07-17)

  • IDE: new ATA implementation with improved performance, reliability and better standards compliance

  • IDE: added experimental support for ATAPI passthrough (to use CD/DVD burners inside VMs)

  • VMM: fixed user mode IOPL handling (hwclock failure)

  • VMM: fixed crashes upon termination in Linux X servers

  • VMM: fixed problems with Knoppix 5.0 (and other Linux kernels 2.6.15+)

  • VMM: improved handling of self modifying code (aka Linux 2.6.15+ errors)

  • VMM: introduce release logging for better serviceability

  • VMM: significant performance improvements, especially for Linux 2.6 guests

  • VRDP: several issues have been fixed

  • VRDP: fixed enhanced rdesktop to build correctly under Linux 2.6.15+

  • Additions: added support for SUSE 10.1 and Fedora Core 5

  • NAT: improved performance and stability

  • NAT: handle host IP configuration changes at runtime

  • VBoxManage: made VRDP authentication configurable

  • VDI: added workaround against possible Windows host deadlocks caused by a synchronization flaw in Windows

  • ACPI: improved host power status reporting


12.36. Version 1.1.6 (2006-04-18)

  • ACPI: added workaround for XP SP2 crash in intelppm.sys (the real problem is a bug in this driver)

  • IDE: added support for image files of up to 8 terabytes

  • API: fixed several race conditions on SMP systems

  • Network: significant performance improvements

  • VRDP: fixed several issues with USB redirection

  • IDE: added workaround for Windows 2000 installation problems due to a bug in the Windows disk driver (see troubleshooting section)

  • VRDP: provide extensive connection information (also exposed through VBoxManage)

  • Linux module: added support for Linux 2.6.16

  • VBoxManage: improved support for immutable disk images

  • iSCSI: several fixes

  • USB: several fixes

  • VBoxSDL: added switch for fixed video mode and guest image centering

  • VMM: improved performance of Linux 2.6.x guests


12.37. Version 1.1.4 (2006-03-09)

Note: The configuration file format has been changed. After applying this update, execute "VBoxManage updatesettings" to convert your configuration to the new format. Note: Guest Additions have to be updated.

  • General: added support for multi-generation snapshots

  • VMM: fixed Linux guest reboot regression

  • VRDP: added client authentication through external authentication libraries (WinLogon and PAM interfaces are provided as sample code)

  • VRDP: close TCP connection immediately when receiving bad data from the remote side

  • VRDP: improved Microsoft RDP client support

  • XPCOM: fixed race condition on SMP systems that could lead to hung client processes (Linux host)

  • API: fixed race condition on SMP systems

  • Network: added AMD PC-Net II 100MBit network card (Am79C973)

  • Network: added PXE boot ROM for network boot

  • Audio: fixed regression with Windows 2000 guests

  • Audio: pause playback when VM is paused

  • iSCSI: added standards compliant iSCSI initiator for transparent access of iSCSI targets

  • VBoxSDL: ship on Windows as well

  • VBoxManage: added command to clone a VDI file to another one having a different UUID

  • Additions: added Linux Additions (timesync, mouse pointer integration and graphics driver)

  • Additions: added Shared Folders for Windows guests (except NT)

  • Linux module: fixed compilation problem on SUSE 10 system

  • Linux installer: added custom shell script installer


12.38. Version 1.1.2 (2006-02-03)

Note: Guest Additions have to be updated. The installation method has changed.

  • BIOS: fixed CMOS checksum calculation (to avoid guest warnings)

  • BIOS: improved APM support (to avoid guest warnings)

  • IDE: Linux 2.6.14+ and OpenBSD now operate the controller in UDMA mode by default

  • VMM: fixed hang when rebooting Windows 2000 guests with enabled audio adapter

  • VMM: fixed random user mode crashes with OpenBSD guests

  • VMM: increased timing accuracy (PIT, RTC), reduced PIT query overhead

  • VMM: tamed execution thread to make GUI more responsive (esp. when executing real mode guest code such as bootloaders)

  • VMM: significant performance enhancements for OpenBSD guests

  • VMM: several performance enhancements

  • VMM: improved memory layout on Windows hosts to allow for large amounts of guest RAM

  • VMM: significantly improved VM execution state saving and restoring (at the expense of state file sizes)

  • ACPI: fixed Windows bluescreen when assigning more than 512MB RAM to a guest

  • ACPI: correctly report battery state when multiple batteries are present on the host (Linux hosts)

  • ACPI: enabled by default for newly created VMs

  • APIC: added optional I/O APIC

  • Graphics: fixed distortion when changing guest color depth without changing the resolution

  • VRDP: added support for remote USB (requires special rdesktop client)

  • VRDP: added support for the Microsoft RDP client

  • VRDP: improved audio support

  • Floppy: controller can be disabled

  • Floppy: fixed "no disk in drive" reporting

  • Floppy: fixed writing to floppy images

  • VBoxManage: restructured USB device filter syntax to make it more intuitive

  • VBoxManage: added command for setting guest logon credentials

  • Additions: added installer for Windows 2000/XP/2003 guests

  • Additions: added custom GINA module which hooks MSGINA and can perform automatic logons using credentials retrieved from the VMM

  • Documentation: added draft of VirtualBox user manual


12.39. Version 1.0.50 (2005-12-16)

Note: Guest Additions have to be updated

  • VMM: added support for OpenBSD guests

  • VMM: fixed a memory leak

  • Network: added Internal Networking (to directly wire VMs without using host interfaces and making the traffic visible on the host)

  • Network: fixed crash/hang at exit with TAP on Linux

  • Graphics: added support for additional custom VESA modes

  • Graphics: added support for VESA modes with y offset

  • VRDP: added support for remote audio (PCM encoding)

  • USB: fixed several potential crashes

  • USB: fixed revision filter matching

  • USB: fixed support for devices with integrated USB hubs


12.40. Version 1.0.48 (2005-11-23)

Note: The configuration has to be deleted as the format has changed. On Linux, issue rm -rf ~/.VirtualBox. On Windows, remove the directory C:\Documents and Settings\<username>\.VirtualBox. If you fail to do so, VirtualBox will not startup. Note: Guest Additions have to be updated

  • VMM: fixed a Linux 2.6 guest panic on certain P4 CPUs

  • VMM: performance improvements

  • Graphics: fixed y offset handling in dynamic resolution mode (secure labeling support)

  • VDI: added support for immutable independent images (part of the upcoming snapshot feature)

  • Additions: added VBoxControl command line utility to get/set the guest video acceleration status

  • Additions: video acceleration is turned off by default, use VBoxControl to enable it. It usually helps for VRDP performance.

  • GUI: DirectDraw support for faster display handling on Win32.

  • GUI: allow creation and assignment of disk images in the New VM wizard.

  • USB: fixed high CPU load on certain Linux distributions

  • VBoxSDL: fixed several secure labeling issues (crash at exit, protection against guest video modes greater than what SDL provides on the host)

  • VBoxManage: convert command line parameters from the current codepage to Unicode


12.41. Version 1.0.46 (2005-11-04)

Note: Guest Additions have to be updated

  • Linux: VirtualBox binaries can now be started from directories other than the installation directory

  • VMM: added support for PAE guest mode

  • VMM: added support for hosts running in NX (No Execute) / DEP (Data Execution Prevention) mode

  • Graphics: fixes for dynamic resolution handling

  • Linux module: yet another kernel panic fix due to weird patches in RedHat Enterprise Linux 4 Update 2

  • VBoxSVC: if VBOX_USER_HOME is set, look for configuration in this directory (default: $HOME/.VirtualBox)


12.42. Version 1.0.44 (2005-10-25)

Note: Guest Additions have to be updated.

  • Installer: greatly improved Windows installer, fixed uninstall and perform driver and COM registration through MSI

  • VBoxManage: added commands to create and delete Win32 Host Interface Networking adapters

  • VDI: updated virtual disk image format (for newly created images; old images continue to work) with enhanced write performance and support for the upcoming snapshot feature

  • Network: performance improvements

  • Graphics: added hardware acceleration to virtual graphics adapter and corresponding Guest Additions driver

  • Graphics/Additions/GUI: added dynamic resizing support

  • Graphics: added workaround for buggy VESA support in Windows Vista/Longhorn

  • VRDP: performance and stability improvements; added support for graphics acceleration architecture

  • USB: restructured USB subsystem; added support for filters to autocapture devices that meet defined criteria

  • GUI: added mouse wheel support

  • VMM: added support for PAE host mode


12.43. Version 1.0.42 (2005-08-30)

Note: The configuration has to be deleted as the format has changed. On Linux, issue rm -rf ~/.VirtualBox. On Windows, remove the directory C:\Documents and Settings\<username>\.VirtualBox. If you fail to do so, VirtualBox will not startup. Note: Guest Additions have to be updated.

  • USB: added USB support for Windows hosts

  • Network: renamed TUN to "Host Interface Networking" and TAP on Linux

  • Network: added support for Host Interface Networking on Windows hosts

  • Network: added "cable connected" property to the virtual network cards

  • Floppy: added a virtual floppy drive to the VM and support for attaching floppy images and capturing host floppy drives

  • DVD/CD: added host CD/DVD drive support

  • BIOS: added boot order support

  • Saved states: made location configurable (default, global setting, machine specific setting, including VBoxManage command support)

  • VMM: added support for host CPUs without FXSR (e.g. Via Centaur)

  • VMM: increased performance of Linux 2.6 guests

  • VMM: improved timing

  • VMM: fixed traps in XP guests with ACPI enabled

  • VBoxManage: added remote session start function (tstHeadless has been removed from the distribution)

  • VBoxManage: restructured commands, added numerous improvements

  • GUI: propagate hostkey change to all running instances

  • GUI: perform image access tests asynchronously

  • GUI: added boot order support

  • GUI: user interface redesign


12.44. Version 1.0.40 (2005-06-17)

Note: The configuration has to be deleted as the format has changed. On Linux, issue rm -rf ~/.VirtualBox. On Windows, remove the directory C:\Documents and Settings\<username>\.VirtualBox. If you fail to do so, VirtualBox will not startup. Note: Guest Additions have to be updated.

  • SDK: ship VirtualBox development tools and sample program

  • BIOS: made startup logo animation configurable for OEM customers

  • BIOS: fixed network card detection under DOS

  • Graphics: fixed VESA modes in XP and XFree86/X.org

  • Network: fixed Linux guest issues

  • Network: fixed NAT DHCP server to work with MS-DOS TCP/IP

  • Network: fixed performance issue under heavy guest CPU load

  • Network: fixed errors with more than one network card

  • USB: added experimental USB support for Linux hosts

  • VMM: fixed DOS A20 gate handling in real mode

  • VMM: fixed TSS IO bitmap handling (crash in Debian/Knoppix hardware detection routine)

  • VMM: fixed IO issue which broke VESA in X11

  • VMM: performance improvements for Linux guests

  • VMM: added local APIC support

  • VBoxSDL: added pointer shape support and use host pointer in fullscreen mode if available

  • GUI: determine system parameters (e.g. maximum VDI size) using the API

  • GUI: added detailed error information dialogs

  • GUI: special handling of inaccessible media

  • API: better error message handling, provide system parameters, handle inaccessible media

  • Guest Additions: implemented full pointer shape support for all pointer color depths including alpha channel

  • VBoxManage: several command extensions


12.45. Version 1.0.39 (2005-05-05)

Note: Guest Additions have to be updated.

  • Linux: converted XPCOM runtime to a single shared object

  • Linux: fixed SIGALRM process crash on certain distributions

  • VMM: fixed Linux guests with grsecurity (address space scrambling)

  • ACPI: added experimental ACPI support

  • VRDP: added shadow buffer for reduced bandwidth usage

  • VRDP: added support for pointer shapes and remote pointer cache

  • GUI: added support for pointer shapes

  • Windows Additions: added support for high resolution video modes, including multi screen modes (2, 3 and 4 screens)

  • VBoxManage: added new command line tool to automate simple administration tasks without having to write application code


12.46. Version 1.0.38 (2005-04-27)

  • GUI: fixed creation of disk images larger than 4GB

  • GUI: added network and audio configuration panels

  • GUI: several keyboard issues fixed

  • VBoxSDL: fixed -tunfd handling and added -tundev (Linux host)

  • IDE: significant performance improvements in DMA modes

  • Video: VRAM size is now configurable (1MB - 128MB; default 4MB)

  • VMM: fixed several crashes and hangs while installing certain builds of Windows 2000 and XP

  • VMM: allow guests to have more than 512MB of RAM

  • VMM: resolved compatibility issues with SMP systems (Windows Host)

  • VRDP: process cleanup on Linux fixed

  • Linux module: fixed build error on Red Hat 2.4.21-15-EL

  • NT Additions: fixed installation and a trap

  • Win2k/XP Additions: fixed installation


12.47. Version 1.0.37 (2005-04-12)

Initial build with change log.


Chapter 13. Known limitations

The following section describes some issues that are known not to work in VirtualBox 3.0.10. Unless marked otherwise these issues are planned to be fixed in later releases.

  • The following Guest SMP (multiprocessor) limitations exist:

    • Poor performance with 32-bit guests on AMD CPUs. This affects mainly Windows and Solaris guests, but possibly also some Linux kernel revisions. Partially solved in 3.0.6 for 32 bits Windows NT, 2000, XP and 2003 guests. Requires 3.0.6 or higher guest additions to be installed.

    • Poor performance with 32-bit guests on certain Intel CPU models, that don't include virtual APIC hardware optimization support. This affects mainly Windows and Solaris guests, but possibly also some Linux kernel revisions.

    • 64-bit guests on 32-bit hosts do not support SMP yet (except on Mac OS X).

  • 64-bit guests on some 32-bit host systems with VT-x can cause instabilities to your system. If you experience this, do not attempt to execute 64-bit guests. Refer to the VirtualBox user forum for additional information.

  • Direct 3D support in Windows guests. For this to work, the Guest Additions must be installed in Windows "safe mode". Press F8 when the Windows guest is booting and select "Safe mode", then install the Guest Additions. Otherwise Windows' file protection mechanism will interfere with the replacement DLLs installed by VirtualBox and keep restoring the original Windows system DLLs.

  • Shrinking virtual disk images is limited to VDI files. The VBoxManage modifyhd --compact command is currently only implemented for VDI files. At the moment the only way to optimize the size of a virtual disk images in other formats (VMDK, VHD) is to clone the image and then use the cloned image in the VM configuration.

  • OVF import/export:

    • Some virtual machine properties supported by VirtualBox's own XML file format are not exported. As a result, when exporting and then re-importing a virtual machine with VirtualBox, the settings need not be identical. This is especially true for the I/O APIC setting, 3D acceleration, hardware virtualization, nested paging and other VM properties.

    • OVF localization (multiple languages in one OVF file) is not yet supported.

    • Some OVF sections like StartupSection, DeploymentOptionSection and InstallSection are ignored.

    • OVF environment documents, including their property sections and appliance configuration with ISO images, are not yet supported.

    • OVA archives (TAR containers) are not yet supported.

    • Remote files via HTTP or other mechanisms are not yet supported.

  • Vista 64-bit hosts have stability issues when using USB.

  • Seamless mode does not work correctly on host systems with multiple monitors.

  • Mac OS X host. The following restrictions apply (all of which will be resolved in future versions):

    • No support for audio input.

    • The numlock emulation has not yet been implemented.

    • The CPU frequency metric is not supported.

    • 3D OpenGL acceleration. In general the OpenGL support for Linux guest is experimental. This counts especially in combination with compiz enabled window managers. Additional we are aware of the following issues:

      • OpenGL windows aren't updated in the Dock Icon real time preview.

      • There are several redraw problems with compiz enabled window managers on Linux guests. E.g. after save/restore state or a resize of the guest window.

      • OpenGL host support is not yet available on 64-bit kernels (Mac OS X 10.6).

  • Linux hosts. There are a few problems when compiz is used as the host's window manager, notably:

    • seamless mode does not work well (garbled screen display if no windows are open in the guest);

    • OpenGL guest acceleration (added with 2.1) is very slow.

    If you experience these problems, you way want to try using a different window manager, such as metacity.

  • Solaris hosts. For OpenSolaris and Solaris 10 U5/U6, the following restrictions apply:

    • There is no support for USB on Solaris 10 hosts. On other supported Solaris systems (OpenSolaris and Nevada), support is experimental. USB device filters do not work at all.

    • No support for audio input.

    • Only experimental USB support for OpenSolaris/Nevada hosts (versions 109 and higher recommended).

    • No ACPI information (battery status, power source) is reported to the guest.

    • No support for using wireless with bridged networking.

    • On Solaris 10 U4, zones are not supported.

  • Guest Additions for OS/2. Shared folders are not yet supported with OS/2 guests. In addition, seamless windows and automatic guest resizing will probably never be implemented due to inherent limitations of the OS/2 graphics system.


Appendix A. Third-party licenses

Table of Contents

A.1. Materials
A.2. Licenses
A.2.1. GNU General Public License (GPL)
A.2.2. GNU Lesser General Public License (LGPL)
A.2.3. Mozilla Public License (MPL)
A.2.4. MIT License
A.2.5. X Consortium License (X11)
A.2.6. zlib license
A.2.7. OpenSSL license
A.2.8. Slirp license
A.2.9. liblzf license
A.2.10. libpng license
A.2.11. lwIP license
A.2.12. libxml license
A.2.13. libxslt licenses
A.2.14. gSOAP Public License Version 1.3a
A.2.15. Chromium licenses
A.2.16. curl license

VirtualBox incorporates materials from several Open Source software projects. Therefore the use of these materials by VirtualBox is governed by different Open Source licenses. This document reproduces these licenses and provides a list of the materials used and their respective licensing conditions. Section 1 contains a list of the materials used. Section 2 reproduces the applicable Open Source licenses. For each material, a reference to its license is provided.

A.1. Materials

  • VirtualBox contains portions of QEMU which is governed by the licenses in A.2.5 and A.2.2 and

    (C) 2003-2005 Fabrice Bellard; Copyright (C) 2004-2005 Vassili Karpov (malc); Copyright (c) 2004 Antony T Curtis; Copyright (C) 2003 Jocelyn Mayer

  • VirtualBox contains code which is governed by the license in A.2.5 and

    Copyright 2004 by the Massachusetts Institute of Technology.

  • VirtualBox contains code of the BOCHS VGA BIOS which is governed by the license in A.2.2 and

    Copyright (C) 2001, 2002 the LGPL VGABios developers Team.

  • VirtualBox contains code of the BOCHS ROM BIOS which is governed by the license in A.2.2 and

    Copyright (C) 2002 MandrakeSoft S.A.; Copyright (C) 2004 Fabrice Bellard; Copyright (C) 2005 Struan Bartlett.

  • VirtualBox contains the zlib library which is governed by the license in A.2.6 and

    Copyright (C) 1995-2003 Jean-loup Gailly and Mark Adler.

  • VirtualBox may contain OpenSSL which is governed by the license in A.2.7 and

    Copyright (C) 1995-1998 Eric Young (eay@cryptsoft.com). This product includes software written by Tim Hudson (tjh@cryptsoft.com).

  • VirtualBox may contain NSPR and XPCOM which is governed by the license in A.2.3 and

    Copyright (C) The Authors.

  • VirtualBox contains Slirp which is governed by the license in A.2.8 and was written by Danny Gasparovski.

    Copyright (C) 1995, 1996 All Rights Reserved.

  • VirtualBox contains liblzf which is governed by the license in A.2.9 and

    Copyright (C) 2000-2005 Marc Alexander Lehmann <schmorp@schmorp.de>

  • VirtualBox may ship with a modified copy of rdesktop which is governed by the license in A.2.1 and

    Copyright (C) Matthew Chapman and others.

  • VirtualBox may ship with a copy of kchmviewer which is governed by the license in A.2.1 and

    Copyright (C) George Yunaev and others.

  • VirtualBox may contain Etherboot which is governed by the license in A.2.1 with the exception that aggregating Etherboot with another work does not require the other work to be released under the same license (see http://etherboot.sourceforge.net/clinks.html). Etherboot is

    Copyright (C) Etherboot team.

  • VirtualBox may contain code from Wine which is governed by the license in A.2.2 and

    Copyright 1993 Bob Amstadt, Copyright 1996 Albrecht Kleine, Copyright 1997 David Faure, Copyright 1998 Morten Welinder, Copyright 1998 Ulrich Weigand, Copyright 1999 Ove Koven

  • VirtualBox contains code from lwIP which is governed by the license in A.2.11 and

    Copyright (C) 2001, 2002 Swedish Institute of Computer Science.

  • VirtualBox contains libxml which is governed by the license in Section A.2.12, “libxml license” and

    Copyright (C) 1998-2003 Daniel Veillard.

  • VirtualBox contains libxslt which is governed by the license in Section A.2.13, “libxslt licenses” and

    Copyright (C) 2001-2002 Daniel Veillard and Copyright (C) 2001-2002 Thomas Broyer, Charlie Bozeman and Daniel Veillard.

  • VirtualBox may contain code from the gSOAP XML web services tools, which are licensed under the license in Section A.2.14, “gSOAP Public License Version 1.3a” and

    Copyright (C) 2000-2007, Robert van Engelen, Genivia Inc., and others.

  • VirtualBox may ship with the application tunctl (shipped as VBoxTunctl) from the User-mode Linux suite which is governed by the license in A.2.1 and

    Copyright (C) 2002 Jeff Dike.

  • VirtualBox contains code from Chromium, an OpenGL implementation, which is goverened by the licenses in Section A.2.15, “Chromium licenses” and

    Copyright (C) Stanford University, The Regents of the University of California, Red Hat, and others.

  • VirtualBox contains libcurl which is governed by the license in Section A.2.16, “curl license” and

    Copyright (C) 1996-2009, Daniel Stenberg.

  • VirtualBox contains dnsproxy which is governed by the license in Section A.2.4, “MIT License” and

    Copyright (c) 2003, 2004, 2005 Armin Wolfermann.

  • VirtualBox may contain iniparser which is governed by the license in Section A.2.4, “MIT License” and

    Copyright (c) 2000-2008 by Nicolas Devillard.


A.2. Licenses

A.2.1. GNU General Public License (GPL)

GNU GENERAL PUBLIC LICENSE Version 2, June 1991

Copyright (C) 1989, 1991 Free Software Foundation, Inc.

51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

Preamble

The licenses for most software are designed to take away your freedom to share and change it. By contrast, the GNU General Public License is intended to guarantee your freedom to share and change free software--to make sure the software is free for all its users. This General Public License applies to most of the Free Software Foundation's software and to any other program whose authors commit to using it. (Some other Free Software Foundation software is covered by the GNU Library General Public License instead.) You can apply it to your programs, too.

When we speak of free software, we are referring to freedom, not price. Our General Public Licenses are designed to make sure that you have the freedom to distribute copies of free software (and charge for this service if you wish), that you receive source code or can get it if you want it, that you can change the software or use pieces of it in new free programs; and that you know you can do these things.

To protect your rights, we need to make restrictions that forbid anyone to deny you these rights or to ask you to surrender the rights. These restrictions translate to certain responsibilities for you if you distribute copies of the software, or if you modify it.

For example, if you distribute copies of such a program, whether gratis or for a fee, you must give the recipients all the rights that you have. You must make sure that they, too, receive or can get the source code. And you must show them these terms so they know their rights.

We protect your rights with two steps: (1) copyright the software, and (2) offer you this license which gives you legal permission to copy, distribute and/or modify the software.

Also, for each author's protection and ours, we want to make certain that everyone understands that there is no warranty for this free software. If the software is modified by someone else and passed on, we want its recipients to know that what they have is not the original, so that any problems introduced by others will not reflect on the original authors' reputations.

Finally, any free program is threatened constantly by software patents. We wish to avoid the danger that redistributors of a free program will individually obtain patent licenses, in effect making the program proprietary. To prevent this, we have made it clear that any patent must be licensed for everyone's free use or not licensed at all.

The precise terms and conditions for copying, distribution and modification follow.

GNU GENERAL PUBLIC LICENSE TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

0. This License applies to any program or other work which contains a notice placed by the copyright holder saying it may be distributed under the terms of this General Public License. The "Program", below, refers to any such program or work, and a "work based on the Program" means either the Program or any derivative work under copyright law: that is to say, a work containing the Program or a portion of it, either verbatim or with modifications and/or translated into another language. (Hereinafter, translation is included without limitation in the term "modification".) Each licensee is addressed as "you".

Activities other than copying, distribution and modification are not covered by this License; they are outside its scope. The act of running the Program is not restricted, and the output from the Program is covered only if its contents constitute a work based on the Program (independent of having been made by running the Program). Whether that is true depends on what the Program does.

1. You may copy and distribute verbatim copies of the Program's source code as you receive it, in any medium, provided that you conspicuously and appropriately publish on each copy an appropriate copyright notice and disclaimer of warranty; keep intact all the notices that refer to this License and to the absence of any warranty; and give any other recipients of the Program a copy of this License along with the Program.

You may charge a fee for the physical act of transferring a copy, and you may at your option offer warranty protection in exchange for a fee.

2. You may modify your copy or copies of the Program or any portion of it, thus forming a work based on the Program, and copy and distribute such modifications or work under the terms of Section 1 above, provided that you also meet all of these conditions:

a) You must cause the modified files to carry prominent notices stating that you changed the files and the date of any change.

b) You must cause any work that you distribute or publish, that in whole or in part contains or is derived from the Program or any part thereof, to be licensed as a whole at no charge to all third parties under the terms of this License.

c) If the modified program normally reads commands interactively when run, you must cause it, when started running for such interactive use in the most ordinary way, to print or display an announcement including an appropriate copyright notice and a notice that there is no warranty (or else, saying that you provide a warranty) and that users may redistribute the program under these conditions, and telling the user how to view a copy of this License. (Exception: if the Program itself is interactive but does not normally print such an announcement, your work based on the Program is not required to print an announcement.)

These requirements apply to the modified work as a whole. If identifiable sections of that work are not derived from the Program, and can be reasonably considered independent and separate works in themselves, then this License, and its terms, do not apply to those sections when you distribute them as separate works. But when you distribute the same sections as part of a whole which is a work based on the Program, the distribution of the whole must be on the terms of this License, whose permissions for other licensees extend to the entire whole, and thus to each and every part regardless of who wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely by you; rather, the intent is to exercise the right to control the distribution of derivative or collective works based on the Program.

In addition, mere aggregation of another work not based on the Program with the Program (or with a work based on the Program) on a volume of a storage or distribution medium does not bring the other work under the scope of this License.

3. You may copy and distribute the Program (or a work based on it, under Section 2) in object code or executable form under the terms of Sections 1 and 2 above provided that you also do one of the following:

a) Accompany it with the complete corresponding machine-readable source code, which must be distributed under the terms of Sections 1 and 2 above on a medium customarily used for software interchange; or,

b) Accompany it with a written offer, valid for at least three years, to give any third party, for a charge no more than your cost of physically performing source distribution, a complete machine-readable copy of the corresponding source code, to be distributed under the terms of Sections 1 and 2 above on a medium customarily used for software interchange; or,

c) Accompany it with the information you received as to the offer to distribute corresponding source code. (This alternative is allowed only for noncommercial distribution and only if you received the program in object code or executable form with such an offer, in accord with Subsection b above.)

The source code for a work means the preferred form of the work for making modifications to it. For an executable work, complete source code means all the source code for all modules it contains, plus any associated interface definition files, plus the scripts used to control compilation and installation of the executable. However, as a special exception, the source code distributed need not include anything that is normally distributed (in either source or binary form) with the major components (compiler, kernel, and so on) of the operating system on which the executable runs, unless that component itself accompanies the executable.

If distribution of executable or object code is made by offering access to copy from a designated place, then offering equivalent access to copy the source code from the same place counts as distribution of the source code, even though third parties are not compelled to copy the source along with the object code.

4. You may not copy, modify, sublicense, or distribute the Program except as expressly provided under this License. Any attempt otherwise to copy, modify, sublicense or distribute the Program is void, and will automatically terminate your rights under this License. However, parties who have received copies, or rights, from you under this License will not have their licenses terminated so long as such parties remain in full compliance.

5. You are not required to accept this License, since you have not signed it. However, nothing else grants you permission to modify or distribute the Program or its derivative works. These actions are prohibited by law if you do not accept this License. Therefore, by modifying or distributing the Program (or any work based on the Program), you indicate your acceptance of this License to do so, and all its terms and conditions for copying, distributing or modifying the Program or works based on it.

6. Each time you redistribute the Program (or any work based on the Program), the recipient automatically receives a license from the original licensor to copy, distribute or modify the Program subject to these terms and conditions. You may not impose any further restrictions on the recipients' exercise of the rights granted herein. You are not responsible for enforcing compliance by third parties to this License.

7. If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not limited to patent issues), conditions are imposed on you (whether by court order, agreement or otherwise) that contradict the conditions of this License, they do not excuse you from the conditions of this License. If you cannot distribute so as to satisfy simultaneously your obligations under this License and any other pertinent obligations, then as a consequence you may not distribute the Program at all. For example, if a patent license would not permit royalty-free redistribution of the Program by all those who receive copies directly or indirectly through you, then the only way you could satisfy both it and this License would be to refrain entirely from distribution of the Program.

If any portion of this section is held invalid or unenforceable under any particular circumstance, the balance of the section is intended to apply and the section as a whole is intended to apply in other circumstances.

It is not the purpose of this section to induce you to infringe any patents or other property right claims or to contest validity of any such claims; this section has the sole purpose of protecting the integrity of the free software distribution system, which is implemented by public license practices. Many people have made generous contributions to the wide range of software distributed through that system in reliance on consistent application of that system; it is up to the author/donor to decide if he or she is willing to distribute software through any other system and a licensee cannot impose that choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the rest of this License.

8. If the distribution and/or use of the Program is restricted in certain countries either by patents or by copyrighted interfaces, the original copyright holder who places the Program under this License may add an explicit geographical distribution limitation excluding those countries, so that distribution is permitted only in or among countries not thus excluded. In such case, this License incorporates the limitation as if written in the body of this License.

9. The Free Software Foundation may publish revised and/or new versions of the General Public License from time to time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new problems or concerns.

Each version is given a distinguishing version number. If the Program specifies a version number of this License which applies to it and "any later version", you have the option of following the terms and conditions either of that version or of any later version published by the Free Software Foundation. If the Program does not specify a version number of this License, you may choose any version ever published by the Free Software Foundation.

10. If you wish to incorporate parts of the Program into other free programs whose distribution conditions are different, write to the author to ask for permission. For software which is copyrighted by the Free Software Foundation, write to the Free Software Foundation; we sometimes make exceptions for this. Our decision will be guided by the two goals of preserving the free status of all derivatives of our free software and of promoting the sharing and reuse of software generally.

NO WARRANTY

11. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE PROGRAM, TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE PROGRAM "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE PROGRAM PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

12. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER PROGRAMS), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONS

A.2.2. GNU Lesser General Public License (LGPL)

GNU LESSER GENERAL PUBLIC LICENSE Version 2.1, February 1999

Copyright (C) 1991, 1999 Free Software Foundation, Inc. 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

[This is the first released version of the Lesser GPL. It also counts as the successor of the GNU Library Public License, version 2, hence the version number 2.1.]

Preamble

The licenses for most software are designed to take away your freedom to share and change it. By contrast, the GNU General Public Licenses are intended to guarantee your freedom to share and change free software--to make sure the software is free for all its users.

This license, the Lesser General Public License, applies to some specially designated software packages--typically libraries--of the Free Software Foundation and other authors who decide to use it. You can use it too, but we suggest you first think carefully about whether this license or the ordinary General Public License is the better strategy to use in any particular case, based on the explanations below.

When we speak of free software, we are referring to freedom of use, not price. Our General Public Licenses are designed to make sure that you have the freedom to distribute copies of free software (and charge for this service if you wish); that you receive source code or can get it if you want it; that you can change the software and use pieces of it in new free programs; and that you are informed that you can do these things.

To protect your rights, we need to make restrictions that forbid distributors to deny you these rights or to ask you to surrender these rights. These restrictions translate to certain responsibilities for you if you distribute copies of the library or if you modify it.

For example, if you distribute copies of the library, whether gratis or for a fee, you must give the recipients all the rights that we gave you. You must make sure that they, too, receive or can get the source code. If you link other code with the library, you must provide complete object files to the recipients, so that they can relink them with the library after making changes to the library and recompiling it. And you must show them these terms so they know their rights.

We protect your rights with a two-step method: (1) we copyright the library, and (2) we offer you this license, which gives you legal permission to copy, distribute and/or modify the library.

To protect each distributor, we want to make it very clear that there is no warranty for the free library. Also, if the library is modified by someone else and passed on, the recipients should know that what they have is not the original version, so that the original author's reputation will not be affected by problems that might be introduced by others.

Finally, software patents pose a constant threat to the existence of any free program. We wish to make sure that a company cannot effectively restrict the users of a free program by obtaining a restrictive license from a patent holder. Therefore, we insist that any patent license obtained for a version of the library must be consistent with the full freedom of use specified in this license.

Most GNU software, including some libraries, is covered by the ordinary GNU General Public License. This license, the GNU Lesser General Public License, applies to certain designated libraries, and is quite different from the ordinary General Public License. We use this license for certain libraries in order to permit linking those libraries into non-free programs.

When a program is linked with a library, whether statically or using a shared library, the combination of the two is legally speaking a combined work, a derivative of the original library. The ordinary General Public License therefore permits such linking only if the entire combination fits its criteria of freedom. The Lesser General Public License permits more lax criteria for linking other code with the library.

We call this license the "Lesser" General Public License because it does Less to protect the user's freedom than the ordinary General Public License. It also provides other free software developers Less of an advantage over competing non-free programs. These disadvantages are the reason we use the ordinary General Public License for many libraries. However, the Lesser license provides advantages in certain special circumstances.

For example, on rare occasions, there may be a special need to encourage the widest possible use of a certain library, so that it becomes a de-facto standard. To achieve this, non-free programs must be allowed to use the library. A more frequent case is that a free library does the same job as widely used non-free libraries. In this case, there is little to gain by limiting the free library to free software only, so we use the Lesser General Public License.

In other cases, permission to use a particular library in non-free programs enables a greater number of people to use a large body of free software. For example, permission to use the GNU C Library in non-free programs enables many more people to use the whole GNU operating system, as well as its variant, the GNU/Linux operating system.

Although the Lesser General Public License is Less protective of the users' freedom, it does ensure that the user of a program that is linked with the Library has the freedom and the wherewithal to run that program using a modified version of the Library.

The precise terms and conditions for copying, distribution and modification follow. Pay close attention to the difference between a "work based on the library" and a "work that uses the library". The former contains code derived from the library, whereas the latter must be combined with the library in order to run.

GNU LESSER GENERAL PUBLIC LICENSE TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

0. This License Agreement applies to any software library or other program which contains a notice placed by the copyright holder or other authorized party saying it may be distributed under the terms of this Lesser General Public License (also called "this License"). Each licensee is addressed as "you".

A "library" means a collection of software functions and/or data prepared so as to be conveniently linked with application programs (which use some of those functions and data) to form executables.

The "Library", below, refers to any such software library or work which has been distributed under these terms. A "work based on the Library" means either the Library or any derivative work under copyright law: that is to say, a work containing the Library or a portion of it, either verbatim or with modifications and/or translated straightforwardly into another language. (Hereinafter, translation is included without limitation in the term "modification".)

"Source code" for a work means the preferred form of the work for making modifications to it. For a library, complete source code means all the source code for all modules it contains, plus any associated interface definition files, plus the scripts used to control compilation and installation of the library.

Activities other than copying, distribution and modification are not covered by this License; they are outside its scope. The act of running a program using the Library is not restricted, and output from such a program is covered only if its contents constitute a work based on the Library (independent of the use of the Library in a tool for writing it). Whether that is true depends on what the Library does and what the program that uses the Library does.

1. You may copy and distribute verbatim copies of the Library's complete source code as you receive it, in any medium, provided that you conspicuously and appropriately publish on each copy an appropriate copyright notice and disclaimer of warranty; keep intact all the notices that refer to this License and to the absence of any warranty; and distribute a copy of this License along with the Library.

You may charge a fee for the physical act of transferring a copy, and you may at your option offer warranty protection in exchange for a fee.

2. You may modify your copy or copies of the Library or any portion of it, thus forming a work based on the Library, and copy and distribute such modifications or work under the terms of Section 1 above, provided that you also meet all of these conditions:

a) The modified work must itself be a software library.

b) You must cause the files modified to carry prominent notices stating that you changed the files and the date of any change.

c) You must cause the whole of the work to be licensed at no charge to all third parties under the terms of this License.

d) If a facility in the modified Library refers to a function or a table of data to be supplied by an application program that uses the facility, other than as an argument passed when the facility is invoked, then you must make a good faith effort to ensure that, in the event an application does not supply such function or table, the facility still operates, and performs whatever part of its purpose remains meaningful.

(For example, a function in a library to compute square roots has a purpose that is entirely well-defined independent of the application. Therefore, Subsection 2d requires that any application-supplied function or table used by this function must be optional: if the application does not supply it, the square root function must still compute square roots.)

These requirements apply to the modified work as a whole. If identifiable sections of that work are not derived from the Library, and can be reasonably considered independent and separate works in themselves, then this License, and its terms, do not apply to those sections when you distribute them as separate works. But when you distribute the same sections as part of a whole which is a work based on the Library, the distribution of the whole must be on the terms of this License, whose permissions for other licensees extend to the entire whole, and thus to each and every part regardless of who wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely by you; rather, the intent is to exercise the right to control the distribution of derivative or collective works based on the Library.

In addition, mere aggregation of another work not based on the Library with the Library (or with a work based on the Library) on a volume of a storage or distribution medium does not bring the other work under the scope of this License.

3. You may opt to apply the terms of the ordinary GNU General Public License instead of this License to a given copy of the Library. To do this, you must alter all the notices that refer to this License, so that they refer to the ordinary GNU General Public License, version 2, instead of to this License. (If a newer version than version 2 of the ordinary GNU General Public License has appeared, then you can specify that version instead if you wish.) Do not make any other change in these notices.

Once this change is made in a given copy, it is irreversible for that copy, so the ordinary GNU General Public License applies to all subsequent copies and derivative works made from that copy.

This option is useful when you wish to copy part of the code of the Library into a program that is not a library.

4. You may copy and distribute the Library (or a portion or derivative of it, under Section 2) in object code or executable form under the terms of Sections 1 and 2 above provided that you accompany it with the complete corresponding machine-readable source code, which must be distributed under the terms of Sections 1 and 2 above on a medium customarily used for software interchange.

If distribution of object code is made by offering access to copy from a designated place, then offering equivalent access to copy the source code from the same place satisfies the requirement to distribute the source code, even though third parties are not compelled to copy the source along with the object code.

5. A program that contains no derivative of any portion of the Library, but is designed to work with the Library by being compiled or linked with it, is called a "work that uses the Library". Such a work, in isolation, is not a derivative work of the Library, and therefore falls outside the scope of this License.

However, linking a "work that uses the Library" with the Library creates an executable that is a derivative of the Library (because it contains portions of the Library), rather than a "work that uses the library". The executable is therefore covered by this License. Section 6 states terms for distribution of such executables.

When a "work that uses the Library" uses material from a header file that is part of the Library, the object code for the work may be a derivative work of the Library even though the source code is not. Whether this is true is especially significant if the work can be linked without the Library, or if the work is itself a library. The threshold for this to be true is not precisely defined by law.

If such an object file uses only numerical parameters, data structure layouts and accessors, and small macros and small inline functions (ten lines or less in length), then the use of the object file is unrestricted, regardless of whether it is legally a derivative work. (Executables containing this object code plus portions of the Library will still fall under Section 6.) Otherwise, if the work is a derivative of the Library, you may distribute the object code for the work under the terms of Section 6. Any executables containing that work also fall under Section 6, whether or not they are linked directly with the Library itself.

6. As an exception to the Sections above, you may also combine or link a "work that uses the Library" with the Library to produce a work containing portions of the Library, and distribute that work under terms of your choice, provided that the terms permit modification of the work for the customer's own use and reverse engineering for debugging such modifications.

You must give prominent notice with each copy of the work that the Library is used in it and that the Library and its use are covered by this License. You must supply a copy of this License. If the work during execution displays copyright notices, you must include the copyright notice for the Library among them, as well as a reference directing the user to the copy of this License. Also, you must do one of these things:

a) Accompany the work with the complete corresponding machine-readable source code for the Library including whatever changes were used in the work (which must be distributed under Sections 1 and 2 above); and, if the work is an executable linked with the Library, with the complete machine-readable "work that uses the Library", as object code and/or source code, so that the user can modify the Library and then relink to produce a modified executable containing the modified Library. (It is understood that the user who changes the contents of definitions files in the Library will not necessarily be able to recompile the application to use the modified definitions.)

b) Use a suitable shared library mechanism for linking with the Library. A suitable mechanism is one that (1) uses at run time a copy of the library already present on the user's computer system, rather than copying library functions into the executable, and (2) will operate properly with a modified version of the library, if the user installs one, as long as the modified version is interface-compatible with the version that the work was made with.

c) Accompany the work with a written offer, valid for at least three years, to give the same user the materials specified in Subsection 6a, above, for a charge no more than the cost of performing this distribution.

d) If distribution of the work is made by offering access to copy from a designated place, offer equivalent access to copy the above specified materials from the same place.

e) Verify that the user has already received a copy of these materials or that you have already sent this user a copy.

For an executable, the required form of the "work that uses the Library" must include any data and utility programs needed for reproducing the executable from it. However, as a special exception, the materials to be distributed need not include anything that is normally distributed (in either source or binary form) with the major components (compiler, kernel, and so on) of the operating system on which the executable runs, unless that component itself accompanies the executable.

It may happen that this requirement contradicts the license restrictions of other proprietary libraries that do not normally accompany the operating system. Such a contradiction means you cannot use both them and the Library together in an executable that you distribute.

7. You may place library facilities that are a work based on the Library side-by-side in a single library together with other library facilities not covered by this License, and distribute such a combined library, provided that the separate distribution of the work based on the Library and of the other library facilities is otherwise permitted, and provided that you do these two things:

a) Accompany the combined library with a copy of the same work based on the Library, uncombined with any other library facilities. This must be distributed under the terms of the Sections above.

b) Give prominent notice with the combined library of the fact that part of it is a work based on the Library, and explaining where to find the accompanying uncombined form of the same work.

8. You may not copy, modify, sublicense, link with, or distribute the Library except as expressly provided under this License. Any attempt otherwise to copy, modify, sublicense, link with, or distribute the Library is void, and will automatically terminate your rights under this License. However, parties who have received copies, or rights, from you under this License will not have their licenses terminated so long as such parties remain in full compliance.

9. You are not required to accept this License, since you have not signed it. However, nothing else grants you permission to modify or distribute the Library or its derivative works. These actions are prohibited by law if you do not accept this License. Therefore, by modifying or distributing the Library (or any work based on the Library), you indicate your acceptance of this License to do so, and all its terms and conditions for copying, distributing or modifying the Library or works based on it.

10. Each time you redistribute the Library (or any work based on the Library), the recipient automatically receives a license from the original licensor to copy, distribute, link with or modify the Library subject to these terms and conditions. You may not impose any further restrictions on the recipients' exercise of the rights granted herein. You are not responsible for enforcing compliance by third parties with this License.

11. If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not limited to patent issues), conditions are imposed on you (whether by court order, agreement or otherwise) that contradict the conditions of this License, they do not excuse you from the conditions of this License. If you cannot distribute so as to satisfy simultaneously your obligations under this License and any other pertinent obligations, then as a consequence you may not distribute the Library at all. For example, if a patent license would not permit royalty-free redistribution of the Library by all those who receive copies directly or indirectly through you, then the only way you could satisfy both it and this License would be to refrain entirely from distribution of the Library.

If any portion of this section is held invalid or unenforceable under any particular circumstance, the balance of the section is intended to apply, and the section as a whole is intended to apply in other circumstances.

It is not the purpose of this section to induce you to infringe any patents or other property right claims or to contest validity of any such claims; this section has the sole purpose of protecting the integrity of the free software distribution system which is implemented by public license practices. Many people have made generous contributions to the wide range of software distributed through that system in reliance on consistent application of that system; it is up to the author/donor to decide if he or she is willing to distribute software through any other system and a licensee cannot impose that choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the rest of this License.

12. If the distribution and/or use of the Library is restricted in certain countries either by patents or by copyrighted interfaces, the original copyright holder who places the Library under this License may add an explicit geographical distribution limitation excluding those countries, so that distribution is permitted only in or among countries not thus excluded. In such case, this License incorporates the limitation as if written in the body of this License.

13. The Free Software Foundation may publish revised and/or new versions of the Lesser General Public License from time to time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new problems or concerns.

Each version is given a distinguishing version number. If the Library specifies a version number of this License which applies to it and "any later version", you have the option of following the terms and conditions either of that version or of any later version published by the Free Software Foundation. If the Library does not specify a license version number, you may choose any version ever published by the Free Software Foundation.

14. If you wish to incorporate parts of the Library into other free programs whose distribution conditions are incompatible with these, write to the author to ask for permission. For software which is copyrighted by the Free Software Foundation, write to the Free Software Foundation; we sometimes make exceptions for this. Our decision will be guided by the two goals of preserving the free status of all derivatives of our free software and of promoting the sharing and reuse of software generally.

NO WARRANTY

15. BECAUSE THE LIBRARY IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE LIBRARY, TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE LIBRARY "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE LIBRARY IS WITH YOU. SHOULD THE LIBRARY PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

16. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE THE LIBRARY AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE LIBRARY (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A FAILURE OF THE LIBRARY TO OPERATE WITH ANY OTHER SOFTWARE), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONS

A.2.3. Mozilla Public License (MPL)

MOZILLA PUBLIC LICENSE Version 1.1

1. Definitions.

1.0.1. "Commercial Use" means distribution or otherwise making the Covered Code available to a third party.

1.1. "Contributor" means each entity that creates or contributes to the creation of Modifications.

1.2. "Contributor Version" means the combination of the Original Code, prior Modifications used by a Contributor, and the Modifications made by that particular Contributor.

1.3. "Covered Code" means the Original Code or Modifications or the combination of the Original Code and Modifications, in each case including portions thereof.

1.4. "Electronic Distribution Mechanism" means a mechanism generally accepted in the software development community for the electronic transfer of data.

1.5. "Executable" means Covered Code in any form other than Source Code.

1.6. "Initial Developer" means the individual or entity identified as the Initial Developer in the Source Code notice required by Exhibit A.

1.7. "Larger Work" means a work which combines Covered Code or portions thereof with code not governed by the terms of this License.

1.8. "License" means this document.

1.8.1. "Licensable" means having the right to grant, to the maximum extent possible, whether at the time of the initial grant or subsequently acquired, any and all of the rights conveyed herein.

1.9. "Modifications" means any addition to or deletion from the substance or structure of either the Original Code or any previous Modifications. When Covered Code is released as a series of files, a Modification is:

A. Any addition to or deletion from the contents of a file containing Original Code or previous Modifications.

B. Any new file that contains any part of the Original Code or previous Modifications.

1.10. "Original Code" means Source Code of computer software code which is described in the Source Code notice required by Exhibit A as Original Code, and which, at the time of its release under this License is not already Covered Code governed by this License.

1.10.1. "Patent Claims" means any patent claim(s), now owned or hereafter acquired, including without limitation, method, process, and apparatus claims, in any patent Licensable by grantor.

1.11. "Source Code" means the preferred form of the Covered Code for making modifications to it, including all modules it contains, plus any associated interface definition files, scripts used to control compilation and installation of an Executable, or source code differential comparisons against either the Original Code or another well known, available Covered Code of the Contributor's choice. The Source Code can be in a compressed or archival form, provided the appropriate decompression or de-archiving software is widely available for no charge.

1.12. "You" (or "Your") means an individual or a legal entity exercising rights under, and complying with all of the terms of, this License or a future version of this License issued under Section 6.1. For legal entities, "You" includes any entity which controls, is controlled by, or is under common control with You. For purposes of this definition, "control" means (a) the power, direct or indirect, to cause the direction or management of such entity, whether by contract or otherwise, or (b) ownership of more than fifty percent (50%) of the outstanding shares or beneficial ownership of such entity.

2. Source Code License.

2.1. The Initial Developer Grant. The Initial Developer hereby grants You a world-wide, royalty-free, non-exclusive license, subject to third party intellectual property claims:

(a) under intellectual property rights (other than patent or trademark) Licensable by Initial Developer to use, reproduce, modify, display, perform, sublicense and distribute the Original Code (or portions thereof) with or without Modifications, and/or as part of a Larger Work; and

(b) under Patents Claims infringed by the making, using or selling of Original Code, to make, have made, use, practice, sell, and offer for sale, and/or otherwise dispose of the Original Code (or portions thereof).

(c) the licenses granted in this Section 2.1(a) and (b) are effective on the date Initial Developer first distributes Original Code under the terms of this License.

(d) Notwithstanding Section 2.1(b) above, no patent license is granted: 1) for code that You delete from the Original Code; 2) separate from the Original Code; or 3) for infringements caused by: i) the modification of the Original Code or ii) the combination of the Original Code with other software or devices.

2.2. Contributor Grant. Subject to third party intellectual property claims, each Contributor hereby grants You a world-wide, royalty-free, non-exclusive license

(a) under intellectual property rights (other than patent or trademark) Licensable by Contributor, to use, reproduce, modify, display, perform, sublicense and distribute the Modifications created by such Contributor (or portions thereof) either on an unmodified basis, with other Modifications, as Covered Code and/or as part of a Larger Work; and

(b) under Patent Claims infringed by the making, using, or selling of Modifications made by that Contributor either alone and/or in combination with its Contributor Version (or portions of such combination), to make, use, sell, offer for sale, have made, and/or otherwise dispose of: 1) Modifications made by that Contributor (or portions thereof); and 2) the combination of Modifications made by that Contributor with its Contributor Version (or portions of such combination).

(c) the licenses granted in Sections 2.2(a) and 2.2(b) are effective on the date Contributor first makes Commercial Use of the Covered Code.

(d) Notwithstanding Section 2.2(b) above, no patent license is granted: 1) for any code that Contributor has deleted from the Contributor Version; 2) separate from the Contributor Version; 3) for infringements caused by: i) third party modifications of Contributor Version or ii) the combination of Modifications made by that Contributor with other software (except as part of the Contributor Version) or other devices; or 4) under Patent Claims infringed by Covered Code in the absence of Modifications made by that Contributor.

3. Distribution Obligations.

3.1. Application of License. The Modifications which You create or to which You contribute are governed by the terms of this License, including without limitation Section 2.2. The Source Code version of Covered Code may be distributed only under the terms of this License or a future version of this License released under Section 6.1, and You must include a copy of this License with every copy of the Source Code You distribute. You may not offer or impose any terms on any Source Code version that alters or restricts the applicable version of this License or the recipients' rights hereunder. However, You may include an additional document offering the additional rights described in Section 3.5.

3.2. Availability of Source Code. Any Modification which You create or to which You contribute must be made available in Source Code form under the terms of this License either on the same media as an Executable version or via an accepted Electronic Distribution Mechanism to anyone to whom you made an Executable version available; and if made available via Electronic Distribution Mechanism, must remain available for at least twelve (12) months after the date it initially became available, or at least six (6) months after a subsequent version of that particular Modification has been made available to such recipients. You are responsible for ensuring that the Source Code version remains available even if the Electronic Distribution Mechanism is maintained by a third party.

3.3. Description of Modifications. You must cause all Covered Code to which You contribute to contain a file documenting the changes You made to create that Covered Code and the date of any change. You must include a prominent statement that the Modification is derived, directly or indirectly, from Original Code provided by the Initial Developer and including the name of the Initial Developer in (a) the Source Code, and (b) in any notice in an Executable version or related documentation in which You describe the origin or ownership of the Covered Code.

3.4. Intellectual Property Matters

(a) Third Party Claims. If Contributor has knowledge that a license under a third party's intellectual property rights is required to exercise the rights granted by such Contributor under Sections 2.1 or 2.2, Contributor must include a text file with the Source Code distribution titled "LEGAL" which describes the claim and the party making the claim in sufficient detail that a recipient will know whom to contact. If Contributor obtains such knowledge after the Modification is made available as described in Section 3.2, Contributor shall promptly modify the LEGAL file in all copies Contributor makes available thereafter and shall take other steps (such as notifying appropriate mailing lists or newsgroups) reasonably calculated to inform those who received the Covered Code that new knowledge has been obtained.

(b) Contributor APIs. If Contributor's Modifications include an application programming interface and Contributor has knowledge of patent licenses which are reasonably necessary to implement that API, Contributor must also include this information in the LEGAL file.

3.5. Required Notices. You must duplicate the notice in Exhibit A in each file of the Source Code. If it is not possible to put such notice in a particular Source Code file due to its structure, then You must include such notice in a location (such as a relevant directory) where a user would be likely to look for such a notice. If You created one or more Modification(s) You may add your name as a Contributor to the notice described in Exhibit A. You must also duplicate this License in any documentation for the Source Code where You describe recipients' rights or ownership rights relating to Covered Code. You may choose to offer, and to charge a fee for, warranty, support, indemnity or liability obligations to one or more recipients of Covered Code. However, You may do so only on Your own behalf, and not on behalf of the Initial Developer or any Contributor. You must make it absolutely clear than any such warranty, support, indemnity or liability obligation is offered by You alone, and You hereby agree to indemnify the Initial Developer and every Contributor for any liability incurred by the Initial Developer or such Contributor as a result of warranty, support, indemnity or liability terms You offer.

3.6. Distribution of Executable Versions. You may distribute Covered Code in Executable form only if the requirements of Section 3.1-3.5 have been met for that Covered Code, and if You include a notice stating that the Source Code version of the Covered Code is available under the terms of this License, including a description of how and where You have fulfilled the obligations of Section 3.2. The notice must be conspicuously included in any notice in an Executable version, related documentation or collateral in which You describe recipients' rights relating to the Covered Code. You may distribute the Executable version of Covered Code or ownership rights under a license of Your choice, which may contain terms different from this License, provided that You are in compliance with the terms of this License and that the license for the Executable version does not attempt to limit or alter the recipient's rights in the Source Code version from the rights set forth in this License. If You distribute the Executable version under a different license You must make it absolutely clear that any terms which differ from this License are offered by You alone, not by the Initial Developer or any Contributor. You hereby agree to indemnify the Initial Developer and every Contributor for any liability incurred by the Initial Developer or such Contributor as a result of any such terms You offer.

3.7. Larger Works. You may create a Larger Work by combining Covered Code with other code not governed by the terms of this License and distribute the Larger Work as a single product. In such a case, You must make sure the requirements of this License are fulfilled for the Covered Code.

4. Inability to Comply Due to Statute or Regulation.If it is impossible for You to comply with any of the terms of this License with respect to some or all of the Covered Code due to statute, judicial order, or regulation then You must: (a) comply with the terms of this License to the maximum extent possible; and (b) describe the limitations and the code they affect. Such description must be included in the LEGAL file described in Section 3.4 and must be included with all distributions of the Source Code. Except to the extent prohibited by statute or regulation, such description must be sufficiently detailed for a recipient of ordinary skill to be able to understand it.

5. Application of this License. This License applies to code to which the Initial Developer has attached the notice in Exhibit A and to related Covered Code.

6. Versions of the License.

6.1. New Versions. Netscape Communications Corporation ("Netscape") may publish revised and/or new versions of the License from time to time. Each version will be given a distinguishing version number.

6.2. Effect of New Versions. Once Covered Code has been published under a particular version of the License, You may always continue to use it under the terms of that version. You may also choose to use such Covered Code under the terms of any subsequent version of the License published by Netscape. No one other than Netscape has the right to modify the terms applicable to Covered Code created under this License.

6.3. Derivative Works. If You create or use a modified version of this License (which you may only do in order to apply it to code which is not already Covered Code governed by this License), You must (a) rename Your license so that the phrases "Mozilla", "MOZILLAPL", "MOZPL", "Netscape", "MPL", "NPL" or any confusingly similar phrase do not appear in your license (except to note that your license differs from this License) and (b) otherwise make it clear that Your version of the license contains terms which differ from the Mozilla Public License and Netscape Public License. (Filling in the name of the Initial Developer, Original Code or Contributor in the notice described in Exhibit A shall not of themselves be deemed to be modifications of this License.)

7. DISCLAIMER OF WARRANTY.

COVERED CODE IS PROVIDED UNDER THIS LICENSE ON AN "AS IS" BASIS, WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, WITHOUT LIMITATION, WARRANTIES THAT THE COVERED CODE IS FREE OF DEFECTS, MERCHANTABLE, FIT FOR A PARTICULAR PURPOSE OR NON-INFRINGING. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE COVERED CODE IS WITH YOU. SHOULD ANY COVERED CODE PROVE DEFECTIVE IN ANY RESPECT, YOU (NOT THE INITIAL DEVELOPER OR ANY OTHER CONTRIBUTOR) ASSUME THE COST OF ANY NECESSARY SERVICING, REPAIR OR CORRECTION. THIS DISCLAIMER OF WARRANTY CONSTITUTES AN ESSENTIAL PART OF THIS LICENSE. NO USE OF ANY COVERED CODE IS AUTHORIZED HEREUNDER EXCEPT UNDER THIS DISCLAIMER.

8. TERMINATION.

8.1. This License and the rights granted hereunder will terminate automatically if You fail to comply with terms herein and fail to cure such breach within 30 days of becoming aware of the breach. All sublicenses to the Covered Code which are properly granted shall survive any termination of this License. Provisions which, by their nature, must remain in effect beyond the termination of this License shall survive.

8.2. If You initiate litigation by asserting a patent infringement claim (excluding declaratory judgment actions) against Initial Developer or a Contributor (the Initial Developer or Contributor against whom You file such action is referred to as "Participant") alleging that:

(a) such Participant's Contributor Version directly or indirectly infringes any patent, then any and all rights granted by such Participant to You under Sections 2.1 and/or 2.2 of this License shall, upon 60 days notice from Participant terminate prospectively, unless if within 60 days after receipt of notice You either: (i) agree in writing to pay Participant a mutually agreeable reasonable royalty for Your past and future use of Modifications made by such Participant, or (ii) withdraw Your litigation claim with respect to the Contributor Version against such Participant. If within 60 days of notice, a reasonable royalty and payment arrangement are not mutually agreed upon in writing by the parties or the litigation claim is not withdrawn, the rights granted by Participant to You under Sections 2.1 and/or 2.2 automatically terminate at the expiration of the 60 day notice period specified above.

(b) any software, hardware, or device, other than such Participant's Contributor Version, directly or indirectly infringes any patent, then any rights granted to You by such Participant under Sections 2.1(b) and 2.2(b) are revoked effective as of the date You first made, used, sold, distributed, or had made, Modifications made by that Participant.

8.3. If You assert a patent infringement claim against Participant alleging that such Participant's Contributor Version directly or indirectly infringes any patent where such claim is resolved (such as by license or settlement) prior to the initiation of patent infringement litigation, then the reasonable value of the licenses granted by such Participant under Sections 2.1 or 2.2 shall be taken into account in determining the amount or value of any payment or license.

8.4. In the event of termination under Sections 8.1 or 8.2 above, all end user license agreements (excluding distributors and resellers) which have been validly granted by You or any distributor hereunder prior to termination shall survive termination.

9. LIMITATION OF LIABILITY. UNDER NO CIRCUMSTANCES AND UNDER NO LEGAL THEORY, WHETHER TORT (INCLUDING NEGLIGENCE), CONTRACT, OR OTHERWISE, SHALL YOU, THE INITIAL DEVELOPER, ANY OTHER CONTRIBUTOR, OR ANY DISTRIBUTOR OF COVERED CODE, OR ANY SUPPLIER OF ANY OF SUCH PARTIES, BE LIABLE TO ANY PERSON FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES OF ANY CHARACTER INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF GOODWILL, WORK STOPPAGE, COMPUTER FAILURE OR MALFUNCTION, OR ANY AND ALL OTHER COMMERCIAL DAMAGES OR LOSSES, EVEN IF SUCH PARTY SHALL HAVE BEEN INFORMED OF THE POSSIBILITY OF SUCH DAMAGES. THIS LIMITATION OF LIABILITY SHALL NOT APPLY TO LIABILITY FOR DEATH OR PERSONAL INJURY RESULTING FROM SUCH PARTY'S NEGLIGENCE TO THE EXTENT APPLICABLE LAW PROHIBITS SUCH LIMITATION. SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THIS EXCLUSION AND LIMITATION MAY NOT APPLY TO YOU.

10. U.S. GOVERNMENT END USERS. The Covered Code is a "commercial item," as that term is defined in 48 C.F.R. 2.101 (Oct. 1995), consisting of "commercial computer software" and "commercial computer software documentation," as such terms are used in 48 C.F.R. 12.212 (Sept. 1995). Consistent with 48 C.F.R. 12.212 and 48 C.F.R. 227.7202-1 through 227.7202-4 (June 1995), all U.S. Government End Users acquire Covered Code with only those rights set forth herein.

11. MISCELLANEOUS. This License represents the complete agreement concerning subject matter hereof. If any provision of this License is held to be unenforceable, such provision shall be reformed only to the extent necessary to make it enforceable. This License shall be governed by California law provisions (except to the extent applicable law, if any, provides otherwise), excluding its conflict-of-law provisions. With respect to disputes in which at least one party is a citizen of, or an entity chartered or registered to do business in the United States of America, any litigation relating to this License shall be subject to the jurisdiction of the Federal Courts of the Northern District of California, with venue lying in Santa Clara County, California, with the losing party responsible for costs, including without limitation, court costs and reasonable attorneys' fees and expenses. The application of the United Nations Convention on Contracts for the International Sale of Goods is expressly excluded. Any law or regulation which provides that the language of a contract shall be construed against the drafter shall not apply to this License.

12. RESPONSIBILITY FOR CLAIMS. As between Initial Developer and the Contributors, each party is responsible for claims and damages arising, directly or indirectly, out of its utilization of rights under this License and You agree to work with Initial Developer and Contributors to distribute such responsibility on an equitable basis. Nothing herein is intended or shall be deemed to constitute any admission of liability.

13. MULTIPLE-LICENSED CODE. Initial Developer may designate portions of the Covered Code as "Multiple-Licensed". "Multiple-Licensed" means that the Initial Developer permits you to utilize portions of the Covered Code under Your choice of the NPL or the alternative licenses, if any, specified by the Initial Developer in the file described in Exhibit A.

EXHIBIT A -Mozilla Public License.

``The contents of this file are subject to the Mozilla Public License Version 1.1 (the "License"); you may not use this file except in compliance with the License. You may obtain a copy of the License at http://www.mozilla.org/MPL/

Software distributed under the License is distributed on an "AS IS" basis, WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License for the specific language governing rights and limitations under the License.

The Original Code is ______________________________________.

The Initial Developer of the Original Code is ________________________. Portions created by ______________________ are Copyright (C) ______ _______________________. All Rights Reserved.

Contributor(s): ______________________________________.

Alternatively, the contents of this file may be used under the terms of the _____ license (the "[___] License"), in which case the provisions of [______] License are applicable instead of those above. If you wish to allow use of your version of this file only under the terms of the [____] License and not to allow others to use your version of this file under the MPL, indicate your decision by deleting the provisions above and replace them with the notice and other provisions required by the [___] License. If you do not delete the provisions above, a recipient may use your version of this file under either the MPL or the [___] License."

[NOTE: The text of this Exhibit A may differ slightly from the text of the notices in the Source Code files of the Original Code. You should use the text of this Exhibit A rather than the text found in the Original Code Source Code for Your Modifications.]

A.2.4. MIT License

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

A.2.5. X Consortium License (X11)

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

A.2.6. zlib license

This software is provided 'as-is', without any express or implied warranty. In no event will the authors be held liable for any damages arising from the use of this software.

Permission is granted to anyone to use this software for any purpose, including commercial applications, and to alter it and redistribute it freely, subject to the following restrictions:

1. The origin of this software must not be misrepresented; you must not claim that you wrote the original software. If you use this software in a product, an acknowledgment in the product documentation would be appreciated but is not required.

2. Altered source versions must be plainly marked as such, and must not be misrepresented as being the original software.

3. This notice may not be removed or altered from any source distribution.

Jean-loup Gailly        Mark Adler
jloup@gzip.org          madler@alumni.caltech.edu

A.2.7. OpenSSL license

This package is an SSL implementation written by Eric Young (eay@cryptsoft.com). The implementation was written so as to conform with Netscape's SSL.

This library is free for commercial and non-commercial use as long as the following conditions are adhered to. The following conditions apply to all code found in this distribution, be it the RC4, RSA, lhash, DES, etc., code; not just the SSL code. The SSL documentation included with this distribution is covered by the same copyright terms except that the holder is Tim Hudson (tjh@cryptsoft.com).

Copyright remains Eric Young's, and as such any Copyright notices in the code are not to be removed. If this package is used in a product, Eric Young should be given attribution as the author of the parts of the library used. This can be in the form of a textual message at program startup or in documentation (online or textual) provided with the package.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. All advertising materials mentioning features or use of this software must display the following acknowledgement: "This product includes cryptographic software written by Eric Young (eay@cryptsoft.com)" The word 'cryptographic' can be left out if the routines from the library being used are not cryptographic related :-).

4. If you include any Windows specific code (or a derivative thereof) from the apps directory (application code) you must include an acknowledgement: "This product includes software written by Tim Hudson (tjh@cryptsoft.com)"

THIS SOFTWARE IS PROVIDED BY ERIC YOUNG ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

The licence and distribution terms for any publicly available version or derivative of this code cannot be changed. i.e. this code cannot simply be copied and put under another distribution licence [including the GNU Public Licence.]

A.2.8. Slirp license

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. All advertising materials mentioning features or use of this software must display the following acknowledgment: This product includes software developed by Danny Gasparovski.

THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL DANNY GASPAROVSKI OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

A.2.9. liblzf license

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. The name of the author may not be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

A.2.10. libpng license

The PNG Reference Library is supplied "AS IS". The Contributing Authors and Group 42, Inc. disclaim all warranties, expressed or implied, including, without limitation, the warranties of merchantability and of fitness for any purpose. The Contributing Authors and Group 42, Inc. assume no liability for direct, indirect, incidental, special, exemplary, or consequential damages, which may result from the use of the PNG Reference Library, even if advised of the possibility of such damage.

Permission is hereby granted to use, copy, modify, and distribute this source code, or portions hereof, for any purpose, without fee, subject to the following restrictions:

1. The origin of this source code must not be misrepresented.

2. Altered versions must be plainly marked as such and must not be misrepresented as being the original source.

3. This Copyright notice may not be removed or altered from any source or altered source distribution.

The Contributing Authors and Group 42, Inc. specifically permit, without fee, and encourage the use of this source code as a component to supporting the PNG file format in commercial products. If you use this source code in a product, acknowledgment is not required but would be appreciated.

A.2.11. lwIP license

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. The name of the author may not be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

A.2.12. libxml license

Except where otherwise noted in the source code (e.g. the files hash.c, list.c and the trio files, which are covered by a similar licence but with different Copyright notices) all the files are:

Copyright (C) 1998-2003 Daniel Veillard. All Rights Reserved.

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE DANIEL VEILLARD BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Except as contained in this notice, the name of Daniel Veillard shall not be used in advertising or otherwise to promote the sale, use or other dealings in this Software without prior written authorization from him.

A.2.13. libxslt licenses

Licence for libxslt except libexslt:

Copyright (C) 2001-2002 Daniel Veillard. All Rights Reserved.

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE DANIEL VEILLARD BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Except as contained in this notice, the name of Daniel Veillard shall not be used in advertising or otherwise to promote the sale, use or other dealings in this Software without prior written authorization from him.

Licence for libexslt:

Copyright (C) 2001-2002 Thomas Broyer, Charlie Bozeman and Daniel Veillard. All Rights Reserved.

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Except as contained in this notice, the name of the authors shall not be used in advertising or otherwise to promote the sale, use or other dealings in this Software without prior written authorization from him.

A.2.14. gSOAP Public License Version 1.3a

The gSOAP public license is derived from the Mozilla Public License (MPL1.1). The sections that were deleted from the original MPL1.1 text are 1.0.1, 2.1.(c),(d), 2.2.(c),(d), 8.2.(b), 10, and 11. Section 3.8 was added. The modified sections are 2.1.(b), 2.2.(b), 3.2 (simplified), 3.5 (deleted the last sentence), and 3.6 (simplified).

1 DEFINITIONS

1.1. "Contributor" means each entity that creates or contributes to the creation of Modifications.

1.2. "Contributor Version" means the combination of the Original Code, prior Modifications used by a Contributor, and the Modifications made by that particular Contributor.

1.3. "Covered Code" means the Original Code, or Modifications or the combination of the Original Code, and Modifications, in each case including portions thereof.

1.4. "Electronic Distribution Mechanism" means a mechanism generally accepted in the software development community for the electronic transfer of data.

1.5. "Executable" means Covered Code in any form other than Source Code.

1.6. "Initial Developer" means the individual or entity identified as the Initial Developer in the Source Code notice required by Exhibit A.

1.7. "Larger Work" means a work which combines Covered Code or portions thereof with code not governed by the terms of this License.

1.8. "License" means this document.

1.8.1. "Licensable" means having the right to grant, to the maximum extent possible, whether at the time of the initial grant or subsequently acquired, any and all of the rights conveyed herein.

1.9. "Modifications" means any addition to or deletion from the substance or structure of either the Original Code or any previous Modifications. When Covered Code is released as a series of files, a Modification is:

A. Any addition to or deletion from the contents of a file containing Original Code or previous Modifications.

B. Any new file that contains any part of the Original Code, or previous Modifications.

1.10. "Original Code" means Source Code of computer software code which is described in the Source Code notice required by Exhibit A as Original Code, and which, at the time of its release under this License is not already Covered Code governed by this License.

1.10.1. "Patent Claims" means any patent claim(s), now owned or hereafter acquired, including without limitation, method, process, and apparatus claims, in any patent Licensable by grantor.

1.11. "Source Code" means the preferred form of the Covered Code for making modifications to it, including all modules it contains, plus any associated interface definition files, scripts used to control compilation and installation of an Executable, or source code differential comparisons against either the Original Code or another well known, available Covered Code of the Contributor's choice. The Source Code can be in a compressed or archival form, provided the appropriate decompression or de-archiving software is widely available for no charge.

1.12. "You" (or "Your") means an individual or a legal entity exercising rights under, and complying with all of the terms of, this License or a future version of this License issued under Section 6.1. For legal entities, "You" includes any entity which controls, is controlled by, or is under common control with You. For purposes of this definition, "control" means (a) the power, direct or indirect, to cause the direction or management of such entity, whether by contract or otherwise, or (b) ownership of more than fifty percent (50%) of the outstanding shares or beneficial ownership of such entity.

2 SOURCE CODE LICENSE.

2.1. The Initial Developer Grant.

The Initial Developer hereby grants You a world-wide, royalty-free, non-exclusive license, subject to third party intellectual property claims:

(a) under intellectual property rights (other than patent or trademark) Licensable by Initial Developer to use, reproduce, modify, display, perform, sublicense and distribute the Original Code (or portions thereof) with or without Modifications, and/or as part of a Larger Work; and

(b) under patents now or hereafter owned or controlled by Initial Developer, to make, have made, use and sell ("offer to sell and import") the Original Code, Modifications, or portions thereof, but solely to the extent that any such patent is reasonably necessary to enable You to utilize, alone or in combination with other software, the Original Code, Modifications, or any combination or portions thereof.

(c)

(d)

2.2. Contributor Grant.

Subject to third party intellectual property claims, each Contributor hereby grants You a world-wide, royalty-free, non-exclusive license

(a) under intellectual property rights (other than patent or trademark) Licensable by Contributor, to use, reproduce, modify, display, perform, sublicense and distribute the Modifications created by such Contributor (or portions thereof) either on an unmodified basis, with other Modifications, as Covered Code and/or as part of a Larger Work; and

(b) under patents now or hereafter owned or controlled by Contributor, to make, have made, use and sell ("offer to sell and import") the Contributor Version (or portions thereof), but solely to the extent that any such patent is reasonably necessary to enable You to utilize, alone or in combination with other software, the Contributor Version (or portions thereof).

(c)

(d)

3 DISTRIBUTION OBLIGATIONS.

3.1. Application of License.

The Modifications which You create or to which You contribute are governed by the terms of this License, including without limitation Section 2.2. The Source Code version of Covered Code may be distributed only under the terms of this License or a future version of this License released under Section 6.1, and You must include a copy of this License with every copy of the Source Code You distribute. You may not offer or impose any terms on any Source Code version that alters or restricts the applicable version of this License or the recipients' rights hereunder. However, You may include an additional document offering the additional rights described in Section 3.5.

3.2. Availability of Source Code.

Any Modification created by You will be provided to the Initial Developer in Source Code form and are subject to the terms of the License. 3.3. Description of Modifications.

You must cause all Covered Code to which You contribute to contain a file documenting the changes You made to create that Covered Code and the date of any change. You must include a prominent statement that the Modification is derived, directly or indirectly, from Original Code provided by the Initial Developer and including the name of the Initial Developer in (a) the Source Code, and (b) in any notice in an Executable version or related documentation in which You describe the origin or ownership of the Covered Code.

3.4. Intellectual Property Matters.

(a) Third Party Claims. If Contributor has knowledge that a license under a third party's intellectual property rights is required to exercise the rights granted by such Contributor under Sections 2.1 or 2.2, Contributor must include a text file with the Source Code distribution titled "LEGAL" which describes the claim and the party making the claim in sufficient detail that a recipient will know whom to contact. If Contributor obtains such knowledge after the Modification is made available as described in Section 3.2, Contributor shall promptly modify the LEGAL file in all copies Contributor makes available thereafter and shall take other steps (such as notifying appropriate mailing lists or newsgroups) reasonably calculated to inform those who received the Covered Code that new knowledge has been obtained.

(b) Contributor APIs. If Contributor's Modifications include an application programming interface and Contributor has knowledge of patent licenses which are reasonably necessary to implement that API, Contributor must also include this information in the LEGAL file.

(c) Representations. Contributor represents that, except as disclosed pursuant to Section 3.4(a) above, Contributor believes that Contributor's Modifications are Contributor's original creation(s) and/or Contributor has sufficient rights to grant the rights conveyed by this License.

3.5. Required Notices. You must duplicate the notice in Exhibit A in each file of the Source Code. If it is not possible to put such notice in a particular Source Code file due to its structure, then You must include such notice in a location (such as a relevant directory) where a user would be likely to look for such a notice. If You created one or more Modification(s) You may add your name as a Contributor to the notice described in Exhibit A. You must also duplicate this License in any documentation for the Source Code where You describe recipients' rights or ownership rights relating to Covered Code. You may choose to offer, and to charge a fee for, warranty, support, indemnity or liability obligations to one or more recipients of Covered Code. However, You may do so only on Your own behalf, and not on behalf of the Initial Developer or any Contributor.

3.6. Distribution of Executable Versions. You may distribute Covered Code in Executable form only if the requirements of Section 3.1-3.5 have been met for that Covered Code. You may distribute the Executable version of Covered Code or ownership rights under a license of Your choice, which may contain terms different from this License, provided that You are in compliance with the terms of this License and that the license for the Executable version does not attempt to limit or alter the recipient's rights in the Source Code version from the rights set forth in this License. If You distribute the Executable version under a different license You must make it absolutely clear that any terms which differ from this License are offered by You alone, not by the Initial Developer or any Contributor. If you distribute executable versions containing Covered Code as part of a product, you must reproduce the notice in Exhibit B in the documentation and/or other materials provided with the product.

3.7. Larger Works. You may create a Larger Work by combining Covered Code with other code not governed by the terms of this License and distribute the Larger Work as a single product. In such a case, You must make sure the requirements of this License are fulfilled for the Covered Code.

3.8. Restrictions. You may not remove any product identification, copyright, proprietary notices or labels from gSOAP.

4 INABILITY TO COMPLY DUE TO STATUTE OR REGULATION.

If it is impossible for You to comply with any of the terms of this License with respect to some or all of the Covered Code due to statute, judicial order, or regulation then You must: (a) comply with the terms of this License to the maximum extent possible; and (b) describe the limitations and the code they affect. Such description must be included in the LEGAL file described in Section 3.4 and must be included with all distributions of the Source Code. Except to the extent prohibited by statute or regulation, such description must be sufficiently detailed for a recipient of ordinary skill to be able to understand it.

5 APPLICATION OF THIS LICENSE.

This License applies to code to which the Initial Developer has attached the notice in Exhibit A and to related Covered Code.

6 VERSIONS OF THE LICENSE.

6.1. New Versions.

Grantor may publish revised and/or new versions of the License from time to time. Each version will be given a distinguishing version number.

6.2. Effect of New Versions.

Once Covered Code has been published under a particular version of the License, You may always continue to use it under the terms of that version. You may also choose to use such Covered Code under the terms of any subsequent version of the License.

6.3. Derivative Works.

If You create or use a modified version of this License (which you may only do in order to apply it to code which is not already Covered Code governed by this License), You must (a) rename Your license so that the phrase "gSOAP" or any confusingly similar phrase do not appear in your license (except to note that your license differs from this License) and (b) otherwise make it clear that Your version of the license contains terms which differ from the gSOAP Public License. (Filling in the name of the Initial Developer, Original Code or Contributor in the notice described in Exhibit A shall not of themselves be deemed to be modifications of this License.)

7 DISCLAIMER OF WARRANTY.

COVERED CODE IS PROVIDED UNDER THIS LICENSE ON AN "AS IS" BASIS, WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS, IMPLIED OR STATUTORY, INCLUDING, WITHOUT LIMITATION, THE IMPLIED WARRANTIES OF MERCHANTABILITY, OF FITNESS FOR A PARTICULAR PURPOSE, NONINFRINGEMENT OF THIRD PARTY INTELLECTUAL PROPERTY RIGHTS, AND ANY WARRANTY THAT MAY ARISE BY REASON OF TRADE USAGE, CUSTOM, OR COURSE OF DEALING. WITHOUT LIMITING THE FOREGOING, YOU ACKNOWLEDGE THAT THE SOFTWARE IS PROVIDED "AS IS" AND THAT THE AUTHORS DO NOT WARRANT THE SOFTWARE WILL RUN UNINTERRUPTED OR ERROR FREE. LIMITED LIABILITY THE ENTIRE RISK AS TO RESULTS AND PERFORMANCE OF THE SOFTWARE IS ASSUMED BY YOU. UNDER NO CIRCUMSTANCES WILL THE AUTHORS BE LIABLE FOR ANY SPECIAL, INDIRECT, INCIDENTAL, EXEMPLARY OR CONSEQUENTIAL DAMAGES OF ANY KIND OR NATURE WHATSOEVER, WHETHER BASED ON CONTRACT, WARRANTY, TORT (INCLUDING NEGLIGENCE), STRICT LIABILITY OR OTHERWISE, ARISING OUT OF OR IN ANY WAY RELATED TO THE SOFTWARE, EVEN IF THE AUTHORS HAVE BEEN ADVISED ON THE POSSIBILITY OF SUCH DAMAGE OR IF SUCH DAMAGE COULD HAVE BEEN REASONABLY FORESEEN, AND NOTWITHSTANDING ANY FAILURE OF ESSENTIAL PURPOSE OF ANY EXCLUSIVE REMEDY PROVIDED. SUCH LIMITATION ON DAMAGES INCLUDES, BUT IS NOT LIMITED TO, DAMAGES FOR LOSS OF GOODWILL, LOST PROFITS, LOSS OF DATA OR SOFTWARE, WORK STOPPAGE, COMPUTER FAILURE OR MALFUNCTION OR IMPAIRMENT OF OTHER GOODS. IN NO EVENT WILL THE AUTHORS BE LIABLE FOR THE COSTS OF PROCUREMENT OF SUBSTITUTE SOFTWARE OR SERVICES. YOU ACKNOWLEDGE THAT THIS SOFTWARE IS NOT DESIGNED FOR USE IN ON-LINE EQUIPMENT IN HAZARDOUS ENVIRONMENTS SUCH AS OPERATION OF NUCLEAR FACILITIES, AIRCRAFT NAVIGATION OR CONTROL, OR LIFE-CRITICAL APPLICATIONS. THE AUTHORS EXPRESSLY DISCLAIM ANY LIABILITY RESULTING FROM USE OF THE SOFTWARE IN ANY SUCH ON-LINE EQUIPMENT IN HAZARDOUS ENVIRONMENTS AND ACCEPTS NO LIABILITY IN RESPECT OF ANY ACTIONS OR CLAIMS BASED ON THE USE OF THE SOFTWARE IN ANY SUCH ON-LINE EQUIPMENT IN HAZARDOUS ENVIRONMENTS BY YOU. FOR PURPOSES OF THIS PARAGRAPH, THE TERM "LIFE-CRITICAL APPLICATION" MEANS AN APPLICATION IN WHICH THE FUNCTIONING OR MALFUNCTIONING OF THE SOFTWARE MAY RESULT DIRECTLY OR INDIRECTLY IN PHYSICAL INJURY OR LOSS OF HUMAN LIFE. THIS DISCLAIMER OF WARRANTY CONSTITUTES AN ESSENTIAL PART OF THIS LICENSE. NO USE OF ANY COVERED CODE IS AUTHORIZED HEREUNDER EXCEPT UNDER THIS DISCLAIMER.

8 TERMINATION.

8.1.

This License and the rights granted hereunder will terminate automatically if You fail to comply with terms herein and fail to cure such breach within 30 days of becoming aware of the breach. All sublicenses to the Covered Code which are properly granted shall survive any termination of this License. Provisions which, by their nature, must remain in effect beyond the termination of this License shall survive.

8.2.

8.3.

If You assert a patent infringement claim against Participant alleging that such Participant's Contributor Version directly or indirectly infringes any patent where such claim is resolved (such as by license or settlement) prior to the initiation of patent infringement litigation, then the reasonable value of the licenses granted by such Participant under Sections 2.1 or 2.2 shall be taken into account in determining the amount or value of any payment or license.

8.4. In the event of termination under Sections 8.1 or 8.2 above, all end user license agreements (excluding distributors and resellers) which have been validly granted by You or any distributor hereunder prior to termination shall survive termination.

9 LIMITATION OF LIABILITY.

UNDER NO CIRCUMSTANCES AND UNDER NO LEGAL THEORY, WHETHER TORT (INCLUDING NEGLIGENCE), CONTRACT, OR OTHERWISE, SHALL YOU, THE INITIAL DEVELOPER, ANY OTHER CONTRIBUTOR, OR ANY DISTRIBUTOR OF COVERED CODE, OR ANY SUPPLIER OF ANY OF SUCH PARTIES, BE LIABLE TO ANY PERSON FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES OF ANY CHARACTER INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF GOODWILL, WORK STOPPAGE, COMPUTER FAILURE OR MALFUNCTION, OR ANY AND ALL OTHER COMMERCIAL DAMAGES OR LOSSES, EVEN IF SUCH PARTY SHALL HAVE BEEN INFORMED OF THE POSSIBILITY OF SUCH DAMAGES. THIS LIMITATION OF LIABILITY SHALL NOT APPLY TO LIABILITY FOR DEATH OR PERSONAL INJURY RESULTING FROM SUCH PARTY'S NEGLIGENCE TO THE EXTENT APPLICABLE LAW PROHIBITS SUCH LIMITATION. SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THIS EXCLUSION AND LIMITATION MAY NOT APPLY TO YOU.

10 U.S. GOVERNMENT END USERS.

11 MISCELLANEOUS.

12 RESPONSIBILITY FOR CLAIMS.

As between Initial Developer and the Contributors, each party is responsible for claims and damages arising, directly or indirectly, out of its utilization of rights under this License and You agree to work with Initial Developer and Contributors to distribute such responsibility on an equitable basis. Nothing herein is intended or shall be deemed to constitute any admission of liability.

EXHIBIT A.

"The contents of this file are subject to the gSOAP Public License Version 1.3 (the "License"); you may not use this file except in compliance with the License. You may obtain a copy of the License at http://www.cs.fsu.edu/~engelen/soaplicense.html. Software distributed under the License is distributed on an "AS IS" basis, WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License for the specific language governing rights and limitations under the License.

The Original Code of the gSOAP Software is: stdsoap.h, stdsoap2.h, stdsoap.c, stdsoap2.c, stdsoap.cpp, stdsoap2.cpp, soapcpp2.h, soapcpp2.c, soapcpp2_lex.l, soapcpp2_yacc.y, error2.h, error2.c, symbol2.c, init2.c, soapdoc2.html, and soapdoc2.pdf, httpget.h, httpget.c, stl.h, stldeque.h, stllist.h, stlvector.h, stlset.h.

The Initial Developer of the Original Code is Robert A. van Engelen. Portions created by Robert A. van Engelen are Copyright (C) 2001-2004 Robert A. van Engelen, Genivia inc. All Rights Reserved.

Contributor(s): "________________________." [Note: The text of this Exhibit A may differ slightly form the text of the notices in the Source Code files of the Original code. You should use the text of this Exhibit A rather than the text found in the Original Code Source Code for Your Modifications.]

EXHIBIT B.

"Part of the software embedded in this product is gSOAP software. Portions created by gSOAP are Copyright (C) 2001-2004 Robert A. van Engelen, Genivia inc. All Rights Reserved. THE SOFTWARE IN THIS PRODUCT WAS IN PART PROVIDED BY GENIVIA INC AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE."

A.2.15. Chromium licenses

A.2.15.1. Main license

Copyright (c) 2002, Stanford University All rights reserved.

Some portions of Chromium are copyrighted by individiual organizations. Please see the files COPYRIGHT.LLNL and COPYRIGHT.REDHAT for more information.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  • Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

  • Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

  • Neither the name of Stanford University nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

A.2.15.2. COPYRIGHT.LLNL file

This Chromium distribution contains information and code which is covered under the following notice:

Copyright (c) 2002, The Regents of the University of California. Produced at the Lawrence Livermore National Laboratory For details, contact: Randall Frank (rjfrank@llnl.gov). UCRL-CODE-2002-058 All rights reserved.

This file is part of Chromium. For details, see accompanying documentation.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

Redistributions of source code must retain the above copyright notice, this list of conditions and the disclaimer below.

Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the disclaimer (as noted below) in the documentation and/or other materials provided with the distribution.

Neither the name of the UC/LLNL nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OF THE UNIVERSITY OF CALIFORNIA, THE U.S. DEPARTMENT OF ENERGY OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Additional BSD Notice

1. This notice is required to be provided under our contract with the U.S. Department of Energy (DOE). This work was produced at the University of California, Lawrence Livermore National Laboratory under Contract No. W-7405-ENG-48 with the DOE.

2. Neither the United States Government nor the University of California nor any of their employees, makes any warranty, express or implied, or assumes any liability or responsibility for the accuracy, completeness, or usefulness of any information, apparatus, product, or process disclosed, or represents that its use would not infringe privately-owned rights.

3. Also, reference herein to any specific commercial products, process, or services by trade name, trademark, manufacturer or otherwise does not necessarily constitute or imply its endorsement, recommendation, or favoring by the United States Government or the University of California. The views and opinions of authors expressed herein do not necessarily state or reflect those of the United States Government or the University of California, and shall not be used for advertising or product endorsement purposes.

A.2.15.3. COPYRIGHT.REDHAT file

This Chromium distribution contains information and code which is covered under the following notice:

Copyright 2001,2002 Red Hat Inc., Durham, North Carolina.

All Rights Reserved.

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation on the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice (including the next paragraph) shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT. IN NO EVENT SHALL RED HAT AND/OR THEIR SUPPLIERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

A.2.16. curl license

COPYRIGHT AND PERMISSION NOTICE

Copyright (c) 1996 - 2009, Daniel Stenberg, daniel@haxx.se.

All rights reserved.

Permission to use, copy, modify, and distribute this software for any purpose with or without fee is hereby granted, provided that the above copyright notice and this permission notice appear in all copies.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY RIGHTS. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Except as contained in this notice, the name of a copyright holder shall not be used in advertising or otherwise to promote the sale, use or other dealings in this Software without prior written authorization of the copyright holder.


Appendix B. VirtualBox privacy policy

Policy version 1.3, June 29, 2009

This privacy policy sets out how Sun Microsystems, Inc. ("Sun") treats personal information related to the virtualbox.org website and the VirtualBox registration process.

§ 1 virtualbox.org. The "virtualbox.org" website, as any other website, logs anonymous usage information such as your IP address, geographical location, browser type, referral source, length of visit and number of page views while you visit (collectively, "anonymous data"). In addition, but only if you choose to register, the website's bug tracking and forum services store the data you choose to reveal upon registration, such as your user name and contact information.

§ 2 Cookies. The virtualbox.org website, the bug tracker and the forum services use cookies to identify and track the visiting web browser and, if you have registered, to facilitate login. Most browsers allow you to refuse to accept cookies. While you can still visit the website with cookies disabled, logging into the bug tracker and forum services will most likely not work without them.

§ 3 VirtualBox registration process. The VirtualBox application may ask that the user register with Sun through the Sun Online mechanism used by many Sun products. This registration is optional. If you choose to register, your name, e-mail address, country and company will be submitted to Sun and stored together with the IP address of the submitter as well as product version and platform being used. The standard Sun Privacy Policy as posted on http://www.sun.com/privacy/ applies to this data.

§ 4 Update notifications. The VirtualBox application may contact Sun Microsystems to find out whether a new version of VirtualBox has been released and notify the user if that is the case. In the process, anonymous data such as your IP address and a non-identifying counter, together with the product version and the platform being used, is sent so that the server can find out whether an update is available. By default, this check is performed once a day. You change this interval or disable these checks altogether in the VirtualBox preferences.

§ 5 Usage of personal information. Sun may use anonymous and personal data collected by the means above for statistical purposes as well as to automatically inform you about new notices related to your posts on the bug tracker and forum services, to administer the website and to contact you due to technical issues. Sun may also inform you about new product releases related to VirtualBox.

In no event will personal data without your express consent be provided to any third parties, unless Sun may be required to do so by law or in connection with legal proceedings.

§ 6 Updates. Sun may update this privacy policy by posting a new version on the website. You should check this page occasionally to ensure you are happy with any changes.


Glossary

A

ACPI

Advanced Configuration and Power Interface, an industry specification for BIOS and hardware extensions to configure PC hardware and perform power management. Windows 2000 and higher as well as Linux 2.4 and higher support ACPI. Windows can only enable or disable ACPI support at installation time.

AHCI

Advanced Host Controller Interface, the interface that supports SATA devices such as hard disks. See Section 5.1, “Hard disk controllers: IDE, SATA (AHCI), SCSI”.

AMD-V

The hardware virtualization features built into modern AMD processors. See Section 1.2, “Software vs. hardware virtualization (VT-x and AMD-V)”.

API

Application Programming Interface.

APIC

Advanced Programmable Interrupt Controller, a newer version of the original PC PIC (programmable interrupt controller). Most modern CPUs contain an on-chip APIC ("local APIC"). Many systems also contain an I/O APIC (input output APIC) as a separate chip which provides more than 16 IRQs. Windows 2000 and higher use a different kernel if they detect an I/O APIC during installation. Therefore an I/O APIC must not be removed after installation.

ATA

Advanced Technology Attachment, an industry standard for hard disk interfaces (synonymous with IDE). See Section 5.1, “Hard disk controllers: IDE, SATA (AHCI), SCSI”.

B

BIOS

Basic Input/Output System, the firmware built into most personal computers which is responsible of initializing the hardware after the computer has been turned on and then booting an operating system. VirtualBox ships with its own virtual BIOS that runs when a virtual machine is started.

C

COM

Microsoft Component Object Model, a programming infrastructure for modular software. COM allows applications to provide application programming interfaces which can be accessed from various other programming languages and applications. VirtualBox makes use of COM both internally and externally to provide a comprehensive API to 3rd party developers.

D

DHCP

Dynamic Host Configuration Protocol. This allows a networking device in a network to acquire its IP address (and other networking details) automatically, in order to avoid having to configure all devices in a network with fixed IP addresses. VirtualBox has a built-in DHCP server that delivers an IP addresses to a virtual machine when networking is configured to NAT; see Chapter 6, Virtual networking.

DKMS

Dynamic Kernel Module Support. A framework that simplifies installing and updating external kernel modules on Linux machines; see Section 2.3.2, “The VirtualBox kernel module”.

E

EHCI

Enhanced Host Controller Interface, the interface that implements the USB 2.0 standard.

G

GUI

Graphical User Interface. Commonly used as an antonym to a "command line interface", in the context of VirtualBox, we sometimes refer to the main graphical VirtualBox program as the "GUI", to differentiate it from the VBoxManage interface.

GUID

See UUID.

I

IDE

Integrated Drive Electronics, an industry standard for hard disk interfaces. See Section 5.1, “Hard disk controllers: IDE, SATA (AHCI), SCSI”.

I/O APIC

See APIC.

iSCSI

Internet SCSI; see Section 5.5, “iSCSI servers”.

M

MAC

Media Access Control, a part of an Ethernet network card. A MAC address is a 6-byte number which identifies a network card. It is typically written in hexadecimal notation where the bytes are separated by colons, such as 00:17:3A:5E:CB:08.

N

NAT

Network Address Translation. A technique to share networking interfaces by which an interface modifies the source and/or target IP addresses of network packets according to specific rules. Commonly employed by routers and firewalls to shield an internal network from the Internet, VirtualBox can use NAT to easily share a host's physical networking hardware with its virtual machines. See Section 6.4, “Network Address Translation (NAT)”.

O

OVF

Open Virtualization Format, a cross-platform industry standard to exchange virtual appliances between virtualization products; see Section 3.8, “Importing and exporting virtual machines”.

P

PAE

Physical Address Extension. This allows accessing more than 4 GB of RAM even in 32-bit environments; see Section 3.7.1.2, “"Advanced" tab”.

PIC

See APIC.

PXE

Preboot Execution Environment, an industry standard for booting PC systems from remote network locations. It includes DHCP for IP configuration and TFTP for file transfer. Using UNDI, a hardware independent driver stack for accessing the network card from bootstrap code is available.

R

RDP

Remote Desktop Protocol, a protocol developed by Microsoft as an extension to the ITU T.128 and T.124 video conferencing protocol. With RDP, a PC system can be controlled from a remote location using a network connection over which data is transferred in both directions. Typically graphics updates and audio are sent from the remote machine and keyboard and mouse input events are sent from the client. VirtualBox contains an enhanced implementation of the relevant standards called "VirtualBox RDP" (VRDP), which is largely compatible with Microsoft's RDP implementation. See Section 7.4, “Remote virtual machines (VRDP support)” for details.

S

SATA

Serial ATA, an industry standard for hard disk interfaces. See Section 5.1, “Hard disk controllers: IDE, SATA (AHCI), SCSI”.

SCSI

Small Computer System Interface. An industry standard for data transfer between devices, especially for storage. See Section 5.1, “Hard disk controllers: IDE, SATA (AHCI), SCSI”.

SMP

Symmetrical Multiprocessing, meaning that the resources of a computer are shared between several processors. These can either be several processor chips or, as is more common with modern hardware, multiple CPU cores in one processor.

U

UUID

A Universally Unique Identifier -- often also called GUID (Globally Unique Identifier) -- is a string of numbers and letters which can be computed dynamically and is guaranteed to be unique. Generally, it is used as a global handle to identify entities. VirtualBox makes use of UUIDs to identify VMs, Virtual Disk Images (VDI files) and other entities.

V

VM

Virtual Machine -- a virtual computer that VirtualBox allows you to run on top of your actual hardware. See Section 1.1, “Virtualization basics” for details.

VRDP

See RDP.

VT-x

The hardware virtualization features built into modern Intel processors. See Section 1.2, “Software vs. hardware virtualization (VT-x and AMD-V)”.

X

XML

The eXtensible Markup Language, a metastandard for all kinds of textual information. XML only specifies how data in the document is organized generally and does not prescribe how to semantically organize content.

XPCOM

Mozilla Cross Platform Component Object Model, a programming infrastructure developed by the Mozilla browser project which is similar to Microsoft COM and allows applications to provide a modular programming interface. VirtualBox makes use of XPCOM on Linux both internally and externally to provide a comprehensive API to third-party developers.