DH Mobility Modder.NET nVidia Edition -- Introduction

--------------------------------------------------------------------------
Copyright 2002-2009 by Driverheaven, written by Ruud Ketelaars
All Rights Reserved
--------------------------------------------------------------------------
The author takes NO WARRANTY. This software is provided "AS IS", we take no
responsibility to any damage to hardware or software or to the loss of anything.
You may not reverse engineer or decompile the program. Last but not least you
are not allowed to Re-distribute this program or any part by any means
(E-mail, CD-ROM, Web-site, etc.) unless given written permission by Ruud Ketelaars.

All logos and names are property of the rightful owners.

This program has no affiliation with any of the companies.
Copyright 2002-2009 by Driverheaven, written by Ruud Ketelaars
Distribution of this text or parts or images needs permission of the Author


Readme

DH Mobility Modder.NET nVidia Edition -- Readme
DH Mobility Modder.NET nVidia Edition

http://www.driverheaven.net/nvmodtool
http://www.drivercleaner.net

=========================================
Table Of Contents
=========================================

- Support Development
- Usage instructions
- System Requirements
- Contact
- Copyright Notice

-----------------------------------------------------------------
Support Development
-----------------------------------------------------------------

If you use Mobility Modder.NET nVidia Edition either for personal or business use and wish to support development so I can continue to improve this product, please donate some money. Every little bit helps in my long hours of developing this tool to further aid the community.

Please use PayPal and use as recipient's email info@drivercleaner.net

For an easy link see the Donate section.

-----------------------------------------------------------------
Usage instruction
-----------------------------------------------------------------

Check the Instructions in the help file for detailed steps.

-----------------------------------------------------------------
System Requirements
-----------------------------------------------------------------

Microsoft .NET Framework 2.0 or higher must be installed.
It runs on all systems where .NET Framework 2.0 or higher can be installed.

-----------------------------------------------------------------
Contact
-----------------------------------------------------------------

Check the Contact page in the help file for details on how to contact us.

-----------------------------------------------------------------
Copyright Notice
-----------------------------------------------------------------

All logos and names are property of the rightful owners.

This program has no affiliation with any of the companies.


DH Mobility Modder.NET nVidia Edition -- Contact
Before reporting any problems directly or asking a question, please check the Support Forum and the FAQ to see if there is a known solution or answer.

We try to process every email we receive as fast as possible. However, it could take up to 48 hours before you get a response.

If a mobility chipset is not supported, send me an email with the chipset and where I can find an older driver.

WWW:
  • Homepage: http://www.driverheaven.net/nvmodtool
  • Homepage: http://www.drivercleaner.net
E-mail:
  • General: info@drivercleaner.net (Subject: Mobility Modder.NET nV General)
  • Technical Support: info@drivercleaner.net (Subject: Mobility Modder.NET nV Support)
Bug Report
Include the following information in the email:
  • Detailed description of the problem you have.
  • The mobile chipset you have.
  • What error message did you get and when did you get it. A screenshot of the error message will also help.
  • Windows version and .NET Framework version
Please add other things that you think could help.

Please attach the log files from the log folder in the installation directory. You can zip the log files into 1 zip file.


DH Mobility Modder.NET nVidia Edition -- System Requirements
Please ensure that you meet the following requirements or Mobility Modder.NET nVidia Edition will not run properly:
  • Computer where you can run .NET Framework 2.0 or higher on
  • .NET Framework 2.0 or higher
Mobility Modder.NET nVidia Edition should run on any computer with Windows where you can install the .NET Framework 2.0 or higher.

Supported operating systems for driver modification: Windows Vista, Windows XP


DH Mobility Modder.NET nVidia Edition -- History
Version 1.1.0.0 (August 2009)
Changes/Bugfixes

  • Fixed problems with modifying files
  • Improved modification speed

    • Version 1.0.0.0 (July 2009)
    Changes/Bugfixes

  • Rewritten most of the modification routines
  • Added more chipsets
  • Added Windows 7 support

    • Version 0.4.0.0 (August 2008)
    Changes/Bugfixes

  • Code improvements
  • Improved mobility tweaks

    • Version 0.3.0.0 (August 2008)
    Initial release version


DH Mobility Modder.NET nVidia Edition -- Donate
If you use Mobility Modder.NET nVidia Edition either for personal or business use and wish to support development so I can continue to improve this product, please donate some money. Every little bit helps in my long hours of developing this tool to further aid the community.

Please use PayPal and use as recipient's email info@drivercleaner.net

info@drivercleaner.net


DH Mobility Modder.NET nVidia Edition -- License Agreement
DH Mobility Modder.NET nVidia Edition License Agreement
Author: Ruud Ketelaars
Copyright 2002-2009 by Driverheaven (Heaven Media LTD)

DH MOBILITY MODDER.NET NVIDIA EDITION END-USER LICENSE AGREEMENT

IMPORTANT-READ CAREFULLY:
This Mobility Modder.NET End-User License Agreement ("EULA") is a legal agreement between you (either an individual or a single entity) and the Author for the SOFTWARE(s) identified above, which includes any associated SOFTWARE components, any media, any printed materials and any "online" or electronic documentation ("SOFTWARE"). By installing, copying, or otherwise using the SOFTWARE, you agree to be bound by the terms of this EULA. If you do not agree to the terms of this EULA, do not install or use the SOFTWARE.

1. GRANT OF LICENSE.
This EULA grants you the following rights:
Installation and Use. You may install and use an unlimited number of copies of the SOFTWARE. The SOFTWARE is licensed, not sold.

2. DISTRIBUTION.
You are not allowed to Re-distribute the SOFTWARE or any part by any means (E-mail, CD-ROM, Web-site, etc.) unless given written permission by the Author.

If you got permission to Re-distribute the SOFTWARE; give exact copies of the original SOFTWARE to anyone; and distribute the SOFTWARE in its unmodified form via electronic means (E-mail, CD-ROM, Web-site, etc.). Your distribution of the SOFTWARE will not entitle you to any compensation from the Author. You must distribute a copy of this EULA with any copy of the SOFTWARE and anyone to whom you distribute the SOFTWARE is subject to this EULA.

3. RESTRICTIONS.
Limitations on Reverse Engineering, Decompilation, and Disassembly.
You may not reverse engineer, decompile, or disassemble the SOFTWARE, except and only to the extent that such activity is expressly permitted by applicable law notwithstanding this limitation.

4. SEPERATION OF COMPONENTS.
The SOFTWARE is licensed as a single product. Its component parts may not be separated for use on more than one computer.

5. TERMINATION.
Without prejudice to any other rights, the Author of this SOFTWARE may terminate this EULA if you fail to comply with the terms and conditions of this EULA. In such event, you must destroy all copies of the SOFTWARE and all of its component parts.

6. COPYRIGHT.
The SOFTWARE is protected by copyright laws and international treaty provisions. You acknowledge that no title to the intellectual property in the SOFTWARE is transferred to you. You further acknowledge that title and full ownership rights to the SOFTWARE will remain the exclusive property of the Author and you will not acquire any rights to the SOFTWARE except as expressly set forth in this license. You agree that any copies of the SOFTWARE will contain the same proprietary notices which appear on and in the SOFTWARE.

7. MISCELLANEOUS.
Should you have any questions concerning this EULA, or if you desire to contact the Author for any reason, please contact by electronic mail at: info@drivercleaner.net

LIMITED WARRANTY

NO WARRANTIES.
The Author of this SOFTWARE expressly disclaims any warranty for the SOFTWARE. The SOFTWARE and any related documentation is provided "as is" without warranty of any kind, either express or implied, including, without limitation, the implied warranties or merchantability, fitness for a particular purpose, or noninfringement. The entire risk arising out of use or performance of the SOFTWARE remains with you.

NO LIABILITY FOR DAMAGES.
In no event shall the author of this SOFTWARE be liable for any damages whatsoever (including, without limitation, damages for loss of business profits, business interruption, loss of business information, or any other pecuniary loss) arising out of the use of or inability to use this product, even if the Author of this SOFTWARE has been advised of the possibility of such damages. Because some states/jurisdictions do not allow the exclusion or limitation of liability for consequential or incidental damages, the above limitation may not apply to you.


Mobility Modder.NET nVidia Edition -- Description

DH Mobility Modder.NET nVidia Edition -- Description

With the Mobility Modder.NET nVidia Edition you can modify original nVidia display drivers to work on your mobility chipsets.

User Account Control is only on Windows Vista.

When the "Use Mobility Tweaks" checkbox is checked then the program will add extra Mobility settings to the driver inf file.
When the "Use Quadro Tweaks" checkbox is checked then the program will add extra Quadro settings to the driver inf file. These tweaks will only be used on Quadro cards.
The Mobility and Quadro tweaks are found in other OEM inf files.

The current modification only works on Windows XP and Windows Vista drivers.

Current supported mobility chipsets:

Mobility Chipset | Windows 7 | Windows Vista | Windows XP
NVIDIA GeForce2 Go | x | x | x
NVIDIA GeForce4 410 Go 16M | x | x | x
NVIDIA GeForce4 420 Go | x | x | x
NVIDIA GeForce4 420 Go 32M | x | x | x
NVIDIA GeForce4 440 Go 64M | x | x | x
NVIDIA GeForce4 440 Go | x | x | x
NVIDIA GeForce4 448 Go | x | x | x
NVIDIA GeForce4 448 Go | x | x | x
NVIDIA GeForce4 460 Go | x | x | x
NVIDIA GeForce4 488 Go | x | x | x
NVIDIA GeForce4 4200 Go | x | x | x
NVIDIA GeForce FX Go 5100 | x | x | x
NVIDIA GeForce FX Go 5200 32/64M | x | x | x
NVIDIA GeForce FX Go 5200 | x | x | x
NVIDIA GeForce FX Go 5250/5500 | x | x | x
NVIDIA GeForce FX Go 53x0 | x | x | x
NVIDIA GeForce FX Go 5600 | x | x | x
NVIDIA GeForce FX Go 5650 | x | x | x
NVIDIA GeForce FX Go 5700 | x | x | x
NVIDIA GeForce FX Go 5700 | x | x | x
NVIDIA GeForce Go 6100 | x | x | x
NVIDIA GeForce Go 6150 | x | x | x
NVIDIA GeForce Go 6200 | x | x | x
NVIDIA GeForce Go 6400 | x | x | x
NVIDIA GeForce Go 6600 | x | x | x
NVIDIA GeForce Go 6600 GT | x | x | x
NVIDIA GeForce Go 6600 TE/6200 TE | x | x | x
NVIDIA GeForce Go 6800 | x | x | x
NVIDIA GeForce Go 6800 Ultra | x | x | x
NVIDIA GeForce Go 7200 | x | x | x
NVIDIA GeForce Go 7300 | x | x | x
NVIDIA GeForce Go 7350 | x | x | x
NVIDIA GeForce Go 7400 | x | x | x
NVIDIA GeForce Go 7450 | x | x | x
NVIDIA GeForce Go 7600 | x | x | x
NVIDIA GeForce Go 7600 GT | x | x | x
NVIDIA GeForce Go 7700 | x | x | x
NVIDIA GeForce Go 7800 | x | x | x
NVIDIA GeForce Go 7800 GTX | x | x | x
NVIDIA GeForce Go 7900 GS | x | x | x
NVIDIA GeForce Go 7900 GTX | x | x | x
NVIDIA GeForce Go 7900 SE | x | x | x
NVIDIA GeForce Go 7950 GTX | x | x | x
NVIDIA GeForce 7000M / nForce 610M | x | x | x
NVIDIA GeForce 7150M / nForce 630M | x | x | x
NVIDIA GeForce 7190M / nForce 650M | x | x | x
NVIDIA GeForce 8400M G | x | x | x
NVIDIA GeForce 8400M GS | x | x | x
NVIDIA GeForce 8400M GT | x | x | x
NVIDIA GeForce 8600M GS | x | x | x
NVIDIA GeForce 8600M GT | x | x | x
NVIDIA GeForce 8600M GTS / 9650M GS | x | x | x
NVIDIA GeForce 8700M GT | x | x | x
NVIDIA GeForce 8800M GTS | x | x | x
NVIDIA GeForce 8800M GTX | x | x | x
NVIDIA GeForce 9200M GS | x | x | x
NVIDIA GeForce 9300M G | x | x | x
NVIDIA GeForce 9300M GS | x | x | x
NVIDIA GeForce 9400M GS | x | x | x
NVIDIA GeForce 9500M G | x | x | x
NVIDIA GeForce 9500M GS | x | x | x
NVIDIA GeForce 9600M GS | x | x | x
NVIDIA GeForce 9600M GT | x | x | x
NVIDIA GeForce 9650M GT | x | x | x
NVIDIA GeForce 9700M GS/GT | x | x | x
NVIDIA GeForce 9700M GTS | x | x | x
NVIDIA GeForce 9800M GT | x | x | x
NVIDIA GeForce 9800M GTS | x | x | x
NVIDIA GeForce 9800M GTS | x | x | x
NVIDIA GeForce 9800M GTX | x | x | x
NVIDIA GeForce 103M G | x | x | x
NVIDIA GeForce 105M G | x | x | x
NVIDIA GeForce 110M G | x | x | x
NVIDIA GeForce 120M GT | x | x | x
NVIDIA GeForce 130M GT | x | x | x
NVIDIA GeForce 150M GTS | x | x | x
NVIDIA GeForce 160M GTS | x | x | x
NVIDIA GeForce 220M GT | x | x | x
NVIDIA GeForce 230M GT | x | x | x
NVIDIA GeForce 240M GT | x | x | x
NVIDIA GeForce 260M GTX | x | x | x
NVIDIA GeForce 280M GTX | x | x | x
NVIDIA Quadro2 Go/MXR/EX | x | x | x
NVIDIA Quadro4 500 GoGL | x | x | x
NVIDIA Quadro4 700 GoGL | x | x | x
NVIDIA Quadro FX 1500M | x | x | x
NVIDIA Quadro FX 1600M | x | x | x
NVIDIA Quadro FX 2500M | x | x | x
NVIDIA Quadro FX 2700M | x | x | x
NVIDIA Quadro FX 3500M | x | x | x
NVIDIA Quadro FX 350M | x | x | x
NVIDIA Quadro FX 360M | x | x | x
NVIDIA Quadro FX 3600M | x | x | x
NVIDIA Quadro FX 3700M | x | x | x
NVIDIA Quadro FX 370M | x | x | x
NVIDIA Quadro FX 540M | x | x | x
NVIDIA Quadro FX 560M | x | x | x
NVIDIA Quadro FX 570M | x | x | x
NVIDIA Quadro FX 770M | x | x | x
NVIDIA Quadro FX Go 700 | x | x | x
NVIDIA Quadro FX Go 1000 | x | x | x
NVIDIA Quadro FX Go 1400 | x | x | x
NVIDIA Quadro NVS 110M | x | x | x
NVIDIA Quadro NVS 120M | x | x | x
NVIDIA Quadro NVS 130M | x | x | x
NVIDIA Quadro NVS 135M | x | x | x
NVIDIA Quadro NVS 140M | x | x | x
NVIDIA Quadro NVS 160M | x | x | x
NVIDIA Quadro NVS 210S / NVIDIA GeForce 6150LE | x | x | x
NVIDIA Quadro NVS 300M | x | x | x
NVIDIA Quadro NVS 310M | x | x | x
NVIDIA Quadro NVS 320M | x | x | x
NVIDIA G70GL | x | x | x
NVIDIA G73M-X | x | x | x
NVIDIA G92-ES | x | x | x
NVIDIA MCP67M | x | x | x
NVIDIA MCP79MH | x | x | x
NVIDIA MCP79MX | x | x | x
NVIDIA MCP79SLI | x | x | x
NVIDIA MCP79U | x | x | x
NVIDIA NB9P-GE | x | x | x
NVIDIA NV31M Pro | x | x | x
NVIDIA NV31M | x | x | x
NVIDIA NV31GLM Pro | x | x | x
NVIDIA NV31GLM | x | x | x
NVIDIA NV36M Pro | x | x | x
NVIDIA NV36MAP | x | x | x
NVIDIA NV44 | x | x | x
NVIDIA NV44GLM | x | x | x
NVIDIA NV44M | x | x | x

* = This is beta and could work.


Frequently Asked Questions (FAQ)

DH Mobility Modder.NET nVidia Edition -- Frequently Asked Questions (FAQ)
- | Initialization Error when starting the program?
- | Does Mobility Modder.NET nVidia Edition require the .NET Framework?
- | Does Mobility Modder.NET nVidia Edition work with all Operating Systems?
- | Does ATI support this?
- | The mobility chipset displayed is not the same as there should be in the system?
- | How can I make a donation?
Q: Initialization Error when starting the program?

A: Most times this is caused by the .NET Framework that it is damaged or an old version. To fix this download the .NET Framework from the Microsoft site and reinstall that.
Q: Does Mobility Modder.NET nVidia Edition require the .NET Framework?

A: Yes, you need to have .NET Framework 2.0 or higher installed. You can download the .NET Framework here.
Q: Does Mobility Modder.NET nVidia Edition work with all Operating Systems?

A: It works on all operating systems where .NET Framework 2.0 or higher can be installed. It will work on 32bit and 64bit operating systems.
Q: Does nVidia support this?

A: No nVidia do not support Mobility Modder.NET nVidia Edition, if you install modded drivers you will get no support from nVidia, you must go to the DriverHeaven forums.
Q: The mobility chipset displayed is not the same as there should be in the system?

A: This is possible, because some mobility chipsets have the same ID only a different Sub ID. The chipsets use the same driver settings, so it is no problem.
Q: How can I make a donation?

A: To make a donation check the Donate page.


DH Mobility Modder.NET nVidia Edition -- Instructions
Usage instructions
  1. Download the newest desktop drivers from http://www.nvidia.com (or get them from Driver Heaven Downloads)
  2. Run the downloaded driver and let it extract or if the driver is in zip format then extract it manually into a folder, for example into C:\NVIDIA\"Windows version"\"Driver version" - but cancel the installation once the driver is extracted.
  3. Run Mobility Modder.NET nVidia Edition and browse to the driver in C:\NVIDIA\"Windows version"\"Driver version" - an example of nVidia GeForce 177.79 would be C:\NVIDIA\WinVista\177.79 - hit modify. Wait until driver is modified.
  4. In Vista, go to C:\NVIDIA\WinVista\177.79 (Or whatever the driver installation folder was called), and run the SETUP.EXE.
  5. Wait until Install is finished and reboot. Enjoy the new drivers !
It is recommended to remove the nVidia Display Driver.
After uninstall the old driver it is best to run Driver Cleaner.NET to remove all traces.
You might see a "Driver is not WHQL certified" message, ignore this and click to continue, as it is a side effect of the modification.