Acerca de AVI ReComp

AVI ReComp (ARC) es un editor AVI.
ARC no es un editor general de AVI, sino que está destinado a fines específicos y se dirige principalmente a los usuarios noveles.

Originalmente ARC fue diseñado con un solo propósito. Se trababa de hacer el vídeo suficientemente compatible en el contenedor AVI para reproducir en el Philips DVP-642/630 independiente del reproductor de DVD. Este reproductor fue el primero en tener la posibilidad de reproducir archivos DivX AVI. El DVP-642/630 reproducía DivX codificados con el Perfil Cine en Casa DivX. Este perfil restringía el reproductor a películas codificadas con las características básicas del codec. La mayoría de las películas encontradas fueron codificadas con el codec Xvid con características avanzadas tales como QPEL y/o múltiples puntos combados GMC. El 642 rechazó estas películas. ARC fue diseñado para permitir a un principiante recodificar (recomprimir) una película y remover estas características avanzadas haciendo así compatible la película con el reproductor.

El reproductor tenía otro punto débil en LA falta de capacidad para visualizar los subtítulos de una manera suficientemente grande o diferente. Para proporcionar una alternativa ARC fue diseñado con la capacidad de codificar subtítulos en un AVI a partir de un archivo de texto sub. SRT, ASS, SSA y SUB son algunos de los formatos permitidos. Los formatos ASS y SSA son particularmente atractivos ya que ARC proporciona la facilidad de editarlos, dando control sobre su posición en la pantalla, el tipo de fuente, tamaño de fuente, color de fuente, sombra, color de la sombra, contorno, color de contorno, negrita y subrayado.

En horas extras surgió la necesidad de otras características. Hasta la fecha ARC incluía los filtros de recortar y redimensionar, un editor de Logo, un editor de Bordes Negros, un editor de audio que incluye un control de volumen. También incluía la capacidad de comprimir con QPEL y/o Cuantificación de adaptación, junto con la posibilidad de crear un flujo de bits empaquetado o desempaquetado (activar/desactivar B-VOP).
Si eres suficientemente inteligente, incluso ARC permite editar sus scripts AVS.
La lista completa de características disponibles en ARC se puede encontrar en nuestro sitio web.

Hasta la fecha ARC soporta todo tipo de formatos válidos de contenedor MPEG-4 AVI. Los archivos de origen puede ser comprimidos con todos los codec MPEG-4 que proporciona un descodificador adecuado instalado y activo. ARC también puede usar archivos MPEG-4 codificados un contenedor de Medios DivX (*.divx), pero sólo si la película se ha renombrado como *.avi
Los archivos de salida siempre son archivos AVI codificados con el codificador Xvid.

En el futuro se espera que ARC continúe evolucionando para abarcar quizás los perfiles HD emergentes de Xvid, codecs HD AVC y tal vez el contenedor MKV.

Para más información acerca de esta traducción de ARC a Español de España, puede visitar la página web del traductor (NokiaJavi).

Valid XHTML 1.1! Valid CSS 2.1! Unicode Encoded Badge

© Derechos de autor 2009-2011 Michael Fisher & Mateusz Gola y Javier Tapia Torres


Instalación

ARC es muy fácil de instalar, siempre y cuando ciertas cosas se tengan en cuenta.

ARC instala una serie de aplicaciones auxiliares.
Una de las más importantes y potencialmente el más problemático es el codec Xvid.

Así como Xvid, ARC también le pedirá instalar VirtualDubMod, AviSynth y VobSub.

VirtualDubMod (VDM) ocupa poco espacio y ARC lo instalará en su propia carpeta por lo que mi consejo es que lo permita, incluso si tiene ésta u otra versión ya instalada.
Si está decidido a utilizar una versión que ya tiene instalada, entonces tenga en cuenta que ARC tiene la intención de utilizar VDM 1.5.10.2 o posterior. Utilizando ARC con versiones anteriores de VirtualDub es probable que produzca resultados indeterminados.
Sin embargo, si tiene la versión correcta de VDM instalada y ARC no la encuentra, vea el estado de VDM en Panel de control de ARC. Si no está bien, entonces tiene la posibilidad de navegar a la carpeta donde tenga instalado VDM. Asegúrese de que el estado se informa como OK.

Si tiene VobSub y AviSynth instaladas en la partición del sistema, entonces tiene dos opciones.
Puede optar por no instalarlas o puede hacer que ARC las sobrescriba. Ambas funcionan correctamente.
Una vez más compruebe en Panel de control de ARC para asegurarse de que AviSynth está bien instalado y ha sido encontrado, se indicará el estado con OK.
No hay verificación de VobSub. VobSub es un filtro de subtítulos y no es indispensable si no se va a trabajar con subtítulos.

Ahora llegamos a Xvid.
En primer lugar esto es muy importante. ARC busca y espera encontrar Xvid instalado en la partición del sistema. ARC lo instalará por defecto en "<System Root>:\Program files\" (NOTE: la localización de <System Root> es usualmente C:\) y no saldrá mal. Instalar Xvid en cualquier otro lugar es un gran NO. Aunque las bibliotecas Xvid serán detectadas y puede parecer que funciona bien, ARC tiene dificultades con la detección de la versión de XviD que está instalada.
En segundo lugar y de nuevo muy importante es usar sólo la versión de XviD que se incluye con ARC. Recuerde que ARC está destinado a utilizarse con Xvid 1.0.3 o posterior. Hasta la fecha sólo el original se basa en Xvid Koepi y Soluciones Xvid han sido utilizadas.
En tercer lugar no sobrescribir Xvid. Al actualizar a una versión más reciente SIEMPRE se desinstalará antes de instalar la versión actualizada.

Si va a instalar ARC por primera vez y no sabe si tiene ya instalado Xvid. Búsquelo en su menú de inicio, si lo encuentra, es probable que haya una opción de desinstalar. Si no existe a continuación busque en su utilidad de Agregar o quitar programas en el Panel de control de su equipo. Si no la encuentra, entonces probablemente no es instalado.

Piensa que puede tener más de Xvid escrito en el pasado o sospecha que su Xvid está dañado?
Bien sólo debe desinstalarlo con cualquiera de los métodos que acabo de describir y luego busque en la carpeta del sistema (System32 o SysWOW64) las bibliotecas Xvid (xvid.dll, xvidcore.dll, xvid.ax, xvidvfw.dll). Si los restos se encuentran entonces simplemente elimínelos. Ahora todo está limpio para trabajar.

Valid XHTML 1.1! Valid CSS 2.1! Unicode Encoded Badge

© Derechos de autor 2009-2011 Mateusz Gola y Javier Tapia Torres


Inicio rápido

Esta sección describe unos pocos pasos necesarios para realizar una sencilla recodificación.
La guía no incluye todas las características disponibles en ARC. Estos son sólo unos pasos básicos que permite nuevos usuarios familiarizarse con la interfaz y con las acciones realizadas con más frecuencia.

Comprobación del estado de aplicación

Antes de empezar, es importante comprobar si todas las aplicaciones necesarias y las herramientas están correctamente instaladas y detectadas.
Toda la información de estado se puede encontrar en la pestaña Panel de control de la sección Aplicaciones.
Todos los indicadores de estado (de VirtualDubMod, AviSynth y XviD) debe estar en verde y marcados como OK.

Cargando archivo origen

Para cargar el archivo de origen que vamos a utilizar el botón Cargar AVI disponible en la pestaña Origen y Destino de la sección Panel de control de Trabajos.

Guardando ruta de destino

Ahora tenemos que guardar la ruta de destino. La ruta para el nuevo archivo AVI recomprimido.
Tenga en cuenta, el nombre del archivo nuevo no puede ser el mismo que el nombre del archivo origen.
Para especificar la ubicación en la que el programa guardará el nuevo archivo creado vamos a utilizar el botón Guardar AVI disponible en la pestaña Origen y Destino de la sección Panel de control de Trabajos.

Configurando el nuevo tamaño del AVI

Este es el tamaño del nuevo archivo AVI recodificado.
Después de cargar un archivo de origen AVI ReComp configurará automáticamente el nuevo tamaño de AVI.
El tamaño puede ser igual al tamaño del archivo de origen, aunque no es obligatorio y puede especificar su propio valor.

Usando características adicionales

Ahora puedes usar una de las características adicionales disponibles en la pestaña Agregar.
Una de las características más utilizadas es la adición de (codificar) subtítulos.

Para añadir sus propios subtítulos vaya a la pestaña Agregar

Ahora puede marcar la casilla de verificación Activar/Desactivar para activar el módulo de subtítulos y use el botón Cargar subtítulos para cargar su propio archivo de subtítulo.

Vista Previa

Siempre es recomendable ejecutar la vista previa antes de iniciar el proceso de recompresión.
La vista previa puede ser generada en la pestaña Cola usando el botón Vista Previa.

Añadiendo un nuevo trabajo

Si todo va bien puede agregar un nuevo trabajo a la Cola.
Simplemente haga clic en el botón Añadir a la cola y un nuevo trabajo será añadido a la Lista de Trabajos con el estado "esperando...".

Comenzando recompresión

Si su trabajo esta ya en la Cola puede usar el botón Comenzar [image] para activar el proceso de recompresión.
El estado del trabajo cambiará a "ejecutando...".
El progreso de todas las operaciones en ejecución se mostrará en la barra de progreso principal.

Tenga en cuenta, el botón Comenzar se pondrá inactivo si hay ya un trabajo ejecutándose en la Cola. Para parar y abortar un trabajo que se está ejecutando actualmente puede usar el botón Parar.

Ahora puede minimizar ARC en el icono de la bandeja del sistema y concentrarse en algún otro trabajo.
Es probable que tenga que esperar desde varios minutos a varias docenas hasta que AVI ReComp complete el trabajo.

Cuando la recompresión esté hecha se le informará por medio de la ventana de Notificación de escritorio mostrada en el área de notificación del sistema.


Panel de control de trabajos

Esta sección contiene 5 pestañas.
Todas las pestañas se refieren al trabajo actual y su configuración.
Cada trabajo consta de un archivo de entrada y uno de salida especificado en la pestaña Origen y Destino.
Usando otras pestañas puede hacer uso de algunas de las características y opciones adicionales y finalmente puede añadir su trabajo a la Cola.

La sección de Panel de control de trabajos incluye las siguientes pestañas:

Origen y Destino
La pestaña Principal permite a los usuarios cargar películas, definir una ruta de salida y el tamaño de destino para los nuevos archivos AVI.
Agregar
Las características adicionales que pueden utilizarse como un suplemento para el proceso de recompresión principal.
Entre otros: Subtítulos, Redimensionar, Bordes Negros, Conversión de Audio.
Configurar
La pestaña Configuración incluye los ajustes adicionales que se pueden utilizar durante la recodificación.
La mayoría de ellos se refiere a las propiedades avanzadas de codificación.
Cola
Este es el lugar donde los trabajos deben ser añadidos a la lista de trabajos.
Después de añadir un número deseado de trabajos se puede iniciar la recompresión.
Registro
La ventana de registro almacena los informes y la información relativa a cada trabajo realizado a partir de la cola.


Origen y Destino

Esta es la primera pestaña disponible en la interfaz de usuario.
El botón Abrir AVI sirve para cargar los clips AVI.
Usando este botón solo puedes abrir archivos con extensión .avi.
AVI ReComp acepta archivos de vídeo válidos MPEG-4 incluidos en contenedores AVI o DivX Media.
Después de cargar el archivo de entrada todos los datos relativos del clip de origen serán mostrados en el panel derecho Datos.
Si la opción Elegir automáticamente ruta de salida está marcada - la ruta de salida será generada automáticamente después de que el archivo de origen sea cargado. AVI ReComp generará un nuevo nombre para el archivo de salida y será guardado en el directorio de origen. En este caso no tendrá que introducir la ruta de salida usando el botón Guardar AVI.
Si no usa la opción Elegir automáticamente ruta de salida, tendrá que mostrar a ARC dónde guardar el nuevo archivo AVI recomprimido.

Use el botón Guardar AVI para especificar la ruta para el nuevo archivo AVI recomprimido.
Nuevo Tamaño AVI es el tamaño AVI deseado que desea obtener después de la recompresión. ¡No es sólo el tamaño de la imagen (pista de vídeo)! Este es el tamaño del archivo AVI final, incluyendo la(s) pista de audio(s).
Nuevo Tamaño AVI está expresado en megabytes.
Puede elegir uno de los ajustes preestablecidos de la lista o también puede introducir su propio valor (a partir de 1 MB).

Por favor tenga en cuenta que puede que no sea posible reducir o incrementar el tamaño del archivo más de un 50%. Puede estar mas allá del poder del codificador lograr esa tasa de (re)compresión.
Y es por eso que por defecto - después de que el archivo origen se ha cargado - AVI ReComp automáticamente ajusta el Nuevo Tamaño AVI con el valor que más se aproxime al tamaño del archivo de entrada.

Para poder iniciar la recompresión tiene que especificar los archivos de entrada y salida (rutas).
Cuando esté listo puede ir a la pestaña Agregar o Configurar para elegir otros ajustes o directamente puede saltar a la pestaña Cola y añadir su trabajo a la lista de trabajos.


Agregar

Las funciones disponibles en la pestaña Agregar no son obligatorias y pueden ser usadas como un suplemento para el proceso de recompresión principal.
Algunas funciones como Recortar, Redimensionar, Bordes negros, Conversión de audio son accesibles solo si el archivo origen ha sido cargado.
En cualquier otro caso los botones permanecerán inactivos.
La ventana principal de la pestaña se divide en unos pocos paneles.
Cada panel contiene los botones y/o casillas de verificación para activar las opciones apropiadas.

La pestaña Agregar permite a los usuarios utilizar las siguientes funciones:

Recortar
Esta característica permite recortar la cantidad deseada de píxeles de los cuatro lados de la imagen.
La herramienta se puede utilizar para quitar bordes no deseados, los bordes de color negro o objetos.
Redimensionar
Con esta herramienta se puede cambiar el tamaño la imagen cambiando su resolución.
El cambio de tamaño se puede realizar manteniendo el original o creando una relación de aspecto nueva.
Bordes negros
La opción permite crear nuevos borde negro - campos oscuros que se añadirán en la parte superior y en la parte inferior de la imagen.
Puede ser útil para los usuarios que deseen codificar subtítulos y ponerlos fuera (en su mayoría por debajo) de la imagen principal.
Conversión de audio
La herramienta de conversión de audio es otra de las características opcionales disponibles en esta pestaña.
Utilizando esta opción se pueden recodificar pistas de audio incluidas en el archivo de origen cambiando su tasa de bits, tasa de muestreo y ajustar el nivel de volumen.
Subtítulos
Probablemente una de las funciones más utilizadas.
Permite al usuario añadir sus propios subtítulos que serán codificados e incorporados de manera permanente en el video.
Además, usando formatos de subtítulos ASS o SSA, es posible personalizar el color, posición y otros parámetros.
Logo
La característica de diseño para añadir logo o marca de agua transparente con el video.
También permite especificar el tiempo de duración, la posición y el efecto de atenuación del logo.


Recortar

La Herramienta de Recortar permite recortar la cantidad deseada de píxeles de los cuatro lados de la imagen.
La herramienta se puede utilizar para quitar bordes no deseados, los bordes de color negro o objetos.
La Herramienta de Recortar está disponible en la sección Resolución de la pestaña Agregar.
Es accesible solo cuando el archivo de origen se ha cargado. En caso contrario, ambas opciones, Recortar y Redimensionar están inactivas.

Después de activar la opción de Recortar dos ventanas aparecerán en la pantalla: Vista previa de Recorte y herramientas de Recorte.
La ventana de Herramientas de Recorte consiste en 4 botones que sirven para recortar la imagen de cada lado: izquierda, arriba, derecha y abajo.
Todos los valores de recortar están expresados en píxeles.
El Recorte se puede realizar mediante el uso de flechas pequeñas (botones arriba y abajo) para cada lado de la imagen. Sin embargo, no es posible introducir (tipear) los valores desde el teclado.
Cada acción de recorte es visible en la ventana Vista previa de recorte.
Puede ir a cualquier parte de la película arrastrando el deslizador de la derecha para avanzar o arrastrando el deslizador hacia la izquierda para retroceder.
El indicador AR corresponde a la relación de aspecto actual (la relación de la anchura de la imagen a su altura).

Si va a utilizar Redimensionar o las opciones de Bordes negros.
El Recorte se realiza siempre antes de redimensionar y de crear bordes negros.
Por lo tanto, se recomienda el uso de recortes, especialmente antes de hacer uso de las Herramientas de Redimensionar y antes de usar la opción de Bordes negros.

Por ejemplo: dispone de ajustes preestablecidos de bordes en negro que siempre se basan en la resolución corriente resultante (relación de aspecto).
Si usa la opción Recortar la resolución resultante cambiará y diferentes ajustes preestablecidos de bordes negros estarán disponibles en la ventana de ajustes de Bordes negros.
Por supuesto AVI ReComp siempre trata de atrapar este tipo de problemas de incompatibilidad y las colisiones y el usuario será informado convenientemente.

Es importante saber que la Vista previa de recorte se basa siempre en la imagen de origen pura (sin añadido de subtítulos, logo, bordes en negro u otras operaciones de la imagen).
Para generar la vista previa global, incluyendo todas las opciones que se usan (subtítulos, etc logo) utilice el botón de Vista Previa.
Como se mencionó anteriormente, la Herramienta de Recortar muestra los resultados en los cambios de resolución. Las aplicaciones de procesamiento esperan que el ancho resultante sea divisible por 4 y la altura resultante por 2. Es por eso que en algunas circunstancias, el cambio de tamaño adicional puede ser requerido después de que la opción Recortar sea usada. El ajuste adicional se realiza siempre de forma automática en segundo plano para que no tenga que preocuparse por eso. Los usuarios más avanzados pueden notar este efecto mediante la edición de scripts de AviSynth.

Después de establecer los valores deseados de recortes se puede utilizar el botón de Vista Previa para generar una vista previa global.
A continuación puede hacer clic en el botón Usar para guardar los cambios.
La opción Restaurar resetea todos los valores del recorte a 0.
El botón Cancelar puede ser usado para cancelar todos los ajustes implementados y volver al estado previo cuando el botón Usar fue usado.


Redimensionar

La Herramienta de Redimensionar permite cambiar la resolución de la imagen.
La característica puede ser especialmente útil si el archivo de origen tiene una relación de aspecto incorrecta (está estirado y no natural).
También se puede utilizar para cambiar el tamaño y reducir la resolución de vídeo a tamaño móvil.
La Herramienta de Redimensionar está disponible en la sección Resolución en la pestaña Agregar.
Es accesible sólo cuando el archivo de origen se ha cargado. De lo contrario, ambas opciones, Redimensionar y Recortar estarán inactivas.

Después de activar la opción de Redimensionar aparecerán dos ventanas en la pantalla: Vista previa de Redimensionar y Herramientas Redimensionar.
La ventana de Herramientas Redimensionar se compone de dos botones principales que sirven para cambiar la anchura o la altura del cuadro de vídeo.
El cambio de tamaño se puede realizar mediante el uso de flechas pequeñas (botones arriba y abajo) para cada coordenada de resolución. Sin embargo, no es posible introducir (tipear) los valores desde el teclado.
Los valores del cambio de tamaño se expresan en píxeles.
Cada acción de cambio de tamaño es visible en la ventana de Vista previa de Redimensionar.
Puede ir a cualquier parte de la película, arrastre el deslizador de la derecha para avanzar o arrastrando el deslizador hacia la izquierda para retroceder.

El puntero de la Resolución Original siempre informa al usuario sobre la resolución de entrada original.

En caso de que la opción Recortar haya sido usada antes y la imagen ha sido recortada entonces los valores de la Resolución Original hacen referencia a la imagen recortada. En estos casos una información adicional se mostrará - (después de recortar).

El indicador AR corresponde a la proporción actual (la relación de la anchura de la imagen a su altura).

La opción Mantener relación permite mantener constante la relación de anchura/altura sin tener en cuenta si se cambia los valores de anchura o altura.
Por ejemplo, digamos que el actual AR es 1.85 - si activa la opción Mantener relación y usa de una de las flechas para cambiar el ancho, la altura se cambiará automáticamente y se ajusta para mantener la proporción entre anchura y altura.

La tramitación de las solicitudes requieren que el ancho resultante sea divisible por 4 y la altura resultante por 2.
Es por eso que siempre ARC calcula automáticamente y ajusta los valores de anchura y altura para encontrar el número más cercano compatible.
Por ejemplo, si la actual es de 720 y se utiliza la flecha arriba para aumentar el ancho entonces el más cercano divisible por cuatro el valor será 724 y no 721.
Si va a utilizar las opciones Recortar o Bordes negros.
El cambio de tamaño siempre se realiza después de recortar y antes de la creación de bordes en negro.
Por lo tanto, para evitar posibles conflictos, es recomendable utilizar redimensionar después de Recortar y antes de hacer uso de la opción Bordes negros.

Por ejemplo: dispone de ajustes preestablecidos de borde negro que siempre se basan en la resolución corriente resultante (relación de aspecto).
Si usa la opción Redimensionar la resolución resultante va a cambiar y diferentes ajustes preestablecidos de borde negro estarán disponible en la ventana de ajustes de Bordes negros.
Por supuesto AVI ReComp siempre trata de atrapar a este tipo de problemas de incompatibilidad y las colisiones y el usuario será informado convenientemente.

Es importante saber que la Vista previa de redimensionar se basa siempre en la imagen de origen pura o la imagen recortada recientemente (independientemente de los subtítulos añadidos, logotipo o borde negro).
Para generar la vista previa completa incluyendo todas las opciones utilizadas (subtítulos, etc logo) utilice el botón Vista previa.

Después de configurar la resolución deseada puede usar el botón de Vista previa para generar la vista previa global.
A continuación puede hacer clic en el botón Usar para guardar los cambios.
La opción Restaurar reinicia el tamaño a los valores originales (iniciales).
El botón Cancelar puede ser usado para cancelar todos los ajustes implementados y volver al estado anterior cuando el borón Usar fue usado.

Si eliges una resolución mayor de 720x576 el programa mostrará una advertencia, en la que se advertirá de que las resoluciones superiores a 720x576 no son soportadas por todos los reproductores de DVD. Si estas seguro de que tu reproductor de DVD acepta dicha resolución pulsa el botón SI, de lo contrario pulse el botón NO y use las herramientas de Redimensionar o Recortar para ajustar el tamaño deseado.


Bordes negros

Los Bordes negros son áreas oscuras adicionales (en su mayoría negro) en la parte superior y en la parte inferior de la película. La mayoría de las películas AVI son codificadas en formato anamórfico (16:9 o "formato de pantalla ancha"). Cuando reproduce películas a partir de un monitor o un televisor 4:3 los bordes en negro son generados automáticamente por el televisor para ajustar la película a la pantalla. AVI ReComp puede crear bordes permanentes para que pueda poner los subtítulos en ellos.
A diferencia de los bordes negros generados automáticamente por la televisión, los bordes negros permanentes están codificados y se convierten en una parte de la imagen. Por lo tanto, no es posible apagarlos con el televisor o el menú del DVD. Y debido a que están codificados, es posible poner los subtítulos en ellos. La mayoría de las veces los usuarios deciden poner sus subtítulos en el borde inferior negro.
La opción de los Bordes negros puede encontrarla en la pestaña Agregar y solo puede ser activada cuando el archivo de origen ha sido cargado. En otro caso la opción permanecerá inactiva.

Si va a utilizar la herramienta Recortar o Redimensionar se recomienda usar la característica de Bordes negros al final - después de usar la herramienta de redimensionar.
El orden recomendado de uso de todas las herramientas de cambio de tamaño es el siguiente: recortar, redimensionar, bordes negros.

Pero por supuesto esto no significa que no pueda usar la opción de Bordes negros sin recortar o cambiar la resolución.
Para abrir la configuración avanzada de los bordes negros simplemente haga clic en el botón Configurar.

Configuración

La ventana de configuración contiene 4 modos predefinidos: Sin bordes, 4:3, 16:9 y Tamaño personalizado para la definición de una medida no estándar de los bordes negros.

La disponibilidad de ajustes preestablecidos concretos puede variar dependiendo de la resolución de la película actualmente en uso (definido).
Por ejemplo, si la película de origen ya está codificada en formato 16:9 o ha usado la Herramienta Redimensionar para redimensionar la imagen a un radio aspecto de 16:9, a continuación el ajuste preestablecido de 16:9 no estará disponible.

Vista previa, Usar, Cancelar

Después de elegir uno de los ajustes preestablecidos disponibles o especificar su propio tamaño de los bordes puede utilizar el botón de Vista previa para generar la vista previa.
El botón de Vista previa estará Desactivado en caso de que ninguna película se haya cargado.
A continuación puede hacer clic en el botón Usar para guardar todos los ajustes.
El botón Cancelar puede ser usado para cancelar todos los ajustes implementados y volver al estado previo cuando el botón Usar fue usado.


Conversión de Audio

AVI ReComp soporta archivos AVI con un número ilimitado de pistas de audio.
Sin embargo solo las dos primeras pistas se muestran en el Panel de Datos.
Si su archivo origen contiene mas de 2 pistas de audio - para ver el rest ode pistas y sus propiedades - haga clic en el botón Mostrar todas que aparecerá en la esquina inferior derecha del Panel de datos cada vez que el archivo de entrada AVI tenga más de 2 pistas de audio.

A pesar de que AVI ReComp es compatible con muchos formatos diferentes de audio (WAV, DTS, AC3, MP3, OGG), la herramienta de audio sólo se puede utilizar para pistas AC3 y MP3.
Vale la pena mencionar que una pista ac3 se puede convertir en una pista de mp3. La conversión inversa no es posible.
Por lo tanto, si la película contiene uno de estos formatos de audio (AC3 o mp3) puede utilizar el botón de Conversión de Audio desde la pestaña Agregar.
De lo contrario la opción estará desactivada.

Después de hacer clic en el botón de arriba verá la ventana de Herramienta de Audio.

Para activar todas las funciones de audio disponibles elija la opción Convertir pista(s) de audio.
Si la opción Desactivar conversión de audio está marcada las pistas de audio no serán recodificada. AVI ReComp recodificará solo la pista de video y todas las pistas de audio permanecerán intactas.

Tenga en cuenta que la función de conversión de audio siempre convierte las pistas de audio existentes en el archivo de origen.
Por lo tanto si la película incluye dos pistas de audio, ambas serán recodificadas con la misma configuración especificada en esta ventana.

Modo de codificación

El codificador LAME utilizado por AVI ReComp es capaz de codificar el audio con uno de sus tres modos de codificación: tasa de bits constante (CBR), tasa de bits media (ABR) y tasa de bits variable (VBR).

Tasa de bits constante (CBR)

En este modo, la tasa de bits será la misma para todo el archivo. Esto significa que cada parte de su archivo mp3 va a utilizar el mismo número de bits. Cada parte del audio se codifica con la misma tasa de bits constante. Es decir, el mismo número de bits se utilizan para representar a cada fragmento del audio independientemente de su complejidad. Las piezas complejas serán de menor calidad que las más sencillas.

Tasa de bits media (ABR)

En este modo, puede elegir una tasa de bits de destino y el codificador tratará de mantener constante una tasa de bits media con tasa de bits altas para las partes de la secuencia de audio que necesitan más bits. El resultado será de una calidad superior a CBR. La calidad percibida del sonido se incrementa con más bits, donde la complejidad es mayor y menor número de bits de donde es menor. Para la codificación de tasa de bits media, esta variación esté hecha dentro de los límites de la media especificada. Por lo tanto, el tamaño del archivo resultante puede ser calculado antes de que sea codificado.

Tasa de bits variable (VBR)

El codificador trata de mantener la calidad dada en todo el archivo eligiendo el número óptimo de bits para gastar en cada parte de su pista de audio. La complejidad del contenido de la información de audio varía con el tiempo. La calidad percibida del sonido se incrementa con más bits, donde la complejidad es mayor y menor número de bits de donde es menor. Para la codificación de tasa de bits variable, esta variación esté hecha dentro de amplios límites. Por lo tanto, no es posible saber el tamaño del archivo resultante con precisión antes de que sea codificado.. Produce archivos de muy buena calidad, aunque no es muy rápido.

Tasa de audio

Seleccione la tasa de bits de audio que se va a utilizar.
El rango de tasa de bits disponible es desde 32 hasta 320 kilobits por segundo.
Según el modo de codificación seleccionado la tasa de bits constante o promedio será utilizada.

Tenga en cuenta que la pista de audio va a ser recomprimida por lo que es imposible lograr una mejor calidad en comparación con la calidad de la fuente original.
Por lo tanto cuando está haciendo una conversión entre el mismo tipo de audio no tiene ningún sentido elevar la calidad más de lo que ya está codificado.

Tasa de muestreo

Puede cambiar la tasa de muestreo de la(s) pista(s) de audio, seleccionando uno de los valores disponibles de tasa de muestreo: 44100 y 48000 Hz.
Si no desea cambiar los parámetros de la tasa de muestreo elija No cambiar. El valor dado en el paréntesis corresponde al valor de la tasa de muestreo actual de la(s) pista(s) de audio original. Si la película contiene más de una pista de audio, las tasas de muestreo de ambas pistas se indican entre paréntesis.
Si el valor actual es, por ejemplo, 48000 Hz, entonces la opción para cambiar la tasa de muestreo a 48.000 Hz estará inactivo y sólo se podrá elegir entre No cambiar y 44100 Hz.

Control de volumen

La opción de Control de volumen permite ajustar el volumen de una nueva pista de audio creada.
Los niveles de volumen se dan en decibelios.
Mueva el control deslizante para establecer un nivel de volumen deseado.
Puede desactivar la opciones eligiendo 0. En este caso su sonido mantendrá el nivel de volumen original.
Todos los valores positivos incrementarán y los valores negativos se reducirán el nivel de sonido.
Puede hacer clic en un valor determinado y el deslizador se moverá automáticamente a la posición correspondiente.

Después de ajustar todos los parámetros haga clic en el botón Usar para usar todos los cambios.
Si marca la opción Desactivar conversión de audio y luego hace clic en el botón Usar todos los ajustes previamente definidos serán descartados y la(s) pista(s) de audio no serán convertidas.
El botón Cancelar puede ser usado para cancelar todos los ajustes implementados y volver al estado anterior cuando el botón Usar fue usado.


Subtítulos

Los formatos de subtítulos siguientes son compatibles y se pueden utilizar en AVI ReComp: TMPlayer (.txt), MicroDVD (.txt / .sub), SubViewer2 (.sub), SubRip (.srt), Advanced SubStation Alpha (.ass), SubStation Alpha (.ssa), VobSub (.sub/.idx).
Los subtítulos pueden ser activados en la pestaña Agregar marcando la opción Activar/desactivar.
Después de marcar esta opción puede cargar su archivo de subtítulos con el botón Cargar subtítulos.
En caso de que cambie de opinión puede desactivar los subtítulos cargados desmarcando la opción Activar/desactivar.

Tenga en cuenta que los subtítulos deben ser válidos de acuerdo a las normas vigentes. De lo contrario obtendrá un mensaje de error o la película no será recodificada correctamente. Incluso si su reproductor preferido de cine es capaz de representar y mostrar los subtítulos que no están al 100% correcto. Es por eso que siempre recomendamos el uso de subtítulos probados de fuentes de confianza y, además, verificados mediante el uso de un editor de subtítulos.

Adicionalmente puede utilizar el botón Auto cargar.
Si esta opción está activada durante la carga de un archivo AVI origen, AVI ReComp cargará automáticamente los subtítulos si están en el mismo directorio y el archivo de subtítulos tiene el mismo nombre que la película.
El estado de la opción de Auto carga El estado de la opción de carga automática se guarda al cerrar y restaurar en el arranque.

Configuración de Subtítulos

La Configuración de los subtítulos sólo está disponible para los formatos Advanced SubStation Alpha (.ass) y SubStation Alpha (.ssa).
Por lo tanto el botón Configurar permanecerá inactivo después de cargar otros tipos de subtítulos.

Si sus subtítulos se guardan en un formato de subtítulos distintos a ASS y SSA puede fácilmente convertirlos utilizando uno de los editores de subtítulos disponibles: Subtitle Processor o Subtitle Workshop.
No se puede utilizar y ajustar la configuración de los subtítulos para los subtítulos guardados en formato distinto de ASS o SSA.
Los demás subtítulos (por ejemplo, SRT o TXT) serán procesados como están con todos los ajustes internos (el formato de estilos).
Además, incluso si carga los subtítulos SSA o ASS no tiene que usar la opción Configurar para obtener sus subtítulos codificados. Cada archivo de subtítulos cargado se añadirá a la película. Incluso si no utiliza la opción Configurar. En caso de que haya cargado subtítulos SSA o ASS y no utilice la ventana de Configuración de los subtítulos serán procesados por defecto y todos los estilos definidos internamente en SubStation Alpha (originalmente creado por un editor de subtítulos que se utilizó para crear y guardar el archivo de subtítulos). Por lo tanto si sabe cómo crear subtítulos SSA o ASS con su editor favorito de subtítulos puede crear sus propios subtítulos y luego cargarlos a ARC, sin necesidad de utilizar la opción Configurar.

Importante: Todos los ajustes de subtítulos son almacenados para los subtítulos cargados actualmente. Los ajustes se restablecen a los valores por defecto cuando un archivo de subtítulos se cargue el nuevo.
Si desea guardar la configuración fija para todos los subtítulos cargados en el futuro puede utilizar la opción Siempre forzar estos ajustes descrita abajo.

En caso de que su subtítulo ASS o SSA no tenga ningún estilo definido dentro del guión de subtítulos, verá el siguiente mensaje:

Esto significa que AVI ReComp no fue capaz de encontrar cualquier tipo declarado en el archivo de subtítulos y todos los parámetros en la ventana de configuración se ajustarán a los valores por defecto. Pero en caso de si hay al menos un estilo definido ARC mostrará todos los valores declarados en este estilo.

A veces el archivo de subtítulos pueden contener más de un estilo. Entonces debería ver la siguiente ventana:

La ventana antes mencionada incluye todos los estilos disponibles guardados en el archivo de subtítulos. Pero sólo uno de ellos puede ser tratado como predeterminado y como estilo principal (el cual se puede cambiar a través de ARC). Otros estilos definidos en el guión de subtítulos se mantendrán intactos. Después de aceptar uno de los estilos disponibles ARC decodificará el estilo de parámetros y la mostrará en la ventana de Configuración.

La ventana principal de Configuración se divide en varios grupos de opciones. Puede configurar los parámetros de subtítulos siguientes: tipo de letra, tamaño, color, posición, sombra, contorno, estilo de fuente y codificación.
Pero hay algunas diferencias entre las opciones disponibles para la ASS y formatos SSA.

Tanto el Contorno como la Sombra tienen sus propios colores. Hay tres estilos de fuente disponibles: Negrita, Cursiva, Subrayado. | Sólo hay un color para el Contorno y la Sombra. Sólo hay 2 estilos de fuente: Negrita y Cursiva.

Tipo de Letra, Tamaño, Color, Posición, Sombra, Contorno, Estilo

Creo que estos parámetros y su uso no requieren una descripción más detallada.

Tenga en cuenta que el tamaño de la fuente ASS y SSA siempre se ajusta a la resolución de la imagen (incluidos los parámetros de cambio de tamaño). Por lo que el mismo tamaño de fuente puede verse de manera diferente en diferentes resoluciones de salida.

Codificación

Esto especifica el conjunto de caracteres o la codificación de la fuente y en varios idiomas de instalaciones de Windows que permite el acceso a los caracteres usados en varios idiomas. Por lo general, debe usar el Predeterminado del Sistema y el conjunto de caracteres será automáticamente detectado por los filtros de procesamiento. Pero en caso de que use dos idiomas diferentes en su sistema operativo y tengan diferentes conjuntos de caracteres de la fuente se puede elegir la codificación correspondiente de la lista.

Ajustes Preestablecidos

Es posible guardar la configuración actual como un ajuste preestablecido de subtítulos.
Puede guardar un número ilimitado de configuraciones y fácilmente utilizarlas en el futuro.
Para crear un ajuste preestablecido de subtítulos elija todas las opciones que desee e introduzca el nombre del nuevo ajuste preestablecido. A continuación, haga clic en el botón Crear para guardar el ajuste preestablecido.

Para cargar uno de los ajustes preestablecidos de subtítulos existentes haga clic en el botón Cargar.
Si no hay ajustes preestablecidos guardados entonces el botón Cargar estará inactivo.
Si tiene por lo menos un ajuste preestablecido guardado verá la ventana de Ajustes subtítulos preestablecidos que permite al usuario elegir uno de ajustes preestablecidos de subtítulos definidos, así como para eliminar un ajuste preestablecido deseado.

Nota importante: Los ajustes preestablecidos se crean y guardan por separado para los formatos de subtítulos SSA y ASS con respecto a las diferencias entre ambos formatos.
Esto significa que los ajustes preestablecidos creados para los subtítulos ASS no estarán disponibles para los SSA y vise versa.

Fijar Estilos

Cada archivo de subtítulos ASS y SSA tiene definido internamente estilos dentro del archivo.
ARC puede detectar y capturar estos estilos internos.
Y es por eso que todos los ajustes son restablecidos después de cargar un archivo de subtítulos nuevo.
Pero es posible que desee guardar de forma permanente sus ajustes favoritos y usarlos en el futuro independientemente del estilo ASS/SSA definido internamente.
Esto se puede hacer mediante el uso de la opción Siempre forzar estos ajustes.

Marque esta opción si desea que la configuración actual sea utilizada siempre para este tipo de subtítulo. El estilo guardado siempre se utilizará en el futuro en lugar de los estilos por defecto declarados dentro de los archivos ASS. Tenga en cuenta, que funciona independientemente y por separado para ASS y formatos SSA. Así que puede guardar el estilo fijo para los ASS y no para los SSA y vise versa. Después de guardar el estilo permanente verá el indicador de estilo fijo en la pestaña Agregar.

Solo el estilo definido permanente para subtítulos ASS. Se utilizará para todos los subtítulos ASS cargados. | Los estilos definidos permanentes tanto para los subtítulos ASS como SSA. El primero será utilizado para todos los subtítulos ASS cargados y el segundo para todos los SSA.

Cuando la opción está activada, ni siquiera tendrá que abrir la ventana de Configuración en el futuro. El estilo fijo siempre se utilizará para todos los diálogos en el archivo de subtítulos.
Para desactivar el estilo fijo abra la ventana de Configuración y desmarque la opción y luego use el botón Usar.

Vista previa, Restaurar, Usar, Cancelar

Después de ajustar todos parámetros puede utilizar el botón de Vista previa para generar la vista previa y comprobar el aspecto de sus subtítulos.
El botón de Vista previa está desactivado en caso de que no se haya cargado una película.
A continuación puede hacer clic en el botón Usar para guardar los cambios.
La opción de Restaurar restaura todos los ajustes por defecto (estilos predeterminados). Por lo tanto, si hay estilo declarado en el archivo de subtítulos todos los parámetros se restaurarán a los estilos internos de ASS / SSA. De lo contrario ARC utilizará su propio estilo por defecto (Tahoma, 22, blanco, con contorno negro).
El botón de Cancelar se puede utilizar para cancelar todos los ajustes implementados y para volver al estado anterior cuando el botón Usar fue usado.

Subtítulos VobSub

Los subtítulos VobSub consisten en una pareja de dos archivos: IDX y SUB.
No importa cuál de ellos (SUB o IDX) será (auto) cargado a ARC.
Pero ambos deben estar en el mismo directorio y tener los mismos nombres.
Si la pareja se ha cargado con éxito después el botón de Configurar cambiará a botón VobSub.

Puede utilizar el botón para elegir el idioma de los subtítulos VobSub.

Referencias

  • SubStation Alpha - formato de descripción en la Wikipedia.
  • Subtitle Processor - uno de los editores de subtítulos mejores y más avanzados para la edición, la reparación y la traducción de los subtítulos para las películas.
  • Subtitle Workshop - herramienta de edición gratuita de subtítulos que soporta casi todos los formatos de subtítulos disponibles.
  • Aegisub - avanzado editor de subtítulos para Windows y UNIX, como Linux, Mac OS X y BSD.


Logo

Usando AVI ReComp puede agregar fácilmente su propio logo (marca de agua) en la pista de vídeo.
Por el momento, sólo imágenes BMP de 24 bits son soportadas.
La función de logo puede ser habilitada en la pestaña Agregar marcando la opción Activar/desactivar.
Después de marcar esta opción puede cargar su archivo de logo usando el botón Cargar logo.
En caso de que cambie de opinión puede desactivar el logo cargado desmarcando la opción Activar/desactivar.

Recuerde que las dimensiones del logotipo no pueden ser mayor que el tamaño del cuadro de vídeo. De lo contrario obtendrá un mensaje de advertencia.

Tenga en cuenta que el tamaño del cuadro de vídeo actual no puede ser igual a la resolución del origen en caso de utilice las herramientas Recortar o Redimensionar antes.

Ajustes del Logo

Puede acceder a los ajustes del logo haciendo clic en el botón Configurar.
Aunque no es obligatorio el uso de la configuración de Logo. Si no lo utiliza AVI ReComp utilizará su configuración predeterminada. El logo aparecerá en la esquina superior izquierda durante 10 segundos.

La configuración del Logo se compone de los siguientes parámetros: posición, tiempo de inicio, duración, transparencia y desvanecimiento.

Posición

Aquí puede definir la posición vertical y horizontal del logo en pixeles.
Los valores por defecto son 0 y 0 para las dos coordenadas. Esto significa que su logo se añadirá en la esquina superior izquierda.
El aumento de los valores de las coordenadas verticales y/u horizontales hará al logo moverse en consecuencia a abajo ya a la derecha.
La mejor manera de comprobar los resultados es el uso de la opción de vista previa para ver la posición exacta del logo.

Tiempo de Inicio

Define el tiempo de inicio donde se empezará a mostrar el logo en la pantalla.
Hay tres campos disponibles para: horas, minutos y segundos.
Por ejemplo, si desea que su logo aparezca después de un minuto debe establecer el tiempo de inicio a 0:1:0.
La configuración por defecto 0:0:0 significa que el logo aparecerá desde el principio de la película.

Duración

Define el tiempo de duración para mostrar el logo en la pantalla.
Hay tres campos disponibles para: horas, minutos y segundos.
Por ejemplo, si desea que su logo se muestre durante 25 segundos debe establecer el tiempo de duración a 0:0:25.
La configuración por defecto 0:0:10 significa que el logo se mostrará durante 10 segundos a partir de la hora de inicio.

Transparencia

La transparencia se expresa por el valor de mezcla alfa (desde 0 a 255).
El valor = 0 significa que el logo será 100% transparente y no será visible en la pantalla. La mezcla alfa = 255 significa que la imagen del logo será casi totalmente desprovista de transparencia. Valores de entre 100 a 128 dará una superposición discreta agradable.

Desvanecimiento

Determina la longitud de tiempo de fade-in(Fundido de Entrada)/fade-out(Fundido de Salida) y está expresada en cuadros.
Los cuadros de aquí se utilizan como una unidad de tiempo. Un cuadro es en su mayoría igual a 1/24, 1/25 o 1/30 de segundos en función de la velocidad de fotogramas de la película original.
Por ejemplo, si el FPS de la película = 25,00 y modifica el tiempo del fade-in a 50 entonces el logo estará desvaneciendo durante 2 segundos.

Vista Previa, Usar, Cancelar

Después de ajustar todos los parámetros puede usar el botón Vista Previa para generar la vista previa y comprobar el aspecto de su logo.
El botón de Vista Previa se desactivada en caso de que no se haya cargado una película.
A continuación puede hacer clic en el botón Usar para guardar todos los ajustes.
El botón Cancelar puede ser usado par cancelar todos los ajustes implementados y volver al estado previo cuando el botón Usar fue usado.


Configurar

La pestaña Configurar incluye ajustes adicionales que pueden ser usados durante la recodificacion.
La mayoría de ellos se refiere a la configuración avanzada de codificación y no se recomienda cambiarlos a menos que realmente sepa para que se utilizan.
Todas las opciones visibles en la pestaña Configurar son específicas para un determinado trabajo. Esto significa que puede utilizar combinaciones de configuraciones diferentes para cada trabajo. Podrá activar algunas opciones para un trabajo y desactivarlas para otro.
Tenga en cuenta, si el trabajo ya se ha agregado a la cola no es posible cambiar su configuración.
Todos los ajustes disponibles en esta pestaña se guardan siempre cuando ARC se cierra y son restaurados en el siguiente inicio.
Para restaurar la configuración por defecto del programa use el botón Ajustes por defecto.

Prioridad

Especifica la prioridad del hilo principal de la codificación. Todas las aplicaciones de codificación (VirtualDubMod, Azid, Lame) se ejecutarán con la prioridad especificada.
Esto es equivalente a la prioridad del proceso que se puede encontrar en el Administrador de tareas de Windows.

Si la prioridad es demasiado alta, el proceso puede consumir toda la CPU, lo que afecta drásticamente el rendimiento y puede perder el control en su sistema. Tenga cuidado al usar los modos Alta o Tiempo Real. Por otro lado, si la prioridad es demasiado baja, el proceso no puede obtener suficientes ciclos de CPU para hacer su trabajo, también afectan el rendimiento y la eficiencia.

Mostrar VirtualDubMod

VirtualDubMod es la principal herramienta utilizada para el procesamiento de vídeo.
Por defecto las ventanas están ocultas e invisibles. La aplicación se ejecuta en segundo plano.
Algunos usuarios pueden querer ver las ventanas de VDubMod durante la recompresión. Y esto es lo que hace esta opción.

Mostrar ventana estado Xvid

Xvid es un codificador MPEG-4 de vídeo utilizado por VirtualDubMod en el proceso de recompresión.
AVI ReComp utiliza el modo de codificación de 2 pasadas.
Los usuarios más avanzados puede que quieran ver la Ventana de estado de Xvid que es una representación gráfica de la recompresión y puede ofrecer algunos detalles técnicos e información sobre el proceso de cuantificación.

Desactivar B-VOPs

B-frames son una especie de fotogramas de vídeo - los llamados fotogramas bidireccionales, que representan uno de los algoritmos de vídeo disponibles.
Principalmente aumenta la capacidad de compresión de video y por defecto está habilitado.
En caso de que sepa exactamente que son los fotogramas B puede utilizar esta opción para excluir este tipo de imágenes de vídeo del proceso de codificación.

Usar codificación QPel

Qpel (un cuarto de píxel) es uno de los algoritmos de codificación avanzados relacionados con la estimación y compensación del movimiento. Está diseñado para mejorar la compresión de vídeo y para aumentar la calidad del macrobloque.
Los vídeos codificados con vectores de movimiento de precisión de cuarto de píxel requieren el doble de potencia de procesamiento y mucho más para codificar. Por desgracia - hasta ahora - la mayoría de los reproductores de DVD independientes no son compatibles con este tipo de algoritmos de codificación y por defecto esta opción está deshabilitada.
Sin embargo, los nuevos reproductores independientes son capaces de decodificar los videos codificados con Qpel.

Active esta opción solo si está seguro de que su reproductor independiente soporta este algoritmo, o en caso de que vaya a ver la película solamente en su PC.

Usar Cuantificación Adaptativa

El ojo humano es mucho menos perceptivo a los errores de codificación en campos muy oscuros o muy claros.
La Cuantificación adaptativa comprime muy oscuras o brillantes las zonas más fuertes que las. más medianas
Los bits guardados por supuesto pasarán otra vez y de esa manera es posible obtener un poco de calidad en las partes de mediano brillo de la imagen que son más perceptibles para el ojo humano.

Al activar esta opción también se puede utilizar La Cuantificación Variable Adaptativa (VAQ) si tiene la versión adecuada de Xvid instalada.

Usar modo Turbo

Esta opción desactiva ciertas funciones matemáticas y algoritmos para acelerar la codificación.
Con esta opción se pueden obtener hasta un 20% más de velocidad pero a costa de cierta pérdida de calidad.

Borrar archivos temporales

Durante la recompresión AVI ReComp siempre crea algunos archivos temporales que se utilizan en procesos particulares.
Todos los archivos temporales siempre se almacenan en la ubicación de salida en el directorio con el sufijo [AVI ReComp temp].
Normalmente todos los archivos por defecto son eliminados después de cada de recompresión exitosa.
Pero en caso de si el trabajo a fallado puede que los archivos no se hayan borrado y se puede utilizar con el fin de identificar las posibles razones de un error.
Si no selecciona la opción entonces los archivos temporales nunca se eliminarán y siempre estarán presentes en el directorio de salida.

Borrar archivo origen

También el archivo de origen puede ser removido después de una recompresión exitosa.
La opción puede ser útil en caso de que si usted no desea utilizar el archivo de origen más y quieres ahorrar el espacio en disco.
Tenga en cuenta, incluso si la opción está activada el archivo de origen no se eliminará si el trabajo no tiene éxito.

Editar script avs

AviSynth es un programa de servidor que actúa como marco de un editor de vídeo no lineal.
AVI ReComp crea scripts AviSynth especiales, que son archivos de texto escrito en el lenguaje de script AviSynth.
Estos scripts son cargados y utilizados por VirtualDubMod.
Los usuarios más avanzados pueden editar y modificar los scripts antes de que un determinado trabajo comience.
Si la opción está activada entonces después de que todas las pistas de video y audio sean demultiplexadas verá una nueva ventana que contiene todas las funciones de procesamiento utilizadas.

El botón Restaurar se puede utilizar para restaurar todas las entradas del script original AviSynth creado por AVI ReComp.
Si utiliza el botón Cancelar entonces todos los nuevos cambios serán descartados y ARC se procederá sin necesidad de modificar el script original de avs.
Para guardar y utilizar las modificaciones haga clic en el botón Usar.


Cola

Existen dos opciones principales disponibles en este lugar: Vista Previa y Cola.

Vista Previa

Es posible previsualizar la película con todos los nuevos ajustes. Puede generar la previsualización general y final usando el botón Vista Previa.
Tenga en cuenta que el botón se activa solo si el archivo de origen está cargado. De lo contrario el botón permanece desactivado.

Por favor tenga en cuenta que el botón Vista Previa previsualiza el archivo de entrada actualmente cargado y sus ajustes, no el trabajo actual seleccionado en la cola.
Del mismo modo toda la información del panel Datos siempre se refiere a el clip actualmente cargado, no a el trabajo seleccionado de la lista de trabajos.

Cola

También en este lugar se pueden añadir los trabajos a la cola.
Así que antes de iniciar el proceso de recompresión hay que añadir el proyecto actual a la lista de trabajo (la cola).
Pulse el botón Añadir a la Cola para añadir la configuración actual a la cola de trabajos.
Tenga en cuenta, el botón estará desactivado si no hay ningún archivo de entrada o/y salida especificado en la pestaña Origen y Destino.
También está desactivado en algunos otros casos, por ejemplo, si una de las aplicaciones necesarias como VirtualDubMod no es detectada en su sistema.
Cada trabajo tiene su nombre. El nombre del trabajo se basa siempre en el nombre del archivo de salida especificado en la pestaña Origen y Destino.
Mientras se añade el trabajo a la cola de ARC analiza y comprueba todos los posibles conflictos y las condiciones (por ejemplo: el espacio libre en el disco, todas las aplicaciones externas necesarias, ajustes de resolución y logotipo, etc.) Por lo que será informado si se encuentra cualquier conflicto.
Cada trabajo tiene su estado. Todos los nuevos trabajos en la cola tendrán el estado "en espera". Cuando comience la cola el primer trabajo en espera se lanza y su estado cambia a "ejecutando". En caso de que algo vaya mal el trabajo tendrá el estado "ha fallado".

Hay tres botones disponibles para gestionar la lista de trabajos.
Los botones Subir y Bajar están activados solo si hay más de un trabajo en la cola y uno de esos trabajos está seleccionado. En los demás casos ambos botones están desactivados.
El botón Eliminar puede ser usado solo si un trabajo deseado está seleccionado.
Tenga en cuenta, no puede eliminar un trabajo que se está ejecutando. Para eliminar el trabajo en ejecución tiene que usar el botón Parar (para abortar el proceso de recodificación) y a continuación - cuando el estado del trabajo a cambiado a "abortado" - puede seleccionarlo y eliminarlo.

Cuando la opción Restablecer ajustes de trabajos está marcada a continuación después de añadir un trabajo a la cola todos los ajustes serán reseteados a la configuración original y predeterminada. Esto reseteará todo - ajustes de logo, subtítulos, audio y resolución. También se restaurará la pestaña Origen y Destino y el panel de Datos a sus estados iniciales y se vaciarán todos los campos en estos lugares.

SI marca la opción Apagar sistema al finalizar los trabajos su PC se apagará automáticamente después de que todos los trabajos se hayan completado.

Una vez que haya agregado todos los trabajos a la cola (puede ser solo un trabajo), puede utilizar el botón Comenzar para comenzar el proceso de codificación.
Tiene que saber que el programa tiene que recodificar toda la película (todos sus cuadros) y es un proceso muy estresante para cada equipo.
El proceso de recompresión puede tardar unos minutos o incluso unas pocas horas dependiendo de la potencia de su PC y la estabilidad, el tamaño del archivo de origen y otros factores.
En cualquier momento puede usar el botón Parar para abortar el proceso de codificación y parar la cola.


Registro

Esta es la última pestaña disponible en el grupo del Panel de Control de Trabajos.

La ventana de Registro se usa para mostrar información útil acerca de los procesos en curso.
El registro es útil sobre todo para fines informativos y depuración únicamente.
Puede limpiar la ventana del Registro en cualquier momento haciendo clic en el botón Borrar registro.

Por otra parte, al mismo tiempo, el programa genera automáticamente los archivos de registro.
Los archivos de registro son los archivos de texto con la extensión *.log que pueden ser útiles para la resolución de problemas.
El progreso de la recodificación se guarda para cada trabajo por separado en los archivos de registro.
Todos los archivos de registro tienen el sufijo "[AVI ReComp]" y se pueden encontrar en las carpetas de archivos de destino.

Por favor asegúrese de que los archivos de registro publicados en nuestro foro, para solucionar problemas, no contienen los títulos de películas o cualquier otra información personal (rutas) que conlleve a sus películas caseras por error, se interpretará como material de derechos de autor. También tenga en cuenta que incluso si usted es dueño del DVD y el país dispone de leyes de Uso Justo, en efecto, no puede aplicarse en nuestro país así que por favor respete esta regla para todos nuestros beneficios.
Cualquier mensaje descubierto en el foro que no cumpla los requisitos será borrado sin más discusión.


Aplicaciones

La sección de Aplicaciones de ARC esta formada por 2 pestañas: Panel de Control e Interfaz.
La sección está apartada y situada en la parte inferior de cada ficha para que esté siempre accesible.

La sección Aplicaciones incluye las siguientes pestañas:

Panel de Control
La pestaña controla el estado de todas las aplicaciones externas indispensables.
Interfaz
Todas las opciones relativas con la interfaz de usuario de ARC (idioma, notificaciones, etc.)


Panel de Control

EL Panel de Control es la primera pestaña de la sección de Aplicaciones.
Sirve para informar sobre el estado de las aplicaciones auxiliares de ARC (Xvid, VirtualDubMod y AviSynth).
También proporciona una opción para navegar manualmente a la ubicación de VirtualDubMod en caso de que ARC no lo encuentre. No tiene que instalar VDubMod viene con el paquete ARC. Pero por favor recuerde que ARC tiene la intención de ser utilizado con VirtualDubMod 1.5.10 o posterior. Otras versiones no serán aceptadas.
Si una aplicación auxiliar está activa y ha sido encontrada ARC informa sobre su Estado con OK (verde).
Cualquier otro Estado como resultado N/A debe ser investigado.


Interfaz

Esta sección incluye todas las opciones relacionadas con la GUI (Interfaz Gráfica de Usuario)

Idioma

El idioma deseado puede elegirlo de la lista de idiomas.
Los nombres de los idiomas siempre se muestran en el idioma del sistema operativo.
AVI ReComp ofrece soporte completo de Unicode para todos los elementos de la GUI.
Si la traducción correspondiente del idioma elegido está incompleta, entonces verá la siguiente advertencia:

Globos de Consejos

Después de habilitar esta opción se podrá ver información sobre herramientas cuando el usuario desplace el cursor sobre un elemento de la interfaz gráfica de usuario (botones, opciones).
La información sobre herramientas se muestra en cada ventana de AVI ReComp.

Asociación de archivos AVI

Es posible asociar ARC con archivos AVI.
Después de usar esta característica una nueva acción será añadida a el menú contextual del botón derecho en el Explorador de Windows para todos los archivos con extensión *.avi.
El icono de la izquierda indica que la opción requiere permisos de administrador para usarlo. En las nuevas versiones de Windows puede ver el UAC (Control de Cuentas de Usuario) del sistema después de hacer clic en el botón Asociar con archivos AVI.
Después de que la asociación se haya añadido correctamente el botón cambiara su nombre a Remover asociación y permitirá remover la asociación creada.
Tenga en cuenta, no será una acción principal que se ejecuta al hacer doble clic en el archivo. Además, ningún elemento de menú contextual será reemplazado.
AVI ReComp siempre crea una nueva e independiente entrada de menú y la principal (primaria) asociación de archivos AVI será preservada. Esto significa que los archivos AVI seguirán asociados a su reproductor de medios favorito.

Notificaciones

las notificaciones se muestran en la bandeja del sistema en forma de una pequeña ventana incluyendo información sobre el número de archivos con éxito recomprimidos.
Esto aparece cuando todos los trabajos de la cola se han completado.
Las notificaciones de escritorio se muestran solo en dos casos:
- si ARC está oculto en la bandeja del sistema
- si la ventana de ARC está inactiva y oculta detrás de otra del Explorador de Windows.

La opción Notificaciones - Configuración permite ajustar algunas propiedades de la ventana de notificación.
Puede modificar la duración (el tiempo que se muestra) y la transparencia de la ventana de notificación.

Siempre visible

Active esta opción si quiere mantener ARC encima de otras ventanas.
La ventana principal de ARC siempre estará encima de otras aplicaciones asi que puede fácilmente arrastrar y soltar archivos AVI desde el Explorador de Windows.

Nuevas versiones

Las nuevas versiones de AVI ReComp pueden ser comprobadas manualmente usando el botón Comprobar ahora y también automáticamente al inicio si la opción Comprobar nuevas versiones al iniciar está activada.
ARC siempre buscará nuevas versiones estables ya que las versiones beta no son publicadas y solo estás disponibles para los beta testers.


Guía de Traducción

Introducción

Si desea crear o actualizar las traducciones puede utilizar los archivos existentes en los directorios de instalación AVI ReComp pero es mucho mejor descargar un Paquete de Traducción especial de nuestro servidor.
Cada vez que voy a lanzar una nueva versión también hay un paquete especial de traducción para la próxima versión de AVI ReComp.
Los paquetes contienen todas las referencias de traducción textual utilizados en una determinada versión de AVI ReComp - todas las cadenas de la interfaz, todos los documentos y guías y archivos de ayuda.

Traducir el archivo de idioma principal

1.

Descargue poEdit - archivos de editor PO código abierto.
Si le gusta trabajar bajo el sistema Linux puede utilizar una gran herramienta Lokalize.
Esta guía se basa en el uso de poEdit.

2.

Busque el archivo template.po.
Debe encontrarlo en el subdirectorio "\Locale" del Paquete de Traducción.
También puede encontrar la última plantilla en el subdirectorio "\Locale" en la carpeta de instalación principal de AVI ReComp.
Copie el archivo donde quiera y cambie el nombre a default.po

3.

Abra su archivo default.po con poEdit (Archivo -> Abrir)

4.

Vaya a Catálogo - > Opciones.
Verá la siguiente ventana:

¡Tiene que rellenar todos los campos correctamente de lo contrario su traducción no funcionará correctamente!
Por favor introduzca el nombre del proyecto y versión, su alias y una dirección de correo electrónico, el idioma de su traducción.
Establezca los tipos de codificación a UTF-8.

Formas Plurales:
Una sola forma (Japonés, Coreano, Húngaro, Turco)
Algunos idiomas sólo requieren una sola forma. No hay distinción entre el singular y el plural.
Una entrada de la cabecera apropiada sería el siguiente:
nplurals=1; plural=0;

Dos formas, singular usadas para uno solo (Danés, Holandés, Inglés, Islas Faroe, Alemán, Noruego, Sueco, Estonio, Finlandés, Griego, Hebreo, Italiano, Portugués, Español)
Una entrada de la cabecera se vería así:
nplurals=2; plural=n != 1;

Dos formas, singular usadas para el cero y uno (Francés, Portugués Brasileño)
Caso excepcional en la familia de las lenguas.
La entrada de la cabecera sería:
nplurals=2; plural=n>1;

Tres formas, casos especiales para los números terminados en 1 y 2, 3, 4, excepto aquellas que terminan en 1[1-4] (Croata, Checo, Ruso, Ucraniano)
La entrada de la cabecera se vería así:
nplurals=3; plural=n%10==1 && n%100!=11 ? 0 : n%10>=2 && n%10<=4 && (n%100<10 || n%100>=20) ? 1 : 2;

Tres formas, caso especial para uno y otros números que terminan en 2, 3, o 4 (Polaco)
La entrada de la cabecera se vería así:
nplurals=3; plural=n==1 ? 0 : n%10>=2 && n%10<=4 && (n%100<10 || n%100>=20) ? 1 : 2;

Cuatro formas, caso especial para uno y todos los números que terminan en 02, 03, o 04 (Esloveno)
La entrada de la cabecera se vería así:
nplurals=4; plural=n%100==1 ? 0 : n%100==2 ? 1 : n%100==3 || n%100==4 ? 2 : 3;

Una vez haya terminado, haga clic en Aceptar para guardar todos los ajustes necesarios.

5.

Activar todas las ventanas disponibles en el menú Ver: Mostrar ventana de comentarios y Mostrar ventana de comentarios automáticos.

Ahora puede empezar a traducir todos los elementos incluidos en el archivo de traducción.
La ventana principal está dividida en cinco paneles. La parte superior y el mayor panel contiene todas las cadenas (traducidas y sin traducir).
Todas las condenas sin traducir están marcadas en azul. Cada artículo traducido se convierte en blanco. También hay cuatro pequeñas ventanas.
La primera ventana (superior izquierda) contiene el elemento original que tiene que ser traducido. La ventana inferior izquierda es para que ingrese su traducción.
El panel superior derecho contiene comentarios especiales escritos por un programador. La mayoría de las veces está vacío, pero a veces se pueden encontrar algunas instrucciones importantes. Por ejemplo: la longitud máxima permitida, significado exacto de una palabra o frase.

La ventana inferior derecha es para que pueda escribir sus propios comentarios. Pueden ser muy útiles para más tarde o para otro traductor que desee continuar su trabajo. Puede añadir su opinión haciendo clic en el botón de abajo:

Cada artículo comentado está marcado con un símbolo especial pequeño (ver en la pantalla de abajo):

A veces puede marcar su traducción como insegura (confusa).
Para marcar el elemento como confuso sólo hay que seleccionarlo y hacer clic en el siguiente botón:

Marcar sus traducciones como confuso puede ayudarle cuando decide guardar su trabajo y comprobar más tarde.
¡Tenga en cuenta, los elementos confusos no son usados por AVI ReComp por lo que no verá estos elementos mientras verifica la traducción!

Ahora, algo acerca de las formas plurales utilizadas en la traducción.
A veces puede encontrar elementos con ese aspecto:

Si se establece una forma plural correcta en la configuración poEdit (ver más arriba), verá que a veces la ventana de su traducción será dividida en una más pequeña. Esto significa que tiene que introducir singular y plural correcto para un nombre dado.
¡No puede omitir la sintaxis %d! Esta es una sintaxis especial que se utiliza para las variables numéricas. Si se omite esta sintaxis no será capaz de compilar su traducción!
¡La misma situación se relaciona con la sintaxis %s (para variables de texto)!

A veces se puede encontrar signos especiales como \n - este símbolo representa un punto de salto de línea.
Yo las utilizo sobre todo para los consejos y mensajes más largos.

Si son demasiado largos y pueden ser demasiado difíciles de leer colocados en una línea.
No tiene que usar estos símbolos en los mismos lugares donde se han fijado. Es de su propia elección en donde usarlos.

6.

Cuando haya terminado, o simplemente desee guardar su trabajo -> haga clic en el siguiente botón:

y su traducción se guardará.
poEdit también compila su archivo PO a un archivo con formato especial MO.
Si la traducción no está terminada y no van a ver cómo funciona puede eliminar este archivo MO.
La próxima vez que decida continuar con su traducción sólo tiene que abrir el archivo PO.

Probar la traducción

Como he mencionado anteriormente poEdit siempre genera un archivo especial de MO durante el guardado de su trabajo.
Este es un archivo de destino utilizado por AVI ReComp para procesar la traducción.
Ahora vaya al directorio de instalación de AVI ReComp y encuentre un directorio llamado "Locale". Hay tiene que crear un nuevo subdirectorio. El nombre de este directorio tiene que hacer referencia al código de idioma que se va a probar. puede utilizar el siguiente enlace para ver cuál es el código de su idioma:
http://dybdahl.dk/dxgettext/docs/beta/online/standards.html
Por ejemplo, si va a comprobar su traducción británica tendrá que dar el nombre de "en_GB" para la carpeta. Si se trata de una traducción al francés a continuación, elija el nombre de la carpeta "fr".
Ahora vamos a crear un subdirectorio mas en su nueva carpeta. Su nombre tiene que ser "LC_MESSAGES".
Y este es el lugar final de su archivo default.mo compilado.
Así que para la traducción al francés la ruta completa será la siguiente:
AVI ReComp install dir\locale\fr\LC_MESSAGES\default.mo
Ahora puede ejecutar ARC y debe ver a su nuevo idioma disponible en la lista de todos los idiomas disponibles. Ahora puede comprobar cómo funciona.

Traducir los complementos

Si quieres un apoyo total en el idioma también puede traducir la documentación: cambios, la licencia y los archivos de instalación de idioma.
¡Tenga en cuenta! Casi todos los contenidos deben ser guardados con una codificación de página en utf-8!
Hay sólo unos pocos documentos que se deben guardar en una codificación ANSI común y todos ellos son utilizados en la instalación de AVI ReComp. Todos los archivos se pueden encontrar en nuestro Paquete de Traducción.
Los archivos de las siguientes carpetas deben ser guardados en codificación ANSI:
- \Documents\License\ANSI for installer only\
- \Install lang\
Después de traducir esos documentos simplemente colóquelos en un subdirectorio correcto y póngales un nombre, de acuerdo con su código de idioma. Por ejemplo changelog_no.txt para Noruego o changelog_sl.txt para Esloveno. Después de esto AVI ReComp debería reconocer automáticamente el idioma del documento en función de un lenguaje actual seleccionado.

Traducir el Sistema de Ayuda

También es posible traducir el sistema de ayuda.
El archivo de ayuda se compone de varios archivos HTML (páginas) que se pueden traducir fácilmente.
Sin embargo, requiere unos conocimientos mínimos y básicos del lenguaje HTML.
Todos los archivos con extensión *.html están localizados en el subdirectorio \Help\en_GB\HTML\ del Paquete de Traducción.
¡Por favor, no modifique el código fuente de los documentos HTML/XHTML! ¡Además, no cambie el nombre de los archivos!
Pero puede reemplazar todas las imágenes del subdirectorio \Help\en_GB\HTML\screenshots\ con sus propias capturas de pantalla (en su idioma nativo).
El archivo Index_en.hhc incluye la lista del contenido de la Ayuda y puede ser traducido.
También puede cambiar el sufijo de "_en" a su propio código de idioma.
Todos los elementos de índice se almacenan en el siguiente formulario: <param name="Nombre" value="Conversión de audio">.
Además todos archivos de HTML/XHTML tienen que ser compilados en un archivo de ayuda.
Y es por eso que todos los usuarios dispuestos a traducir el sistema de ayuda se solicita ponerse en contacto conmigo directamente y me envíen todos los archivos de los que se compone.
No obstante los usuarios más avanzados pueden compilar el archivo de ayuda por sí mismos.
Para compilar el archivo de ayuda se necesita descargar e instalar Microsoft HTML Help Workshop.
AVI ReComp_en.hhp es el guión principal de ayuda que se pueden cargar fácilmente a HTML Help Workshop y luego compilarlo en el archivo de Ayuda de final.
Utilizando HTML Help Workshop puede editar el archivo de proyecto y cambiar algunos parámetros principales ( Título, Idioma y el archivo de contenido en caso de que haya modificado su nombre o la ubicación).

Publicar la traducción

Finalmente puede publicar la traducción en esta sección de mi foro describir lo cual es el idioma de la traducción y con que versión de ARC está relacionada.
Después de la traducción sea publica y verificada la añadiré a la lista de todas las traducciones disponibles.
Por favor, siempre intente incluir su archivo PO. El Archivo PO es el más importante. El archivo MO es una versión compilada y no contiene ningún comentario, etc.
Si tiene cualquier pregunta o problema, por favor inicie un nuevo tema en esta sección del panel de discusión de AVI ReComp o ponerse en contacto conmigo directamente a través de MP.