ASP.NET 用 MMC スナップイン

ASP.NET
ASP.NET 用 MMC スナップイン
ドロップダウン

このセクションでは Microsoft 管理コンソール (MMC: Microsoft Management Console) スナップインを使用して ASP.NET および ASP.NET アプリケーションを構成する方法について説明します。

MMC は、コンピュータ、サービス、その他のシステム コンポーネントおよびネットワークの管理に使用できる管理ツールをホストします。Web アプリケーションを管理するコンソールに、スナップインと呼ばれるこれらの管理ツールを 1 つ以上追加できます。MMC 用の ASP.NET スナップイン ツールには、Web サーバーおよびそれがホストするアプリケーションを 1 回の操作で構成するためのユーザー インターフェイス (UI) が用意されています。カスタムのエラー処理やユーザー認証などの特定の機能を管理できる、いくつかのダイアログ ボックスが含まれています。

このセクションの内容

[全般] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
[カスタム エラー] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
[承認] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
[認証] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
[アプリケーション] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
[状態の管理] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
[場所] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
[接続文字列の編集と追加] ダイアログ ボックス
[アプリケーション設定の編集と追加] ダイアログ ボックス
[カスタム エラー ハンドラの編集と追加] ダイアログ ボックス
[規則の編集] ダイアログ ボックス
[プロジェクトの場所] ダイアログ ボックスの追加

関連するセクション

ASP.NET アプリケーションの構成

ASP.NET 構成モデルについての情報を提供します。XML ファイルおよび構成プログラミング API の用途が含まれています。
このトピックについてのご提案や障害報告をお送りいただく場合は、こちらを参照してください。


[全般] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)

[全般] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
参照
ドロップダウン

[ASP.NET 構成の設定] ダイアログ ボックスの [全般] タブでは、次の 2 種類の構成設定を管理できます。

  • 接続文字列。データベースなどのデータ ストアへの接続を確立する際に使用する情報を定義します。

  • アプリケーション設定。アプリケーション全体に関連する値を中央で集中して作成できる、簡易名と値の組み合わせです。これにより、Web アプリケーションの任意の場所からアプリケーション値にアクセスできるようになります。アプリケーション設定を構成の一部として保持することによって、設定を容易に変更できます。アプリケーション設定は、常に文字列として格納されます。

[全般] タブで行った設定は、[プロパティ] ダイアログ ボックスを表示する前に選択していた Web アプリケーションに適用されます。

メモ メモ

構成設定は継承できます。Machine.config ファイルに設定を定義すると、サーバー上のすべての Web サイトおよび Web アプリケーションの基本構成として使用できます。Web アプリケーション レベルで構成設定を作成することにより、新しい設定を作成したり、継承した設定をオーバーライドしたりできます。

[全般] ダイアログ ボックスを表示するには

  1. Microsoft Windows で [管理ツール] を起動し、[インターネット インフォメーション サービス (IIS) マネージャ] をクリックします。

    IIS Manager が起動します。

  2. [インターネット インフォメーション サービス] で Servername (ローカル コンピュータ) を展開し、[Web サイト] を展開します。次に、Websitename か [既定の Web サイト] を右クリックし、[プロパティ] をクリックします。

    [Web サイトのプロパティ] ダイアログ ボックスが表示されます。

  3. [ASP.NET] タブをクリックし、[構成の編集] をクリックします。

    [ASP.NET 構成の設定] ダイアログ ボックスが表示されます。

  4. [全般] タブをクリックします。

処理手順

[全般] タブでは、次の操作を行うことができます。

  • Web アプリケーションのデータベース接続文字列を定義する。

  • 文字列値を作成して、頻繁に使用する情報を格納する。これにより、アプリケーション内の任意の場所から情報にアクセスでき、その情報を容易に変更できるようになります。

UI 要素

[接続文字列マネージャ]

選択した Web アプリケーション用に定義した接続文字列を一覧表示します。継承した設定は斜体で、継承した設定をオーバーライドした場合は、太字で表示されます。

[追加]

クリックすると、[接続文字列の編集と追加] ダイアログ ボックスが表示されます。このダイアログ ボックスでは、新しい接続文字列を作成できます。

[編集]

クリックすると、[接続文字列の編集と追加] ダイアログ ボックスが表示されます。このダイアログ ボックスでは、既存の接続文字列を編集できます。

継承した設定をオーバーライドできます。この場合、オーバーライドした設定は、選択している Web アプリケーションにだけ適用されます。継承した設定を編集して、構成の階層構造内で上位にある設定の値を変更することはできません。

[削除]

クリックすると、接続文字列を削除または無効にできます。

対象の Web アプリケーションに定義されている新しい設定を完全に削除できます。継承した設定を削除した場合、元の設定は階層構造の元の場所にそのまま保持されます。そして、IIS Manager によって、この設定に対して <remove> エントリが作成され、設定が無効になります。

[リセット]

クリックすると、オーバーライドした設定または削除した設定が元の値に復元されます。

IIS Manager では、ローカルでオーバーライドした値を削除するか、<remove> エントリを削除することによって、継承した設定を優先させることができます。

アプリケーション設定

アプリケーション設定のキーと値の組み合わせが一覧表示されます。

[追加]

クリックすると、[アプリケーション設定の編集と追加] ダイアログ ボックスが表示されます。このダイアログ ボックスでは、新しいキーと値の組み合わせを作成できます。

[編集]

クリックすると、[アプリケーション設定の編集と追加] ダイアログ ボックスが表示されます。このダイアログ ボックスでは、新しいキーと値の組み合わせを作成できます。

継承した設定をオーバーライドできます。この場合、オーバーライドした設定は、選択している Web アプリケーションにだけ適用されます。継承した設定を編集して、構成の階層構造内で上位にある設定の値を変更することはできません。

[クリア]

クリックすると、キーと値の組み合わせを削除または無効にできます。

対象の Web アプリケーションに定義されている新しいアプリケーション設定を完全に削除できます。継承した設定を削除した場合、元の設定は階層構造の元の場所にそのまま保持されます。そして、IIS Manager によって、この設定に対して <remove> エントリが作成され、設定が無効になります。

[リセット]

クリックすると、オーバーライドまたは削除したキーと値の組み合わせが元の値に復元されます。

IIS Manager では、ローカルでオーバーライドした値を削除するか、<remove> エントリを削除することによって、継承した設定を優先させることができます。

参照

処理手順

方法 : プログラムによって ASP.NET 構成設定にアクセスする

関連項目

[認証] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
[承認] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
[カスタム エラー] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
[場所] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
connectionStrings 要素 (ASP.NET 設定スキーマ)
appSettings 要素 (全般設定スキーマ)

概念

ASP.NET 構成の概要


[カスタム エラー] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)

[カスタム エラー] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
参照
ドロップダウン

ASP.NET の Web ページまたはコンポーネントでエラーが発生すると、エラー コードが発生します。エラーには、次の種類があります。

  • コンパイル時

  • パーサー (不正な ASP.NET 要素)

  • 構成

  • 実行時

既定では、エラーの説明、エラーが発生したページの名前、およびスタック トレースを含むエラー ページが動的に生成されます。デバッグ モードが有効な場合には、この動的に生成されたページに、エラー発生元のソース コードの抜粋も表示されます。カスタム エラーを定義することにより、エラーが発生したときの Web アプリケーションの応答を指定できます。

メモ メモ

デバッグ モードの詳細については、「[アプリケーション] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)」を参照してください。

[ASP.NET 構成の設定] ダイアログ ボックスの [カスタム エラー] タブを表示するには

  1. Microsoft Windows で [管理ツール] を起動し、[インターネット インフォメーション サービス (IIS) マネージャ] をクリックします。

    IIS Manager が起動します。

  2. [インターネット インフォメーション サービス] で Servername (ローカル コンピュータ) を展開し、[Web サイト] を展開します。次に、Websitename または [既定の Web サイト] を右クリックし、[プロパティ] をクリックします。

    [Web サイトのプロパティ] ダイアログ ボックスが表示されます。

  3. [ASP.NET] タブをクリックし、[構成の編集] をクリックします。

    [ASP.NET 構成の設定] ダイアログ ボックスが表示されます。

  4. [カスタム エラー] タブをクリックします。

処理手順

[カスタム エラー] タブでは、次の操作を行うことができます。

  • Web アプリケーション内で ASP.NET エラーが発生したときに表示する既定のエラー ページを指定する。

  • 特定の HTTP エラー コードを対応するエラー ページに割り当てる。

    メモ メモ

    エラー コードの割り当ては、ASP.NET に通知されたエラーに対してのみ行うことができます。たとえば、既定では、HTTP 404 エラー ("ページが見つかりません") は ASP.NET に通知されません。このようなエラーを受信するには、Web サイトのプロパティを設定して HTTP エラーを .aspx ページに割り当てます。

  • カスタム エラー ページをすべてのユーザーに表示するか、リモート ユーザー (管理者以外) に表示するか、またはどのユーザーにも表示しないかを指定します。

UI 要素

[カスタム エラー モード]

カスタム エラーの表示方法を指定するモードをクリックします。モードの種類は次のとおりです。

  • [On]

    常にカスタム エラー ページが表示されます。この設定を使用すると、Web アプリケーションの開発時にエラーを表示できます。

  • [Off]

    カスタム エラー ページは表示されません。代わりに、動的に生成された ASP.NET エラー ページにエラー表示します。

  • [Remote Only]

    ローカル Web サーバーが要求元でない場合にのみ、エラーをリダイレクトします。このモードを使用すると、サーバーでの作業中に ASP.NET エラーを確認する一方で、 Web アプリケーションのユーザーに対してはカスタム エラーを表示することができます。

[規定のリダイレクト URL]

Web アプリケーション内で発生した処理ができないエラーに対して表示されるページの名前 (.aspx または .htm) を入力します。

[継承されたカスタム エラー]

上位の階層の構成ファイルから継承されたカスタム エラー ページを一覧表示します。継承したエラー設定をオーバーライドするには、オーバーライドするステータス コードにローカル カスタム エラーを追加します。

[ローカルのカスタム エラー]

特に、現在の Web サイトのエラー ページを一覧表示します。

[追加]

クリックすると [カスタム エラー ハンドラの編集と追加] ダイアログ ボックスが表示され、ASP.NET でエラーが検出されたときに表示される HTTP エラー コードとページを指定できます。

メモ メモ

エラー コードの割り当ては、ASP.NET に通知されたエラーに対してのみ行うことができます。たとえば、既定では、HTTP 404 エラー ("ページが見つかりません") は ASP.NET に通知されません。このようなエラーを受信するには、Web サイトのプロパティを設定して HTTP エラーを .aspx ページに割り当てます。

HTTP エラー コードおよび割り当て先ページの URL を指定する必要があります。参照するページは、現在の Web サイトになくてもかまいません。

メモ メモ

IIS Manager では、入力した URL を検証しません。

[編集]

クリックすると [カスタム エラー ハンドラの編集と追加] ダイアログ ボックスが表示され、[ローカルのカスタム エラー] で選択したページの名前やエラー コードを変更できます。

[削除]

クリックすると、エラー ページの割り当てを削除できます。

参照

処理手順

方法 : プログラムによって ASP.NET 構成設定にアクセスする

関連項目

[認証] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
[承認] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
[場所] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
connectionStrings 要素 (ASP.NET 設定スキーマ)
appSettings 要素 (全般設定スキーマ)

概念

ASP.NET 構成の概要


[承認] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)

[承認] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
参照
ドロップダウン

[ASP.NET 構成の設定] ダイアログ ボックスの [承認] タブでは、現在の Web サイト ディレクトリの承認規則を、ユーザー アカウントとロールに基づいて管理できます。Microsoft Windows 認証または ASP.NET フォーム認証 (ASP.NET メンバシップ) を使用すると、ユーザー アカウントとロールを作成できます。現在の Web サイト ディレクトリに対する規則を追加、編集、または削除できます。規則は、子サブディレクトリ内の構成ファイル設定によって上書きされない限り、現在の URL の現在のサブディレクトリおよびすべての子サブディレクトリに適用されます。

Machine.config 構成ファイルおよび親仮想ディレクトリから継承した規則も表示されますが、編集はできません。継承した規則の影響を変更するには、新しい設定を Web サイト レベルで作成します。アプリケーション設定は常に文字列として格納されます。

[承認] タブで行った設定は、[プロパティ] ダイアログ ボックスを表示する前に選択していた Web サイトに適用されます。

メモ メモ

構成設定は継承できます。Machine.config ファイルに設定を定義すると、サーバー上のすべての Web サイトの基本構成として使用できます。ASP.NET 構成ファイルの詳細については、「ASP.NET 構成ファイルの階層と継承」を参照してください。

[承認] ダイアログ ボックスを表示するには

  1. Windows で [管理ツール] を起動し、[インターネット インフォメーション サービス (IIS) マネージャ] をクリックします。

    IIS Manager が起動します。

  2. [インターネット インフォメーション サービス] で Servername (ローカル コンピュータ) を展開し、[Web サイト] を展開します。次に、Websitename か [既定の Web サイト] を右クリックし、[プロパティ] をクリックします。

    [Web サイトのプロパティ] ダイアログ ボックスが表示されます。

  3. [ASP.NET] タブをクリックし、[構成の編集] をクリックします。

  4. [ASP.NET 構成の設定] ダイアログ ボックスが表示されます。

  5. [承認] タブをクリックします。

処理手順

[承認] タブでは、次の操作を行うことができます。

  • Machine.config ファイルを含め、継承したすべての構成ファイル内に定義された承認規則を表示する。

  • 現在の Web サイト ディレクトリに対する承認規則を追加、編集、および削除する。

規則の優先順位

承認規則は、上から下の順序で適用されます。場合によっては、正しいアクセス許可を確立するために、同じフォルダ内に複数の規則を作成する必要があります。たとえば、匿名ユーザー アカウントへのアクセスを拒否する規則を作成した後、Guest のロールを持つユーザー アカウントへのアクセスを拒否する 2 番目の規則を作成します。このようにすると、ログオンしている匿名以外のユーザーで、Guest 以外のグループに属するユーザーだけがフォルダにアクセスできます。

Web.config 設定

[セキュリティ] タブで管理される Web.config 設定は、<authorization>、<roleManager>、<authentication> の各セクションです。

Web サイトのサブディレクトリへのアクセスを制限する Web.config ファイルの抜粋を次に示します。制限されたサブディレクトリへのアクセスは、管理者および John という名前のユーザーに対しては許可されますが、匿名ユーザーに対しては拒否されます。

コードのコピー コードのコピー
<?xml version="1.0" encoding="utf-8"?>
<configuration>
    <system.web>
        <authorization>
            <allow roles="administrators" />
            <allow users="John"/>
            <deny users="?" />
        </authorization>
    </system.web>
</configuration>

UI 要素

[継承された承認の規則]

「ASP.NET 構成ファイルの階層と継承」で定義されているとおりに、Machine.config ファイルまたは親仮想ディレクトリに定義されている、継承した承認規則を一覧表示します。継承した設定は斜体で、継承した設定をオーバーライドした場合は、太字で表示されます。

[ローカルの承認の規則]

現在の Web サイト ディレクトリおよびすべての子ディレクトリに適用される承認規則を一覧表示します。

[追加]

クリックすると、[規則の編集] ダイアログ ボックス が表示され、新しい規則を作成できます。

[編集]

クリックすると、[規則の編集] ダイアログ ボックス が表示され、選択した規則を編集できます。

[削除]

クリックすると、[ローカルの承認の規則] で選択した行を削除できます。

参照

処理手順

方法 : プログラムによって ASP.NET 構成設定にアクセスする

関連項目

[認証] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
[場所] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
connectionStrings 要素 (ASP.NET 設定スキーマ)
appSettings 要素 (全般設定スキーマ)

概念

ASP.NET 構成の概要

その他の技術情報

ASP.NET 用 MMC スナップイン


[認証] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)

[認証] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
参照
ドロップダウン

[ASP.NET 構成の設定] ダイアログ ボックスの [認証] タブでは、現在の Web サイトに対するユーザー アカウントとロールの認証を管理できます。ASP.NET 認証とは、ユーザー名やパスワードなどのユーザーを識別するための資格情報をユーザー アカウントから取得し、それらの情報を証明機関に照会して検証するプロセスです。ASP.NET が認証を実装するしくみの詳細については、「ASP.NET の認証」を参照してください。

また、[認証] タブでは、現在の Web アプリケーションに対するメンバシップ プロバイダの追加、削除、構成のサポート、およびロール管理を行うことができます。ASP.NET ロール管理では、アプリケーションのユーザー アカウントがアクセスするリソースを指定できます。ロール管理では、ユーザー アカウントをロールに割り当てることにより、ユーザー アカウントのグループを単位として扱うことができます。ASP.NET ロール管理の詳細については、「ロール管理について」を参照してください。

Web アプリケーションにカスタム メンバシップ プロバイダを作成したり、使用したりすることができます。カスタム メンバシップ プロバイダを実装する方法の詳細については、「メンバシップ プロバイダの実装」を参照してください。

[認証] タブで行った設定は、[プロパティ] ダイアログ ボックスを表示する前に選択していた Web サイトに適用されます。

メモ メモ

構成設定は継承できます。Machine.config ファイルに設定を定義すると、サーバー上のすべての Web サイトの基本構成として使用できます。ASP.NET 構成ファイルの詳細については、「ASP.NET 構成ファイルの階層と継承」を参照してください。

[ASP.NET 構成の設定] ダイアログ ボックスの [認証] タブを表示するには

  1. Microsoft Windows で [管理ツール] を起動し、[インターネット インフォメーション サービス (IIS) マネージャ] をクリックします。

    IIS Manager が起動します。

  2. [インターネット インフォメーション サービス] で Servername (ローカル コンピュータ) を展開し、[Web サイト] を展開します。次に、Websitename か [既定の Web サイト] を右クリックし、[プロパティ] をクリックします。

    [Web サイトのプロパティ] ダイアログ ボックスが表示されます。

  3. [ASP.NET] タブをクリックし、[構成の編集] をクリックします。

    [ASP.NET 構成の設定] ダイアログ ボックスが表示されます。

  4. [認証] タブをクリックします。

処理手順

[認証] タブでは、次の操作を行うことができます。

  • 現在の Web アプリケーションに使用する認証の種類を構成する。

  • 現在の Web アプリケーションのメンバシップ プロバイダを追加、削除、および変更する。

  • 現在の Web アプリケーションのロール メンバシップ プロバイダを追加、削除、および変更する。

UI 要素

[認証モード]

クリックすると、現在の Web サイトの認証モードを指定できます。各認証モードの詳細については、「ASP.NET の認証」を参照してください。

[HTTP cookie 名]

現在の Web サイトの認証に使用する HTTP Cookie の名前を入力します。[HTTP cookie 名] は、フォーム認証を設定する場合にのみ使用できます。

[ログイン URL]

有効な認証 Cookie が見つからない場合に、ログオンのために要求をリダイレクトする先の URL を入力します。既定は login.aspx です。[ログイン URL] は、フォーム認証を設定する場合にのみ使用できます。

[Cookie の保護]

クリックすると、認証 Cookie に使用する暗号化の種類を指定できます。[Cookie の保護] は、フォーム認証を設定する場合にのみ使用できます。

[Cookie のタイムアウト]

認証 Cookie のタイムアウトまでの所要時間を整数値 (分) で入力します。既定は 30 です。[Cookie のタイムアウト] は、フォーム認証を設定する場合にのみ使用できます。

[SSL を必要とする]

このチェック ボックスをオンにすると、認証 Cookie の送信に SSL 接続が必要なことを指定できます。[SSL を必要とする] は、フォーム認証を設定する場合にのみ使用できます。

[スライド式有効期限を有効にする]

このチェック ボックスをオンにすると、要求が行われてタイムアウト間隔の 1/2 以上が経過した場合に、有効な認証 Cookie の有効期限をリセットできます。[スライド式有効期限を有効にする] は、フォーム認証を設定する場合にのみ使用できます。

[メンバシップ プロバイダ クラス]

クリックすると、現在の Web サイト用に構成されたメンバシップ プロバイダを指定できます。

[プロバイダの管理]

クリックすると、[プロバイダの設定] ダイアログ ボックスが表示され、現在の Web サイトのメンバシップ プロバイダを追加、削除、および構成できます。

[ロール管理を有効にする]

このチェック ボックスをオンにすると、ロール管理が有効になり、ユーザー アカウントのグループに関するアクセス規則を管理できます。

[ロール プロバイダ クラス]

クリックすると、現在の Web サイト用に構成されたロール メンバシップ プロバイダを指定できます。

[プロバイダの管理]

クリックすると、[プロバイダの設定] ダイアログ ボックスが表示され、現在の Web サイトのロール メンバシップ プロバイダを追加、削除、および構成できます。

参照

概念

メンバシップ プロバイダの実装
ロール管理について
ASP.NET 構成ファイルの階層と継承

その他の技術情報

ASP.NET の認証
ASP.NET 用 MMC スナップイン


[アプリケーション] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)

[アプリケーション] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
参照
ドロップダウン

[ASP.NET 構成の設定] ダイアログ ボックスの [アプリケーション] タブでは、次の 3 種類の構成設定を管理できます。

  • 共通コンパイル、ページおよびランタイムの設定

  • グローバリゼーションの設定

  • ID の設定

[ASP.NET 構成の設定] ダイアログ ボックスを、インターネット インフォメーション サービス (IIS) マネージャから表示するには

  1. Web アプリケーションの [プロパティ] ダイアログ ボックスを開きます。

  2. [ASP.NET] をクリックし、[構成の編集] をクリックして [アプリケーション] をクリックします。

[アプリケーション] タブで行った設定が、[プロパティ] ダイアログ ボックスの表示前に選択していた Web アプリケーションに適用されます。[アプリケーション] タブで適用した設定が、該当する Web アプリケーションの Web.config ファイルの system.web 構成セクションに表示されます。

メモ メモ

構成設定は継承できます。Machine.config ファイルに設定を定義すると、サーバー コンピュータ上のすべての Web サイトおよび Web アプリケーションの基本構成として使用できます。Web アプリケーション レベルで構成設定を作成することにより、新しい設定を作成したり、継承した設定をオーバーライドしたりできます。

[ASP.NET 構成の設定] については、「ASP.NET 構成の概要」を参照してください。

処理手順

  • [アプリケーション] タブを使用すると、次のタスクを実行できます。

  • Web アプリケーションの ASP.NET ページに対して、既定の言語を設定します。

  • Web アプリケーションに既定のテーマとマスタ ページを設定します。

  • Web アプリケーションのデバッグを有効にします。

  • 要求が ASP.NET によって自動的にシャットダウンされるまでの最長実行秒数を指定します。

  • 要求、応答およびカルチャの設定に対するコンテンツ エンコーディング文字セットを設定します。カルチャの設定は、日付、数値、通貨の書式設定などのカルチャ依存機能の結果を決定するものです。

  • ウィンドウの ID を設定します。この ID が偽装され、その下で ASP.NET ページが実行されます。

UI 要素

[アプリケーション] タブには次の 3 つのカテゴリがあります。

  • [共通コンパイル、ページおよびランタイムの設定]

  • [グローバリゼーションの設定]

  • [ID の設定]

[共通コンパイル、ページおよびランタイムの設定]

[ページ言語の既定]、[ページ テーマの既定]、[ページ マスタの既定]、[デバッグを有効にする] および [要求の実行のタイムアウト (秒)] の構成設定ができます。

[ページ言語の既定]

動的なコンパイル ファイルで使用する既定のプログラミング言語を選択できます。選択可能な言語は、[vb] (Microsoft Visual Basic 開発システム)、[c#]、[js] (Microsoft JScript 開発ソフトウェア) および [vj#] (Microsoft Visual J# 開発ツール) です。

[ページ テーマの既定]

Web アプリケーションのすべてのページに適用する既定のテーマを指定できます。

[ページ マスタの既定]

ローカルの構成ファイルに対するマスタ ページ ファイルの相対パスを指定できます。

[デバッグを有効にする]

リテール用バイナリとデバッグ用バイナリのいずれをコンパイルするかを指定できます。チェック ボックスをオフにすると、値は false になります。

[要求の実行のタイムアウト (秒)]

要求が ASP.NET によって自動的にシャットダウンされるまでの最長実行秒数を設定できます。

[グローバリゼーションの設定]

[要求のエンコード]、[応答のエンコード]、[カルチャ] および [UI カルチャ] の構成設定ができます。

要求のエンコード

ポストされたデータやクエリ文字列など、着信する各要求で想定されるエンコード方式を指定できます。既定値は UTF-8 です。

応答のエンコード

応答のコンテンツ エンコード方式を指定できます。既定値は UTF-8 です。

ファイルのエンコード

.aspx、.asmx、.asax の各ファイルを解析するための既定のエンコード方式を指定できます。

[カルチャ]

着信する Web 要求を処理するための既定のカルチャを指定できます。カルチャは、日付、数値、通貨の書式設定などのカルチャ依存機能の結果を決定します。

[UI カルチャ]

ロケール依存のリソース検索を処理するための既定のカルチャを指定できます。

[ID の設定]

[ローカル 偽装]、[ユーザー名] および [パスワード] の構成設定ができます。

[ローカル 偽装]

各要求に対してクライアント偽装を使用するかどうかを指定できます。

[ユーザー名]

各要求にクライアント偽装が使用される場合、使用するユーザー名を指定できます。

[パスワード]

各要求にクライアント偽装が使用される場合、使用するパスワードを指定できます。

参照

処理手順

方法 : プログラムによって ASP.NET 構成設定にアクセスする
方法 : ASP.NET Web ページのグローバリゼーション用のカルチャおよび UI カルチャを設定する

関連項目

[認証] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
[承認] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
[カスタム エラー] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
[全般] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
[場所] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)

概念

ASP.NET 構成の概要
ASP.NET のテーマとスキンの概要
ASP.NET マスター ページの概要


[状態の管理] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)

[状態の管理] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
参照
ドロップダウン

[ASP.NET 構成の設定] ダイアログ ボックスの [状態の管理] タブでは、現在の Web サイトのページに対する複数の要求について、状態情報とページ情報を管理できます。ASP.NET のセッション状態を使用すると、Web アプリケーションを構成する別の ASP.NET ページにユーザーが移動したときにユーザー アカウントの値を格納および取得できます。[状態の管理] タブでは、値の格納方法と格納場所を構成できます。

[状態の管理] タブで行った設定は、[プロパティ] ダイアログ ボックスを表示する前に選択していた Web サイトに適用されます。

メモ メモ

構成設定は継承できます。Machine.config ファイルに設定を定義すると、サーバー上のすべての Web サイトの基本構成として使用できます。ASP.NET 構成ファイルの詳細については、「ASP.NET 構成ファイルの階層と継承」を参照してください。

[ASP.NET 構成の設定] ダイアログ ボックスの [状態の管理] タブを表示するには

  1. Microsoft Windows の [スタート] をクリックし、[すべてのプログラム] をポイントします。次に、[管理ツール] をポイントし、[インターネット インフォメーション サービス (IIS) マネージャ] をクリックします。

    IIS Manager が起動します。

  2. [インターネット インフォメーション サービス] で Servername (ローカル コンピュータ) を展開し、[Web サイト] を展開します。次に、Websitename または [既定の Web サイト] を右クリックし、[プロパティ] をクリックします。

    [Web サイトのプロパティ] ダイアログ ボックスが表示されます。

  3. [ASP.NET] タブをクリックし、[構成の編集] をクリックします。

    [ASP.NET 構成の設定] ダイアログ ボックスが表示されます。

  4. [状態の管理] タブをクリックします。

処理手順

[状態の管理] タブでは、次の操作を行うことができます。

  • 現在の Web アプリケーションに対してセッション状態モードを選択する。

  • SQLServer セッション状態モードと StateServer セッション状態モードを設定する。

UI 要素

[セッション状態モード]

[セッション状態モード] をクリックします。既定のセッション状態モードは、InProc (Web サーバー上のメモリ内) です。ASP.NET で使用できるセッション状態モードの一覧については、「セッション状態モード」を参照してください。

[Cookie なしのモード]

ユーザーの情報を保持するために、いつ Cookie を使用するかを定義するには、Cookie モードをクリックします。使用できる Cookie なしモードの詳細については、「HttpCookieMode」を参照してください。

[セッションのタイムアウト]

分単位で時間を指定します。指定した時間を過ぎても次の要求がない場合は、セッションが終了します。

[接続文字列]

StateServer モードの ASP.NET 状態サービスのサーバー名とポートを識別する接続文字列を入力します。

[ネットワークのタイムアウト]

秒単位で時間を指定します。指定した時間を過ぎても次の要求がない場合は、StateServer モードのネットワーク セッションが終了します。

[接続文字列]

SQLServer モードのサーバー名とポートを識別する接続文字列を入力します。

参照

関連項目

HttpCookieMode

概念

セッション状態モード
ASP.NET 構成ファイルの階層と継承

その他の技術情報

ASP.NET 用 MMC スナップイン


[場所] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)

[場所] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
参照
ドロップダウン

適切な path 属性を指定して location タグを使用すると、特定の Web アプリケーションやディレクトリに構成設定を適用できます。path 属性は、一意な構成設定の適用対象とする特定のファイルまたは子ディレクトリを識別するために使用します。[ASP.NET 構成の設定] ダイアログ ボックスの [場所] タブを使用すると、構成ファイル内に構成設定を埋め込むことができます。

[ASP.NET 構成の設定] ダイアログ ボックスの [場所] タブで、次の構成設定を管理できます。

  • 場所の構成。ノードの構成ファイルで定義されるパスの場所の構成です。

[ASP.NET 構成の設定] ダイアログ ボックスを、インターネット インフォメーション サービス (IIS) マネージャから表示するには

  1. Web アプリケーションの [プロパティ] ダイアログ ボックスを開きます。

  2. [ASP.NET] をクリックし、[構成の編集] をクリックして [アプリケーション] をクリックします。

[場所] タブで行った設定が、[プロパティ] ダイアログ ボックスの表示前に選択していた Web アプリケーションに適用されます。

メモ 構成設定は継承できます。Machine.config ファイルに設定を定義すると、サーバー コンピュータ上のすべての Web サイトおよび Web アプリケーションの基本構成として使用できます。Web アプリケーション レベルで Web.config ファイル内に構成設定を作成することにより、新しい設定を作成したり、継承した設定をオーバーライドしたりできます。

[ASP.NET 構成の設定] については、「ASP.NET 構成の概要」を参照してください。

処理手順

[場所] タブを使用すると、次のタスクを実行できます。

  • ノードの構成ファイルで定義されるパスの場所の構成を指定します。

UI 要素

[場所の構成]

[追加]

[場所の追加] ダイアログ ボックスを表示して、[ASP.NET 構成の設定] ダイアログ ボックス内の [場所の構成] ダイアログ ボックスに新しい場所を追加するインデックスと位置を指定できます。

[構成の編集]

格納している構成ファイルで指定されたパスのノード用に新しい [ASP.NET 構成の設定] タブを表示できます。

[削除]

このノードの構成ファイルから場所のエントリを削除できます。

参照

処理手順

方法 : プログラムによって ASP.NET 構成設定にアクセスする

関連項目

[全般] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
[認証] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
[承認] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
[カスタム エラー] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
[アプリケーション] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)

概念

ASP.NET 構成の概要
ASP.NET 構成の保護


[接続文字列の編集と追加] ダイアログ ボックス

[接続文字列の編集と追加] ダイアログ ボックス
参照
ドロップダウン

[接続文字列の編集と追加] ダイアログ ボックスにより、新しい ConnectionString プロパティの作成や既存の ConnectionString プロパティの編集ができます。[ASP.NET 構成の設定] ダイアログ ボックスの [全般] タブの [追加] または [編集] をクリックすると、[接続文字列の編集と追加] ダイアログ ボックスが表示されます。

[ASP.NET 構成の設定] ダイアログ ボックスを、インターネット インフォメーション サービス (IIS) マネージャから表示するには

  1. Web アプリケーションの [プロパティ] ダイアログ ボックスを開きます。

  2. [ASP.NET] をクリックし、[構成の編集] をクリックして [アプリケーション] をクリックします。

[ASP.NET 構成の設定] ダイアログ ボックスの [全般] タブの [追加] をクリックすると [接続文字列の編集と追加] ダイアログ ボックスを表示できます。そこで、ConnectionString プロパティおよび Connection パラメータの名前またはキーを指定します。

[ASP.NET 構成の設定] ダイアログ ボックスの [全般] タブの [編集] をクリックして [接続文字列の編集と追加] ダイアログ ボックスを表示することもできます。ここで、既存の ConnectionString プロパティを編集できます。選択した ConnectionString プロパティが、[接続パラメータ] ボックスに表示されます。

メモ メモ

継承した設定をオーバーライドできます。この場合、オーバーライドした設定は、選択している Web アプリケーションにだけ適用されます。継承した設定を編集して、構成の階層構造内で上位にある設定の値を変更することはできません。

[ASP.NET 構成の設定] については、「ASP.NET 構成の概要」を参照してください。

処理手順

[接続文字列の編集と追加] ダイアログ ボックスを使用すると、次のタスクを実行できます。

  • [全般] タブの [接続文字列マネージャ] ダイアログ ボックスに新しい ConnectionString プロパティを追加します。

  • [全般] タブの [接続文字列マネージャ] ダイアログ ボックスで既存の ConnectionString プロパティを編集します。

UI 要素

[接続文字列の編集と追加]

[名前]

ConnectionString プロパティの名前を指定できます。

[全般] タブの [編集] をクリックして [接続文字列の編集と追加] ダイアログ ボックスを呼び出した場合は、接続文字列の名前を指定できません。

[接続パラメータ]

ConnectionString プロパティの値を指定できます。

[全般] タブの [編集] をクリックして [接続文字列の編集と追加] ダイアログ ボックスを呼び出した場合は、[接続パラメータ] ボックスに既存の ConnectionString プロパティの値が入ります。

[OK]

作成した新しい ConnectionString プロパティ、または既存の ConnectionString プロパティに加えた変更を適用できます。

[キャンセル]

[接続文字列の編集と追加] ダイアログ ボックスを閉じることができます。変更は、接続文字列マネージャに書き込まれません。

参照

関連項目

[全般] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
connectionStrings 要素 (ASP.NET 設定スキーマ)

概念

ASP.NET 構成の概要


[アプリケーション設定の編集と追加] ダイアログ ボックス

[アプリケーション設定の編集と追加] ダイアログ ボックス
参照
ドロップダウン

アプリケーション設定は、キーと値の単純なペアで、アプリケーション全体に関連する値を中央で集中して作成できます。この設定の格納場所は Web アプリケーション内のどこからでもアクセスできます。アプリケーション設定を構成の一部として Web.config ファイルに保持することによって、設定を容易に変更できます。[全般] タブの [アプリケーションの設定] ダイアログ ボックスに、アプリケーション設定の、キーと値のペアのリストが表示されます。

[アプリケーション設定の編集と追加] ダイアログ ボックスにより、Web アプリケーションの設定を作成および編集できます。

[ASP.NET 構成の設定] ダイアログ ボックスの [全般] タブの [アプリケーションの設定] 部分にある [追加] をクリックして、[アプリケーション設定の編集と追加] ダイアログ ボックスを表示できます。次に AppSettings プロパティのキーと値を指定します。このキーと値は、Web アプリケーションの [アプリケーションの設定] ダイアログ ボックスおよび Web.config ファイルに追加されます。

同様に、[アプリケーションの設定] ダイアログ ボックスで設定を選択して [編集] をクリックします。ここで、選択した AppSettings プロパティの値を変更できます。変更は、Web アプリケーションの [アプリケーションの設定] ダイアログ ボックスおよび Web.config ファイルに追加されます。

[ASP.NET 構成の設定] ダイアログ ボックスを、インターネット インフォメーション サービス (IIS) マネージャから表示するには

  1. Web アプリケーションの [プロパティ] ダイアログ ボックスを開きます。

  2. [ASP.NET] をクリックし、[構成の編集] をクリックして [アプリケーション] をクリックします。

[ASP.NET 構成の設定] については、「ASP.NET 構成の概要」を参照してください。

処理手順

[アプリケーション設定の編集と追加] ダイアログ ボックスを使用すると、次のタスクを実行できます。

  • アプリケーション全体に関連する値を中央で集中して作成できる、新しいキーと値の単純なペアを作成します。

  • 現在、Web アプリケーションにあるキーと値のペアを編集します。

UI 要素

[キー]

キーと値のペアに、新しいキーを追加します。[編集] をクリックすると、テキストボックスに新しいキーを指定できません。

[値]

キーと値のペアに、新しい値を追加します。[編集] をクリックすると、選択したキーと値のペアの値を変更できます。

[OK]

作成した新しい AppSettings プロパティ、または既存のアプリケーション設定に加えた変更が適用できます。

[キャンセル]

Web アプリケーションのアプリケーション設定や Web.config ファイルを変更することなく、[アプリケーション設定の編集と追加] ダイアログ ボックスを閉じることができます。

参照

関連項目

[全般] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
appSettings 要素 (全般設定スキーマ)

概念

ASP.NET 構成の概要


[カスタム エラー ハンドラの編集と追加] ダイアログ ボックス

[カスタム エラー ハンドラの編集と追加] ダイアログ ボックス
参照
ドロップダウン

[カスタム エラー ハンドラの編集と追加] ダイアログ ボックスでは、エラー コードを特定のエラー ページにマップできます。ASP.NET によってエラー コードが生成されると、指定したページが表示されます。

[カスタム エラー ハンドラの編集と追加] ダイアログ ボックスで行った設定は、[プロパティ] ダイアログ ボックスを表示する前に選択していた Web アプリケーションに適用されます。

メモ メモ

構成設定は継承できます。Machine.config ファイルに設定を定義すると、サーバー上のすべての Web サイトおよび Web アプリケーションの基本構成として使用できます。Web アプリケーション レベルで構成設定を作成することにより、新しい設定を作成したり、継承した設定をオーバーライドしたりできます。

メモ ASP.NET は、404 などの特定のエラー コードを受け取りません。マップできるのは、ASP.NET で内部的に生成されたエラー コードだけです。

[カスタム エラー ハンドラの編集と追加] ダイアログ ボックスを表示するには

  1. Microsoft Windows で [管理ツール] を起動し、[インターネット インフォメーション サービス (IIS) マネージャ] をクリックします。

    IIS Manager が起動します。

  2. [インターネット インフォメーション サービス] で Servername (ローカル コンピュータ) を展開し、Websitename または [既定の Web サイト] を展開して、[プロパティ] をクリックします。

    [Web サイトのプロパティ] ダイアログ ボックスが表示されます。

  3. [ASP.NET] タブをクリックし、[構成の編集] をクリックします。

    [ASP.NET 構成の設定] ダイアログ ボックスが表示されます。

  4. [カスタム エラー] をクリックします。

    • カスタム エラー ハンドラを追加するには、[追加] をクリックします。

    • カスタム エラー ハンドラを編集するには、[編集] をクリックします。

    [カスタム エラー ハンドラの編集と追加] ダイアログ ボックスが表示されます。

UI 要素

[ステータス コード]

HTTP エラー コードを入力すると、エラー ページにマップできます。

[リダイレクト URL]

エラー コードへの応答として表示される ASP.NET ページの URL を入力します。参照するページは、現在の Web サイトになくてもかまいません。

メモ メモ

ASP.NET では、入力した URL を検証しません。

[OK]

クリックすると、カスタム エラー ハンドラを保存できます。

[キャンセル]

クリックすると、変更をキャンセルできます。

参照

関連項目

[カスタム エラー] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
[カスタム エラー] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)


[規則の編集] ダイアログ ボックス

[規則の編集] ダイアログ ボックス
参照
ドロップダウン

[規則の編集] ダイアログ ボックスでは、新しい承認規則の作成または既存の承認規則の編集を行うことができます。Microsoft Windows 認証または ASP.NET フォーム認証 (ASP.NET メンバシップ) を使用すると、ユーザー アカウントとロールを作成できます。

[規則の編集] ダイアログ ボックスを表示するには

  1. Windows で [管理ツール] を起動し、[インターネット インフォメーション サービス (IIS) マネージャ] をクリックします。

    IIS Manager が起動します。

  2. [インターネット インフォメーション サービス] で Servername (ローカル コンピュータ) を展開し、[Web サイト] を展開します。次に、Websitename または [既定の Web サイト] を右クリックし、[プロパティ] をクリックします。

    [Web サイトのプロパティ] ダイアログ ボックスが表示されます。

  3. [ASP.NET] タブをクリックし、[構成の編集] をクリックします。

    [ASP.NET 構成の設定] ダイアログ ボックスが表示されます。

  4. [承認] タブをクリックします。

    • 規則を追加するには、[追加] をクリックします。

    • 規則を編集するには、規則をクリックし、[編集] をクリックします。

    [規則の編集] ダイアログ ボックスが表示されます。

処理手順

[規則の編集] ダイアログ ボックスでは、次の操作を行うことができます。

  • 新しい承認規則を作成するか、既存の規則を編集する。

UI 要素

[規則の種類]

すべてのユーザー アクセスを許可するには、[許可] をクリックします。

または

すべてのユーザー アクセスを拒否するには、[拒否] をクリックします。

規則の詳細については、「AuthorizationRuleCollection」を参照してください。

[動詞]

すべての ASP.NET HTTP 伝送方法によってアクセスできるように指定するには、[すべての動詞] をクリックします。既定は [すべての動詞] です。

[特定の動詞] をクリックした場合は、アクセスを許可する HTTP 伝送方法の一覧をコンマ区切りで入力します。

ASP.NET に登録されている動詞は、GET、HEAD、POST、および DEBUG です。

[ユーザーとロール]

必ず指定します。

次の操作を 1 つまたは複数完了すると、規則が適用されます。

  • すべてのユーザーに規則を適用するには、[すべてのユーザー] をクリックします。

  • 匿名ユーザー アカウントにのみ規則を適用するには、[匿名ユーザー] をクリックします。

  • 特定のユーザー アカウント グループに規則を適用するには、[ユーザー] をクリックして、ユーザー アカウント名の一覧をコンマ区切りで入力します。

  • 特定のロール セットに規則を適用するには、[ロール] チェック ボックスをオンにして、ロール名の一覧をコンマ区切りで入力します。

[ユーザー] と [ロール] の両方を指定すると、特定のロールのユーザー アカウントにのみ、規則が適用されます。

Windows 認証または ASP.NET フォーム認証 (ASP.NET メンバシップ) を使用すると、ユーザー アカウントとロールを定義できます。

[OK]

クリックすると、規則を適用できます。

[キャンセル]

クリックすると、変更をキャンセルできます。

参照

処理手順

方法 : 簡単なフォーム認証を実装する

関連項目

[承認] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
[承認] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)

概念

アプリケーション間のフォーム認証

その他の技術情報

ASP.NET のロールによる承認の管理 (Visual Studio)


[プロジェクトの場所] ダイアログ ボックスの追加

[プロジェクトの場所] ダイアログ ボックスの追加
参照
ドロップダウン

[場所の追加] ダイアログ ボックスにより、Web サイトに新しい場所の構成設定を追加できます。構成設定を特定のリソースだけに適用するには、<location> タグに適切な path 属性を設定して使用します。path 属性は、一意な構成設定の適用対象とする特定のファイルまたは子ディレクトリを識別するために使用します。

[ASP.NET 構成の設定] ダイアログ ボックスの [場所] タブの下の [追加] をクリックすると、[場所の追加] ダイアログ ボックスが表示されます。

[ASP.NET 構成の設定] ダイアログ ボックスを、インターネット インフォメーション サービス (IIS) マネージャから表示するには

  1. Web アプリケーションの [プロパティ] ダイアログ ボックスを開きます。

  2. [ASP.NET] をクリックし、[構成の編集] をクリックして [場所] をクリックします。

[場所の追加] ダイアログ ボックスを使用すると、次の操作を行うことができます。

  • 場所アイテムのインデックス (キー) を指定します。

  • [場所] 構成リストに追加する場所の値を指定します。

UI 要素

[インデックス]

場所アイテムのインデックス (キー) を指定します。

[場所]

リストに追加するアイテムの値を指定します (特定のファイルやディレクトリへのパスなど)。

[OK]

[ASP.NET 構成の設定] ダイアログ ボックスの [場所の構成] ボックスに入力した新しい場所の値を適用します。[場所の追加] ダイアログ ボックスを閉じます。

[キャンセル]

[場所の追加] ダイアログ ボックスを閉じます。変更は [場所の構成] ボックスに書き込まれません。

参照

関連項目

[場所] タブ ([ASP.NET 構成の設定] ダイアログ ボックス)
[ローカル IIS] タブ ([場所の選択] または [Web サイトを開く] ダイアログ ボックス)

概念

ASP.NET 構成の概要


dv_aspnetmmchxs {2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

dv_aspnetmmchxs {2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}
ドロップダウン

dv_aspnetmmchxs {2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

{2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

{2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

全文検索とインデックス デバッグ トピック グラフィック