[テキスト形式の定義] ダイアログ ボックス

[image]

[テキスト形式の定義] ダイアログ ボックス
最新の情報をお客様に提供するために、マイクロソフトはこの製品のドキュメントをオンラインで参照できるよう移動しました。詳細については、「Microsoft Developer Network (MSDN) リソース ページ (http://go.microsoft.com/fwlink/?LinkId=282669)」を参照してください。

© Microsoft Corporation. All rights reserved.


Access 用ファイル

[image]

Access 用ファイル


Excel ファイル

[image]

Excel ファイル


[システム データベースの選択] ダイアログ ボックス

[image]

[システム データベースの選択] ダイアログ ボックス


[ODBC Microsoft Excel セットアップ] ダイアログ ボックス

[image]

[ODBC Microsoft Excel セットアップ] ダイアログ ボックス


Paradox ファイル

[image]

Paradox ファイル


[新しいデータベース] ダイアログ ボックス

[image]

[新しいデータベース] ダイアログ ボックス


[ODBC Paradox セットアップ] ダイアログ ボックス

[image]

[ODBC Paradox セットアップ] ダイアログ ボックス


[ODBC テキスト セットアップ] ダイアログ ボックス

[image]

[ODBC テキスト セットアップ] ダイアログ ボックス


[詳細オプションの設定] ダイアログ ボックス

[image]

[詳細オプションの設定] ダイアログ ボックス


[ODBC Microsoft Access セットアップ] ダイアログ ボックス

[image]

[ODBC Microsoft Access セットアップ] ダイアログ ボックス


一般的な ODBC コンポーネント ファイル

[image]

一般的な ODBC コンポーネント ファイル


データ ソースの変換

[image]

データ ソースの変換


テキスト ISAM ファイル

[image]

テキスト ISAM ファイル


[ODBC dBASE セットアップ] ダイアログ ボックス

[image]

[ODBC dBASE セットアップ] ダイアログ ボックス


[データベースの選択] ダイアログ ボックス

[image]

[データベースの選択] ダイアログ ボックス


製品サポート (ODBC Jet)

[image]

製品サポート (ODBC Jet)


[最適化元データベース] ダイアログ ボックス

[image]

[最適化元データベース] ダイアログ ボックス


dBASE ファイル

[image]

dBASE ファイル


IISAM レジストリ エントリ

[image]

IISAM レジストリ エントリ


Access のシステム データベース ログイン

[image]

Access のシステム データベース ログイン


[インデックスの選択] ダイアログ ボックス

[image]

[インデックスの選択] ダイアログ ボックス


[ブックの選択] ダイアログ ボックス

[image]

[ブックの選択] ダイアログ ボックス


[データベースの修復] ダイアログ ボックス

[image]

[データベースの修復] ダイアログ ボックス


.topic 2
変更を保存せずに、このダイアログ ボックスを閉じます。

.topic 3
データ ソース名 (Payroll、Personnel など) を識別します。 Microsoft Excel 3.0 または 4.0 ドライバーを使用している場合は、ODBC ドライバーがデータ ファイルを検索する既定のデータ ディレクトリを指定します。 Microsoft Excel 5.0、7.0、または 97 の場合は、ODBC ドライバーがデータ ファイルを検索する既定のデータ ブックを指定します。

.topic 4
データ ソース内のデータについての説明 (省略可)。たとえば、"入社日、給与履歴、および現在の評価"。

.topic 5
このダイアログ ボックスのヘルプを表示します。

.topic 6
[セットアップ] ダイアログ ボックスを閉じ、変更を保存します。

.topic 7
データベースの更新を禁止して読み取り専用にする場合に選択します。

.topic 8
各列のデータ型を判断するためにスキャンする行数です。 Microsoft Excel ドライバーでは 1 ～ 16 の任意の数で、既定値は 8 です。0 に設定すると、すべての行がスキャンされます。

.topic 9
[ディレクトリの選択] ダイアログ ボックスを開く場合にクリックします。アクセスするファイルを含むディレクトリを選択できます。 データ ソース ディレクトリを定義している場合は、最もよく使用する Excel ファイルがあるディレクトリを指定します (Microsoft Excel 3.0 または 4.0 の場合)。

.topic 10
[ブックの選択] ダイアログ ボックスを開く場合にクリックします。アクセスするブックを含むディレクトリを選択できます。

.topic 11
アプリケーションの現在の作業ディレクトリをデータ ソース ディレクトリにする場合に選択します。 オフの場合、[ディレクトリの選択] ボタンをクリックして、データ ソース ディレクトリを選択できます。 Microsoft Excel 5.0、7.0、および 97 では、無効です。

.topic 12
使用するファイルの Excel のバージョンを指定します。

.topic 13
これらのオプションを使用して、Excel ファイルの場所とバージョンを変更します。

.topic 14
これらのオプションを使用して、ドライバー固有の属性を構成します。

.topic 15
ドライバー固有の属性を構成する場合にクリックします。

.topic 16
選択した Excel ディレクトリの場所です。

.topic 17
選択した Excel ブックの場所です。

.topic 201
[拡張子] ボックスに入力した拡張子を追加する場合にクリックします。

.topic 202
変更を保存せずに、このダイアログ ボックスを閉じます。

.topic 203
データ ソース名 (Payroll、Personnel など) を識別し、ODBC ドライバーがデータ ファイルを検索する既定のデータ ディレクトリを指定します。

.topic 204
選択されている場合、ディレクトリ内のすべてのファイルを使用できます。 オフの場合、[拡張子の一覧] の既定の拡張子は *.asc、*.csv、*.tab、および *.txt であり、必要に応じて特定の拡張子を追加および削除できます。

.topic 205
[テキスト形式の定義] ダイアログ ボックスを開く場合にクリックします。列の書式の定義や、データ ソース ディレクトリ内のテーブル スキーマの指定ができます。

.topic 206
データ ソース内のデータについての説明 (省略可)。たとえば、"入社日、給与履歴、および現在の評価"。

.topic 207
追加するファイル拡張子を *.xxx の形式で入力してください。 たとえば、.dat ファイルを使用するには、拡張子を「*.dat」と入力します。

.topic 208
データ ソース内のテキスト ファイルのファイル名拡張子を、[既定] チェック ボックスがオフかオンかに基づいて一覧表示します。

.topic 214
これらのオプションを使用して、特定のファイルの種類の形式を指定します。

.topic 215
これらのオプションを使用して、[拡張子の一覧] に対して既定以外のファイル拡張子の追加または削除ができます。 ファイル拡張子を追加するには、[既定] チェック ボックスをオフにし、[拡張子] ボックスに新しい拡張子を入力して、[追加] をクリックします。

.topic 216
これらのオプションを使用して、テキスト ファイルの場所を選択し、ファイル名を表示します。

.topic 209
このダイアログ ボックスのヘルプを表示します。

.topic 210
[セットアップ] ダイアログ ボックスを閉じ、変更を保存します。

.topic 211
[拡張子の一覧] から選択したファイル拡張子を削除する場合にクリックします。

.topic 212
[ディレクトリの選択] ダイアログ ボックスを開く場合にクリックします。アクセスするファイルを含むディレクトリを選択できます。

.topic 213
アプリケーションの現在の作業ディレクトリをデータ ソース ディレクトリにする場合に選択します。 オフになっている場合は、[ディレクトリの選択] をクリックして、データ ソース ディレクトリを選択できます。

.topic 217
テキスト ファイル属性を構成し、テキスト ファイルの種類を追加または削除する場合にクリックします。

.topic 218
テキスト ファイルの場所を識別します。

.topic 301
[データ型]、[名前]、[幅] の各フィールドの値を使用して列を追加する場合にクリックします。

.topic 302
変更を保存せずに、このダイアログ ボックスを閉じます。

.topic 321
文字セットとして ANSI または OEM を指定します。

.topic 303
[テーブル] の一覧で選択されている項目の形式として、文字セットに ANSI を指定します。

.topic 304
選択されたテーブルの最初の行の列を列名として使用するかどうかを指定します (オンの場合は TRUE、オフの場合は FALSE)。

.topic 305
[テーブル] ボックスの一覧で選択されたテーブルの各列の列名を一覧表示し、テーブル内の列の順序を反映します。

.topic 319
選択されているテキスト ファイルの列属性を定義できます。

.topic 306
データ型を表示します。データ型は、BIT、BYTE、CHAR、CURRENCY、DATE、FLOAT、INTEGER、LONGCHAR、SHORT、または SINGLE です。

.topic 307
列を区切るために使用するカスタム区切り記号文字です。 長さが 1 文字である必要があります。二重引用符 (") は使用できません。 [書式] ボックスで [カスタム区切り] を選択した場合に有効になります。

.topic 308
区切り形式か固定長です。区切り形式の場合は、使用する区切り記号の種類を指定します。

.topic 309
[書式] ボックスの選択内容に従ってテーブルの内容をスキャンし、選択されているテーブルの列のデータ型、名前、および幅の値を生成します。 テーブル形式が区切り形式の場合に有効になります。

.topic 310
このダイアログ ボックスのヘルプを表示します。

.topic 311
[データ型]、[名前]、[幅] の各フィールドの値を使用して、選択されている列を変更します。

.topic 312
選択した列の名前を表示します。 既存の列または新しい列の新しい列名を指定するために使用できます。

.topic 313
このダイアログ ボックスを閉じ、変更を保存します。

.topic 314
選択されている列を削除します。

.topic 315
列および列のデータ型を設定するときにセットアップまたはドライバーがスキャンする行数です。 [テーブル] ボックスの一覧で選択されている項目の形式が定義されていない場合、既定で 25 に設定されます。1 ～ 32767 の任意の整数を指定できます。

.topic 316
[ODBC テキスト セットアップ] ダイアログ ボックスで指定されている拡張子の一覧に一致するすべてのファイルを一覧表示します。 テーブル属性を表示または変更するファイルを選択してください。

.topic 320
これらのオプションを使用して、選択されているテキスト ファイルのテーブル属性を定義します。

.topic 317
列の幅です。CHAR または LONGCHAR データ型の列で変更できます。 その他のデータ型の場合、[幅] は無効になり、値は表示されません。 [テーブル] ボックスの一覧で選択されている項目の形式が定義されていない場合、既定で 1 に設定されます。

.topic 318
[テーブル] の一覧で選択されているファイルの形式として、非 ANSI 文字セット (既定値) を指定します。

.topic 401
変更を保存せずに、このダイアログ ボックスを閉じます。

.topic 402
フィールドの並べ替え順序です。ASCII (既定値)、インターナショナル、スウェーデン語 - フィンランド語、またはノルウェー語 - デンマーク語です。

.topic 403
データ ソース名 (Payroll、Personnel など) を識別し、ODBC ドライバーがデータ ファイルを検索する既定のデータ ディレクトリを指定します。

.topic 404
データ ソース内のデータについての説明 (省略可)。たとえば、"入社日、給与履歴、および現在の評価"。

.topic 405
オンの場合、データベースは排他モードで開かれます。排他モードでは、アクセスが一度に 1 人のユーザーに制限され、パフォーマンスが向上します。 オフの場合、データベースは共有モードで開かれ、複数のユーザーが同時にアクセスできるようになります。

.topic 406
このダイアログ ボックスのヘルプを表示します。

.topic 407
Paradox データにアクセスするときに使用するネットワーク アクセス スタイルを指定します。Paradox 3.x の場合は "3.x"、Paradox 4.x または 5.x の場合は "4.x" です。 Paradox Versions 4.x および 5.x では、"3.x" または "4.x" に設定できます。Paradox Version 3.x では、スタイルは "3.x" にする必要があります。

.topic 408
[セットアップ] ダイアログ ボックスを閉じ、変更を保存します。

.topic 409
未使用のページがバッファーに保持される時間 (10 分の 1 秒単位)。 既定値は 600 (つまり 60 秒) です。0 より大きい値を指定する必要があります。

.topic 410
[ディレクトリの選択] ダイアログ ボックスを開く場合にクリックします。アクセスするファイルを含むディレクトリを選択できます。

.topic 415
Paradox ファイルの場所を識別します。

.topic 411
ネットワーク ディレクトリを選択する前に、[ユーザー名] ボックスに Paradox ユーザー名を入力する必要があります。 次に、[ネットワーク ディレクトリの選択] をクリックして、ネットワーク ディレクトリを選択します。

.topic 416
Paradox ロック データベースと、Pdoxusrs.net ファイル (Paradox 4.x の場合) または Paradox.net ファイル (Paradox 5.x の場合) があるディレクトリのパスです。 ディレクトリにこれらのファイルのいずれかが存在しない場合は、Paradox ドライバーによって作成されます。

.topic 412
アプリケーションの現在の作業ディレクトリをデータ ソース ディレクトリにする場合に選択します。 オフになっている場合は、[ディレクトリの選択] をクリックして、データ ソース ディレクトリを選択できます。

.topic 413
ロックがかかったときに Paradox ファイルの他のユーザーに表示される Paradox ユーザー名。

.topic 414
使用されているファイルの Paradox バージョン (たとえば Paradox 4.x、Paradox 5.x など) を指定します。

.topic 417
これらのオプションを使用して、Paradox データベースのバージョンと場所を表示および選択します。

.topic 418
これらのオプションを使用して、Paradox ドライバーを構成します。

.topic 419
ドライバー固有の属性を構成する場合にクリックします。

.topic 501
テーブル サイズ統計情報を概算するかどうかを指定します。 このオプションは、dBASE ドライバーを使用するすべてのデータ ソースに適用されます。

.topic 502
変更を保存せずに、このダイアログ ボックスを閉じます。

.topic 503
フィールドの並べ替え順序です。ASCII (既定値) またはインターナショナルです。

.topic 504
データ ソース名 (Payroll、Personnel など) を識別し、ODBC ドライバーがデータ ファイルを検索する既定のデータ ディレクトリを指定します。

.topic 505
データ ソース内のデータについての説明 (省略可)。たとえば、"入社日、給与履歴、および現在の評価"。

.topic 506
オンの場合、データベースは排他モードで開かれます。排他モードでは、アクセスが一度に 1 人のユーザーに制限され、パフォーマンスが向上します。 オフの場合、データベースは共有モードで開かれ、複数のユーザーが同時にアクセスできるようになります。

.topic 507
このダイアログ ボックスのヘルプを表示します。

.topic 508
[セットアップ] ダイアログ ボックスを閉じ、変更を保存します。

.topic 509
未使用のページがバッファーに保持される時間 (10 分の 1 秒単位)。 既定値は 600 (つまり 60 秒) です。常に 0 より大きい値を指定する必要があります。

.topic 515
dBASE データベースの場所を識別します。

.topic 510
[ディレクトリの選択] ダイアログ ボックスを開く場合にクリックします。アクセスするファイルを含むディレクトリを選択できます。

.topic 511
[インデックスの選択] ダイアログ ボックスを開く場合にクリックします。dBASE ファイルをインデックス ファイルに関連付けることができます。

.topic 512
削除済みのマークが付けられている行を取得または位置指定できるかどうかを指定します。 オフの場合 (既定の状態)、削除した行は表示されません。オンの場合、削除した行は削除していない行と同じように扱われます。

.topic 513
アプリケーションの現在の作業ディレクトリをデータ ソース ディレクトリにする場合に選択します。 オフになっている場合は、[ディレクトリの選択] をクリックして、データ ソース ディレクトリを選択できます。

.topic 514
使用されている dBASE ファイルのバージョン (たとえば dBASE III、dBASE IV、dBASE 5.0 など) を指定します。

.topic 516
これらのオプションを使用して、dBASE データベースのバージョンと場所を表示および選択します。

.topic 517
これらのオプションを使用して、dBASE ドライバーを構成します。

.topic 518
ドライバー固有の属性を構成する場合にクリックします。

.topic 701
パフォーマンスを調整するためにドライバーの詳細オプションを設定する場合にクリックします。

.topic 702
ディスクとの間でデータを転送するために Microsoft Access によって使用される内部バッファーのサイズ (KB 単位)。 既定値は 2048 KB です ("2048" と表示されます)。 256 で割り切れる任意の整数値を入力してください。

.topic 703
変更を保存せずに、このダイアログ ボックスを閉じます。

.topic 704
Access データベースを作成する場合にクリックします。

.topic 705
既存の Access データベースの無駄な領域を減らす場合にクリックします。

.topic 706
データ ソース名 (Payroll、Personnel など) を識別し、ODBC ドライバーがデータ ファイルを検索する既定のデータ ディレクトリを指定します。

.topic 707
現在選択されている Access データベースの場所です。 データベースを選択するには、[選択] をクリックします。

.topic 708
データ ソース内のデータについての説明 (省略可)。たとえば、"入社日、給与履歴、および現在の評価"。

.topic 709
オンの場合、データベースは排他モードで開かれます。排他モードでは、アクセスが一度に 1 人のユーザーに制限され、パフォーマンスが向上します。 オフの場合、データベースは共有モードで開かれ、複数のユーザーが同時にアクセスできるようになります。

.topic 710
このダイアログ ボックスのヘルプを表示します。

.topic 711
システム データベースを使用しない場合は、特定の Access データベースの Admin (DefaultUser) ユーザーとしてログインするために、このオプションを選択してください。

.topic 712
[セットアップ] ダイアログ ボックスを閉じ、変更を保存します。

.topic 713
未使用のページがバッファーに保持される時間 (10 分の 1 秒単位)。 既定値は 0.5 秒です。常に 0 より大きい値を指定する必要があります。

.topic 714
データベースの更新を禁止して読み取り専用にする場合に選択します。

.topic 715
破損した Access データベースを修復する場合にクリックします。

.topic 716
特定の Access データベースを選択する場合にクリックします。

.topic 723
システム データベースを使用する場合に選択します。 次に、[システム データベース] をクリックします。

.topic 717
[システム データベースの選択] ダイアログ ボックスを開く場合にクリックします。使用するシステム (ワークグループ) データベースを選択できます。

.topic 718
これらのオプションを使用して、Access データベースの場所を表示したり、データベースのメンテナンス機能を実行したりします。

.topic 719
これらのオプションを使用して、システム (ワークグループ) データベースを選択したり、その場所を表示したりします。

.topic 720
現在選択されている Access データベースの場所です。

.topic 721
これらのオプションを使用して、Access ドライバーを構成します。

.topic 722
ドライバー固有の属性を構成する場合にクリックします。